Списание остатков взаиморасчетов в УНФ 1.6

06.06.19

Учетные задачи - Взаиморасчеты

Обработка формирует документ Корректировка регистров списывая остатки взаиморасчетов с контрагентами по регистру накопления "Расчеты с покупателями" и "Расчеты с поставщиками" в базе УНФ 1.6.

Скачать исходный код

Наименование Файл Версия Размер
Обработка "Простить всем долги" в УНФ 1.6:
.epf 7,06Kb
22
.epf 7,06Kb 22 Скачать

Эта обработка пригодится тем, кто хочет "обнулить" взаиморасчеты с контрагентами в УНФ в разрезе по организации.

Обработка тестировалась в Управление нашей фирмой, редакция 1.6 (1.6.16.178).

В качестве примера рассмотрим списание взаиморасчетов по регистру накопления "Расчеты с покупателями":

 

&НаСервере
Процедура кит_ПроститьДолгиПокупателямНаСервере()
	Если Не ЗначениеЗаполнено(ДатаОстатков) Тогда
		Сообщить("Укажи дату остатков");
		Возврат;
	КонецЕсли; 
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
	               |	РасчетыСПокупателямиОстаткиИОбороты.Регистратор КАК Регистратор
	               |ИЗ
	               |	РегистрНакопления.РасчетыСПокупателями.ОстаткиИОбороты(, &КонПериода, Регистратор, , Организация = &Организация) КАК РасчетыСПокупателямиОстаткиИОбороты
	               |ГДЕ
	               |	(РасчетыСПокупателямиОстаткиИОбороты.СуммаКонечныйОстаток <> 0
	               |			ИЛИ РасчетыСПокупателямиОстаткиИОбороты.СуммаРегКонечныйОстаток <> 0)";
	
	Запрос.УстановитьПараметр("КонПериода", 	КонецДня(ДатаОстатков));
	Запрос.УстановитьПараметр("Организация", 	Организация);
	
	РезультатЗапроса = Запрос.Выполнить().Выгрузить();
	
	Если РезультатЗапроса.Количество() = 0 Тогда
		Сообщить("Долгов нет");
		Возврат;
	КонецЕсли; 
	
	//
	ДокОбъект = Документы.КорректировкаРегистров.СоздатьДокумент();
	
	ДокОбъект.Дата = КонецДня(ДатаОстатков);
	ДокОбъект.Комментарий = "#Корректировка создана обработкой от " + ТекущаяДата() + " #";
	
	ДокОбъект.УстановитьНовыйНомер();
	
	ДокОбъект.Автор = Пользователи.ТекущийПользователь();
	
	МетаданныеРегистраНакопления = РегистрыНакопления.РасчетыСПокупателями.СоздатьНаборЗаписей().Метаданные();
	
	ДокОбъект.ТаблицаРегистров.Очистить();
	
	нс = ДокОбъект.ТаблицаРегистров.Добавить();
	нс.Имя = МетаданныеРегистраНакопления.Имя;
	
	ДвиженияДокумента = ДокОбъект.Движения.РасчетыСПокупателями;
	ДвиженияДокумента.Очистить();
	ДвиженияДокумента.Записывать = Истина;
	
	Для Каждого Строка Из РезультатЗапроса Цикл
	
		НаборЗаписей = РегистрыНакопления.РасчетыСПокупателями.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Регистратор.Установить(Строка.Регистратор);
		НаборЗаписей.Прочитать();
		
		Для Каждого Запись Из НаборЗаписей Цикл
			НовоеДвижение = ДвиженияДокумента.Добавить();
			ЗаполнитьЗначенияСвойств(НовоеДвижение, Запись);
			
			НовоеДвижение.Период = КонецДня(ДатаОстатков);
			
			НовоеДвижение.Сумма 	= - НовоеДвижение.Сумма;
			НовоеДвижение.СуммаВал 	= - НовоеДвижение.СуммаВал;
			НовоеДвижение.СуммаРег 	= - НовоеДвижение.СуммаРег;
		КонецЦикла;
		
	КонецЦикла;
	
	ДокОбъект.Записать();
	
	Сообщить("Создан документ " + Строка(ДокОбъект.Ссылка));
КонецПроцедуры

 

УНФ Взаиморасчеты Списание долгов Долги

См. также

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191648    135    239    

270

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22730    186    7    

167

УТ 11, КА 2, ERP 2: Настраиваемые под каждую организацию печать и подпись ответственных лиц в печатных формах (ТОРГ-12, Счёт-фактура, УПД, УКД, Заказ клиента, Акт сверки, М-15 и др.)

Печатные формы Взаиморасчеты Оптовая торговля Производство готовой продукции (работ, услуг) Акт сверки Бухгалтер Пользователь Оперативный учет Управляемые формы 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Задайте для каждой организации свою печать и для каждого физического лица свою подпись. Выберите в документе печатную форму "... с печатью и подписью" - и автоматически сформируется табличный документ с печатью и подписями той организации и ответственных лиц, которые указаны в документе.

12000 руб.

13.03.2018    57283    187    76    

117

Дебиторская задолженность по срокам долга

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Один из лучших вариантов отчета по дебиторской задолженности. Отображает сроки возникновения задолженности, просроченной задолженности с точностью до регистратора, а также многое другое, вне зависимости от схемы взаиморасчетов (online / offline) и объекта расчетов (УТ 11.3, 11.4, 11.5, КА 2.4, 2.5, ERP 2.4, 2.5), состояния флажка "по документам расчета" ( УТ 10, КА 1.1, УПП 1.3) в договоре. Группирует задолженность по интервалам. Имеет большое количество настроек. Не требует доработок конфигурации.

15120 руб.

28.09.2012    95222    590    281    

141

Автоматический зачет авансов в 1С:УНФ по ФИФО

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Знаем о взаиморасчетах в Управлении нашей фирмой все, что только можно знать. Самая большая проблема взаиморасчетов в УНФ в том, что зависают непонятные долги и предоплаты, в Пульсе бизнеса показываются неадекватные цифры, отчеты по долгам показывают не пойми что. Автоматический зачет авансов в 1С:УНФ поможет решить эту проблему.

12000 руб.

22.07.2021    24015    26    34    

33

Перенос начальных остатков из Парус 7.71 в БГУ

Внешние источники данных Взаиморасчеты Учет ОС и НМА Логистика, склад и ТМЦ Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 1С:Бухгалтерия государственного учреждения Государственные, бюджетные структуры Россия Бюджетный учет Абонемент ($m)

Перенос словарей и начальных остатков из ПП Парус-Бухгалтерия Бюджет 7.71 в 1Сv8 БГУ2. Заполнение словарей и документов по вводу начальных остатков. Не требуется установка ПП Парус7. Возможна дозагрузка. Позволит автоматически ввести основные данные в программу для начала работы. 

10 стартмани

08.12.2011    81867    4    Skaredov    124    

147

Отчеты по расчетам с контрагентами для 1С:Бухгалтерии

Взаиморасчеты Бизнес-аналитик Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Внешние управленческие отчеты показывают дебиторскую и кредиторскую задолженность при расчетах с контрагентами – подробно и в различных разрезах, в том числе по срокам долга.

3600 руб.

13.01.2023    7083    11    9    

10
Оставьте свое сообщение