Автоматическое формирование актов сверки (Бухгалтерия предприятия 3.0)

16.05.19

Учетные задачи - Взаиморасчеты

Внешняя обработка для автоматического формирования актов сверки по контрагентам. Причиной создания стало не удовлетворительное качество имеющихся на инфостарте обработок и желание закрыть этот вопрос навсегда. Возможности: формирование по оборотам в периоде и по справочнику договоров; управление дополнительными настройками заполнения актов сверки; представителей организации и контрагента; формирование актов по договорам и сводно по контрагентам; возможность убрать не нужные договоры; перезаполнение существующих актов сверки.

Скачать исходный код

Наименование Файл Версия Размер
Автоматическое формирование актов сверки (Бухгалтерия Предприятия 3.0):
.epf 21,82Kb
102
.epf 1.0 21,82Kb 102 Скачать

Работает так: выбираете период и организацию и заполняете таблицу с договорами. 

Важно, если дата, которой формируются акты сверки отличается от даты конца периода, то ее можно поменять вручную. В нижней части экрана, но сделать это нужно до заполнения списка договоров, сразу после установки периода. 

Для этого над ней есть две кнопки (см картинку):
 1) "заполнить всеми" - заполняет по справочнику договоров с учетом отборов (по группе контрагентов, по виду договоров), в список попадают договоры действующие на дату начала периода (реквизит "Срок действия до" в договоре) и не помеченные на удаление. 
Автоматически флажок устанавливается лишь у тех, где есть обороты
 2) "Заполнить по оборотам" - заполняет теми договорами/контрагентами, у кого есть обороты за выбранный период.
В любом случае в список включаются не действующие или помеченные на удаление договоры, если по ним были обороты в периоде заполнения. Важно: можно указать второй квартал и сформировать акты сверки с начала года. Для этого установите флажок "Формировать с начала года" в нижней части окна.

Чтобы сформировать акты, нажмите кнопку "Сформировать/перезаполнить акты сверок".

При наличии актов сверки и установленном флажке "Перезаполнять акты сверки", акты перезаполняются. 

Настройки заполнения/формирования актов устанавливаются в нижней части окна.

Представителем контрагента в акте устанавливается основное контактное лицо контрагента.

Если акт сверки существует, но сверка уже согласована, то акт не перезаполняется, а выводится сообщение об ошибке.

Двойной щелчок на контрагенте, договоре или акте открывает форму выбранного объекта.

В нижней части окна находятся настройки заполнения актов сверки, совпадающих с настройками внутри документа Акт сверки. Настройки запоминаются автоматически.

Тестировалась на релизе: Бухгалтерия предприятия, редакция 3.0.70.25.

Обработка автоматическое создание заполнение актов сверки акты

См. также

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191677    135    239    

270

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22750    186    7    

167

УТ 11, КА 2, ERP 2: Настраиваемые под каждую организацию печать и подпись ответственных лиц в печатных формах (ТОРГ-12, Счёт-фактура, УПД, УКД, Заказ клиента, Акт сверки, М-15 и др.)

Печатные формы Взаиморасчеты Оптовая торговля Производство готовой продукции (работ, услуг) Акт сверки Бухгалтер Пользователь Оперативный учет Управляемые формы 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Задайте для каждой организации свою печать и для каждого физического лица свою подпись. Выберите в документе печатную форму "... с печатью и подписью" - и автоматически сформируется табличный документ с печатью и подписями той организации и ответственных лиц, которые указаны в документе.

12000 руб.

13.03.2018    57320    187    76    

117

Автоматический зачет авансов в 1С:УНФ по ФИФО

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Знаем о взаиморасчетах в Управлении нашей фирмой все, что только можно знать. Самая большая проблема взаиморасчетов в УНФ в том, что зависают непонятные долги и предоплаты, в Пульсе бизнеса показываются неадекватные цифры, отчеты по долгам показывают не пойми что. Автоматический зачет авансов в 1С:УНФ поможет решить эту проблему.

12000 руб.

22.07.2021    24029    27    34    

33

Дебиторская задолженность по срокам долга

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Один из лучших вариантов отчета по дебиторской задолженности. Отображает сроки возникновения задолженности, просроченной задолженности с точностью до регистратора, а также многое другое, вне зависимости от схемы взаиморасчетов (online / offline) и объекта расчетов (УТ 11.3, 11.4, 11.5, КА 2.4, 2.5, ERP 2.4, 2.5), состояния флажка "по документам расчета" ( УТ 10, КА 1.1, УПП 1.3) в договоре. Группирует задолженность по интервалам. Имеет большое количество настроек. Не требует доработок конфигурации.

15120 руб.

28.09.2012    95235    590    281    

141

Перенос начальных остатков из Парус 7.71 в БГУ

Внешние источники данных Взаиморасчеты Учет ОС и НМА Логистика, склад и ТМЦ Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 1С:Бухгалтерия государственного учреждения Государственные, бюджетные структуры Россия Бюджетный учет Абонемент ($m)

Перенос словарей и начальных остатков из ПП Парус-Бухгалтерия Бюджет 7.71 в 1Сv8 БГУ2. Заполнение словарей и документов по вводу начальных остатков. Не требуется установка ПП Парус7. Возможна дозагрузка. Позволит автоматически ввести основные данные в программу для начала работы. 

10 стартмани

08.12.2011    81892    4    Skaredov    124    

147

Отчеты по расчетам с контрагентами для 1С:Бухгалтерии

Взаиморасчеты Бизнес-аналитик Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Внешние управленческие отчеты показывают дебиторскую и кредиторскую задолженность при расчетах с контрагентами – подробно и в различных разрезах, в том числе по срокам долга.

3600 руб.

13.01.2023    7099    11    9    

10
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Hi-Hightower 45 04.09.19 16:00 Сейчас в теме
Возможен ли отбор только тех контрагентов, по которым есть сальдо на дату формирования? Например, частая задача - рассылать Акты Сверки только должникам.
2. user1244407 11.01.21 11:56 Сейчас в теме
Купила, пользуюсь, хорошо. Не хватает в разделе "3.Рассылка" выделения цветом тех актов, которые согласованы. Возможна ли доработка???
3. Black-fog 56 12.01.21 08:28 Сейчас в теме
(2) в этой обработке нет рассылки актов и раздел 3 я там не делал вроде. Вы, случаем, не перепутали обработку?
4. user1244407 12.01.21 11:30 Сейчас в теме
Извините, извините, не Ваш отчет ))
5. zavsom 104 24.11.23 09:34 Сейчас в теме
если хотите , чтобы акты сохранялись с названием Контрагента перед "акт сверки ..." , надо слегка доработать в общем модуле ОбщегоНазначенияБП вот эту процедуру:

// Процедура формирует имя сохраняемого файла путем формирования представления документа и удаления из него символов "точка"
Процедура УстановитьИмяСохраняемогоФайла(ОбъектыПечати, КоллекцияПечатныхФорм, ИмяФайлаПоВходящимНомерам)

Если НЕ КоллекцияПечатныхФорм.Количество() = 1 Тогда
Возврат;
КонецЕсли;

ПечатнаяФорма = КоллекцияПечатныхФорм[0];
Если ЗначениеЗаполнено(ПечатнаяФорма.ИмяФайлаПечатнойФормы) Тогда
// Имя файла уже задано ранее, не меняем его.
Возврат;
КонецЕсли;

ИмяФайлаПечатнойФормы = Новый Соответствие;

Для Каждого ОбъектПечати Из ОбъектыПечати Цикл

ПредставлениеДокументаДляПечатнойФормы = СформироватьЗаголовокПервичногоДокумента(
ОбъектПечати.Значение, ПечатнаяФорма.СинонимМакета, ИмяФайлаПоВходящимНомерам);

ПредставлениеДокументаДляПечатнойФормы = СтрЗаменить(ПредставлениеДокументаДляПечатнойФормы, ".", "");

//*** ШО 2023-11-23
Если ОбъектПечати.Значение.Ссылка.Метаданные().Имя = "АктСверкиВзаиморасчетов" Тогда
ПредставлениеДокументаДляПечатнойФормы = ОбъектПечати.Значение.Контрагент.Наименование + " " + ПредставлениеДокументаДляПечатнойФормы;
КонецЕсли;
//*** шо 2023-11-23

ИмяФайлаПечатнойФормы.Вставить(ОбъектПечати.Значение, ПредставлениеДокументаДляПечатнойФормы);

КонецЦикла;

ПечатнаяФорма.ИмяФайлаПечатнойФормы = ИмяФайлаПечатнойФормы;

КонецПроцедуры


В БП 83 общий модуль общегоназначенияБП
Оставьте свое сообщение