Создание дисконтных карт по номеру телефона

11.09.20

Функциональные - Управление взаимоотношениями с клиентами (CRM)

В расширение скрыта кнопка код, поиск карты осуществляется по номеру телефона. Регистрация новой дисконтной карты, идет по принципу номер телефона = номер карты.

Скачать исходный код

Наименование Файл Версия Размер
Создание дисконтных карт по номеру телефона:
.cfe 55,73Kb
30
.cfe 55,73Kb 30 Скачать

Для удобства работы с дисконтными карта можно произвести настройку выдачи дисконтных карт покупателю прямо из интерфейса РМК. А так же произвести опрос покупателя:

  1. ФИО
  2. Дата рождения
  3. Пол
  4. Фактический адрес
  5. Телефон
  6. Электронная почта.

Для начала надо произвести настройку прав пользователя и магазина. Наcтройка РМК - Изменение настройки РМК. Выбираем флаг Проводить опрос владельца карты и переходим на закладку Кнопки нижней панели

Заходим в дополнительные права пользователей. И ставим флаг Разрешить регистрацию дисконтной карты при считывании нового кода

Отжимаем флаг Разрешить выбор карты по номеру телефона без SMS подтверждения при поиске

Теперь нам надо найти Шаблоны по которым будут создаваться наши дисконтные карты. Найти эту функцию можно в Администрировании или в разделе Все функции - регистры сведений.

Вид карты Магнитная, длинна кода 11 – длина номера телефона, Начало диапазона - 79000000000 и Конец диапазона - 79999999999, Вид дисконтной карты в моем случае Бонусная и ставим обязательно флаг Проводить опрос владельца при регистрации.

Протестировано на конфигурации Розница 8 2.3 (2.3.5.24)

Дисконтные карты телефон

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    92119    116    40    

206

ККТ-ОНЛАЙН 54-ФЗ: Обработка для работы онлайн касс АТОЛ, ШТРИХ, VIKI PRINT и т.д. МАРКИРОВКА (Разрешит. режим) + ЭКВАЙРИНГ + БЕСПЛАТНЫЙ ДЕМО

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    775680    4710    9505    

2804

ЕГАИС++. Опт, производство, импорт

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    167414    728    362    

391

Обмен с системой ЦРПТ (Универсальная конфигурация ХамелеонЦРПТ + маркировка табака, обуви, одежды, лекарств, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин)

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте нам вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, мы накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111175    27    114    

179

Загрузка номенклатуры в УТ11, КА 2, ERP 2, Розница 2 из Excel. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка номенклатуры из файлов Excel (xls, xlsx, ods, csv, mxl) в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212972    635    526    

448

Интеграция 1С со СберМаркетом для 1С:Розница 2.3/3.0, УНФ 3.0, УТ 11.4/11.5, КА 2.4/2.5

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

25000 руб.

14.10.2022    8053    9    13    

7

54-ФЗ и Разрешительный режим. Обработки для подключения онлайн-касс к 1С 8 (поддержка Маркировки) + Эмулятор + ФФД 1.2

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    323239    1859    3024    

1003
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. tof 24.04.21 20:22 Сейчас в теме
Розница, редакция 2.3 (2.3.7.19) не взлетело
2. fixin 4258 01.02.22 14:48 Сейчас в теме
(1) там надо две картинки из расширения убрать:
ор_НоменклатураПродаваемаяСовместно
ор_СостояниеНоменклатурыПродаваемойСовместно

А вообще да, расширение кривое, там только формы Обработка.РМКУправляемыйРежим
Форма и ФормаПоискаДисконтнойКарты расширены.

РасчетСкидокДляАнализаДиапазонаКарт(); - функция отсутствует, т.е. код функции не прописан.

Собственно весь код по поиску ДК тут, как видно никаких дополнительных настроек нет:

&Вместо("ОповещениеОткрытьФормуПоискаДисконтнойКарты")
&НаКлиенте
Процедура Mf_ОповещениеОткрытьФормуПоискаДисконтнойКарты(РезультатОткрытияФормы, ДополнительныеПараметры) Экспорт
	
	Если НЕ РезультатОткрытияФормы = Неопределено Тогда
		КодЗначение = РезультатОткрытияФормы.ВведенноеЧисло;
		//Mf+
		Если РезультатОткрытияФормы.РежимПоискаКарты = "НомерТелефона" тогда
			РезультатыПоиска = НайтиКарту(РезультатОткрытияФормы, ДополнительныеПараметры); 
			Если РезультатыПоиска.Количество() = 0 тогда
				РезультатОткрытияФормы.Вставить("РежимПоискаКарты","КодЗначение");
			КонецЕсли;
			
		КонецЕсли;
		//Mf-
		Если РезультатОткрытияФормы.РежимПоискаКарты = "ФИО"
			ИЛИ РезультатОткрытияФормы.РежимПоискаКарты = "НомерТелефона" 
			ИЛИ РезультатОткрытияФормы.РежимПоискаКарты = "Email" Тогда
			НайтиИУстановитьКарту(РезультатОткрытияФормы, ДополнительныеПараметры);
		Иначе
			Если ЗначениеЗаполнено(КодЗначение) Тогда
				ИсполняемаяОперацияЛогирования = "ВведенНомерКарты";
				
				// + Диапазон карт
				НомерКартыДляАнализаДиапазона = КодЗначение;
				НайденаКартаПоДиапазону = РасчетСкидокДляАнализаДиапазонаКарт();
				// - Диапазон карт
				// + Бонусный сервис
				ПередаваемыеПараметры = Новый Структура("НомерКарты, ВведенВручную, ПроверкаБонусныхКарт", КодЗначение);
				Если ПараметрыСобытийПО.Свойство("ДанныеОборудования") Тогда
					ПараметрыСобытийПО.ДанныеОборудования = ПередаваемыеПараметры;
				Иначе
					ПараметрыСобытийПО.Вставить("ДанныеОборудования", ПередаваемыеПараметры);
				КонецЕсли;
				Если НЕ ПараметрыСобытийПО.Свойство("ПроверкаБонусныхКарт") Тогда
					ПараметрыСобытийПО.ДанныеОборудования.Вставить("ПроверкаБонусныхКарт");
				КонецЕсли;
				// - Бонусный сервис
				
				СтруктураПараметровКлиента = ПолученМагнитныйКод(КодЗначение);
				ОбработатьДанныеПоКодуКлиент(СтруктураПараметровКлиента);
				
				// + Бонусный сервис
				Если СтруктураПараметровКлиента.Свойство("ЕстьРегистрацияНовойКарты") Тогда
					Если НЕ ПараметрыСобытийПО.Свойство("ЕстьРегистрацияНовойКарты") Тогда
						ПараметрыСобытийПО.Вставить("ЕстьРегистрацияНовойКарты");
					КонецЕсли;
					
					СтруктураПараметровКлиента = ПолученМагнитныйКод(СтруктураПараметровКлиента.ЕстьРегистрацияНовойКарты);
					ОбработатьДанныеПоКодуКлиент(СтруктураПараметровКлиента);
					
					Если ПараметрыСобытийПО.Свойство("ЕстьРегистрацияНовойКарты") Тогда
						ПараметрыСобытийПО.Удалить("ЕстьРегистрацияНовойКарты");
					КонецЕсли;
				КонецЕсли;
				// - Бонусный сервис
				
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры
Показать


Проверено на Розница 2.3.10.43
4. hulkulya 27.04.22 05:03 Сейчас в теме
(2)в итоге удалось сделать, чтобы заработало? я уже что только не перенастраивал, не работает...
5. fixin 4258 27.04.22 10:59 Сейчас в теме
(4) да, но не через это расширение. свое написал (для последней розницы), хотя кое-какие из идей отсюда задействовал.
6. hulkulya 27.04.22 14:08 Сейчас в теме
(5)а можно ссылку на вашу работу? Скачать рабочую версию?
3. fixin 4258 01.02.22 16:40 Сейчас в теме
Хотя в целом проверил, наверное будет работать таким образом. Если убрать эти две картинки.
Просто мой клиент хотел выбор вида карты при создании.
Пришлось по другому пути пойти
7. YA_1130000057973079 01.09.22 04:21 Сейчас в теме
1. Для УТ11 будет работать?
2. Можно ли сделать обязательные к заполнению поля ФИО?
Оставьте свое сообщение