Обработка Заполнения ГТД и стран в документы поступления и возврат товаров

04.07.12

Задачи пользователя - Адаптация типовых решений

Обработка позволяет менять ГТД и страны в документах поступления и возврате. Полезна когда много номенклатуры в документе и ГТД у всех нужно поменять на одинаковую какую-нибудь. В данных документах лишь создаём кнопку на эту обработку.

Скачать исходный код

Наименование Файл Версия Размер
ЗаполнениеГТДиСтраныВДокументы.epf
.epf 11,51Kb
14
.epf 11,51Kb 14 Скачать

В кнопке документа необходимо прописать похожую процедуру:

	 Процедура КоманднаяПанельТоварыПодборГТД(Кнопка)
    ЭтотОбъект.Записать(РежимЗаписиДокумента.Запись);
    Эл= Обработки.ЗаполнениеГТДиСтраныВДокументы.Создать();     
    i=1;
    Эл.ДокССылка = ЭтотОбъект.Ссылка;
    Для Каждого Стр Из Товары Цикл
        Если ПустаяСтрока(Стр.СерияНоменклатуры) Тогда
            СтрокаТабЧ=Эл.Товары.Вставить(i);
            СтрокаТабЧ.Номерок=Стр.НомерСтроки;
            СтрокаТабЧ.Флажок=Истина;
            СтрокаТабЧ.Номенклатура=Стр.Номенклатура;
            СтрокаТабЧ.Код=Стр.Номенклатура.Код;
            СтрокаТабЧ.Артикул=Стр.Номенклатура.Артикул;
            СтрокаТабЧ.НомерГТД="";
            СтрокаТабЧ.СтранаПроисхождения="";
            СтрокаТабЧ.Количество=Стр.Количество;
        КонецЕсли;
        i=i+1;
    КонецЦикла;
    Форма=Эл.ПолучитьФорму("Форма",ЭтотОбъект);
    Форма.Открыть();
КонецПроцедуры



См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4858    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3233    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4319    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2363    dimanich70    8    

14

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2269    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2474    33    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
0. Vint88 41 03.07.12 14:51 Сейчас в теме
Обработка позволяет менять ГТД и страны в документах поступления и возврате. Полезна когда много номенклатуры в документе и ГТД у всех нужно поменять на одинаковую какую-нибудь. В данных документах лишь создаём кнопку на эту обработку.

Перейти к публикации

1. ninch 51 13.07.12 06:50 Сейчас в теме
В УТ10 по кнопке "изменить" можно сделать такую же фигню (в поступлении точно) - то есть все стандартно. А в УПП нету чтоли?
2. Vint88 41 13.07.12 16:20 Сейчас в теме
В Упп тоже есть такая фигня, просто она выдаёт всю номенклатуру, а нужно чтобы только те позиции, у которых нет ГТД. Чтобы вручную не искать, а если просто ГТД захотел поменять, то можно пользоваться именно стандартной функцией
3. Поручик 4677 24.07.12 14:11 Сейчас в теме
(2) Ради этого курочить конфигурацию? Про внешние обработки заполнения табличных частей не слыхали?
Оставьте свое сообщение