Отключение вывода префикса информационной базы для стандартных конфигураций

28.05.21

Задачи пользователя - Адаптация типовых решений

Номер документа в печатной форме без префикса информационной базы. Для тех, кому требуется в печатных формах очистить номер документа не только от префикса Организации, но и от префикса базы. Раскрыт код для самостоятельного исправления, также доступно расширение конфигурации для скачивания и легкого внедрения.

Скачать исходный код

Наименование Файл Версия Размер
Отключить вывод префикса информационной базы для стандартных конфигураций:
.cfe 6,18Kb
12
.cfe 6,18Kb 12 Скачать

В стандартных конфигурациях УТ, КА, ЕРП предусматривается отключение префикса организации, но префикс информационной базы выводится всегда, почти всегда (в Счет-фактуре не выводится). Настройка не предусмотрена.

А всего-то нужно заменить в коде один параметр. Пришлось сделать расширение конфигурации. Для исправления одного слова в коде.

Модуль "ПрефиксацияОбъектовКлиентСервер"
 

//&ИзменениеИКонтроль("НомерНаПечать")
&Вместо("НомерНаПечать")

Функция КвБезПрефика_НомерНаПечать(Знач НомерОбъекта, УдалитьПрефиксИнформационнойБазы, УдалитьПользовательскийПрефикс)

	// {Обработчик: ПриПолученииНомераНаПечать} Начало
	СтандартнаяОбработка = Истина;

	ПрефиксацияОбъектовКлиентСерверПереопределяемый.ПриПолученииНомераНаПечать(НомерОбъекта, СтандартнаяОбработка,
	УдалитьПрефиксИнформационнойБазы, УдалитьПользовательскийПрефикс);

	Если СтандартнаяОбработка = Ложь Тогда
		Возврат НомерОбъекта;
	КонецЕсли;
	// {Обработчик: ПриПолученииНомераНаПечать} Окончание

	НомерОбъекта = СокрЛП(НомерОбъекта);

	// Удаляем пользовательские префиксы из номера объекта.
	Если УдалитьПользовательскийПрефикс Тогда

		НомерОбъекта = УдалитьПользовательскиеПрефиксыИзНомераОбъекта(НомерОбъекта);

	КонецЕсли;

	// Удаляем лидирующие нули из номера объекта.
	НомерОбъекта = УдалитьЛидирующиеНулиИзНомераОбъекта(НомерОбъекта);

	// Удаляем префикс организации и префикс информационной базы из номера объекта.
//#Удаление
//	НомерОбъекта = УдалитьПрефиксыИзНомераОбъекта(НомерОбъекта, Истина, УдалитьПрефиксИнформационнойБазы);
//#КонецУдаления
//#Вставка
	НомерОбъекта = УдалитьПрефиксыИзНомераОбъекта(НомерОбъекта, Истина, Истина);
//#КонецВставки
	
	Возврат НомерОбъекта;
КонецФункции

 

Тестировал на платформе 1С:Предприятие 8.3 (8.3.17.1851)

Конфигурации: 

  • Управление торговлей, редакция 11 (11.4.13.180)
  • Комплексная автоматизация 2 (2.4.13.170)
  • ERP Управление предприятием 2 (2.4.13.187)

Расширение конфигурации прилагаю для скачивания для тех, кому лень самому интегрировать этот код в базу.

Префикс номера документа печатная форма

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4855    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3232    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4317    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2354    dimanich70    8    

14

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2264    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2474    33    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. WiseSnake 1520 20.12.22 16:55 Сейчас в теме
Можно проще:

&Вместо("НомерНаПечать")
Функция КорДГ_НомерНаПечать(Знач НомерОбъекта, УдалитьПрефиксИнформационнойБазы, УдалитьПользовательскийПрефикс)
	УдалитьПрефиксИнформационнойБазы = Истина;
	Результат = ПродолжитьВызов(НомерОбъекта, УдалитьПрефиксИнформационнойБазы, УдалитьПользовательскийПрефикс);
	Возврат Результат;
КонецФункции
Оставьте свое сообщение