Конструктор разнесения статей ДДС в банковских документах

22.06.22

Учетные задачи - Банковские операции

Знакомая многим ситуация когда надо разнести статьи ДДС в банковских документах в зависимости от значений реквизитов документов, пусть это будет вид операции, назначение, контрагент итд. И чтоб каждый раз не лести в код создано это расширение.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Конструктор разнесения статей ДДС в банковских документах:
.cfe 24,81Kb
6
6
1 SM
Скачать Купить за 1 850 руб.

"ИИИИИИИИИИгорь, у нас на новый год новые статьи ДДС, надо настроить разнесение при загрузке банка", слышу я  частенько, и доблестно и с важным видом иду в модуль объекта,  в событие "Перед записью" документа. Чувствуя свое высшее предназначение писать код, в сотый раз переписываю конструкции "НайтиПоКоду" и многоуровневые "Если".

Хватит это терпеть скажете вы, и я тоже так подумал и решил создать гибкий пользовательский интерфейс для разнесения статей ДДС в банковских реквизитов, который бы учитывал любые комбинации условий и реквизитов.

Теперь пару слов о реализации:

1. За основу был взят механизм отбора компоновки данных, с помощью которого можно настраивать любые отборы по реквизитам объекта (привычный всем инструмент настройки отбора в отчетах или динамических списках), ниже пример создаваемого условия

 

 

2. Был создан регистр сведений с измерениями: СтатьяДДС, ИмяМетаданных, и ресурсами: "ВариантОтбора", "Приоритет". Приоритет служит чтоб не создавать взаимоисключающие условия, а выставить их в приоритете (При попадании в первый отбор, дальше условия не смотрятся). Ниже форма списка данного регистра, где непосредственно идет настройка условий.

 

 

3. Доработан "МенеджерОбменаЧерезУниверсальныйФормат", "ОтложеннаяОбработка" документов списание и поступление на р/с, так как в моем варианте первично банк загружается в БП, затем синхронизируется в УНФ. Ниже пример кода инициализации отбора СКД, и определения необходимой статьи ДДС.

&После("ОтложеннаяОбработка_ПБДС")
Процедура РДДС_ОтложеннаяОбработка_ПБДС(Объект)
	//получим варианты отбора на дату
	//получим первую подходящую статью
	СтатьяНайдена = Ложь;
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	РДДС_НастройкиРазнесенияДДС.ВариантОтбора КАК ВариантОтбора,
	|	РДДС_НастройкиРазнесенияДДС.СтатьяДДС КАК СтатьяДДС
	|ИЗ
	|	РегистрСведений.РДДС_НастройкиРазнесенияДДС КАК РДДС_НастройкиРазнесенияДДС
	|ГДЕ
	|	РДДС_НастройкиРазнесенияДДС.ПолноеИмяМетаданных = &ИмяМетаданныхДокумента
	|
	|УПОРЯДОЧИТЬ ПО
	|	РДДС_НастройкиРазнесенияДДС.Приоритет";
	ИмяМетаданныхДокумента =  Объект.Метаданные().имя;
	Запрос.УстановитьПараметр("ИмяМетаданныхДокумента",	ИмяМетаданныхДокумента);	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ОтборСКД = ВыборкаДетальныеЗаписи.ВариантОтбора;
		ОтборСКД =  ОтборСКД.Получить();
		ДокументПоОтбору= ПолучитьДокументПоОтборуСКД(ИмяМетаданныхДокумента, Объект.ссылка, ОтборСКД);
		Если ДокументПоОтбору <> 0 Тогда
			Объект.Статья = ВыборкаДетальныеЗаписи.СтатьяДДС;
			СтатьяНайдена = Истина;
			Прервать;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Функция ПолучитьДокументПоОтборуСКД(ИмяМетаданныхДокумента,СсылкаНаДокумент, ОтборСКД)   экспорт
	ТекстЗапроса = "ВЫБРАТЬ Разрешенные _.* ИЗ Документ."+ИмяМетаданныхДокумента+" КАК _ ";
	Схема = ПолучитьОбщийМакет("РДДС_СхемаОтбораДокумента");
	Схема.НаборыДанных.НаборДанных1.Запрос = ТекстЗапроса;
	// восстановим настройки и добавим отбор по ссылке 
	РДДС_ОбщегоНазначения.СкопироватьЭлементы(Схема.НастройкиПоУмолчанию.Отбор, ОтборСКД);
	
	ЭлементОтбора = Схема.НастройкиПоУмолчанию.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
	ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Ссылка");
	ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
	ЭлементОтбора.ПравоеЗначение = СсылкаНаДокумент;
	ЭлементОтбора.Использование = Истина;
	
	Настройки = Схема.НастройкиПоУмолчанию;
	//
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных();
	МакетКомпоновки = КомпоновщикМакета.Выполнить(Схема,Настройки,,, Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
	Результат = ПроцессорВывода.Вывести(ПроцессорКомпоновки);
	Возврат Результат.Количество();
КонецФункции 

4. Расширение создавалось для конфигурации УНФ 1.6.26.191, но привязка к объектам конфигурации минимальная, Единственное, может быть расхождения по имени метаданных документов по банку и по версии Менеджера обмена, в данной конфигурации используется 1.8.

P.S В ответ музыкантам, баянистам) скажу, что под свою задачу похожих разработок не нашел, и поэтому выкладываю свою. 

См. также

Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Расширение "Проекты" добавляет в типовую конфигурацию управленческий учет по проектам: позволяет вести список проектов, привязывать проекты к документам, подсчитывать доходы и расходы в разрезе проектов в 1С.

15000 руб.

30.11.2021    22044    102    49    

81

Банковские операции Обмен с интернет-банком Эквайринг/ридер магнитных карт Программист Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Устали вручную дозаполнять и корректировать документы по банку после загрузки банковской выписки? С помощью правил обработки банковской выписки вы сможете автоматически определять правильный вид хозяйственной операции, заполнять расшифровку, аналитику платежа и многое другое.

15000 руб.

21.03.2023    9543    53    14    

51

Учет доходов и расходов БДР, БДДС Бизнес-аналитик Бухгалтер Пользователь Руководитель проекта Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Комплект из 3 самых популярных финансовых управленческих отчетов для директоров и владельцев (Управленческий баланс, Отчет о движении денежных средств, Отчет о финансовом результате (бывший отчет о прибылях и убытках), написанный в виде внешних отчетов для конфигурации 1С: Бухгалтерия 3.0. Универсальные, подходят для большинства видов деятельности, простые в установке и работе.

25000 руб.

16.12.2019    34818    64    68    

39

Учет доходов и расходов БДР, БДДС Бюджетный учет Бизнес-аналитик Пользователь Руководитель проекта 8.3.14 Конфигурации 1cv8 1С:Управление торговлей 11 Беларусь Россия Казахстан Бюджетный учет Управленческий учет Платные (руб)

Как держать деньги под контролем с помощью 1С УНФ, УТ, КА, ERP или БП и 2 часов в неделю без внедрения бюджетирования и найма финансиста. Дополнение для 1С 8.3 Модуль реализован в виде конфигурации и рассчитан для собственников компаний с чистой прибылью до 10 млн руб. / мес. То есть, пока вам не рентабельно вести сложные модули типа «Бюджетирование», «Казначейство», но нужно знать, сколько платить на этой неделе и хватит ли средств, чтобы отложить в дивиденды, обучение сотрудников, закупку и ремонт оборудования

45000 руб.

20.07.2023    4371    7    0    

36

SALE! 50%

Производство готовой продукции (работ, услуг) Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Бухгалтерский учет Налоговый учет Платные (руб)

Данный отчет показывает себестоимость реализованной продукции в разузлованном виде, как с выделением входящих в нее полуфабрикатов любых уровней, так и свернутый до статей затрат и материалов, видов работ. Отчет работает независимо от метода оценки стоимости товаров и подходит для любых производственных компаний с многопередельным производством. Отчет можно использовать как в типовой 1С:ERP, так и в отраслевых решениях на ее базе (например, 1С:ERP Управление птицеводческим предприятием, Молокозавод и т.д.).Отчет подходит для анализа затрат на гособоронзаказы ГОЗ.

70000 35000 руб.

30.11.2022    12495    15    24    

20

Учет доходов и расходов Взаиморасчеты БДР, БДДС Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Мы доработали типовой платежный календарь, добавив в него планируемые постоянные расходы. Теперь можно видеть картину денежных средств в совокупности с текущей динамикой ожидаемых поступлений и расходов. Отчет позволяет увидеть остатки денежных средств в кассе и банке, их движение в разрезе статей ДДС с возможностью выбрать любой период (день, неделя, месяц). Данный отчет подходит для всех основных конфигураций линейки продуктов 1С:Предприятие 8.3 (8.3.18.1289): 1С:Бухгалтерия предприятия, редакция 3.0 (3.0.77.95), 1С:Управление торговлей, 1С:Комплексная автоматизация 2 (2.4.11.67), Объединенное решение: Модуль 1С:CRM 3 (3.0.21.3) +1С:ERP Управление предприятием 2 (2.4.13.111). Также есть возможность адаптации отчета под другие конфигурации. Мобильное приложение работает как на Android, так и на IOS.

2880 руб.

16.03.2021    21371    6    13    

26

SALE! 50%

Производство готовой продукции (работ, услуг) Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Данный отчет показывает себестоимость выпущенной продукции с разузлованием полуфабрикатов любых уровней, входящих в ее состав, до статей затрат и материалов. Отчет работает независимо от метода оценки стоимости товаров и подходит для любых производственных компаний с многопередельным производством. Отчет можно использовать как в типовой 1С:ERP, так и в отраслевых решениях на ее базе (например, 1С:ERP Управление птицеводческим предприятием и т.д.). Отчет подходит для анализа затрат на гособоронзаказы ГОЗ.

70000 35000 руб.

08.12.2021    25168    19    72    

32

Обмен с интернет-банком Банковские операции Программист Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Модуль представляет собой комплексную автоматизацию обмена данными 1С с банком для БП 3.0, ERP 2.4, ERP 2.5. Выписка клиент-банка загружается и обрабатывается по Вашим правилам. Заполнение реквизитов документов, анализ назначения платежа. Работа с клиент банком не отличается от типового варианта, а документы автоматически заполняются так, как нужно вам. Дополнительная обработка, работающая совместно с основным расширением позволяет подключать собственные произвольные алгоритмы.

20400 руб.

03.04.2013    124067    247    377    

161
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Nezu 06.07.22 15:08 Сейчас в теме
Добрый день!
Этот конструктор работает только при обмене ? из БП в УНФ
Или мы говорим про документы в УНФ , например если будет создан документ Приходная накладная и на его основании будет создан документ Расход из кассы , подставит ДДС по правилам?
2. con-men 184 18.07.22 08:53 Сейчас в теме
(1) В данном варианте установка ДДС привязана именно к событию обмена (синхронизации), но тут минимальные правки чтоб привязать это действие к примеру, к созданию нового документа или ввода на основании
Оставьте свое сообщение