Рекурсивный опрос FTP сервера

31.01.13

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Предлагаю вашему вниманию небольшую заметку по работе с FTP сервером. Рассмотрим поиск файлов по маске во всех каталогах ресурса. Для перехода во вложенные папки до самого нижнего уровня реализуем рекурсию. Можно конечно воспользоваться методом НайтиФайлы(<Путь>, <Маска>, <ИскатьВПодкаталогах>)  где указать в качестве 3-го параметра истину, но настройки безопасности большинства ресурсов в интернете не дадут вам этого сделать.

Скачать исходный код

Наименование Файл Версия Размер
Обработка рекурсивного опроса ftp сервера (управляемая форма).
.epf 10,68Kb
21
.epf 10,68Kb 21 Скачать

План работы:

  1. Подключаемся к FTP серверу на основании обязательных данных (адрес сервера, имя пользователя)
  2. Опрашиваем каждую папку сервера на предмет совпадения по максе с помощью рекурсии
  3. Выводим полученные данные в табличный документ.

 Подключаемся к ftp серверу:

&НаКлиенте
Функция ПодключитьсяКFTPСерверу(ИмяУзла = "", Порт = 21, ИмяПользователя = "anonymous", Пароль = "pochta@mail.ru", ПассивноеСоединение = Ложь, ТаймАут = 10)
    Попытка
        Состояние("Подключаюсь к FTP серверу ...");
        ФТП = Новый FTPСоединение(  ИмяУзла,
                                    Порт,
                                    "",
                                    "",
                                    ,
                                    ПассивноеСоединение,
                                    ТаймАут);
    Исключение
        Возврат ОписаниеОшибки();
    КонецПопытки;
    Возврат ФТП; 
КонецФункции

Все реквизиты необходимые для подключения функция получает через параметры. Это делает функцию универсальной. В операторных скобках "попытка" выполняется подключение к FTP серверу и в случае удачи возвращает объект FTP. Если в процессе подключения возникли ошибки, то функция вернёт строку с содержанием этой ошибки. К серверу подключились можно переходить ко 2 части плана, а именно рекурсивному опросу.

&НаКлиенте
//перебирает файлы на ФТП сервере рекурсивно
Процедура ПолучитьФайлыРекурсивно(ФТП = Неопределено, Каталог = "", МаскаФайлов = Неопределено)
	//без соединения опрашивать будет нечего
	Если ФТП = Неопределено Тогда
		Возврат;
	КонецЕсли;
    Состояние("Веду опрос каталога: " + Каталог);
    Попытка
        МасивFTPФайлов = ФТП.НайтиФайлы(Каталог,
                                    "*",
                                    Ложь);
    Исключение
        Сообщить(
            "Во время рекурсивного поиска файлов произошла исключительная ситуация:" +
            ОписаниеОшибки(),
            СтатусСообщения.Важное);
        Возврат;                            
    КонецПопытки;
    Для Каждого ЭлементМассива Из МасивFTPФайлов Цикл
		Если ЭлементМассива.ЭтоФайл() Тогда
			Если МаскаФайлов.НайтиПоЗначению("*" + ЭлементМассива.Расширение) <> Неопределено Тогда
				СтрокаТЗ                			= Объект.Файлы.Добавить();
				СтрокаТЗ.Путь           			= "ftp://" + ФТП.Сервер + ЭлементМассива.Путь + ЭлементМассива.Имя;
				СтрокаТЗ.РасширениеФайла 			= ЭлементМассива.Расширение;
				СтрокаТЗ.ДатаПоследнегоИзменения 	= ЭлементМассива.ПолучитьВремяИзменения();
				СтрокаТЗ.Размер         			= Окр(ЭлементМассива.Размер() / 1024, 2);
			КонецЕсли;
        ИначеЕсли ЭлементМассива.ЭтоКаталог()
            И ЭлементМассива.ПолноеИмя <> Лев(Каталог, СтрДлина(Каталог) - 1)
            И ЭлементМассива.Имя <> "."
            И ЭлементМассива.Имя <> ".." Тогда
            ПолучитьФайлыРекурсивно(ФТП, ЭлементМассива.ПолноеИмя, МаскаФайлов);
        КонецЕсли;    
    КонецЦикла;
КонецПроцедуры

Понять как работает рекурсивная процедура проще всего по схеме:

Схема рекурсивного вызова

Так как в массиве файлов, возвращаемым методом НайтиФайлы, есть и каталоги и файлы мы не выйдем из цикла пока не будет ни единого каталога. То есть мы опросим весь сервер. В процессе работы выполняется и 3 пункт нашей программы - заполнение табличной части информацией. Осталось только увязать наши механизмы в управляющей процедуре.

&НаКлиенте
Процедура ОпроситьFTP(Команда)
    ФТП = ПодключитьсяКFTPСерверу(    Объект.FTPСервер,
                                    Объект.Порт,
                                    Объект.ИмяПользователя, 
                                    Объект.Пароль,
                                    Объект.ПассивноеСоединение,
                                    Объект.ТаймАут);
                                    Если ТипЗнч(ФТП) <> Тип("Строка") Тогда
        СтрокаМасок = Объект.МаскаФайлов;
        СписокМасок = РазбитьСтрокуНаПодстроки(СтрокаМасок, ";");
        Объект.Файлы.Очистить();
        ПолучитьФайлыРекурсивно(ФТП, Объект.ОтносительныйКаталог, СписокМасок);
        Элементы.Закладки.ТекущаяСтраница = Элементы.РезультатыОпроса;
        //Элементы.Файлы.Обновить();
        //Сообщить("Нашлось: " + Объект.Файлы.Количество());
    Иначе
        Предупреждение(ФТП, 10);
    КонецЕсли;
КонецПроцедуры

Вотсобственно и всё. В качестве бонуса приведу процедурку выгружающую результаты опроса в эксель.

&НаКлиенте
Процедура ВыгрузитьВЭксель(Команда)
    Экс = Новый COMОбъект("excel.application");
    Книга = Экс.Workbooks.add();
    //удалим не нужные листы
    Для н = -Книга.Worksheets.Count По -2 Цикл
        Книга.Worksheets(1).Delete();
    КонецЦикла;
    Лист = Книга.Worksheets(1);
    Лист.Cells(1, 1).Value = "Путь";
    Лист.Cells(1, 2).Value = "Тип";
    Лист.Cells(1, 3).Value = "Изменён";
    Лист.Cells(1, 4).Value = "Размер (кб)";
    Лист.Range(Лист.Cells(1, 1), Лист.Cells(1, 4)).Font.Bold = Истина;
    Лист.Range(Лист.Cells(1, 1), Лист.Cells(1, 4)).Font.Size = 16;
    Лист.Range(Лист.Cells(1, 1), Лист.Cells(1, 4)).Interior.ColorIndex = 24;
    Лист.Name = "Содержимое FTP " + Объект.FTPСервер;
    Для Каждого СтрокаТЗ Из Объект.Файлы Цикл
        Лист.Cells(СтрокаТЗ.НомерСтроки + 1, 1).Value = СтрокаТЗ.Путь;
        Лист.Cells(СтрокаТЗ.НомерСтроки + 1, 2).Value = Сред(СтрокаТЗ.РасширениеФайла, 2);
        Лист.Cells(СтрокаТЗ.НомерСтроки + 1, 3).Value = СтрокаТЗ.ДатаПоследнегоИзменения;
        Лист.Cells(СтрокаТЗ.НомерСтроки + 1, 4).Value = СтрокаТЗ.Размер;
        //для чётных строк
        МаркерЧётности = (СтрокаТЗ.НомерСтроки + 1) / 2;
        Если МаркерЧётности = Цел(МаркерЧётности) Тогда
            Область = Лист.Range(Лист.Cells(СтрокаТЗ.НомерСтроки + 1, 1), Лист.Cells(СтрокаТЗ.НомерСтроки + 1, 4));
            Область.Interior.ColorIndex = 17;
        КонецЕсли;
    КонецЦикла;
    Лист.UsedRange().Columns.AutoFit();
    Экс.visible = Истина;
КонецПроцедуры

 

Хочу обратить ваше внимание на то, что настройки удалённого ftp сервера могут иметь свои особенности. Например можно запретить анонимному пользователю заходить в папки ниже 3 уровня вложенности, или ограничить по трафику в 200 кб. В связи с этим можно наблюдать не адекватность при выполнении обработки. Сама обработка представлена как показательный рекурсивный механизм и не преследует цель обработать все возможные исключительные ситуации в роботе по протоколу FTP.

Настроки подключения

Тыльная часть обработки


См. также

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    136629    729    292    

393

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69493    166    141    

112

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47486    203    64    

164

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    21068    138    38    

97

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34803    83    58    

81

SALE! 10%

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183615    565    508    

509

SALE! 10%

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 25200 руб.

24.06.2020    61673    45    27    

75

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    68403    41    124    

46
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. invertercant 22 21.10.13 11:32 Сейчас в теме
Мне вообще не удалось применить стандартную функцию НайтиФайлы в режиме поиска по подкаталогам. Даже для своего поднятого ftp-сервера, где есть полные права.
CWD ftp
550 CWD failed. "/ftp": directory not found.
Неправильно меняет директорию.
Кажется стандартная функция не работает по подкаталогам вообще.
2. makc2k 107 22.10.13 10:03 Сейчас в теме
Для самой правильной проверки рекомендую консольный ftp клиент. Там можно сделать скажем ls -r (вывод листинга содержимого каталога рекурсивно).
Оставьте свое сообщение