Импорт поступлений по родительской плате в документ "Кассовое поступление" для БГУ 2.0 из файлов выгрузки Сбербанка

13.03.23

Учетные задачи - Банковские операции

Внешняя обработка табличной части документа "Кассовое поступления" - позволяет загрузить данные по поступлению родительской платы из файла выгрузки Сбербанка (можно настроить под любой формат выгрузки).

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Импорт поступлений по родительской плате в документ "Кассовое поступление" для БГУ 2.0 из файлов выгрузки Сбербанка:
.epf 10,92Kb
38
38
5 SM
Скачать Купить за 3 050 руб.

Внешняя обработка табличной части документа "Кассовое поступление" в БГУ 2.0 для загрузки родительской платы из выгруженных реестров Сбербанка (теоретически можно настроить на любой формат, любого банка).

Тестировалась в конфигурации Бухгалтерия государственного учреждения, редакция 2.0 (2.0.89.48) 

Платформа 1С:Предприятие 8.3 (8.3.22.1750)

По сравнению с БГУ 1.0, во второй версии вместо документа "Поступление родительской платы" используется документ "Кассовое поступление", где надо поставить галочку признака родительской платы и сформировать табличную часть.

Была поставлена задача полного заполнения документа кассового поступления по кнопке из выгруженных реестров Сбербанка.

В итоге была сделана внешняя обработка табличной части для файлов выгрузки из клиент-банка Сбербанка формата (пример имени 01_дс1_03234643177350002800_260.y09):

 

Пример сформированного документа кассового поступления - все заполняется автоматически: галочка, счета, табличная часть, бухгалтерская операция. Документ может формироваться как с нуля, так и на основе уже сформированных кассовых поступлений, загруженных из СУФД. Все сделано для облегчения разноски родительской платы. Особенно для централизованных бухгалтерий. 

 

Установка происходит стандартно. В администрировании ставим галочку в разделе:

 

Потом выбираем

 

По кнопке добавить из файла - загружаем внешнюю обработку.

Должно получиться так:

 

После этого в документе кассового поступления появляется кнопка.

Которая сделает все автоматически.

Скорее всего обработка потребует настройки под себя.

Для этого ее надо открыть в конфигураторе и в коде формы поправить параметры.

Обработка простая и ее легко доработать под любые нужды.

 

Также, возможно, придется изменить код анализа лицевых счетов согласно комментариям кода!

Вы всегда можете спрашивать в комментариях что надо сделать, я оперативно отвечаю.

Перед загрузкой рекомендую показать ваш формат реестров и пример лицевых счетов!

реестр загрузка импорт родительская плата сбербанк кассовое поступление БГУ

См. также

SALE! 10%

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    138052    760    292    

404

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70336    173    146    

116

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21756    144    40    

104

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62326    51    27    

80

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184480    573    509    

516

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48385    208    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    69125    46    126    

49

SALE! %

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 27000 руб.

24.04.2015    192396    141    241    

272
Отзывы
69. Jek69 17.05.23 12:22 Сейчас в теме
Отличная работа!
Код снабжен развернутыми комментариями для небольших самостоятельных правок, если правки побольше - автор без проблем оперативно помогает.
Спасибо!
YA_514896950; +1 Ответить
106. Татуля 26.09.23 11:37 Сейчас в теме
(102) вроде разобралась))))
YA_514896950; +1 Ответить
68. mart1120 27.03.23 14:50 Сейчас в теме
Большое спасибо за помощь и оперативность! Все работает!
Остальные комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. YA_514896950 26 22.02.23 12:32 Сейчас в теме
На вопрос - "почему у вас такой код анализа лицевых счетов?", могу ответить что в нашей конфигурации так сложилось
что код лицевого счета ребенка имеет длину 10 символов, начинается с буквы Х как английской так и русской, именно поэтому
приходится делать такие проверки.
если у вас иная ситуация то просто в конфигураторе установите свою длину кода в начале процедуры модуля формы.
все параметры идут в начале
настроечные переменные

а так же измените эти строки
код
109. softline72 2 05.03.24 12:36 Сейчас в теме
(1)Добрый день, под этот файл какие нужно внести изменения?
Прикрепленные файлы:
Platn_7216005773_03234643716240006700_388 (1) — копия.txt
110. YA_514896950 26 05.03.24 13:48 Сейчас в теме
(109)что тут является полем лицевого счета?
да конечно надо вносить правки.
111. softline72 2 05.03.24 14:45 Сейчас в теме
(110)вот л/с
Прикрепленные файлы:
112. YA_514896950 26 05.03.24 14:49 Сейчас в теме
(111)
значит в начале обработки как описано в публикации правьте
НомерВреестреЛС = 4
НомерВреестрееСум=10
ДлинКодаЛС=12
и этого должно хватить
если что пишите.
2. Lemmonbri 127 22.02.23 14:41 Сейчас в теме
Тоже была идея выложить такую штуку сюда, но сразу же отказался от неё, каждый клиент - каждый раз переделываем по особенности ведения учета. А по ту сторону сидят бухгалтера, которые вряд ли поправят эти параметры вручную.
3. YA_514896950 26 22.02.23 19:51 Сейчас в теме
(2)ну может кому то и пригодится....аналог в виде обработки у кого то почти 50 раз скачали)
а править моем случае мало чего надо....там не сложно.
даже не программист а просто тот кто обновляет базы - справится.
4. Ashny 01.03.23 14:16 Сейчас в теме
а у меня ваша обработка не работает совсем..
файл вам присылала свой.не видит детей
помогите плз
срочно надо
деньги то заплатили
5. YA_514896950 26 01.03.23 14:38 Сейчас в теме
(4)
под ваш формат надо исправить код
первые 52 строки кода формы замените в конфигураторе вот так и сохраните.
ваш файл должен начинаться со слова реестр и удалите из него строки дублей (пока можете попробовать оставить)

код
6. YA_514896950 26 02.03.23 08:44 Сейчас в теме
(4) ваш код первых 72 строк модуля формы с правильной загрузкой под ваш формат
Код начала модуля формы
7. Ashny 02.03.23 09:59 Сейчас в теме
(6) {ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(178,17)}: Обнаружено логическое завершение исходного текста модуля
~НеВыбралиФайл:<<?>> (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(178,17)}: Обнаружено логическое завершение исходного текста модуля
~НеВыбралиФайл:<<?>> (Проверка: Тонкий клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Тонкий клиент)

(6) ошибки при отладке
8. YA_514896950 26 02.03.23 10:07 Сейчас в теме
(7)
Обнаружено логическое завершение исходного текста модуля

вот тот код что я скинул вам, его надо поместить в начало модуля до
&НаСервере
Процедура ЗапНаСервере(Объект, мас, пар)

то есть все что перед этим удалить, и вставить код
9. Ashny 02.03.23 10:14 Сейчас в теме
(28) выдает ошибки при отладке

(8)все проверила несколько раз
10. YA_514896950 26 02.03.23 10:16 Сейчас в теме
(9)
Скрытый текст
11. Ashny 02.03.23 10:20 Сейчас в теме
(10)
(10)
&НаКлиенте
//Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт 
//	НомерВреестреЛС = 7;
//    НомерВреестреСум = 11;
//    НомерВреестреФио = 6;
//    ДлинаКодаЛс=10;

//	мПар = новый Структура("мКорСч,мИстФин,мИстСр,мКБКназн,мКОСГУназн"); 
//	//-----------------------НАСТРОЙКИ ЗАПОЛНЕНИЯ ТАБЛИЧНОЙ ЧАСТИ---------------
//	
//	мПар.мКорСч= "205.00";
//	//мПар.мИстФин= "Местный бюджет";
//    мПар.мИстСр= "06"; //средства юрлиц
//    мПар.мКБКназн = "07011000004003130";
//    мПар.мКОСГУназн = "131";
//	//--------------------------------------------------------------------------
//	//-----------------------НАСТРОЙКИ ЗАПОЛНЕНИЯ БУХ. ОПЕРАЦИИ-----------------
//	мПар2 = новый Структура("мСчПост,КПС_20110,ПроводкиИсполненияПлана");
//	мПар2.мСчПост = "201.11";	    
//	мПар2.КПС_20110 = "00000000000000000";   
//	мПар2.ПроводкиИсполненияПлана = Истина; //формировать проводки по исполнению плана доходов? 
//	//--------------------------------------------------------------------------
//	            
//    Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
//       Если Диалог.Выбрать() Тогда
//         ФайлРеестра = Диалог.ПолноеИмяФайла;
//      иначе
//     Перейти ~НеВыбралиФайл;
//     КонецЕсли;
//Текст = Новый ТекстовыйДокумент;
//Текст.Прочитать(ФайлРеестра);

//масс = новый массив;
//Если Найти(ФайлРеестра,"\реестр")<>0 тогда //файл реестра сбера У НАС ВСЕГДА НАЧИНАЕТСЯ С 01_, поправьте если у вас не так - на ваш случай

//Для Сч = 1 по Текст.КоличествоСтрок() Цикл
//СтрокаРеестра = Текст.ПолучитьСтроку(Сч);
//СтруктураПлатежа = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(СтрокаРеестра,";");
////проверяем дошли до конца файла или нет
//Если (СтруктураПлатежа.Количество() = 6 или СтруктураПлатежа.Количество() = 7) И Сч = Текст.КоличествоСтрок() Тогда
//Прервать;
//КонецЕсли;
//ЛицевойСчет = Прав(СтруктураПлатежа[НомерВреестреЛС],СтрДлина(СтруктураПлатежа[НомерВреестреЛС])-СтрНайти(СтруктураПлатежа[НомерВреестреЛС]," ",НаправлениеПоиска.СКонца));
//Назначение = СтруктураПлатежа[9]; //не используется
//Сумма = Число(СтруктураПлатежа[НомерВреестреСум]);
//элт = Новый Структура("ЛС,СУМ,ФИО");
//элт.ЛС = ЛицевойСчет;
//элт.СУМ = Сумма;
//элт.ФИО = СтруктураПлатежа[НомерВреестреФио];
//масс.Добавить(элт);
//КонецЦикла;
//КонецЕсли;
 //&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт
//НАСТРОЙКА ОСНОВНЫХ ПАРАМЕТРОВ
НомерВреестреЛС = 7;
НомерВреестреСум = 11;
НомерВреестреФио = 6;
ДлинаКодаЛс=10;

мПар = новый Структура("мКорСч,мИстФин,мИстСр,мКБКназн,мКОСГУназн");
//-----------------------НАСТРОЙКИ ЗАПОЛНЕНИЯ ТАБЛИЧНОЙ ЧАСТИ---------------
мПар.мКорСч= "205.00";
мПар.мИстФин= "Местный бюджет";
мПар.мИстСр= "06"; //средства юрлиц
мПар.мКБКназн = "07010000000000130";
мПар.мКОСГУназн = "131";
//--------------------------------------------------------------------------
//-----------------------НАСТРОЙКИ ЗАПОЛНЕНИЯ БУХ. ОПЕРАЦИИ-----------------
мПар2 = новый Структура("мСчПост,КПС_20110,ПроводкиИсполненияПлана");
мПар2.мСчПост = "201.11";
мПар2.КПС_20110 = "00000000000000000";
мПар2.ПроводкиИсполненияПлана = Истина; //формировать проводки по исполнению плана доходов?
//--------------------------------------------------------------------------

Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Если Диалог.Выбрать() Тогда
ФайлРеестра = Диалог.ПолноеИмяФайла;
иначе
Перейти ~НеВыбралиФайл;
КонецЕсли;
Текст = Новый ТекстовыйДокумент;
Текст.Прочитать(ФайлРеестра);

масс = новый массив;
Если Найти(ФайлРеестра,"\реестр")<>0 тогда //файл реестра сбера У НАС ВСЕГДА НАЧИНАЕТСЯ С 01_, поправьте если у вас не так - на ваш случай

Для Сч = 1 по Текст.КоличествоСтрок() Цикл
СтрокаРеестра = Текст.ПолучитьСтроку(Сч);
СтруктураПлатежа = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(СтрокаРеестра,";");
//проверяем дошли до конца файла или нет
Если (СтруктураПлатежа.Количество() = 6 или СтруктураПлатежа.Количество() = 7) И Сч = Текст.КоличествоСтрок() Тогда
Прервать;
КонецЕсли;
ЛицевойСчет = Прав(СтруктураПлатежа[НомерВреестреЛС],СтрДлина(СтруктураПлатежа[НомерВреестреЛС])-СтрНайти(СтруктураПлатежа[НомерВреестреЛС]," ",НаправлениеПоиска.СКонца));
Назначение = СтруктураПлатежа[9]; //не используется
Сумма = Число(СтруктураПлатежа[НомерВреестреСум]);
элт = Новый Структура("ЛС,СУМ,ФИО");
элт.ЛС = ЛицевойСчет;
элт.СУМ = Сумма;
элт.ФИО = СтруктураПлатежа[НомерВреестреФио];
масс.Добавить(элт);
КонецЦикла;
КонецЕсли;

ОбъектФормы = ВладелецФормы.Объект;
//заполняем объект данными
ЗапНаСервере(ОбъектФормы,масс,мПар);
КопироватьДанныеФормы(ОбъектФормы, ВладелецФормы.Объект);
ВладелецФормы.ОбновитьОтображениеДанных();
//включаем флажок род платы
ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
ВладелецФормы.Элементы, "РасшифровкаПлатежаРебенок", "Видимость", ИСТИНА);
ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
ВладелецФормы.Элементы, "РасшифровкаПлатежаКонтрагент", "Видимость", НЕ ИСТИНА);

ВладелецФормы.Записать();
//заполняем бух операцию
запбо(ОбъектФормы,мПар2);
//обновляем данные
ВладелецФормы.Прочитать();
ВладелецФормы.ОбновитьОтображениеДанных();
~НеВыбралиФайл:
КонецПроцедуры

		//***********	 
	Если Найти(ФайлРеестра,"\01_")=0 тогда    // не сбер - пример разделения, код надо настраивать  по аналогии ВЫШЕ
	Для Сч = 1 по Текст.КоличествоСтрок() Цикл
		
		СтрокаРеестра = Текст.ПолучитьСтроку(Сч);
		
		СтруктураПлатежа = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(СтрокаРеестра,";");
		
		Если СтруктураПлатежа.Количество() = 6 И Сч = Текст.КоличествоСтрок() Тогда
			Прервать;
		КонецЕсли;
		
		Если СтруктураПлатежа.Количество() <> 15 Тогда
			Сообщить("Не могу разобрать строку №" + Строка(Сч + 1) + ", ожидается 15 полей, а получено: " + СтруктураПлатежа.Количество());
			Сообщить(СтрокаРеестра);
			Продолжить;
		КонецЕСли;
		
		Если СтрДлина(СтруктураПлатежа[6])=5 тогда
			ЛицевойСчет = "X0000" + СтруктураПлатежа[6];
		ИначеЕсли СтрДлина(СтруктураПлатежа[6])=6 тогда
			ЛицевойСчет = "X000" + СтруктураПлатежа[6];
		ИначеЕсли СтрДлина(СтруктураПлатежа[6])=10 тогда
			//ЗАКОММЕНТИРОВАТЬ ЕСЛИ У ВАС ЛИЦЕВЫЕ СЧЕТА БЕЗ Х
			ЛицевойСчет = "X" + Прав(СтруктураПлатежа[6],СтрДлина(СтруктураПлатежа[6])-1);
			//Сообщить(ЛицевойСчет);
		Иначе
			Сообщить("Лицевой счет не опознан " + СтрокаРеестра);
			ЛицевойСчет = "";
		конецесли;
		Назначение = СтруктураПлатежа[10];
		Сумма = Число(СтруктураПлатежа[12]);
		
		 элт = Новый Структура("ЛС,СУМ,ФИО");
		 элт.ЛС = ЛицевойСчет;
		 элт.СУМ = Сумма; 
		 элт.ФИО = СтруктураПлатежа[8];	
		 масс.Добавить(элт);

	КонецЦикла;
    КонецЕсли;
    ОбъектФормы = ВладелецФормы.Объект;     
	//заполняем объект данными
	ЗапНаСервере(ОбъектФормы,масс,мПар);       
	КопироватьДанныеФормы(ОбъектФормы, ВладелецФормы.Объект);
	ВладелецФормы.ОбновитьОтображениеДанных();  
	//вклюючаем флажок род платы
	ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
	ВладелецФормы.Элементы, "РасшифровкаПлатежаРебенок", "Видимость", ИСТИНА);
	ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
	ВладелецФормы.Элементы, "РасшифровкаПлатежаКонтрагент", "Видимость", НЕ ИСТИНА); 
	
	ВладелецФормы.Записать();  
	//заполняем бух операцию
	запбо(ОбъектФормы,мПар2);  
	//обновляем данные
    ВладелецФормы.Прочитать();  
 	ВладелецФормы.ОбновитьОтображениеДанных();  
	~НеВыбралиФайл:
КонецПроцедуры
 
&НаСервере
Процедура ЗапНаСервере(Объект, мас, пар)
 		ссылка = Документы.КассовоеПоступление.НайтиПоНомеру(Объект.Номер,ТекущаяДата());   
		//Сообщить(ссылка);   
		обе = ссылка.ПолучитьОбъект();
		
		ОбъектНазначения = Объект;
		ОбъектНазначения.РодительскаяПлата = Истина; 		
		ОбъектНазначения.КорСчет = ПланыСчетов.ЕПСБУ.НайтиПоКоду(пар.мКорСч);
		ОбъектНазначения.ИФО = Справочники.ИсточникиФинансовогоОбеспечения.НайтиПоНаименованию(пар.мИстФин);		   
		обс = 0;   
		ОбъектНазначения.РасшифровкаПлатежа.Очистить();
		для каждого м из мас цикл         
		стр = ОбъектНазначения.РасшифровкаПлатежа.Добавить();  
		стр.СуммаВал = м.СУМ;  
		обс = обс + м.СУМ;     
		//-----------------------------Пытаемся определить ребенка по ЛИЦЕВОМУ-------------
		//Сообщить(м.ЛС);
		стр.Ребенок = Справочники.Дети.НайтиПоКоду(м.ЛС); 
		//Сообщить(Строка(стр.Ребенок) + " = " + Строка(стр.Ребенок.Организация));
		стр.Контрагент =  ОбщегоНазначения.ЗначениеРеквизитаОбъекта(стр.Ребенок, "Контрагент");
		если стр.Ребенок.Пустая() или стр.Ребенок.Организация <> ОбъектНазначения.Организация  тогда 
			стр.Ребенок = Справочники.Дети.НайтиПоКоду("Х"+Прав(м.ЛС,9));//тут пробуем русскую Х 
			стр.Контрагент =  ОбщегоНазначения.ЗначениеРеквизитаОбъекта(стр.Ребенок, "Контрагент");
		//Сообщить(Строка(стр.Ребенок) + " \ " + стр.Ребенок.Организация); 
		если  стр.Ребенок.Организация <> ОбъектНазначения.Организация тогда
			стр.Ребенок=Неопределено;	
			стр.Контрагент=Неопределено;
		КонецЕсли;
		конецесли; 
		//---------------------------------------------------------------------------------
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ РАЗРЕШЕННЫЕ
		|	СоставГруппДДУ.ГруппаДетскогоУчреждения КАК ГруппаДетскогоУчреждения,
		|	СоставГруппДДУ.СтавкаОплаты КАК СтавкаОплаты,
		|	СоставГруппДДУ.Льгота КАК Льгота,
		|	СоставГруппДДУ.Договор КАК Договор,
		|	СоставГруппДДУ.Период КАК Период,
		|	СоставГруппДДУ.Актуальность КАК Актуальность
		|ИЗ
		|	РегистрСведений.СоставГруппДДУ КАК СоставГруппДДУ
		|ГДЕ
		|	СоставГруппДДУ.Ребенок = &Ребенок
		|
		|УПОРЯДОЧИТЬ ПО
		|	Период";
	
	Запрос.УстановитьПараметр("Ребенок", стр.Ребенок);
	РезультатЗапроса = Запрос.Выполнить(); 
	р = РезультатЗапроса.Выбрать(); 
	р.Следующий();
	//Сообщить(р.Договор);     
	стр.Договор = р.Договор; 
	
	стр.ИсточникСредств = Справочники.ИсточникиСредств.НайтиПоКоду(пар.мИстСр).Ссылка;  
	если стр.Ребенок.Пустая() или стр.Ребенок=Неопределено тогда
	стр.Примечание = "не найдено! ФИО = "+м.ФИО+" "+ТекущаяДата();	 
	Сообщить(стр.Примечание);
	иначе
	стр.Примечание = "импорт реестра успешен "+ТекущаяДата();
	КонецЕсли;
	стр.КФО = Перечисления.КВД.Внебюджет;  
	стр.КБКНазначениеПлатежа = Справочники.КлассификационныеПризнакиСчетов.НайтиПоКоду(пар.мКБКназн).Ссылка;
	стр.КОСГУНазначениеПлатежа = Справочники.КОСГУ.НайтиПоКоду(пар.мКОСГУназн).Ссылка;  
	конеццикла;
	
	ОбъектНазначения.СуммаДокументаВВалюте=обс;  	
КонецПроцедуры        

&НаСервере
Процедура запбо(Объект,пар) 
	ссылка = Документы.КассовоеПоступление.НайтиПоНомеру(Объект.Номер,ТекущаяДата());   
		//Сообщить(ссылка);   
	обе = ссылка.ПолучитьОбъект();
	то = Справочники.ТиповыеОперации.НайтиПоНаименованию("Поступление родительской платы");//тип операции   
	
	ректип = Справочники.ТиповыеОперации.ДополнительныеРеквизитыТиповойОперации(то);  
	ДополнительныеРеквизиты = Новый Структура("СчетПоступления", ПланыСчетов.ЕПСБУ.НайтиПоКоду(пар.мСчПост));  
	ДополнительныеРеквизиты.Вставить("КПС_20110",Справочники.КлассификационныеПризнакиСчетов.НайтиПоКоду(пар.КПС_20110).Ссылка);
	ДополнительныеРеквизиты.Вставить("ПроводкиИсполненияПлана",пар.ПроводкиИсполненияПлана);
	БухгалтерскиеОперацииСервер.ДобавитьДанныеДляПроведения(обе,то,ДополнительныеРеквизиты,Ложь);    
	обе.Записать(РежимЗаписиДокумента.Запись);
КонецПроцедуры

&НаСервере
Функция ИщемТО()
	Возврат Справочники.ТиповыеОперации.НайтиПоНаименованию("Поступление родительской платы");   
КонецФункции      
Показать


во то что вставила
все равно ошибки
12. YA_514896950 26 02.03.23 10:27 Сейчас в теме
(11)
скопировано не правильно

~НеВыбралиФайл:
КонецПроцедуры

после него лишнее
должно сразу быть

&НаСервере
Процедура запбо(Объект,пар)

смотрите внимательнее
13. Ashny 02.03.23 10:42 Сейчас в теме
(12)
(12)Скопировала 72 строки,
заремила остальное все

оставила
&НаСервере
Процедура запбо(Объект,пар) 
	ссылка = Документы.КассовоеПоступление.НайтиПоНомеру(Объект.Номер,ТекущаяДата());   
		//Сообщить(ссылка);   
	обе = ссылка.ПолучитьОбъект();
	то = Справочники.ТиповыеОперации.НайтиПоНаименованию("Поступление родительской платы");//тип операции   
	
	ректип = Справочники.ТиповыеОперации.ДополнительныеРеквизитыТиповойОперации(то);  
	ДополнительныеРеквизиты = Новый Структура("СчетПоступления", ПланыСчетов.ЕПСБУ.НайтиПоКоду(пар.мСчПост));  
	ДополнительныеРеквизиты.Вставить("КПС_20110",Справочники.КлассификационныеПризнакиСчетов.НайтиПоКоду(пар.КПС_20110).Ссылка);
	ДополнительныеРеквизиты.Вставить("ПроводкиИсполненияПлана",пар.ПроводкиИсполненияПлана);
	БухгалтерскиеОперацииСервер.ДобавитьДанныеДляПроведения(обе,то,ДополнительныеРеквизиты,Ложь);    
	обе.Записать(РежимЗаписиДокумента.Запись);
КонецПроцедуры

&НаСервере
Функция ИщемТО()
	Возврат Справочники.ТиповыеОперации.НайтиПоНаименованию("Поступление родительской платы");   
КонецФункции      
Показать



не работает
14. YA_514896950 26 02.03.23 10:51 Сейчас в теме
15. Ashny 02.03.23 10:52 Сейчас в теме
(14) при отладке ошибок нет, но совсем ничего не заполняет
таблица пустая
и ничего не сообщает
что то не так
16. YA_514896950 26 02.03.23 10:56 Сейчас в теме
попробуйте полностью заменить на мой код модуль формы
как минимум сообщения должны выдаваться

&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт 
	//НАСТРОЙКА ОСНОВНЫХ ПАРАМЕТРОВ
	НомерВреестреЛС = 7;      
	НомерВреестреСум = 11;
	НомерВреестреФио = 6;  
	ДлинаКодаЛс=10;

	мПар = новый Структура("мКорСч,мИстФин,мИстСр,мКБКназн,мКОСГУназн"); 
	//-----------------------НАСТРОЙКИ ЗАПОЛНЕНИЯ ТАБЛИЧНОЙ ЧАСТИ---------------
	мПар.мКорСч= "205.00"; 
	мПар.мИстФин= "Местный бюджет"; 
	мПар.мИстСр= "06"; //средства юрлиц 
	мПар.мКБКназн  = "07010000000000130";   
	мПар.мКОСГУназн  = "131";
	//--------------------------------------------------------------------------
	//-----------------------НАСТРОЙКИ ЗАПОЛНЕНИЯ БУХ. ОПЕРАЦИИ-----------------
	мПар2 = новый Структура("мСчПост,КПС_20110,ПроводкиИсполненияПлана");
	мПар2.мСчПост = "201.11";	    
	мПар2.КПС_20110 = "00000000000000000";   
	мПар2.ПроводкиИсполненияПлана = Истина; //формировать проводки по исполнению плана доходов? 
	//--------------------------------------------------------------------------
	
	Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	Если Диалог.Выбрать() Тогда
		ФайлРеестра = Диалог.ПолноеИмяФайла; 
	иначе	
		Перейти  ~НеВыбралиФайл;
	КонецЕсли;
	Текст = Новый ТекстовыйДокумент;
	Текст.Прочитать(ФайлРеестра);
	
	масс = новый массив;
	Если Найти(ФайлРеестра,"\реестр")<>0 тогда //файл реестра сбера У НАС ВСЕГДА НАЧИНАЕТСЯ С 01_, поправьте если у вас не так - на ваш случай
		  
		Для Сч = 1 по Текст.КоличествоСтрок() Цикл
		СтрокаРеестра = Текст.ПолучитьСтроку(Сч);
		СтруктураПлатежа = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(СтрокаРеестра,";");
		//проверяем дошли до конца файла или нет
		Если (СтруктураПлатежа.Количество() = 6 или СтруктураПлатежа.Количество() = 7) И Сч = Текст.КоличествоСтрок() Тогда
			Прервать;
		КонецЕсли;
			ЛицевойСчет = Прав(СтруктураПлатежа[НомерВреестреЛС],СтрДлина(СтруктураПлатежа[НомерВреестреЛС])-СтрНайти(СтруктураПлатежа[НомерВреестреЛС]," ",НаправлениеПоиска.СКонца));                                                                                                            
		Назначение = СтруктураПлатежа[9]; //не используется
		Сумма = Число(СтруктураПлатежа[НомерВреестреСум]);
		 элт = Новый Структура("ЛС,СУМ,ФИО");
		 элт.ЛС = ЛицевойСчет;
		 элт.СУМ = Сумма; 
		 элт.ФИО = СтруктураПлатежа[НомерВреестреФио];		 
		 масс.Добавить(элт);
		КонецЦикла;
	КонецЕсли;    
			 
    ОбъектФормы = ВладелецФормы.Объект;     
	//заполняем объект данными
	ЗапНаСервере(ОбъектФормы,масс,мПар);       
	КопироватьДанныеФормы(ОбъектФормы, ВладелецФормы.Объект);
	ВладелецФормы.ОбновитьОтображениеДанных();  
	//включаем флажок род платы
	ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
	ВладелецФормы.Элементы, "РасшифровкаПлатежаРебенок", "Видимость", ИСТИНА);
	ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(
	ВладелецФормы.Элементы, "РасшифровкаПлатежаКонтрагент", "Видимость", НЕ ИСТИНА); 
	
	ВладелецФормы.Записать();  
	//заполняем бух операцию
	запбо(ОбъектФормы,мПар2);  
	//обновляем данные
    ВладелецФормы.Прочитать();  
 	ВладелецФормы.ОбновитьОтображениеДанных();  
	~НеВыбралиФайл:
КонецПроцедуры
 
&НаСервере
Процедура ЗапНаСервере(Объект, мас, пар)
 		ссылка = Документы.КассовоеПоступление.НайтиПоНомеру(Объект.Номер,ТекущаяДата());   
		//Сообщить(ссылка);   
		обе = ссылка.ПолучитьОбъект();
		
		ОбъектНазначения = Объект;
		ОбъектНазначения.РодительскаяПлата = Истина; 		
		ОбъектНазначения.КорСчет = ПланыСчетов.ЕПСБУ.НайтиПоКоду(пар.мКорСч);
		ОбъектНазначения.ИФО = Справочники.ИсточникиФинансовогоОбеспечения.НайтиПоНаименованию(пар.мИстФин);		   
		обс = 0;   
		ОбъектНазначения.РасшифровкаПлатежа.Очистить();
		для каждого м из мас цикл         
		стр = ОбъектНазначения.РасшифровкаПлатежа.Добавить();  
		стр.СуммаВал = м.СУМ;  
		обс = обс + м.СУМ;     
		//-----------------------------Пытаемся определить ребенка по ЛИЦЕВОМУ-------------
		//Сообщить(м.ЛС);
		стр.Ребенок = Справочники.Дети.НайтиПоКоду(м.ЛС); 
		//Сообщить(Строка(стр.Ребенок) + " = " + Строка(стр.Ребенок.Организация));
		стр.Контрагент =  ОбщегоНазначения.ЗначениеРеквизитаОбъекта(стр.Ребенок, "Контрагент");
		если стр.Ребенок.Пустая() или стр.Ребенок.Организация <> ОбъектНазначения.Организация  тогда 
			стр.Ребенок = Справочники.Дети.НайтиПоКоду("Х"+Прав(м.ЛС,9));//тут пробуем русскую Х 
			стр.Контрагент =  ОбщегоНазначения.ЗначениеРеквизитаОбъекта(стр.Ребенок, "Контрагент");
		//Сообщить(Строка(стр.Ребенок) + " \ " + стр.Ребенок.Организация); 
		если  стр.Ребенок.Организация <> ОбъектНазначения.Организация тогда
			стр.Ребенок=Неопределено;	
			стр.Контрагент=Неопределено;
		КонецЕсли;
		конецесли; 
		//---------------------------------------------------------------------------------
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ РАЗРЕШЕННЫЕ
		|	СоставГруппДДУ.ГруппаДетскогоУчреждения КАК ГруппаДетскогоУчреждения,
		|	СоставГруппДДУ.СтавкаОплаты КАК СтавкаОплаты,
		|	СоставГруппДДУ.Льгота КАК Льгота,
		|	СоставГруппДДУ.Договор КАК Договор,
		|	СоставГруппДДУ.Период КАК Период,
		|	СоставГруппДДУ.Актуальность КАК Актуальность
		|ИЗ
		|	РегистрСведений.СоставГруппДДУ КАК СоставГруппДДУ
		|ГДЕ
		|	СоставГруппДДУ.Ребенок = &Ребенок
		|
		|УПОРЯДОЧИТЬ ПО
		|	Период";
	
	Запрос.УстановитьПараметр("Ребенок", стр.Ребенок);
	РезультатЗапроса = Запрос.Выполнить(); 
	р = РезультатЗапроса.Выбрать(); 
	р.Следующий();
	//Сообщить(р.Договор);     
	стр.Договор = р.Договор; 
	
	стр.ИсточникСредств = Справочники.ИсточникиСредств.НайтиПоКоду(пар.мИстСр).Ссылка;  
	если стр.Ребенок.Пустая() или стр.Ребенок=Неопределено тогда
	стр.Примечание = "не найдено! ФИО = "+м.ФИО+" "+ТекущаяДата();	 
	Сообщить(стр.Примечание);
	иначе
	стр.Примечание = "импорт реестра успешен "+ТекущаяДата();
	КонецЕсли;
	стр.КФО = Перечисления.КВД.Внебюджет;  
	стр.КБКНазначениеПлатежа = Справочники.КлассификационныеПризнакиСчетов.НайтиПоКоду(пар.мКБКназн).Ссылка;
	стр.КОСГУНазначениеПлатежа = Справочники.КОСГУ.НайтиПоКоду(пар.мКОСГУназн).Ссылка;  
	конеццикла;
	
	ОбъектНазначения.СуммаДокументаВВалюте=обс;  	
КонецПроцедуры        

&НаСервере
Процедура запбо(Объект,пар) 
	ссылка = Документы.КассовоеПоступление.НайтиПоНомеру(Объект.Номер,ТекущаяДата());   
		//Сообщить(ссылка);   
	обе = ссылка.ПолучитьОбъект();
	то = Справочники.ТиповыеОперации.НайтиПоНаименованию("Поступление родительской платы");//тип операции   
	
	ректип = Справочники.ТиповыеОперации.ДополнительныеРеквизитыТиповойОперации(то);  
	ДополнительныеРеквизиты = Новый Структура("СчетПоступления", ПланыСчетов.ЕПСБУ.НайтиПоКоду(пар.мСчПост));  
	ДополнительныеРеквизиты.Вставить("КПС_20110",Справочники.КлассификационныеПризнакиСчетов.НайтиПоКоду(пар.КПС_20110).Ссылка);
	ДополнительныеРеквизиты.Вставить("ПроводкиИсполненияПлана",пар.ПроводкиИсполненияПлана);
	БухгалтерскиеОперацииСервер.ДобавитьДанныеДляПроведения(обе,то,ДополнительныеРеквизиты,Ложь);    
	обе.Записать(РежимЗаписиДокумента.Запись);
КонецПроцедуры

&НаСервере
Функция ИщемТО()
	Возврат Справочники.ТиповыеОперации.НайтиПоНаименованию("Поступление родительской платы");   
КонецФункции      
Показать
17. Ashny 02.03.23 11:19 Сейчас в теме
(14) заменила все

(16) заменила все
теперь при отладке снова ошибки
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(94,18)}: Переменная не определена (ОбщегоНазначения)
стр.Контрагент = <<?>>ОбщегоНазначения.ЗначениеРеквизитаОбъекта(стр.Ребенок, "Контрагент"); (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(97,18)}: Переменная не определена (ОбщегоНазначения)
стр.Контрагент = <<?>>ОбщегоНазначения.ЗначениеРеквизитаОбъекта(стр.Ребенок, "Контрагент"); (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(155,1)}: Переменная не определена (БухгалтерскиеОперацииСервер)
<<?>>БухгалтерскиеОперацииСервер.ДобавитьДанныеДляПроведения(обе,то,ДополнительныеРеквизиты,Ложь); (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(38,20)}: Переменная не определена (СтроковыеФункцииКлиентСервер)
СтруктураПлатежа = <<?>>СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(СтрокаРеестра,";"); (Проверка: Тонкий клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(60,1)}: Переменная не определена (ОбщегоНазначенияКлиентСервер)
<<?>>ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы( (Проверка: Тонкий клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(62,1)}: Переменная не определена (ОбщегоНазначенияКлиентСервер)
<<?>>ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы( (Проверка: Тонкий клиент)
18. YA_514896950 26 02.03.23 11:24 Сейчас в теме
(17) заменили именно модуль формы?
19. Ashny 02.03.23 11:25 Сейчас в теме
20. YA_514896950 26 02.03.23 11:27 Сейчас в теме
(19) тогда таких ошибок быть не должно
22. Ashny 02.03.23 11:29 Сейчас в теме
(20)тогда я не знаю
ошибки пишет
вот ваша обработка
25. YA_514896950 26 02.03.23 11:34 Сейчас в теме
(22)у меня этот файл работает
27. YA_514896950 26 02.03.23 11:35 Сейчас в теме
(22)вы обновили в самой 1с внешнюю обработку?
потому что сейчас все работает....
21. YA_514896950 26 02.03.23 11:27 Сейчас в теме
у меня сейчас этот код на вашем реестре отрабатывает - сообщает лицевые счета
23. Ashny 02.03.23 11:29 Сейчас в теме
(21) что делаю не так посмотрите
24. YA_514896950 26 02.03.23 11:31 Сейчас в теме
26. YA_514896950 26 02.03.23 11:35 Сейчас в теме
(23)запустил - все работает.
28. YA_514896950 26 02.03.23 11:37 Сейчас в теме
(23)
Прикрепленные файлы:
29. Ashny 02.03.23 11:47 Сейчас в теме
(28)открыла в конфигураторе вашу обработку
внешний отчет и в форме модуля все поменяла
а эти сообщения не найдено фио что означают?
30. YA_514896950 26 02.03.23 11:48 Сейчас в теме
(29) то что у меня в базе ваших детей нет.
при этом сам документ формируется без ошибок
31. YA_514896950 26 02.03.23 11:48 Сейчас в теме
(29)теперь в 1с ее обновите из файла
32. Ashny 02.03.23 11:55 Сейчас в теме
(31) Я ТАК И ДЕЛАЮ
у меня при отладке в конфигураторе ошибки
33. YA_514896950 26 02.03.23 11:58 Сейчас в теме
(32)я не знаю что значит при отладке в конфигураторе.
я скачал ваш файл, загрузил его в 1с согласно инструкции, потом импортировал ваш файл реестра в кассовое.
никаких проблем.
34. YA_514896950 26 02.03.23 11:59 Сейчас в теме
(32)инструкцию смотрите в публикации
35. Ashny 02.03.23 12:10 Сейчас в теме
(34)
(34) я все так и делаю
в табличной части не встает ни один контрагент
только суммы и все
и пишет не найдено фамилии
36. Ashny 02.03.23 12:24 Сейчас в теме
(34) в конфигураторе я нажимаю на кнопку проверка модуля
и пишет ошибки
сохранила так
по этому файлу из сбербанка все сработало
взяла другой файл вобще ничего
у меня 46 шт этих детских садов
Прикрепленные файлы:
дс34.y15
37. YA_514896950 26 02.03.23 12:26 Сейчас в теме
40. Ashny 02.03.23 12:33 Сейчас в теме
(37)да спасибо
сработало
но только мне непонятно про сообщения при проверке модуля файла в конфигураторе
не обращать внимания или как?
41. YA_514896950 26 02.03.23 12:34 Сейчас в теме
(40)в конфигураторе не знаю что у вас....не обращайте внимания
42. Ashny 02.03.23 12:57 Сейчас в теме
(41) спасибо вам
вытерпили меня
а еще вопрос? мне надо в регистрах сведений по детям поменять плательщика и ставки
из бгу 1.0 эти реквизиты не перенеслись
детей много 4000 т. чел каждого переделать , очень хлопотно
подскажи как лучше сделать?
может какая обработка есть у вас
43. YA_514896950 26 02.03.23 13:01 Сейчас в теме
(42)тут нужна более подробная информация....
вообще не могло не перенестись....
а что значит поменять плательщика?
теоретически обработку написать можно - но надо смотреть более конкретно задание.
44. Ashny 02.03.23 13:04 Сейчас в теме
(43) в справочнике дети нет плательщика
пустое значение
надо поставить просто одно значение
родитель
45. YA_514896950 26 02.03.23 13:05 Сейчас в теме
(44) а как обработка узнает какого родителя надо поставить ребенку?
46. Ashny 02.03.23 13:10 Сейчас в теме
(45)ввести просто одного контрагента для всех
в квитанции все проходит
фио для каждого необязательно
47. YA_514896950 26 02.03.23 13:11 Сейчас в теме
(46)у вас в базе получается нет данных по родителям? только дети?
48. YA_514896950 26 02.03.23 13:14 Сейчас в теме
(46)с родителем понятно, а как ставки задавать? они же по идее разные
делать какой то отбор по детям и всем ставить такого то контрагента и такую то ставку?
теоретически можно
49. Ashny 02.03.23 15:41 Сейчас в теме
(48) а если сделать?
ООООчень надо
50. YA_514896950 26 02.03.23 15:54 Сейчас в теме
(49)
я попробую, если что выложу здесь.
сейчас доделываю обработку выгрузки реестров для сбербанка
делает csv для того что бы загружать в клиент-банк
51. Ashny 02.03.23 16:34 Сейчас в теме
38. YA_514896950 26 02.03.23 12:31 Сейчас в теме
Для вашего файла садов сам файл переименуйте чтобы начинался со слова реестр
39. YA_514896950 26 02.03.23 12:32 Сейчас в теме
Эта обработка вообще говоря предназначена для РОДИТЕЛЬСКОЙ ПЛАТЫ
а она есть только в садиках!
в школах есть только расчеты по платным услугам.
52. Ashny 03.03.23 09:46 Сейчас в теме
(39)доброе утро
спасибо вам за отклик я нашла в бгу помощник изменения параметров по детям
там все есть и изменение плательщика и изменения ставок
запрятали так, что трудно найти
спасибо вам
есть еще задача по загрузке реестра налоговых поступлений из суфд для казенных учреждений
было бы очень здорово сделать эту обработку
может решите эту проблему
спасибо
53. YA_514896950 26 04.03.23 15:35 Сейчас в теме
(52) у 1с есть же обмен с казначейством, там как бюджетные так и казенные, опишите пожалуйста подробнее задачу
54. Ashny 06.03.23 12:32 Сейчас в теме
(53) Добрый день
при загрузки родительской платы обнаружилась ошибка
не проставляет сумму по документу
сумма стоит только в табличной части по контрагентам
поэтому после проведения документа сумм нет
стоят только проводки без сумм
исправьте пожалуйста
(53)
55. YA_514896950 26 06.03.23 13:57 Сейчас в теме
(54)то есть в сам документ суммы попадают, но проводки не формируются с суммами?
56. YA_514896950 26 06.03.23 13:57 Сейчас в теме
(54)договор в документе подтягивается к контрагентам?
57. Ashny 06.03.23 17:19 Сейчас в теме
(56) я поправила
разобралась
договор подтягивается к контрагентам
там сумма в документе вставала только как сумма в валюте
добавила
для каждого м из мас цикл
		стр = ОбъектНазначения.РасшифровкаПлатежа.Добавить();
		стр.СуммаВал = м.СУМ;
		стр.Сумма = м.СУМ;
		обс = обс + м.СУМ;
//и вот здесь

конеццикла;


ОбъектНазначения.СуммаДокументаВВалюте = обс;
ОбъектНазначения.СуммаДокумента = ОбъектНазначения.СуммаДокументаВВалюте;
КонецПроцедуры
тогда все работает
58. YA_514896950 26 06.03.23 22:33 Сейчас в теме
(57) странно - у нас все работает и так.....
а про ту задачу с загрузкой из суфд...есть пример файла который надо загрузить?
и в какой документ?
59. terra_ink 16.03.23 11:36 Сейчас в теме
добрый день. а если централизованная бухгалтерия и в организациях разная длина лицевого счета. можно ли как-то адаптировать код? или добавлять условие по организации?
60. YA_514896950 26 16.03.23 15:30 Сейчас в теме
(59)покажите примеры ваших лиц счетов
адаптировать к разной длине можно конечно, однако род плата есть только в садах, что именно вы планируете загружать в ЦБ?
так же можете показать форматы ваших файлов поступлений, я помогу
61. mart1120 23.03.23 15:56 Сейчас в теме
Добрый день! Помогите пожалуйста адаптировать загрузку наших файлов. Сама пробовала разобраться, не получилось.
Прикрепленные файлы:
sоsh2_6448008740_03234643636490006000_054.txt
соглашение 5с.pdf
62. YA_514896950 26 23.03.23 18:36 Сейчас в теме
63. YA_514896950 26 23.03.23 22:54 Сейчас в теме
(61)у вас в файле лицевой счет ребёнка как выглядит?
353861873714 или 000000000004715
далее файл реестра по идее должен содержать данные по одному учреждению
у вас почему то разные как я вижу в одном реестре?
64. mart1120 24.03.23 00:56 Сейчас в теме
(62) Бухгалтер мне прислал этот файл. Это централизованная бухгалтерия. Уточню завтра. Там в "соглашении" есть описание структуры файла.
65. YA_514896950 26 24.03.23 08:04 Сейчас в теме
(64)
у нас тоже централизованная бухгалтерия, но детей ведем по учреждениям.
у нас 31 детский сад.
описание структуры видел, сейчас вопрос пока только по тому какие именно у вас лицевые счета.
66. mart1120 24.03.23 11:07 Сейчас в теме
Файлы Сбера.
Прикрепленные файлы:
Attachments_cbmouhval@mail.ru_2023-03-24_10-45-39.zip
YA_514896950; +1 Ответить
67. YA_514896950 26 27.03.23 13:02 Сейчас в теме
(66)отправил вам на эту почту обработку.
там поправил эти строки
//НАСТРОЙКА ОСНОВНЫХ ПАРАМЕТРОВ
	НомерВреестреЛС = 5;      
	НомерВреестреСум = 11;
	НомерВреестреФио = 6;  
	ДлинаКодаЛс=15;

Если истина тогда //Найти(ФайлРеестра,"\реестр")<>0 тогда
.....

.....
сам лицевой у вас получается просто ЛицевойСчет = СтруктураПлатежа[НомерВреестреЛС];

проверьте все ли работает.
у меня ваши файлы прочитались.
если что пишите
68. mart1120 27.03.23 14:50 Сейчас в теме
Большое спасибо за помощь и оперативность! Все работает!
69. Jek69 17.05.23 12:22 Сейчас в теме
Отличная работа!
Код снабжен развернутыми комментариями для небольших самостоятельных правок, если правки побольше - автор без проблем оперативно помогает.
Спасибо!
YA_514896950; +1 Ответить
70. Mesh 21.05.23 23:27 Сейчас в теме
Здравствуйте, у меня централизованная бухгалтерия, лицевые счета даже разной длины, лицевой счет внебюджетный. Не получается исправить
Выгрузка из Сбербанка: 03-05-2023;12-52-27;9013;9013999V;603324699897;177000005134;МАМЕДОВА ДАРЬЯ;МУНИЦИПАЛЬНОЕ БЮДЖЕТНОЕ ДОШКОЛЬНОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ ?ДЕТСКИЙ САД ОБЩЕРАЗВИВАЮЩЕГО ВИДА № 177?;ДОШКОЛЬНОЕ ВОСПИТАНИЕ;92400000000000000131;20701000;МАМЕДОВА ИРАДА ВАХИД КЫЗЫ;1864,32;1864,32;0,00
03-05-2023;17-22-21;9013;9013999V;453987685002;17700013189;ГЛЕБОВ БОГДАН;МУНИЦИПАЛЬНОЕ БЮДЖЕТНОЕ ДОШКОЛЬНОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ ?ДЕТСКИЙ САД ОБЩЕРАЗВИВАЮЩЕГО ВИДА № 177?;ДОШКОЛЬНОЕ ВОСПИТАНИЕ;92400000000000000131;20701000;ГЛЕБОВА ВАЛЕРИЯ ГЕННАДЬЕВНА;5659,40;5659,40;0,00
=2;7523,72;7523,72;0,00;257678;04-05-2023
71. YA_514896950 26 22.05.23 11:39 Сейчас в теме
(70)
03-05-2023;12-52-27;9013;9013999V;603324699897;177000005134;МАМЕДОВА ДАРЬЯ;МУНИЦИПАЛЬНОЕ БЮДЖЕТНОЕ ДОШКОЛЬНОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ ?ДЕТСКИЙ САД ОБЩЕРАЗВИВАЮЩЕГО ВИДА № 177?;ДОШКОЛЬНОЕ ВОСПИТАНИЕ;92400000000000000131;20701000;МАМЕДОВА ИРАДА ВАХИД КЫЗЫ;1864,32;1864,32;0,00
03-05-2023;17-22-21;9013;9013999V;453987685002;17700013189;ГЛЕБОВ БОГДАН;МУНИЦИПАЛЬНОЕ БЮДЖЕТНОЕ ДОШКОЛЬНОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ ?ДЕТСКИЙ САД ОБЩЕРАЗВИВАЮЩЕГО ВИДА № 177?;ДОШКОЛЬНОЕ ВОСПИТАНИЕ;92400000000000000131;20701000;ГЛЕБОВА ВАЛЕРИЯ ГЕННАДЬЕВНА;5659,40;5659,40;0,00
=2;7523,72;7523,72;0,00;257678;04-05-2023

что именно тут лицевой счет?
72. Mesh 22.05.23 21:42 Сейчас в теме
лицевой счет 177000005134, но это в данном случае, в других учреждениях может начинаться с буквы и длина у всех разная. Кодировка windows-1251.
Спасибо за быструю реакцию.
74. YA_514896950 26 23.05.23 09:15 Сейчас в теме
(72) конечно лицевые счета должны быть одинаковые, я попробую под ваш файл сделать с учетом возможных разных
длин л\с - но в идеале л\с должны быть шаблонными, мы в свое время приводили их к одному виду.
73. Mesh 22.05.23 21:44 Сейчас в теме
Валютный учет отключен
75. YA_514896950 26 23.05.23 09:16 Сейчас в теме
(73)это ни на что не влияет
76. Mesh 24.05.23 07:41 Сейчас в теме
77. YA_514896950 26 24.05.23 14:26 Сейчас в теме
(76) как отправить вам файл?
78. Mesh 24.05.23 21:41 Сейчас в теме
Добрый вечер, если можно на почту tea-63@mail.ru
79. YA_514896950 26 26.05.23 08:47 Сейчас в теме
80. Mesh 26.05.23 19:40 Сейчас в теме
Добрый вечер все встало на свои места, но при проведении в проводках нет сумм
Прикрепленные файлы:
проводки.docx
81. Mesh 27.05.23 08:58 Сейчас в теме
Здравствуйте, спасибо, немного доделала все работает