Проблема НДФЛ аванса (и вариант решения) в ЗУП 3.1.23.653 / 3.1.25.37

20.04.23

Учетные задачи - Зарплата

Внезапно обнаружилось, что в ряде организаций по ряду сотрудников в ЗУП 3.1.23.653 / 3.1.25.37 не рассчитывается НДФЛ. На скорую руку решил через расширение. Делюсь.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
3.1.23.653 / 3.1.25.37 - проблема НДФЛ аванса (и вариант решения):
.cfe 22,37Kb
12
12
1 SM
Скачать Купить за 1 850 руб.

Утро началось с того, что прочитал новость об очередной проблеме в ЗУП на БЭ https://buhexpert8.ru/1s-zup/glavnaya-1s-zup/novosti-zup/oshibka-v-zup-3-1-23-653-3-1-25-37-ne-rasschityvaetsya-ndfl-s-avansa.html

Проверил - в одной из организаций проблема проявляется.

В документе "Начисление за первую половину" в ТЧ "Начисления" - 60 человек, в ТЧ "НДФЛ" - 20 (в предыдущие месяца - количество +/- совпадало).

Не поленился, написал простое расширение для перерасчета каждого сотрудника (стандартное - выделить всех и "Пересчитать сотрудника") проблемы не решает.

В расширении - заимствовал процедуру "ПриСозданииНаСервере" формы "ФормаДокумента"

Собственно, все содержимое расширения - вот оно
 

&НаСервере
Процедура НДФЛА_ПриСозданииНаСервереПосле(Отказ, СтандартнаяОбработка)
	НоваяКоманда = ЭтаФорма.Команды.Добавить("НДФЛА_ПересчитатьВсехСотрудников");
	НоваяКоманда.Заголовок = "ПересчитатьВсехСотрудников";
	НоваяКоманда.Действие = "НДФЛА_ДействиеКомандыПересчитатьВсехСотрудников"; //указываем только имя процедуры
	
	
	НоваяКнопка = Элементы.Вставить("КнопкаНДФЛА_ПересчитатьВсехСотрудников", Тип("КнопкаФормы"),ЭтаФорма.Элементы.ОсновныеКоманды);
	НоваяКнопка.Заголовок = "Пересчитать всех сотрудников";
	НоваяКнопка.ИмяКоманды = "НДФЛА_ПересчитатьВсехСотрудников";	
	
КонецПроцедуры

&НаКлиенте
Процедура НДФЛА_ДействиеКомандыПересчитатьВсехСотрудников()
	Для каждого стр из Объект.Начисления цикл
		Массив = Новый Массив();
		Массив.Добавить(стр.НомерСтроки-1);
		НДФЛА_ДействиеРасчетСотрудникаБезИтогов("Начисления",Массив,"Сотрудник",Тип("СправочникСсылка.Сотрудники"));
	КонецЦикла;
	НДФЛА_ДействиеРасчетИтогов();
КонецПроцедуры

&НаСервере
Процедура НДФЛА_ДействиеРасчетСотрудникаБезИтогов(ИмяТаблицы, ВыбранныеСтроки, ВедущееПоле, ТипВедущегоПоля)
	РасчетЗарплатыРасширенный.ПересчитатьСотрудникаНаСервере(ЭтаФорма, ИмяТаблицы, ВыбранныеСтроки, ВедущееПоле, ТипВедущегоПоля);
КонецПроцедуры

&НаСервере
Процедура НДФЛА_ДействиеРасчетИтогов()
	РассчитатьИтогиПоДокументу();
КонецПроцедуры


То есть - добавил новую команду, новую кнопку, назначил этой кнопке добавленную команду, и, собственно, выполнение этой добавленной команды путём обхода ТЧ "Начисления" и выполнения стандартного действия перерасчета.

Не самый быстрый вариант (чуть больше секунды на одного сотрудника), но - какой есть.

Методика:

0. Добавляем расширение в конфигурацию, перезапускаем, чтобы оно сработало.

1. Создаём документ, стандартно заполняем.

2. Смотрим на сумму НДФЛ, количество сотрудников в ТЧ "НДФЛ"

3. Нажимаем добавленную кнопку "Пересчитать всех сотрудников", ждём

4. Смотрим на сумму НДФЛ, количество сотрудников в ТЧ "НДФЛ"

Всё.

Проверялось на ЗУП ПРОФ 3.1.23.653 и 3.1.25.37

ЗУП НДФЛ авансы

См. также

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    142540    672    352    

234

Перенос данных 1C Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    57899    148    141    

125

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5016    11    5    

20

Зарплата Программист Бизнес-аналитик Бухгалтер Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

15600 руб.

14.09.2022    13782    66    26    

68

Зарплата Роли и права Системный администратор Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управление правами 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Молдова Россия Казахстан Бухгалтерский учет Платные (руб)

Расширение позволяет максимально полно ограничить доступ пользователей к данным по заработной плате, а именно закрывает доступ к документам начисления и выплаты заработной платы, не позволяет просматривать бухгалтерские отчеты по счету учета зарплаты а также убирает зарплатные проводки из журнала проводок. Расширение запрещает просматривать платежные документы на выплату зарплаты, так же не доступны регламентные отчеты в ПФР и ИФНС. Расширение предлагает готовые настроенные профили "Бухгалтер без зарплаты", "Только просмотр без зарплаты".

5700 руб.

27.05.2021    34208    215    89    

173

Корректировка данных Зарплата Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    3294    33    17    

40

Внешние источники данных Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 7.хх учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

24000 руб.

24.04.2017    49292    97    165    

87
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ixijixi 1828 20.04.23 20:49 Сейчас в теме
ОМГ, на что приходится идти, чтобы получить хоть какое-то подобие корректного расчета!
2. burgomister 59 21.04.23 05:17 Сейчас в теме
О сколько нам ошибок трудных готовит просвещенья дух...
3. aleksey2 87 21.04.23 10:46 Сейчас в теме
4. KirillHome 5 21.04.23 12:34 Сейчас в теме
(3) Если это не сарказм - то, несомненно, спасибо!

А если сарказм... Буду с этим жить.
5. KirillHome 5 21.04.23 13:03 Сейчас в теме
Забыл написать....
Что бы расширение работало нормально и под "ограниченными ролями" (тип "Расчетчик") - надо снять птицу "Безопасного режима"
6. RaHit 21.04.23 14:42 Сейчас в теме
Всем кому интересно, ошибка уже исправлена в 3.1.23.656
Так что качайте, как только появится на выдаче.
KirillHome; +1 Ответить
7. RaHit 21.04.23 15:24 Сейчас в теме
Ну и в 3.1.25.40 соответственно.
KirillHome; +1 Ответить
8. KirillHome 5 21.04.23 16:07 Сейчас в теме
(7) Спасибо!
Пошёл проверять...
10. KirillHome 5 21.04.23 17:13 Сейчас в теме
(7) Проверил "проблемную базу" и на 3.1.23.656 и на 3.1.25.40

Эта проблема с НДФЛ аванса - отсутствует (другие проблемы - не искал).
9. RaHit 21.04.23 17:00 Сейчас в теме
Ну, 25.40 ещё не выложили, я жду, а кто на 23 версии уже могут обновляться :)
Оставьте свое сообщение