Курсы выбранных валют на дату

28.06.24

Учетные задачи - Банковские операции

Обработка, которая позволяет получить курсы выбранных валют при помощи http-запроса к ресурсу Центробанка. Курсы выбранных валют отображаются в табличной части обработки и полученные курсы валют сразу записываются в регистр сведений "Курсы валют".

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Обработка "Курсы выбранных валют на дату".:
.epf 8,64Kb
0
0
3 SM
Скачать Купить за 2 450 руб.

При помощи данной обработки мы будем решать такую задачу - необходимо получить курсы валют из списка выбранных валют, отобразить полученный результат в табличной части обработки и результат выгрузить в регистр сведений "Курсы валют".

 

1. Получаем массив значений выбранных курсов валют

//добавляем валюты из списка значений в массив
	МассивВалют = Новый Массив;
	МассивВалют = Валюта.ВыгрузитьЗначения();

2.  Указываем сервер получения данных и адрес

// Сервер
	Сервер = "www.cbr.ru";
	
	// Курсы всех валют на  дату
	Адрес = "/scripts/XML_daily.asp?date_req=" + Формат(Дата, "ДФ=dd/MM/yyyy");

3. Создаем ПостроительDom

	
	// Построение объектной модели XML-документа
	ПостроительDOM = Новый ПостроительDOM;
	ДокументDOM = ПостроительDOM.Прочитать(ЧтениеXML);

4. При помощи построителя читаем данные из XML (перебираем узлы). Полученные данные записываем в регистр сведений "Курсы валют".

		Для Каждого УказаннаяВалюта из  МассивВалют Цикл     
			
			Если УказаннаяВалюта.Наименование = Наименование Тогда 
				
		ТЗСтрока = Таблица.Добавить();  
		ТЗСтрока.Наименование = Наименование;
		ТЗСтрока.НаименованиеВалюты = НаименованиеВалюты;
		ТЗСтрока.Курс = Курс;
		ТЗСтрока.Код = Код;
		ТЗСтрока.Кратность = Кратность;
		
		
		//Запись полученных данных в  справочник "Валюты" (если нет такой валюты)
		
		НоваяВалюта = Справочники.Валюты.НайтиПоНаименованию(Наименование);
		
		Если НоваяВалюта.Пустая() Тогда
			НоваяВалюта = Справочники.Валюты.СоздатьЭлемент();
			
			НоваяВалюта.Наименование = Наименование; 
			НоваяВалюта.Код = Код;
			НоваяВалюта.НаименованиеПолное = НаименованиеВалюты;
			НоваяВалюта.Записать();
			
			Сообщения.ДобавитьСтроку("В справочник ""Валюты"" добавлен новый элемент - " + НаименованиеВалюты);	
						
		КонецЕсли;
		 //Запись полученных данных в регистр Сведений "КурсыВалют"
		НоваяЗаписьРегистра = НаборЗаписей.Добавить();
		НоваяЗаписьРегистра.Период = НужнаяДата;
		НоваяЗаписьРегистра.Валюта = УказаннаяВалюта.Ссылка;
		НоваяЗаписьРегистра.Курс = Курс;
		НоваяЗаписьРегистра.Кратность = Кратность;    
	КонецЕсли;
	КонецЦикла;

 

Проверено на следующих конфигурациях и релизах:

  • Управление торговлей, редакция 11, релизы 11.5.18.37

Обработка Курс Валюта

См. также

Банковские операции Обмен с интернет-банком Эквайринг/ридер магнитных карт Программист Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Устали вручную дозаполнять и корректировать документы по банку после загрузки банковской выписки? С помощью правил обработки банковской выписки вы сможете автоматически определять правильный вид хозяйственной операции, заполнять расшифровку, аналитику платежа и многое другое.

15000 руб.

21.03.2023    9421    53    14    

50

Сайты и интернет-магазины Интеграция WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Интеграция 1С и Битрикс 24. Разработка имеет двухстороннюю синхронизацию 1С и Bitrix24 задачами. Решение позволяет создавать пользователя в 1С из Битрикс24 и наоборот. Данная разработка технически подходит под все основные конфигурации линейки продуктов 1С:Предприятие 8.3 (платформа начиная с 8.3.23). При приобретении предоставляется 1 месяц бесплатных обновлений разработки. Доступна демо-версия продукта с подключением Вашего Битрикс24

5040 руб.

04.05.2021    18973    10    16    

17

Обмен с интернет-банком Банковские операции Программист Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Модуль представляет собой комплексную автоматизацию обмена данными 1С с банком для БП 3.0, ERP 2.4, ERP 2.5. Выписка клиент-банка загружается и обрабатывается по Вашим правилам. Заполнение реквизитов документов, анализ назначения платежа. Работа с клиент банком не отличается от типового варианта, а документы автоматически заполняются так, как нужно вам. Дополнительная обработка, работающая совместно с основным расширением позволяет подключать собственные произвольные алгоритмы.

20400 руб.

03.04.2013    123973    248    377    

161

Управление взаимоотношениями с клиентами (CRM) WEB-интеграция Анализ продаж Системный администратор Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Подсистема интеграции Amo CRM с 1С: технические требования, порядок работы, возможности, доработки и обновления. Бесплатный период техподдержки - 1 месяц.

60000 руб.

07.05.2019    31837    62    40    

23

Сайты и интернет-магазины WEB-интеграция Системный администратор Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Автомобили, автосервисы Россия Управленческий учет Платные (руб)

Интеграционный модуль обмена между конфигурацией Альфа Авто 5 и Альфа Авто 6 и порталом AUTOCRM. Данный модуль универсален. Позволяет работать с несколькими обменами AUTOCRM разных брендов в одной информационной базе в ручном и автоматическом режиме.

36000 руб.

03.08.2020    16712    15    19    

15

WEB-интеграция Программист Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бытовые услуги, сервис Платные (руб)

Внешняя обработка разрабатывалась для загрузки документов из Ветменеджер в 1С: Бухгалтерия 3.0

12000 руб.

02.02.2021    16987    45    49    

26
Оставьте свое сообщение