Обработка "Меню торгового представителя" для планшетов для конфигурации "1С:Комплексная автоматизация", редакция 1.1. С помощью обработки сотрудники могут удаленно заносить сведения в базу.

21.05.20

Учетные задачи - Оптовая торговля

Обработка "Меню торгового представителя" для планшетов, писалась под конфигурацию 1С:Комплексная автоматизация, редакция 1.1 (1.1.36.1).

Скачать исходный код

Наименование Файл Версия Размер
Меню торгового представителя
.epf 56,54Kb
4
.epf 1.1.1.1 56,54Kb 4 Скачать
bat файл для запуска 1С.
.bat 0,40Kb
4
.bat 0,40Kb 4 Скачать

Обработка "Меню торгового представителя" для планшетов, писалась под конфигурацию 1С:Комплексная автоматизация, редакция 1.1 (1.1.36.1) с целью удаленной работы торговых представителей и оформлений накладных на отгрузку,так же просмотра остатков и дебиторки, для более удобного подбора товаров из списка с учетом остатков разработана кнопка "Подбор", тестировалась и работает на планшетах "7" Планшет Wexler.Tab 7t 8Gb 3G, 1280x800", может запускаться на других моделях. 

Осуществил доработку в конфигурации по увеличению шрифта для пользователя при удаленном подключении к базе, с помощью объекта "Стили" конфигурации. Следующий код:

Процедура ПередНачаломРаботыСистемы(Отказ)

Если НЕ РольДоступна("Пользователь")
И (НЕ РольДоступна("ПолныеПрава")) Тогда

Предупреждение("Вам не назначена роль ""Пользователь"". Запуск конфигурации невозможен.");
Отказ = Истина;
Возврат;
КонецЕсли;

Отказ = НЕ УправлениеПользователями.ПользовательОпределен();

// ОбновлениеВерсииИБ
Отказ = Отказ ИЛИ НЕ ОбновлениеИнформационнойБазыКлиент.ВозможноВыполнитьОбновлениеИнформационнойБазы();
// Конец ОбновлениеВерсииИБ
//МНач
ГлавныйСтиль = БиблиотекаСтилей.Получить(ПолучитьНомерСтиляПользователя());
//МКон
КонецПроцедуры



Функция ПолучитьНомерСтиляПользователя()

Запрос = Новый Запрос;
Запрос.текст = "ВЫБРАТЬ
| СтилиПользователей.НомерСтиля
|ИЗ
| РегистрСведений.СтилиПользователей КАК СтилиПользователей
|ГДЕ
| СтилиПользователей.Пользователь = &Пользователь";
Запрос.УстановитьПараметр("Пользователь", ПараметрыСеанса.ТекущийПользователь);
Рез = Запрос.Выполнить().Выбрать();
Если рез.Следующий() Тогда
Возврат рез.НомерСтиля;
иначе
Возврат 0;
КонецЕсли;

КонецФункции

Осуществил автоматический запуск 1с и обработки при входе с планшета с помощью командной строки, в обработке работает механизм полного завершения работы пользователя над БД по кнопке "Выход", автоматическое удаление товара из списка при отсутствии его на остатках.

Сама обработка сохраняется во внешних обработках базы, для того чтобы она запускалась при открытии, создал роль "ТорговыйПредставитель", если пользователь входит с этой ролью срабатывает код:

Если РольДоступна("ТорговыйПредставитель") Тогда

ОбОбработки = Справочники.ВнешниеОбработки.НайтиПоНаименованию("Меню торгового представителя").ПолучитьОбъект();
ОбОбработки = ПолучитьСерверТО().ПолучитьВнешнююОбработку(ОбОбработки.Ссылка);
МенюТО = ОбОбработки.ПолучитьФорму("Форма");
МенюТО.ОткрытьМодально();

КонецЕсли;

В модуль объекта обработки ТОСервер прописываем:

//МНач
Функция ПолучитьВнешнююОбработку(Ссылка) Экспорт
Если НЕ ЗначениеЗаполнено(Ссылка) Тогда
Возврат Неопределено;
КонецЕсли;

Имя = СтрЗаменить(Строка(Ссылка.УникальныйИдентификатор()), "-", "");

ДвоичныеДанные = Ссылка.ХранилищеВнешнейОбработки.Получить();
Если ДвоичныеДанные = Неопределено Тогда
Общегоназначения.СообщитьОбОшибке("Не установлена обработка !");
Возврат Неопределено;
КонецЕсли;
ИмяФайла = ПолучитьИмяВременногоФайла();

Попытка
ДвоичныеДанные.Записать(ИмяФайла);
об = ВнешниеОбработки.Создать(ИмяФайла);
Исключение
Общегоназначения.СообщитьОбОшибке("Не удалось инициализировать обработку !
|Файл не является внешней обработкой.
|Либо, данная обработка не предназначена для
|запуска в этой конфигурации.");
УдалитьФайлы(ИмяФайла);
Возврат Неопределено;
КонецПопытки;

Попытка
Комментарий = Ссылка.КомментарийКФайлуИсточнику;
Начало = Найти(Комментарий,"изменен:")+8;
Комментарий = Сред(Комментарий,Начало);
Начало = Найти(Комментарий,";");
Если Начало>0 Тогда
об.ВерсияВнешнейОбработки = Лев(Комментарий,Начало-1);
КонецЕсли;
Исключение
КонецПопытки;

глЗначениеПеременнойУстановить("Обработка_" + Имя, об);

УдалитьФайлы(ИмяФайла);

Возврат об;

КонецФункции
//МКон

Почему решил сохранять обработку в базе, потому что не раз сталкивался с тем что админы могут перемещать или закрывать доступ к некоторым каталогам, либо могут возникнуть сбои системы, если бекапы базы настроены, то за все эти доработки можно особо не беспокоиться.

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    91823    116    40    

203

ККТ-ОНЛАЙН 54-ФЗ: Обработка для работы онлайн касс АТОЛ, ШТРИХ, VIKI PRINT и т.д. МАРКИРОВКА (Разрешит. режим) + ЭКВАЙРИНГ + БЕСПЛАТНЫЙ ДЕМО

ККМ Кассовые операции Розничная торговля Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    774931    4704    9505    

2800

ЕГАИС++. Опт, производство, импорт

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    167279    711    362    

391

Загрузка номенклатуры из Excel в УТ11, КА 2, ERP 2, Розница 2. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка из файлов xls, xlsx, ods, csv, mxl в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212792    632    526    

447

54-ФЗ и Разрешительный режим. Обработки для подключения онлайн-касс к 1С 8 (поддержка Маркировки) + Эмулятор + ФФД 1.2

ККМ Кассовые операции Розничная торговля Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    322866    1856    3023    

999

Обмен с системой ЦРПТ (Универсальная конфигурация ХамелеонЦРПТ + маркировка табака, обуви, одежды, лекарств, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин)

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте нам вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, мы накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

104000 руб.

18.03.2019    111065    34    114    

179
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. пользователь 03.01.14 11:47
Сообщение было скрыто модератором.
...
2. zayden 18 07.11.17 09:35 Сейчас в теме
Запускаю под УПП почему то поле ввода Организация не активно
Нужно включить доступность Поля выбора
3. improg 640 07.11.17 14:00 Сейчас в теме
Здравствуйте, это древняя обработка я про нее уже забыл, скорее всего ее еще нужно скорректировать, как руки дойдут гляну, спасибо за инфу.
Оставьте свое сообщение