Как подключить весы Vibra AJ к 1С?

09.06.15

Учетные задачи - Розничная торговля

Недавно возникла необходимость соединения весов с 1С. Искал информацию в интернете и не нашел полного описания. Вот по этому поводу решил написать мини-статью с руководством. И для себя будет как заметка, и другим пригодится.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Компонента
.rar 59,74Kb
15
15
1 SM
Скачать Купить за 1 850 руб.
Обработка с примером настройки весов в 1С
.epf 7,81Kb
11
11
1 SM
Скачать Купить за 1 850 руб.

   1. Необходимо зарегистрировать внешнюю компоненту.

Файлик внешней компоненты поместите на диск С или можно в другой удобный для вас каталог и нажмите кнопку Пуск; – в текстовое поле Найти программы и файлы введите regsvr32 C:\us_rs232.dll –> Enter (Для Win7).

   2. Подключение и передача параметров для работы компоненты

При открытии формы необходимо Подключить внешнюю компоненту: 

	Процедура ПодключитьВесы() //ТекПользователь = глЗначениеПеременной("глТекущийПользователь");  //ВесовоеОб = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекПользователь, "ВесовоеОборудование"); //Порт = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекПользователь, "Порт"); //СкоростьОбмена = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекПользователь, "СкоростьОбмена"); //БитыДанных = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекПользователь, "БитыДанных"); //Четность = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекПользователь, "Четность"); //СтопБиты = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекПользователь, "СтопБиты"); //Чувствительность= УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекПользователь, "Чувствительность");
	ВесовоеОб = "Vibra AJ";
	Порт = "COM7";
	СкоростьОбмена = "1200";
	БитыДанных = "8";
	Четность = "НЕТ";
	СтопБиты = "1";
	Чувствительность = "30"; Если (ВесовоеОб = Неопределено) или (ВесовоеОб = Перечисления.ВесовоеОборудование.ПустаяСсылка()) Тогда Возврат; Иначе //загрузить компоненты Если Не ВесовоеОб = Перечисления.ВесовоеОборудование.VibraAJ Тогда Возврат; КонецЕсли; КонецЕсли; Если Порт = "" Тогда
	Сообщить("Не указан Порт!",СтатусСообщения.Важное); Возврат; КонецЕсли;
	ПрогИД = "AddIn.us_rs232"; Попытка
	ПодключитьВнешнююКомпоненту(ПрогИД); Исключение
	Сообщить("Неудалось подключить внешную компоненту AddIn.us_rs232"); Возврат; КонецПопытки; Попытка ДллВесы = новый (ПрогИД); Исключение
	Сообщить("Неудалось создать обьект AddIn.us_rs232");
	СтатусКомпоненты = Ложь;
	ДллВесы = Неопределено; // Статус(); Возврат; КонецПопытки; Попытка
	НовУстройство = дллВесы.СоздатьУстройство(); Исключение
	Сообщить("Невозможно создать больше устройств! Удалите какие нибудь из имеющихся!"); Возврат; КонецПопытки;
	Устройство = НовУстройство;
	дллВесы.НомерУстройства = Устройство; // заполняем параметры по умолчанию
	дллВесы.НомерУстройства = Устройство; Попытка
	дллВесы.ИмяСобытия = "USBarCodeValue";
	дллВесы.Порт = СокрЛП(Порт);
	дллВесы.СкоростьОбмена = СокрЛП(СкоростьОбмена);
	дллВесы.БитыДанных = СокрЛП(БитыДанных);
	дллВесы.Четность = СокрЛП(Четность);
	дллВесы.СтопБиты = СокрЛП(СтопБиты);
	дллВесы.Чувствительность = СокрЛП(Чувствительность);
	дллВесы.Маркер = "";
	дллВесы.Префикс = "";
	дллВесы.Суффикс = "";
	дллВесы.ОткрытьПорт();
	дллВесы.Пуск(); Исключение
	Сообщить("Неудалось открыть порт с текущими настройками подключения. Проверьте настройки и закройте другие программы подключенные к оборудованию!"); Возврат; КонецПопытки; ЭлементыФормы.Вес.Доступность = Ложь; КонецПроцедуры

   3. Обработка внешнего события

Необходимо обработать внешнее событие в форме и распарсить результат, который возвращают нам весы в нужный нам формат (подробно это реализовано в обработке)

   4. Обработка ПриЗакрытии

При закрытии формы необходимо закрыть порт:

	Процедура ПриЗакрытии() Попытка
	дллВесы.Стоп();
	дллВесы.ЗакрытьПорт();
	дллВесы.УдалитьУстройство(); Исключение КонецПопытки; КонецПроцедуры

   5. Настройка режима весов

В руководстве по эксплуатации весов вы найдете, как установить Контроль вывода данных в позицию - "Непрерывный вывод данных при стабильных показаниях".

Можно, конечно, и другой режим, но на мое усмотрение это самый подходящий режим.

Весы Внешняя компонента

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93366    119    40    

210

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168481    755    364    

394

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    787018    4739    9507    

2812

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет/Купер. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет/Купер, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

35000 руб.

14.10.2022    8567    15    13    

10

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111704    28    114    

181

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    329157    1886    3030    

1014
Оставьте свое сообщение