Исправление ошибки Поле объекта не обнаружено (CountryCode) при обновлении Бухгалтерия предприятия с 2.0 на редакцию 3.0

15.11.18

Задачи пользователя - Адаптация типовых решений

Уже у третьего клиента вижу ошибку Поле объекта не обнаружено (CountryCode) Значит, как говаривал Винни-Пух - это неспроста. Ну и точно неспроста, 1С что-то подшаманили в контактной информации.

Скачать исходный код

Наименование Файл Версия Размер
Исправление ошибки Поле объекта не обнаружено (CountryCode) при обновлении Бухгалтерия предприятия с 2.0 на редакцию 3.0:
.cfe 5,38Kb
19
.cfe 5,38Kb 19 Скачать

Постановка задачи:

При обновлении Бухгалтерия предприятия редакция 2.0 на редакцию 3.0 при выполнении на старте обработчиков Обновление информационной базы появляется ошибка Поле объекта не обнаружено (CountryCode)

Решение:

Расширение конфигурации, которое дает штатно пройти процессу обновления. 

Порядок работы:

Подключаем расширение в конфигураторе 1С перед (!) стартом ИБ после обновления.
Добавляем расширение, и выбираем - загрузить конфигурацию из...

Снимаем флажки "Безопасный режим..." и "Защита от опасных действий..."

Запускаем 1С Предприятие - процедура обновления отработает, после этого убираем расширение.

Требования к запуску обработки:

Расширение предназначено для использования с актуальными типовыми конфигурациями, или нетиповыми, Бухгалтерия предприятия (КОРП), редакция 3.0 (3.0.65.х) :

для России:

  1. Бухгалтерия предприятия, редакция 3.0

Также возможна адаптация под любую имеющуюся у пользователя типовую или нетиповую конфигурацию. 

Установка и использование обработки:

  1. Расширение выполнено с использованием управляемых форм, соответственно, требует для работы запуска в управляемом интерфейсе.
  2. Может использоваться платформа  8.3.12.х и старше

 

         Поддержка отчета, лицензирование:

  1. Расширение не имеет ограничений по периоду действия, количеству организаций и информационных баз.
  2. При возникновении вопросов по работе с отчетом, их можно обсудить в комментариях к публикации, личных сообщениях либо по e-mail, указанному в письме с отчетом.

Не верю, что мне приходится писать для пользователей этого сайта, но как оказалось нужно.

Если вы не представляете: что такое 1С Предприятие,  файл и зачем вам нужна эта кухня.

Все файлы из интернет считаете зараженными вирусом.

Если физиологические, моральные, религиозные или другие причины не позволяют вам заполнять справочники, документы, настраивать отчеты 1С и запускать обработки.

А платить вы за это не будете так как программист с десятилетним стажем.

Закройте эту страницу не продолжая чтения дальше.

Для адекватных людей:

Если оно есть у вас или предложения по улучшению - пишите.

поле объекта не обнаружено (CountryCode)

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4871    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3246    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4351    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2421    dimanich70    8    

15

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2279    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2492    34    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. НовенькийЯ 16.11.18 11:19 Сейчас в теме
Сам столкнулся с такой проблемой, на днях переводил БП20 на 30
поиск в инете ничего не дал.
Поиск по коду дал интересный результат.
У меня УТ10, выгрузка в БП20
1 - в УТ есть РС Контактная информация.
В этом РС есть поля Вид и Тип, при \этом Тип - имеет тип Строка+Справочник ВидыКи
2 - Пользователи очень часто при заполнении КИ пишут ВидКи= Адрес, типКИ = "Тут строка которую пользователь сам накатал".
3 - все это дело выгружается в БП 20
а при обновление БП20 на БП30 как раз и происходит ошибка как у автора.
Решается просто, либо убираются все контактные данные, у которых ТипКи с типом строка, либо во всех таких контактных данных ТипКи меняется на вновь элемент справочника.
Т.е. у меня был например тип Ки "Телефон бухгалтерии" - строка, создал в справочнике новый элемент "Телефон бухгалтерии" и поменял строку на этот элемент.
Обновление БП после этого прошло на ура, точнее идет до сих пор, запустил в конфигураторе ТиИ, уже 5е сутки лопатится РН.ИпДоходы
2. FilippovRI 73 23.11.18 13:10 Сейчас в теме
Я решил так, добавил расширение, в расширение добавил модуль Управление контактной информацией, туда код, в коде меняем
КодСтраны     = "";
	КодГорода     = "";
	НомерТелефона = "";

&Вместо("ЗаполнитьРеквизитыТабличнойЧастиДляТелефона")
Процедура ЗаполнитьРеквизитыТабличнойЧастиДляТелефона1(СтрокаТабличнойЧасти, Телефон)
	
	Если НЕ ЗначениеЗаполнено(Телефон) Тогда
		Возврат;
	КонецЕсли;
	
	// Умолчания
	СтрокаТабличнойЧасти.НомерТелефонаБезКодов = "";
	СтрокаТабличнойЧасти.НомерТелефона         = "";
	
	КодСтраны     = "";
	КодГорода     = "";
	НомерТелефона = "";
	
	Если СтрНачинаетсяС(КодСтраны, "+") Тогда
		КодСтраны = Сред(КодСтраны, 2);
	КонецЕсли;
	
	Поз = СтрНайти(НомерТелефона, ",");
	Если Поз <> 0 Тогда
		НомерТелефона = Лев(НомерТелефона, Поз-1);
	КонецЕсли;
	
	Поз = СтрНайти(НомерТелефона, Символы.ПС);
	Если Поз <> 0 Тогда
		НомерТелефона = Лев(НомерТелефона, Поз-1);
	КонецЕсли;
	
	СтрокаТабличнойЧасти.НомерТелефонаБезКодов = УбратьРазделителиВНомерТелефона(НомерТелефона);
	СтрокаТабличнойЧасти.НомерТелефона         = УбратьРазделителиВНомерТелефона(Строка(КодСтраны) + КодГорода + НомерТелефона);
	
КонецПроцедуры
Показать
Mechanik21; EvgenAEY; +2 Ответить
5. EvgenAEY 2 02.06.21 18:07 Сейчас в теме
(2)
&Вместо("ЗаполнитьРеквизитыТабличнойЧастиДляТелефона")


Спасибо тебе милчеловек!

Единственное что нужно "изменение" в расширении поставить и убрать безопасный режим
Прикрепленные файлы:
3. abryazgin 2 02.04.20 16:50 Сейчас в теме
Может кому пригодится.
Решаю вопрос перехода на БП 3.0 в БП 2.0, в которую загружались данные из УТ 10.3.

1) Сначала была ошибка:
Недопустимая попытка обновления с версии %2)
Необходимо восстановить информационную базу из резервной копии
и повторить обновление согласно файлу 1cv8upd.htm'

Система ждала версию конфигурации "3.0.1.11".
При этом взят дистрибутив перехода на 3.0 для версии 3.0.61.37.
Обошел в модуле ОбновлениеСПредыдущейРедакции.ПриОпределенииВозможностиОбновления
	//ДопустимаяВерсия = "3.0.61.37";
	ДопустимаяВерсия = "3.0.1.11";



2) Дальше связана с контактной информацией
Поле объекта не обнаружено
{ОбщийМодуль.УправлениеКонтактнойИнформациейСлужебный.Модуль(4178)}: ОжидаемыйТип = Перечисления.ТипыКонтактнойИнформации[КонтактнаяИнформация.type];
{ОбщийМодуль.УправлениеКонтактнойИнформациейСлужебный.Модуль(2777)}: XMLСтрока = КонтактнаяИнформацияИзJSONВXML(ЗначенияПолей, ТипКонтактнойИнформации);
{ОбщийМодуль.УправлениеКонтактнойИнформацией.Модуль(476)}: Результат = УправлениеКонтактнойИнформациейСлужебный.ПривестиКонтактнуюИнформациюXML(Новый Структура(
{ОбщийМодуль.УправлениеКонтактнойИнформацией.Модуль(4693)}: СтрокаКонтактнойИнформации.ЗначенияПолей = КонтактнаяИнформацияВXML(СтрокаКонтактнойИнформации.Значение,
{ОбщийМодуль.УправлениеКонтактнойИнформациейСлужебный.Модуль(1708)}: УправлениеКонтактнойИнформацией.ВосстановитьПустыеЗначениеПредставление(СтрокаКонтактнойИнформации);
{ОбщийМодуль.УправлениеКонтактнойИнформацией.Модуль(421)}: УправлениеКонтактнойИнформациейСлужебный.УстановитьКонтактнуюИнформациюОбъекта(СсылкаИлиОбъект, КонтактнаяИнформация, ОбъектМетаданных, Замещать);
{ОбщийМодуль.ОбновлениеСПредыдущейРедакции.Модуль(626)}: УправлениеКонтактнойИнформацией.УстановитьКонтактнуюИнформациюОбъекта(ОбъектВладелец, КонтактнаяИнформацияОбъекта);
{ОбщийМодуль.ОбновлениеСПредыдущейРедакции.Модуль(212)}: ПереносКИПриОбновленииС20();
{(1)}:ОбновлениеСПредыдущейРедакции.ПереносКИиДопСвойствПриОбновленииС20()
{ОбщийМодуль.ОбщегоНазначения.Модуль(4879)}: Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(4862)}: ОбщегоНазначения.ВыполнитьМетодКонфигурации(Обработчик.Процедура, ПараметрыОбработчика);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(1709)}: ВыполнитьОбработчикОбновления(Обработчик, ПараметрыОбработчика, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(232)}: ИтерацияОбновления.ВыполненныеОбработчики = ВыполнитьИтерациюОбновления(ИтерацияОбновления, Параметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(1843)}: Результат = ВыполнитьОбновлениеИнформационнойБазы(ПараметрыОбновления);
{(1)}:ОбновлениеИнформационнойБазыСлужебный.ВыполнитьОбновлениеИнформационнойБазыВФоне(Параметры[0],Параметры[1])
{ОбщийМодуль.ОбщегоНазначения.Модуль(4879)}: Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ДлительныеОперации.Модуль(969)}: ОбщегоНазначения.ВыполнитьМетодКонфигурации(ИмяПроцедуры, ПараметрыВызова);
{ОбщийМодуль.ДлительныеОперации.Модуль(959)}: ВызватьПроцедуру(ВсеПараметры.ИмяПроцедуры, ВсеПараметры.ПараметрыПроцедуры);
Показать


Причина: данные. В виде контактной информации не указан тип контактной информации.
Если допустимо отказаться от такой информации, то можно обойти отсечением такой КИ в запросе получения данных.
в процедуре ОбновлениеСПредыдущейРедакции.ПереносКИПриОбновленииС20
В коде добавленное условие отбора выделено комментарием.
	|ИЗ
	|	РегистрСведений.УдалитьКонтактнаяИнформация КАК УдалитьКонтактнаяИнформация
	|		ЛЕВОЕ СОЕДИНЕНИЕ ОбъектыСКИ КАК ОбъектыСКИ
	|		ПО УдалитьКонтактнаяИнформация.Объект = ОбъектыСКИ.Ссылка
	|ГДЕ
	|	ТИПЗНАЧЕНИЯ(УдалитьКонтактнаяИнформация.Вид) <> ТИП(СТРОКА)
	|	И НЕ УдалитьКонтактнаяИнформация.Объект.Ссылка ЕСТЬ NULL
	|	И ОбъектыСКИ.Ссылка ЕСТЬ NULL
	|   //ban {
	|	И НЕ ( УдалитьКонтактнаяИнформация.Вид.Тип is null ) 
	|	И УдалитьКонтактнаяИнформация.Вид.Тип <> Значение(Перечисление.ТипыКонтактнойИнформации.ПустаяСсылка)
	|   //ban } 
	|	   
	|ИТОГИ ПО
	|	Объект";

Показать


Второй вариант - разбираться с такими записями до в базе БП 2 (до обновления) или уже в БП 3 (через внешнюю обработку).
4. user1486576 01.11.20 22:30 Сейчас в теме
не могу воспользоваться вашим решением тк я в КЗ, не могли бы вы объяснить, что именно нужно исправить? спасибо!
Оставьте свое сообщение