Счёт-фактура 1137 для "старых" ТиС

Публикация № 106058

Печать - Печатные формы документов

29
Счёт-фактура по форме пост. 1137 для "старой" ТиС 7.7 (делалась под релиз 937)

Типовая внешняя форма СФ 1137 от 1С не работает на старых релизах ТиС - возникают синтаксические ошибки.

Небольшой тюнинг позволил решить эту проблему. Скопируйте оба файла в PrnForms.

Что собственно сделано: Макет оставлен без изменения, в модуле правим:

1. Ошибка

Если Докум.ДатаДок >= глДатаПостановления451 <>Тогда
{C:\PROGRAM FILES\1CV77\АСК\EXTFORMS\PRNFORMS\SF1137.ERT(81)}: Переменная не определена (глДатаПостановления451)

Эта переменная отсутствует в старых релизах, по умолчанию, её значение 9 июня 2009, поэтому

Если Докум.ДатаДок >= '09.06.2009' Тогда

2. Ошибка

БратьСуммыИзУчета = глБратьСуммыИзУчета<>(Докум.ДатаДок, Докум.ДокОснование.КодОперации); {C:\PROGRAM FILES\1CV77\АСК\EXTFORMS\PRNFORMS\SF1137.ERT(336)}: Функция не обнаружена (глБратьСуммыИзУчета) БратьСуммыИзУчета = глБратьСуммыИзУчета<>(Докум.ДатаДок); {C:\PROGRAM FILES\1CV77\АСК\EXTFORMS\PRNFORMS\SF1137.ERT(338)}: Функция не обнаружена (глБратьСуммыИзУчета)

В строй конфе нет этой функции, соответственно можем закомментировать весь блок
    //Если глЕстьРеквизитШапки("КодОперации", ВидОсн) = 1 Тогда
    //    БратьСуммыИзУчета = глБратьСуммыИзУчета(Докум.ДатаДок, Докум.ДокОснование.КодОперации);
    //Иначе
    //    БратьСуммыИзУчета = глБратьСуммыИзУчета(Докум.ДатаДок);
    //КонецЕсли;
    //
    //Если БратьСуммыИзУчета = 1 Тогда
    //    СкорректироватьТаблицуОснования(Докум, ТаблицаОснования, ВидОсн);
    //КонецЕсли;
Или по Вашему желанию оставьте (в прилагаемом файле закомментировано

СкорректироватьТаблицуОснования(Докум, ТаблицаОснования, ВидОсн);

После этого у меня вышла ещё одна ошибка, связанная с отсутствием поля Предприниматель у СвоегоЮрЛица

Если Докум.Фирма.ЮрЛицо.ИндивидуальныйПредприниматель = 1 Тогда
{D:\BASE\CL\УХС_СКЛАД\EXTFORMS\PRNFORMS\1137_000_СЧЕТ-ФАКТУРА_ТИПОВАЯ.ERT(122)}: Поле агрегатного объекта не обнаружено (ИндивидуальныйПредприниматель)

Правим

        // Индивидуальный предприниматель
    //Если Докум.Фирма.ЮрЛицо.ИндивидуальныйПредприниматель = 1 Тогда
    //    Рекв.ДобавитьЗначение("", "РуководительРасшифровка");
    //    Рекв.ДобавитьЗначение("", "ГлБухгалтерРасшифровка");
    //    Рекв.ДобавитьЗначение(Шаблон("№ [Докум.Фирма.ЮрЛицо.СвидетельствоСерияНомер] от [Докум.Фирма.ЮрЛицо.СвидетельствоДатаВыдачи] г."), "ПредпринимательРеквизитыСвидетельства");
    //    Рекв.ДобавитьЗначение(Шаблон("/[Докум.Фирма.ЮрЛицо.Руководитель.Получить(Докум.ДатаДок)]/"),"ПредпринимательРасшифровка");
    //Иначе
        Рекв.ДобавитьЗначение(Шаблон("/[Докум.Фирма.ЮрЛицо.Руководитель.Получить(Докум.ДатаДок)]/"), "РуководительРасшифровка");
        Рекв.ДобавитьЗначение(Шаблон("/[Докум.Фирма.ЮрЛицо.ГлБухгалтер.Получить(Докум.ДатаДок)]/"), "ГлБухгалтерРасшифровка");
        Рекв.ДобавитьЗначение("","ПредпринимательРеквизитыСвидетельства");
        Рекв.ДобавитьЗначение("","ПредпринимательРасшифровка");
    //КонецЕсли;



29

Скачать файлы

Наименование Файл Версия Размер
Внешняя печатная форма
.ert 50,50Kb
26.07.13
113
.ert 50,50Kb 113 Скачать
Файл подключения
.EFD 0,07Kb
26.07.13
30
.EFD 0,07Kb 30 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. tonic-spb 30.01.12 09:41 Сейчас в теме
спасибо! все реально исправить ручками за пять минут! помогло!
2. Neon3 31.01.12 16:51 Сейчас в теме
Пасибо с этой заработало
3. Neon3 31.01.12 17:42 Сейчас в теме
Если незатруднит можно еще выложить счет фактуру 2012 для старых тис с возможностью выбора грузополучателя.
4. Neon3 31.01.12 17:43 Сейчас в теме
или подскажите как исправить такую ошибку
Возврат Константа.СуммыВПечатныхФормахПоУчету;
{Глобальный модуль(328)}: Поле агрегатного объекта не обнаружено (СуммыВПечатныхФормахПоУчету)
5. alecsco 01.02.12 07:18 Сейчас в теме
почти все хорошо
в Столбце 10a это(Краткое наименование) если у товара нет страны вылетает ошибка.

МнЧ.СтранаК = РаспредГТД.Страна.Код;
{C:\TRADE\EXTFORMS\PRNFORMS\SF1137.ERT(504)}: Значение не представляет агрегатный объект (Код)

вбивать для каждого товара страну это не решение.
как исправить не понятно.
justadude; +1 Ответить
7. Timesoft 272 05.02.12 20:17 Сейчас в теме
(5) alecsco, Думаю,это не в случае, когда у товара нет страны....

Попробуйте в этом месте поменять код на:
 				// Если таблица была свёрнута, то она не спозиционирована ни на какой строке
				РаспредГТД.ПолучитьСтрокуПоНомеру(1);
				//
				МнЧ.НомерГТД    = РаспредГТД.Номер;
				МнЧ.СтранаН     = РаспредГТД.Страна;
				МнЧ.СтранаК     = РаспредГТД.Страна.Код;

Дело, по-моему в том, что товар списался несколькими партиями, без ГТД. Таблица РаспердГТД свёрнута и, как следствие не спозиционирована, а идёт обращение к её данным, в результате чего Страна и не определена.
6. infosoft-v 02.02.12 09:31 Сейчас в теме
Спасибо вам.
Очень помогли мне в этот горячий отчётный период. Экономия времени на лицо.
8. Il 11 06.02.12 10:33 Сейчас в теме
9. Гость 06.02.12 16:09
А под 930 есть такая же обработка?
Если незатруднит можно еще выложить счет фактуру 2012 для старых тис с возможностью выбора грузополучателя.
полностью согласен. И желательно под последние релизы)) Просто нет возможности сейчас вызывать програмиста 1с.
10. Timesoft 272 06.02.12 16:26 Сейчас в теме
(9) Гость,
А под 930 какие ошибки выдаёт ?
Если незатруднит можно еще выложить счет фактуру 2012 для старых тис с возможностью выбора грузополучателя.
полностью согласен. И желательно под последние релизы))

Если бы делал - выложил, не жалко.
Но под последние релизы на сайте же есть с грузополучателем ?
11. aindel 14.02.12 13:45 Сейчас в теме
12. vas5780 41 18.02.12 10:02 Сейчас в теме
Спасибо! За то что не поленились всё расписать. За это жирный плюс.
13. zotik87 04.03.12 22:17 Сейчас в теме
А в стране происхождения товара, цифровой код(ГТД и краткое наименование страны...) автоматом прописывается в печатной форме?
14. Serg_F1 12.03.12 14:19 Сейчас в теме
Спасибо Автору огромное)) отличная вещь, помогло отвязать от торгового отдела))) еще и бонус заработать)))
15. Serg_F1 13.03.12 10:15 Сейчас в теме
я ставил и на еще более страый 926 и все пошло как надо поэтому не задавайте вопросов, качайте спокойно))
16. vladtimof 13.03.12 14:44 Сейчас в теме
спасибо автору!отличная вещь!))
17. Darkid 29 24.03.12 00:07 Сейчас в теме
Timesoft,
А СФ полученная--это отдельный файл или твою ВПФ можно как-то подключить????
18. Timesoft 272 25.03.12 14:27 Сейчас в теме
(17) Darkid, СФ полученный - это отдельный документ\объект метаданных, соответственно у него свои ВПФ, но можно взять эту за основу и творчески переработать
19. Darkid 29 25.03.12 15:48 Сейчас в теме
(18)
Спасибо, уже работаю.... ))))
20. RASH999 29.03.12 22:49 Сейчас в теме
она фармирует счет фактуру на аванс?
21. aronskiy 12 09.04.12 13:19 Сейчас в теме
Присоединяюсь!
На аванс формирует?
Оставьте свое сообщение