Сканирование изображений, используя TWAIN компоненту WIA

Публикация № 1128189

Управление - Документооборот и делопроизводство

Универсальная обработка сканирование управляемые формы прикрепление файлов БП 3.0 УНФ УТ ЗКГУ

14
Универсальная обработка заполнения объектов для сканирования изображений сохранения в любом формате и прикрепления его к документу. Можно использовать как самостоятельную обработку, так и добавить через "Администрирование" во "Дополнительные обработки и отчеты". Протестирована на БП 3.0, УНФ 1.6, ЗКГУ 3.1, УТ 11.4, Розница 2.2. Не требуется установка дополнительных программ и компонентов (кроме драйвера сканера, естественно)

Данная обработка использует компоненту Twain которая хранится в макете обработки, никакие внешние процедуры из конфигурации ей не нужны что делает ее универсальной. Единственное только возможны изменения в процедурах регистрации обработки

	Если Метаданные.ОбщиеМакеты.Найти("ПрисоединенныеФайлы")<>Неопределено ТОгда
		Для каждого Спр Из Метаданные.Справочники Цикл
			Если ПрисоединенныеФайлы.КОбъектуМожноПрисоединятьФайлы(Справочники[Спр.Имя].ПустаяСсылка()) Тогда
				ПараметрыРегистрации.Назначение.Добавить("Справочник." + Спр.Имя);
			КонецЕсли;
		КонецЦикла;
		Для каждого Спр Из Метаданные.Документы Цикл
			Если ПрисоединенныеФайлы.КОбъектуМожноПрисоединятьФайлы(Документы[Спр.Имя].ПустаяСсылка()) Тогда
				ПараметрыРегистрации.Назначение.Добавить("Документ." + Спр.Имя);
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;

Для работы со сканерами мы используем Windows Image Acquisition (WIA)-это полнофункциональный компонент для обработки изображений, обеспечивающий сквозные возможности обработки изображений. Уровень автоматизации WIA позволяет легко получать изображения с цифровых камер, сканеров или веб-камер, а также вращать, масштабировать и аннотировать файлы изображений https://docs.microsoft.com/en-us/previous-versions/windows/desktop/wiaaut/-wiaaut-wiadevicetype

 
.....
	КодВозврата = ПодключитьВнешнююКомпоненту("ВнешняяОбработка.СканированиеДокументов.Макет.КомпонентаTWAIN", "twain");
.....
	Соответсвие = Новый Соответствие;
	
	Соответсвие.Вставить("DeviceManager", Новый COMОбъект("WIA.DeviceManager"));
	Соответсвие.Вставить("ImageFile", Новый COMОбъект("WIA.ImageFile"));
	Соответсвие.Вставить("CommonDialog", Новый COMОбъект("WIA.CommonDialog"));
	Соответсвие.Вставить("ImageProcess", Новый COMОбъект("WIA.ImageProcess"));
.....

Для определения списка устройств:

Функция ПолучитьУстройства() Экспорт
	
	Массив = Новый Массив;
	
	Если Не ПроинициализироватьКомпоненту() Тогда
		Возврат Массив;
	КонецЕсли;
	
	Для Каждого DeviceInfo Из Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["DeviceManager"].DeviceInfos() Цикл
		Массив.Добавить(DeviceInfo.Properties("Name").Value);
	КонецЦикла;
	
	Возврат Массив;
	
КонецФункции

Получить нужное устройство для работы и обработки:

 
Функция ПолучитьУстройство(ИмяУстройства)
	
	Для Каждого DeviceInfo Из Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["DeviceManager"].DeviceInfos() Цикл
		Если ВРЕГ(DeviceInfo.Properties("Name").Value) = ВРЕГ(ИмяУстройства) Тогда
			Возврат DeviceInfo;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Неопределено;
	
КонецФункции

Для работы с диалоговыми окнами необходимо определить несколько переменных:

Типы файлов:

	СоответствиеФорматID = Новый Соответствие;
	СоответствиеФорматID.Вставить(-1, "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("BMP", "{B96B3CAB-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("PNG", "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("GIF", "{B96B3CB0-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("JPG", "{B96B3CAE-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("JPEG", "{B96B3CAE-0728-11D3-9D7B-0000F81EF32E}");
	СоответствиеФорматID.Вставить("TIFF", "{B96B3CB1-0728-11D3-9D7B-0000F81EF32E}");
 

Типы изображений:

	СоответствиеЦветностьID = Новый Соответствие;
	СоответствиеЦветностьID.Вставить(-1, 0);	//Не задано
	СоответствиеЦветностьID.Вставить(0, 4);		//Монохромное (текст)
	СоответствиеЦветностьID.Вставить(1, 2);		//Чернобелое
	СоответствиеЦветностьID.Вставить(2, 1);		//Цветное

Для запуска сканера в нужном режиме без диалога:

 
  Image = CommonDialog.ShowAcquireImage(WiaDeviceType, WiaImageIntent, WiaImageBias, СоответствиеФорматID.Получить(ФорматКартинки));

Для запуска помощника сканирования:

 
....
 objDevice=CommonDialog.ShowSelectDevice(WiaDeviceType,false,false);
 Image = CommonDialog.ShowAcquisitionWizard(objDevice); //ПолучитьУстройство(ИмяУстройства));		
....

Если желаем полностью настроить сканер программно и запустить сканирование без диалогов:

 
РазмерГоризонтально = Окр(210 / 25.4 * Разрешение, 0);
РазмерВертикально = Окр(296 / 25.4 * Разрешение, 0);

Device =  Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["DeviceManager"]; //Новый COMОбъект("WIA.DeviceManager");
DeviceInfo = Device.DeviceInfos();
Если DeviceInfo.Count() > 0 Тогда
	objDevice = CommonDialog.ShowSelectDevice(WiaDeviceType, Ложь, Ложь);

	Сканер = objDevice.Items(1);
	СканерПараметры = Сканер.Properties();
	СканерПараметры.Item("6146").Value = Цветность;
	СканерПараметры.Item("6147").Value = Разрешение;
	СканерПараметры.Item("6148").Value = Разрешение;

	СканерПараметры.Item("6149").Value = 0;
	СканерПараметры.Item("6150").Value = 0;

	СканерПараметры.Item("6151").Value = РазмерГоризонтально;
	СканерПараметры.Item("6152").Value = РазмерВертикально;

	Image = Сканер.Transfer();

КонецЕсли;

Весь список свойств можно получить через отладку

И последнее - это как и где получить возможные разрешения для сканера. Они также хранятся в свойствах каждого элемента.

В принципе, для работы со сканером как бы все есть, даже более. 

Также данную библиотеку можно использовать и для получения видео и для обработки изображений. Например, вот так с помощью нее можно конвертировать изображение в нужный формат данных:

 
ImageProcess = Обработка_ПараметрыПриложения["СтандартныеПодсистемы.ИнтерфейсWIA"]["ImageProcess"];
	
Если  ImageProcess.Filters.Count = 0 ТОгда
	ImageProcess.Filters.Add(ImageProcess.FilterInfos("Convert").FilterID);
Конецесли;
ImageProcess1 = ImageProcess.Filters(1);
Для К = 1 По ImageProcess1.Properties.Count Цикл
	Если ImageProcess1.Properties(К).Name = "FormatID" Тогда
		ImageProcess1.Properties(К).Value = СоответствиеФорматID.Получить(ФорматКартинки);
		Прервать;
	КонецЕсли;
КонецЦикла;
	
Image = ImageProcess.Apply(Image); //применяем фильтр на изображение

Обработка тестировалась на платформе 1С:Предприятие 8.3 (8.3.15).

Проверено на конфигурациях БП 3.0, ЗКГУ 3.1, УНФ 1.6, УТ 11.4, Розница 2.2.

14

Скачать файлы

Наименование Файл Версия Размер
Сканирование изображений используя TWAIN компоненту WIA:
.epf 120,73Kb
26.09.19
2
.epf 120,73Kb 2 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. amd1986 27.09.19 11:18 Сейчас в теме
Компонента работает на 64 битной платформе 1С? Ранее то не работала..
2. vik070777 168 27.09.19 12:12 Сейчас в теме
Щас проверю на ВебКлиенте точно не работает
3. vik070777 168 27.09.19 12:36 Сейчас в теме
Работает
Прикрепленные файлы:
Оставьте свое сообщение

См. также

Совместное использование 1С:Сервер взаимодействия и Документооборот 8 КОРП, редакция 2.1.13 - Уведомления для рабочего стола 21

Статья no Архив с данными v8 ДО УУ Документооборот и делопроизводство Абонемент ($m) Пользователю системы Работа с интерфейсом Интеграция

С версии ДО 2.1.13 в программу встроена подсистема Обсуждения. Данная подсистема позволяет производить уведомление пользователей без необходимости открытия программы.

1 стартмани

18.06.2019    4977    ilya.rudziak    6       

Рабочий стол пользователя 22

Отчеты и формы Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Рабочее место

Простой в использовании инструмент, позволяющий настраивать навигацию по программе.

1 стартмани

04.06.2019    2978    21    sam271091_m    11       

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть 17

Инструменты и обработки Бухгалтер Расширение (cfe) v8 ERP2 БУ Документооборот и делопроизводство Абонемент ($m) Внешние источники данных

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

2 стартмани

07.04.2019    2830    8    sapervodichka    6       

Расширение для загрузки в 1С сканов документов, pdf файлов, распознанных с помощью продуктов ABBY 13

Инструменты и обработки Бухгалтер Пользователь Архив с данными v8 1cv8.cf Россия Windows Документооборот и делопроизводство Абонемент ($m) Обработка документов

Подсистема, предназначенная для автоматического разбора распознанного файла, извлечение из него полезной информации и загрузки данных в 1С.

1 стартмани

27.03.2019    2058    13    trim89    2       

Визуализация электронной подписи на исходящих документах в соответствии с ГОСТ Р 7.0.97-2016. Полная автоматизация 15

Отчеты и формы Программист Пользователь Архив с данными v8 ДО Россия Документооборот и делопроизводство Абонемент ($m) Печатные формы документов

Визуализация ЭЦП по ГОСТу Р 7.0.97-2016, предложенная в предыдущей статье (https://infostart.ru/public/931674/) на данную тему, очень прижилась у меня в организации. Начальник часть писем повелел подписывать ЭЦП и не тревожить его по пустякам. Но механизм подписи требовал некоторого количества ручных действий, а хочется полной автоматизации. Итак, постановка задачи: штамп должен позиционироваться сам, pdf-файл со штампом ЭЦП должен создаваться сам и в карточку исходящего документа тоже должен сам загружаться.

1 стартмани

19.02.2019    4503    23    soulner    19       

СМС2 - эрзац-мессенджер в вашей конфигурации 1С 17

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::УФ Windows Абонемент ($m) Практика программирования Работа с интерфейсом Рабочее место

Обработка предоставит вам некоторый функционал мессенджера внутри используемой конфигурации. Вложения с файлами и ссылками, аватары у пользователей, всё это можно и в 1С.

1 стартмани

17.12.2018    3725    4    semagin@gmail.com    15       

Централизованное управление списком доступных баз 1С у пользователей 7

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Стартеры 1С Сервисные утилиты Рабочее место

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    4543    7    RomikR    7       

Мобильный сканер документов 20

Инструменты и обработки Бухгалтер Пользователь Архив с данными v8 ДО ERP2 БП3.0 Россия Документооборот и делопроизводство Абонемент ($m) Обработка документов Пользователю системы Обработка справочников

Если под рукой нет обычного сканера, то можно воспользоваться собственным телефоном в качестве сканера для документов 1С.

3 стартмани

29.09.2018    5261    12    RSConsulting    16       

Модуль предварительного просмотра документов и файлов 18

Инструменты и обработки no Архив с данными v8 v8::УФ ДО Windows Документооборот и делопроизводство Абонемент ($m) Универсальные обработки Рабочее место

Модуль предварительного просмотра предназначен для продукта 1С:Документооборот. Он позволяет посмотреть содержимое файла или документа не открывая его в сторонних программах. Поддерживаются популярные форматы файлов и документов: pdf, doc, xls, odt, ods, jpg и другие.

10 стартмани

28.09.2018    6493    34    fr13    20       

Расширение "Интерфейс Плюс" 40

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    9795    88    RocKeR_13    81       

Планировщик задач 20

Отчеты и формы no Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Абонемент ($m) Рабочее место

Предназначен для оперативного учета событий. УФ, 8.3.

5 стартмани

14.08.2018    5216    5    maksa2005    9       

Инструменты бухгалтера: Быстрые отборы в списках 15

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 Россия Абонемент ($m) Универсальные обработки Рабочее место

В обычных формах очень удобный стандартный функционал быстрых отборов в списках, то чего лишены управляемые формы, кнопки позволяющие в одно действие отобрать по значению текущей колонки, отключить отборы или использовать ранее наложенные быстрые отборы. Расширение добавляет этот функционал в формы списков документов кнопки быстрых отборов "Отбор по значению в текущей колонке", "Отбор и сортировка", "Отключить отбор" и подменю "История отборов".

1 стартмани

02.08.2018    5201    31    Bazil    2       

Печать pdf документа со штампом ЭЦП 16

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ ДО Документооборот и делопроизводство Абонемент ($m) Печатные формы документов

Печать pdf файла, прикрепленного к внутреннему документу, подписанному ЭЦП, с установкой отметки о подписании.

1 стартмани

24.05.2018    8566    61    App0st0l    12       

Простая подсистема согласования 54

Отчеты и формы no Архив с данными v8 v8::УФ 1cv8.cf УУ Документооборот и делопроизводство Абонемент ($m) Рабочее место

Простая система согласования (утверждения), с простой установкой на любую конфигурацию с управляемыми формами.

1 стартмани

27.03.2018    10335    49    eugenevk    22       

Андроид-решение для создания заказов в 1С 37

Отчеты и формы Программист Пользователь Подсистема v8 1cv8.cf УУ Android Оптовая торговля Учет ТМЦ Абонемент ($m) Рабочее место

Разработка создает заказы в 1С на Андроид-телефонах через RDP-клиент. Описана технология подобных разработок.

2 стартмани

23.03.2018    14150    9    Rustig    54       

Очередная система ведения учета задач 46

Отчеты и формы no Архив с данными v8 Россия УУ Учет рабочего времени Абонемент ($m) Рабочее место Личная эффективность

Конфигурация предназначена для учета времени при выполнении каких-нибудь работ за компьютером. В конфигурации акцент сделан на минимальные затраты времени исполнителей при создании, поиске и вводе задач в работу.

7 стартмани

28.02.2018    11520    114    asdes    42       

Выбор цены в РМК для УТ 11.3 и УТ 11.4 (расширение) 18

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ УТ11 Россия УУ Кассовые операции Розничная торговля Абонемент ($m) Рабочее место

Расширение для УТ 11.3 и УТ 11.4, разрешает в рабочем месте кассира выбор вида цены или установку произвольной цены на каждую позицию.

1 стартмани

29.12.2017    18969    109    kassbar    76       

Эмулятор скриптов в 1С:Документооборот 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 ДО Документооборот и делопроизводство Абонемент ($m) Инструментарий разработчика

В 1С:Документообороте можно использовать программный код 1С в пользовательском режиме (не в конфигураторе). Однако если в конфигураторе есть отладчик, то в пользовательском режиме протестировать скрипт достаточно сложно. Внешняя обработка Эмулятор скриптов позволяет вывести результаты скрипта и проверить работу алгоритма на разных документах.

2 стартмани

13.12.2017    9445    61    vlush78    0       

Инструменты бухгалтера: Виджеты рабочего стола 124

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 Windows Абонемент ($m) Универсальные обработки Рабочее место

Настраиваемые виджеты на начальной странице, своеобразная панель для быстрого доступа к объектам. Виджеты это элементы интерфейса в виде цветных прямоугольников со ссылками на объекты конфигурации. Использование виджетов позволяет сконцентрировать на начальной странице часто используемые функции, например, варианты отчетов, списки документов, или используя виджет вводить новый документ прямо из начальной страницы.

2 стартмани

28.08.2017    25326    158    Bazil    22       

Рабочий стол (Панель функций) 53

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Рабочее место

Рабочий стол (Панель функций) предназначен для создания панельки, где будут находиться созданные вами ярлыки(кнопки) для открытия документов, журналов, справочников, обработок, отчетов и пр. объектов конфигурации. Также ее можно разрисовать таким образом, чтобы для пользователя была ясна последовательность рабочего процесса. Из панели можно открывать списки с отбором по сотруднику, если в документах списка присутствует реквизит "Сотрудник" или "Ответственный". С данным инструментом может работать даже неподготовленный пользователь.

1 стартмани

09.08.2017    13452    36    KillerMann    16       

Загрузка всех онлайн-чеков с сервиса проверки чеков ФНС – обработка для получения данных о покупках по чекам онлайн-касс с загрузкой в Авансовый отчет 13

Инструменты и обработки Системный администратор Программист Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf Россия Документооборот и делопроизводство Кассовые операции Розничная торговля Учет ТМЦ Абонемент ($m) Внешние источники данных WEB Бухгалтерия

В продолжение статьи «Свой кусочек информационного пирога по 54-ФЗ – обработка для получения данных о своих покупках по чекам ОФД» (на примере сети магазинов «Лента») (http://infostart.ru/public/647711/). Однако, в предыдущей публикации был показан пример получения данных с сервиса ОФД Такском по одному магазину, в новой публикации – показан пример загрузки всех чеков по всем ОФД непосредственно с сервиса проверки чеков ФНС. Опубликованы обработки, позволяющие работать по двум схемам: вносить данные по каждому чеку, получая данные с ФНС, или загружать чеки в мобильное приложение ФНС, выбирая в последующем для загрузки нужные чеки из списка.

3 стартмани

26.07.2017    16679    82    delta    10       

Рабочее место кассира 1С:Розница 2.2 (РМК) как Фронт-офис с поиском по цене и только положительными остатками 30

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ УУ Кассовые операции Розничная торговля Абонемент ($m) Рабочее место

РМК Розница 2.2.9 с изменениями: 1) Только положительные остатки 2) Поиск по цене 3) Форма РМК с полем ввода (полем поиска) 4) Форма подбора товаров с окном характеристик 5) Внесение ден.средств без РКО и др.

1 стартмани

11.07.2017    30953    121    Vlx    79       

Знакомство с 1С:Документооборот. История автоматизации и доработок. Печатная форма Лист согласования 23

Статья Программист Архив с данными v8 ДО УУ Документооборот и делопроизводство Абонемент ($m) Практика программирования

Документооборот 2.1.10.2 ПРОФ. История автоматизации и доработок. Ввод на основании внутреннего документа из задачи согласование с переносом прикрепленных файлов(копировать и вставить файлы). ПФ Лист согласования для процесса Согласование и для справочника Внутренние документы(печатается с историей). Автоматическая загрузка справочника по com-соединению из другой базы.

1 стартмани

04.07.2017    15194    24    SPonomareff    14       

Остатки и цены номенклатуры для УТ 11 16

Отчеты и формы Руководитель проекта Внешняя обработка (ert,epf) v8 v8::ОУ УТ11 Россия УУ Windows Оптовая торговля Учет ТМЦ Абонемент ($m) Рабочее место

Внешняя обработка для менеджера, чтобы быстро информировать клиента о ценах и остатках.

1 стартмани

30.03.2017    11733    67    ssn5810    14       

Рабочий стол Управление финансами для конфигурации УЛФин 18

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Домашние учет и финансы УУ Банковские операции Финансовый учет и бюджетирование (FRP) Абонемент ($m) Рабочее место

Мне показалось, что было бы неплохо реализовать возможность отражать движение денежных средств так же, как это делается в личном кабинете интернет-банкинга

2 стартмани

25.03.2017    10146    1    echo77    0       

Настройка начальной страницы (Рабочего стола) 47

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Рабочее место Универсальные обработки

Альтернатива стандартной настройке начальной страницы. В типовой доступны лишь те формы, что явно "разрешены" разработчиком в режиме конфигуратора. Эта обработка позволяет собрать "Рабочий стол" из любых подходящих форм в пользовательском режиме. Без программирования. БСП не используется. Не расширение. Универсальна, т.е. подойдет для любой конфигурации (в т.ч. самописной).

2 стартмани

19.10.2016    24101    186    Erne100    24       

Блокировка повторного запуска комплексного процесса в 1С: Документооборот 2 19

Инструменты и обработки Системный администратор Программист Архив с данными v8 ДО Документооборот и делопроизводство Абонемент ($m) Администрирование данных 1С

Острой проблемой при работе документооборота стал повторный запуск комплексного процесса. Пользователи несколько раз  запускали один и тот же комплексный процесс по документу, не убедившись, что этот же процесс уже запущен. В результате наступил хаос, все возмущались и недоумевали, почему один и тот же документ приходил на согласование и исполнение несколько раз. 

2 стартмани

04.10.2016    15618    65    zabaluev    23       

Управление небольшим проектом в стиле Канбан (аналог Trello досок) 36

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Управление взаимоотношениями с клиентами (СRM) Абонемент ($m) Рабочее место

Система, основанная на карточках и наследующая принципы KanBan. Позволяет организовать персональную работу за минимальное время. Подходит для стартапов, домашних проектов и просто для хранения идей. В текущем виде проектируется для организации работы службы поддержки в целях оптимизации бизнес-процессов и замены текущего инструмента (Trello досок) используемого для обработки входящих обращений в CRM

1 стартмани

26.09.2016    15986    43    vagipov    30       

Универсальный рабочий стол для неуправляемых форм 15

Инструменты и обработки no Внешняя обработка (ert,epf) v8 УТ10 Россия Абонемент ($m) Рабочее место

Универсальный рабочий стол для неуправляемых форм с возможностью изменения в пользовательском режиме

3 стартмани

22.09.2016    6913    22    Vit aka proger    7       

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации 126

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    36599    217    BlizD    177       

Рабочее место менеджера по продажам 18

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Украина УУ Windows Оптовая торговля Абонемент ($m) Рабочее место

Каждый день менеджеры создают кучу документов. Это и заказы покупателей и сопутствующие документы, которые создаются на основании. Менеджеру всегда необходимо иметь под рукой наиболее эффективный инструмент для формирования заявки от покупателя. Таковым я постарался сделать и эту обработку. Обработка "Рабочее место менеджера продаж" позволяет быстро узнать информацию о товарах на складах, цены товара в различных типах цен номенклатуры, узнать какие цены у поставщиков по выбранному товару и так далее. Много месяцев текущая обработка работает на благо сотрудников и приносит действительно большую пользу. Правда, она более внедрена в работу организации, но даже её модифицированная часть для общества должна принести не менее выгоды в работе с товарами и и заказами покупателей. Так что вот она.

5 стартмани

16.07.2016    20613    50    yarsort    9       

Планировщик для БСП 21

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Рабочее место

Планировщик задач на базе подсистемы "Напоминания пользователя" для БСП. Должен работать и на других конфигурациях (УТ, УНФ и пр.), где есть эта подсистема.

1 стартмани

30.04.2016    12233    57    Mopo3    9       

Номенклатура (Расширенная форма списка) и Корзина [Расширение] 80

Инструменты и обработки Бухгалтер Пользователь Расширение (cfe) v8 БП3.0 Windows Учет ТМЦ Абонемент ($m) Обработка справочников Рабочее место

Красивая, удобная и эргономичная форма списка номенклатуры. В общем списке номенклатуры отображаются и остатки, и цены. А еще есть возможность быстро создать документы по выбранным позициям через корзину.

5 стартмани

29.02.2016    26381    118    mrXoxot    45       

Самый простой клиент ЕГАИС УТМ для розницы. $m 52

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия УУ Windows Розничная торговля Абонемент ($m) Внешние источники данных Рабочее место

Данная обработка позволяет обеспечить приходную часть магазина розничной торговли алкоголем(ЕГАИС розница), или прочего предприятия. Эти действия становятся обязательными для розничного звена в городских поселениях с 01.01.2016 и будут достаточными до 01.07.2016. Предлагаю Вашему вниманию простое и доступное решение, которое позволяет отсрочить проблему интеграции ЕГАИС в розничное звено до указанной даты. (открытый код). Реализовано на открытой модели http://infostart.ru/public/402052/.

2 стартмани

14.12.2015    33408    6    Terrain25    47       

Канбан-доска без изменения конфигурации для УПП, УТ 10, КА 76

Инструменты и обработки Пользователь Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 1С:Франчайзи, автоматизация бизнеса УУ Windows Монитор заказов Абонемент ($m) Рабочее место

Канбан - крайне эффективный подход, разработанный для тойотовской системы управления, давно разошелся в разные сферы. Например, канбан-доски прижились для управления разработкой софта или в логистике. Данная обработка - упрощенная заготовка для типовых конфигураций, которая демонстрирует данный подход.

1 стартмани

11.12.2015    17133    85    informa1555    9       

Выгрузка и подготовка данных для программы "Перечень льготных профессий" для 1С: ЗУП 2.5 (ОТКРЫТЫЙ КОД) 29

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 Россия БУ Windows Управление персоналом (HRM) ФОМС, ПФ, ФСС Абонемент ($m) Внешние источники данных Рабочее место

Обработка для формирования и редактирования данных для перечня льготных профессий. В связи с прекращением поддержки ЗУП 2.5 и отсутствием времени на доработку для сдачи годовой отчетности открыл код модуля. Не очередная выгрузка стажей, а практически полный аналог перечня для 1С. Формирование и редактирование стажей с последующей выгрузкой в формат перечня, но только ГОРАЗДО удобнее и быстрее. В общем, смотрите видео. Где-то половина времени на написание обработки ушла именно на удобство и скорость работы. Внимание: код модуля обработки открыт

5 стартмани

09.11.2015    40711    51    Black-fog    62       

Создание договоров по шаблонам Word в УТ 11.2, БП 3.0 с возможностью хранения в справочнике "Файлы" 40

Инструменты и обработки Программист Архив с данными v8 БП3.0 УТ11 УУ Документооборот и делопроизводство Абонемент ($m) Универсальные печатные формы Универсальные обработки

Публикация предназначена тем, кто ведет договоры в УТ 11 не только в справочнике "Договоры с контрагентами", но также формирует и согласовывает с контрагентами договоры в формате Word (*.doc). А так как программисты люди ленивые и я не являюсь исключением в этом (хорошем) смысле :), была создана эта печатная форма. Но это не простая печатная форма, а инструмент, который позволяет на основании шаблона, хранящегося в информационной базе в справочнике "Файлы", быстро заполнять и сохранять тут же в справочник "Файлы", но в другую папку, уже заполненный на основании шаблона договор в формате Word.

1 стартмани

08.10.2015    27129    232    Diversus    49       

Агрегатор событий работы с клиентами на базе сообщений электронной почты 17

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 Россия УУ Windows Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Абонемент ($m) Обработка документов

Данная внешняя обработка служит для тех случаев, когда по каким-либо причинам невозможна, нерациональна или нежелательна установка 1С на устройства (компьютеры) некоторых пользователей, тем не менее необходимо обеспечить им возможность добавлять документы "Событие". При этом желательно, чтобы пользователи делали это привычным для них способом, таким как электронная почта.

5 стартмани

15.07.2015    11417    9    INTECH1    5