Проверка торгового оборудования только у определенного пользователя!!!!

Публикация № 123866

Администрирование - Информационная безопасность

17
Настраиваем проверку торгового оборудования только на том пользователе который с ним работает!

Давно раздражало когда заходишь в 1с под пользователем который не работает с торговым оборудованием а тебе!

 

"

************: Ошибка при подключении устройства.
Необходимо убедиться, что устройство правильно настроено и соответствующий порт не занят другим приложением.
Произошла ошибка при подключении торгового оборудования

"

Настройки средствами 1с для этих целей в УТ 8.2 10.3 НЕТ! что очень раздражает!!! Вот мое решение:

 

Способ первый:

 

1: Делаем резервную копию базы!

2: Открываем конфигуратор/Обработки/ТОСервер/МодульОбъекта

3: Находим функцию "ПодключитьОборудование(Вид, Клиент)"

4: Находим следующие строки "

Запрос.УстановитьПараметр("Вид" , Вид);
Запрос.УстановитьПараметр("Компьютер", ПолучитьИмяКомпьютераТО());
СтрокиТО = Запрос.Выполнить().Выгрузить();
СтрокаТО = Неопределено;
Для Каждого СтрокаТО Из СтрокиТО Цикл"

5: Сразу после этих строк добавляем:

Если НЕ ПараметрыСеанса.ТекущийПользователь = Справочники.Пользователи.НайтиПоНаименованию("*****") Тогда
Продолжить;
КонецЕсли;

Вместо "*****" указываем Имя пользователя для которого торговое оборудование так же будет проверяться! А всем остальным можно радоваться)))

6: Сохраняем конфигурацию "F7" Все готово, запускаем и радуемся)

 

Способ второй:

 

1: Открываем конфигуратор и находим «Планы видов характеристик»

2: Далее открываем «НастройкиПользователей/Прочее/Предопределенные»

3: Добавляем новый вид и называем его к примеру

Имя: «ПроверкаТорговогоОборудования»

Тип: «Булево»

Наименование: «Проверка подключения торгового оборудования»

 

Так, с этим все =)

 

4: Далее идем «Обработки/ТОСервер»

5: Жмем «Действие/Открыть модуль объекта»

6: В открывшемся модули ищем строки:

 

                        Запрос.УстановитьПараметр("Вид"      , Вид);

                        Запрос.УстановитьПараметр("Компьютер", ПолучитьИмяКомпьютераТО());

                        СтрокиТО = Запрос.Выполнить().Выгрузить();

                        СтрокаТО = Неопределено;

                        Для Каждого СтрокаТО Из СтрокиТО Цикл

 

И после них вставляем:

мТекущийПользователь = ПараметрыСеанса.ТекущийПользователь;

Проверка = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(мТекущийПользователь, "ПроверкаТорговогоОборудования");

 Если НЕ Проверка Тогда

             Продолжить;

     КонецЕсли;

 

7: Сохраняем конфигурацию =)

 

Теперь в «Настройках пользователя» можно выбрать нужно этому пользователю проверять подключение или нет =)

 

Всем удачи)

17

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. anton.fly7 149 05.04.12 12:10 Сейчас в теме
Ну очень универсальное решение!
Особенно если пользователей >100
2. mob51 138 05.04.12 12:22 Сейчас в теме
(1) anton.fly7, А вы бы вместо упреков свое решение выложите!
kamsky93; +1 Ответить
3. anton.fly7 149 05.04.12 12:27 Сейчас в теме
(2) у меня в плане видов характеристик ПраваПользователей добавил предопределнное булево значение НеПодключатьОборудование
если у пользователя это значение Ложь, то проверка отключена, примерно там же где и у вас
4. mob51 138 05.04.12 12:36 Сейчас в теме
(3) anton.fly7, Вот видите, лучше людям помочь=) Если вы не против добавлю в статью с ссылкой на автора.
6. smilejka 30 05.04.12 13:43 Сейчас в теме
(3) anton.fly7,
Аналогичное решение и у меня. Только я не предопределенное значение указывал, а в пользовательском режиме добавил и ищу по коду. При обновлениях план видов характеристик может обновится и придется перетирать изменения. В пользовательском режиме обязательно нужно создавать с префиксом, чтобы после обновления, если добавятся новые предопределенные значения, небыло элементов с одинаковым кодом.
5. anton.fly7 149 05.04.12 12:49 Сейчас в теме
7. Levran123 5 05.04.12 13:55 Сейчас в теме
3: Находим функцию "ПодключитьОборудование(Вид, Клиент)"

4: Находим следующие строки "

Запрос.УстановитьПараметр("Вид" , Вид);
Запрос.УстановитьПараметр("Компьютер", ПолучитьИмяКомпьютераТО());
СтрокиТО = Запрос.Выполнить().Выгрузить();
СтрокаТО = Неопределено;
Для Каждого СтрокаТО Из СтрокиТО Цикл"

5: Сразу после этих строк добавляем:

а почему бы не проверить пользователя на право пользования торговым оборудованием в начале функции???
Kabal; Рамзес; yku; +3 Ответить
8. yku 331 07.04.12 23:39 Сейчас в теме
А я регистр сведений создал: какому пользователю, какое оборудование подключается.
9. mob51 138 08.04.12 15:48 Сейчас в теме
(8) yku, напишите подробнее, добавлю в статью для других людей
10. Angeros 10.04.12 03:47 Сейчас в теме
Лучше скажите как быть когда люди пересаживаются и у всех терминал сервер.?!
11. mob51 138 13.04.12 02:40 Сейчас в теме
Не вижу проблемы, все в любом случае заходят под своим Логином и паролем. Если я вас не правильно понял то прошу описать проблему развернуто.
12. alenakrr 25.04.12 10:57 Сейчас в теме
У меня какая-то неправильная стандартная конфигурация?
потому что у меня есть в обработках пользователей ТО возможность указать список пользователей, которых на подключение ТО проверяют.
13. mob51 138 27.04.12 00:37 Сейчас в теме
(12) alenakrr, У вас скорее всего более ранняя версия конфигурации в которой есть такая возможность.
14. bzmax 27.04.12 02:11 Сейчас в теме
Была аналогичная проблемка. Это у старых конфигураций. Новые уже учитывают пользователя.
Итак.
Задача стояла в том, что нужно было к серверу терминалов подключить сеть розничных магазинов. Основная заковырка была в том что на клиентских машинах стоял линукс.
Пришлось com-порты с линуксоидных машин на сервер RDP перебрасывать утилитами com-tcp.
В итоге на сервере терминалов образовалось аж 24 com-порта. И вот тут и возникла потребность в подключении оборудования с учетом пользователя. Т.к. например один и тот же драйвер ФР для разных пользователей должен обращаться к разным com-портам.
Решение нашлось быстро и легко. Посмотрите на регистр сведений "Торговое оборудование" ресурс "Компьютер" - это строка 100 символов. В которую записывается имя компа к которому подключается оборудование. Кто мешает в этот ресурс вписывать строку такого формата [имя_компа]\\[имя_пользователя]. Таким образом вы получите оборудование и в разрезе компов и пользователей. Для этого достаточно отредактировать одну сроку в конфигурации -
Обработка.ТОСервер (модуль объекта)

// Функция возвращает строку c именем компьютера для нужд торгового оборудования.
//
// Возвращаемое значение:
//  Строка - имя компьютера для торгового оборудования.
//
Функция ПолучитьИмяКомпьютераТО() Экспорт

	Если мИмяКомпьютера = Неопределено Тогда
		//мИмяКомпьютера = ВРег(ИмяКомпьютера());	// старая строка
		мИмяКомпьютера = ВРег(ИмяКомпьютера()+"\\"+ИмяПользователя()); // новая строка
	КонецЕсли;

	Возврат мИмяКомпьютера;

КонецФункции // ПолучитьИмяКомпьютераТО()
Показать

Вот и вся хитрость :).
Тем же пользователям которым не нужно торговое оборудование, его в настройках торгового оборудования просто не нужно включать(настраивать).
Прикрепленные файлы:
Spacer; Leoon; smolyakov; Shomak; PONOM; Рамзес; DimaP; Alexey55; LudmilaFP; avega; +10 Ответить
15. renmy 86 04.10.13 10:54 Сейчас в теме
(14) bzmax,
Немного переделал, т.к. один и тот же пользователь может заходить в 1с с разных рабочих мест, оборудование может быть недоступно или он захватит оборудование с другого компьютера. В данном случае лучше привязывать оборудование к терминальному пользователю.

Функция ПолучитьИмяКомпьютераТО() Экспорт

	//ren
	ПользовательРДП = "";
	Попытка
		WshShell = Новый COMОбъект ("WScript.Network");
		ПользовательРДП = WshShell.UserName;
		WshShell = Неопределено;
	Исключение
	КонецПопытки;
	Если ПустаяСтрока(ПользовательРДП) Тогда
		ПользовательРДП = ИмяПользователя();
	КонецЕсли;
	//ren
	
	Если мИмяКомпьютера = Неопределено Тогда
		//ren мИмяКомпьютера = ВРег(ИмяКомпьютера());
		мИмяКомпьютера = ВРег(ИмяКомпьютера()+"\\"+ПользовательРДП);//ren
	КонецЕсли;

	Возврат мИмяКомпьютера;

КонецФункции // ПолучитьИмяКомпьютераТО()
Показать
Nefertary; Miket78; smolyakov; +3 Ответить
16. bzmax 04.10.13 11:40 Сейчас в теме
(15) renmy,
Можно и так :)
Но технологически неправильно что бы с разных "мест" один и тот же пользователь заходил (!)Одновременно.
17. Miket78 5 02.12.13 14:37 Сейчас в теме
А как узнать работает в терминальном режиме пользователь или в обычном? У меня 50/50 работают. Хочу чтоб для обычного режима имя компьютера формировалось по прежнему, только по имени компа, чтобы не перенастраивать на всех компах, да и не зависело от того, кто запустил 1с.
18. andrey314 11 28.05.14 17:49 Сейчас в теме
(17) Miket78, Можно так:

Функция ПолучитьИмяКомпьютераТО() Экспорт

	Если мИмяКомпьютера = Неопределено Тогда
		мИмяКомпьютера = ВРег(ИмяКомпьютера());
	КонецЕсли;

	// РДП сессия
	ШелСкрипт=Новый COMОбъект("WScript.Shell");
	ИмяТерминальногоКлиента = ШелСкрипт.ExpandEnvironmentStrings("%clientname%");	
	Если ИмяТерминальногоКлиента <> "%clientname%" Тогда
		мИмяКомпьютера = ВРЕГ(ИмяТерминальногоКлиента);
	КонецЕсли;
	//
	
	Возврат мИмяКомпьютера;

КонецФункции // ПолучитьИмяКомпьютераТО()
Показать
19. Daniayr 22.08.17 13:18 Сейчас в теме
нужно ли что то менять когда отключаем оборудование в коде?
Процедура ОтключитьОборудование(Клиент)

	ТО              = ПолучитьТО();
	Клиенты         = ПолучитьПараметрСервераТО("Клиенты",      "Соответствие");
	ВидТО           = Неопределено;
	СтруктураПоиска = Новый Структура("Вид");

	Для Каждого ВидТО Из Перечисления.ВидыТорговогоОборудования Цикл
		Если Клиент.ПоддерживаетсяВидТО(ВидТО) Тогда
			СтруктураПоиска.Вид = ВидТО;
			СтрокиТО            = ТО.НайтиСтроки(СтруктураПоиска);
			СтрокаТО            = Неопределено;
			Для Каждого СтрокаТО Из СтрокиТО Цикл
				Если      СтрокаТО.Ссылки = 1 Тогда
					СтрокаТО.Ссылки = 0;
					СтрокаТО.Обработка.Отключить(СтрокаТО.Объект);
				ИначеЕсли СтрокаТО.Ссылки > 1 Тогда
					СтрокаТО.Ссылки = СтрокаТО.Ссылки - 1;
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
	КонецЦикла;

	Клиенты.Удалить(Клиент);

КонецПроцедуры // ОтключитьОборудование()
Показать


у меня это не происходит
20. Amur_MVS 123 21.10.17 11:52 Сейчас в теме
21. ЮлияМ 11.07.19 08:19 Сейчас в теме
Все сделало в УПП и ничего не получается .
АТОЛ: ККТ с передачей данных: Ошибка при подключении устройства.
Необходимо убедиться, что устройство правильно настроено и соответствующий порт не занят другим приложением.
22. Sakh1CPRO 18.07.19 06:36 Сейчас в теме
(21)у меня такая же проблема ( Атол1Ф , вы нашли решение?
23. Veika 25 14.08.19 22:40 Сейчас в теме
Коллеги, та же проблема.
Обновила сегодня УТ 10.3 и драйвер Атол 10.5.0 и ...
При попытке открыть документ Чек ККМ,

АТОЛ: ККТ с передачей данных: Ошибка при подключении устройства.
Необходимо убедиться, что устройство правильно настроено и соответствующий порт не занят другим приложением.
К
24. Veika 25 15.08.19 21:18 Сейчас в теме
Коллеги, все-таки методом тыка разобралась с проблемой.
Кому если поможет:
В Торговом оборудовании в параметрах надо снять галочку в строке
Не отключаться от ККТ и все ... сообщение об ошибке перестало выходить...
Оставьте свое сообщение

См. также

Права пользователя исключительно на просмотр (чтение) для УТ 11.4 35

Статья Программист Нет файла v8 v8::Права УТ11 Россия Бесплатно (free) Роли и права

Простая и понятная инструкция по шагам для создания профиля группы доступа «Только чтение» для УТ 11.4. Выполняется в режиме пользователя, без использования конфигуратора и снятия базы с поддержки.

21.11.2019    2615    Aleksandr55555    4       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Типичные ошибки при разработке прав доступа 109

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Роли и права

Рассмотрим самые распространенные ошибки в разработке прав доступа.

02.10.2019    9168    YPermitin    45       

Чеки ККМ для расчетов с ИП по безналу. Новые обязательные реквизиты в чеке 32

Статья Программист Нет файла v8 v8::ОУ УТ11 УУ Windows Оптовая торговля Бесплатно (free) Практика программирования ККМ Разработка

Новые требования законодательства по пробитию чеков ККМ при расчетах с индивидуальными предпринимателями по безналу. Нюансы подключения интеграционной компоненты ДТО 10.5.0 на примере кассы ККТ АТОЛ 11Ф и конфигурации 1С УТ 11.4. Необходимые доработки типовой конфигурации УТ 11.4 для вывода на печать новых обязательных реквизитов: покупатель, ИНН, ГТД, страна происхождения.

22.07.2019    9074    ids79    16       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

1С и компьютерное зрение: новый подход к контролю за ассортиментом магазина 24

Статья Бизнес-аналитик Нет файла v8 1С:Франчайзи, автоматизация бизнеса УУ Розничная торговля Бесплатно (free) Внешние источники данных

Машинное зрение в магазинах и 1С. Как поднять эффективность торгового предприятия (магазин. кафе, шоурум и т.д.) с совершенно неожиданной стороны? Как получить реальные демографические данные покупателей и, самое главное, как это использовать в повседневной работе магазина? Как можно расширить привычные ABC и XYZ анализ, добавив в них пласт данных о трафике и демографии покупателей? Что необходимо для 1С, чтобы использовать данные видеоанализа людского трафика?

20.06.2019    5428    osipov_cvizi    16       

Назад в прошлое! Небольшие заметки по администрированию пользователей в УПП 74

Статья Системный администратор Программист Стажер Нет файла v8 УПП1 Бесплатно (free) Роли и права

Небольшие заметки по функционалу "Администрирование пользователей" конфигурации "Управление производственным предприятием" версии 1.3. Затрагиваются такие темы как: роли, профили доступа, дополнительные права, настройки пользователей и ограничения доступа на уровне записей (RLS).

06.06.2019    8778    YPermitin    18       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Сжатие данных в мобильном приложении 1С:Предприятие 42

Статья Программист Нет файла v8 v8::Mobile 1cv8.cf УУ Розничная торговля Бесплатно (free) Мобильная разработка

Эту небольшую статью я планировал опубликовать у себя на сайте, чтобы такие любители мобильного приложения от 1С:Предприятие, как я, могли использовать её без дополнительно потраченных двух дней на поиски вариантов написания алгоритма. Во-первых, хотел сказать, что я небольшой разработчик, который начинал делать свои первые шаги ещё на заре правления "Семерки". Новая платформа версии 8 была как глоток свежего воздуха - бодрящий и легко воспринимаемый организмом. Я был очень удивлен, да что сказать, до сих пор удивляюсь как элементарные вещи можно делать на 1С, и как это стремно делается на других языках программирования. Во-вторых, обилие разнообразных интерпретаций платформы позволяет развернуться на все 360 градусов, захватив своими проектами, наверное, любые ветки бизнеса. Так вот, о небольшом нюансе работы с новой мобильной платформой я и хотел рассказать... Сам додумался, так сказать.

27.05.2019    9815    yarsort    27       

Подсистема БСП «Управление доступом», основные объекты и регистры 113

Статья Программист Нет файла v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free) БСП (Библиотека стандартных подсистем) Роли и права

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    12391    ids79    8       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 178

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    22280    ids79    9       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Использование утилиты ring для выяснения данных о программных лицензиях 34

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) Информационная безопасность

Использование утилиты ring для управления программными лицензиями без ее установки на компьютер пользователя.

22.12.2018    7332    Vovan58    20       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Прикладной пример переработки стандартной формы РМК - Розница 76

Статья Программист Нет файла v8 Розница УУ Кассовые операции Розничная торговля Бесплатно (free) Работа с интерфейсом

Простой пример, как с помощью программного изменения шрифтов элементов формы достичь наилучшего результата отображения на примере формы РМК.

04.10.2018    13489    asdfgcom    56       

Авансы, кредиты и предоплаты. Примеры чеков ФФД 1.05 25

Статья Бухгалтер Нет файла v8 УТ11 Розничная и сетевая торговля (FMCG) Россия БУ Розничная торговля Бесплатно (free) ККМ

В публикации рассмотрено, как должны выглядеть корректные чеки ФФД 1.05 при авансах, кредитах и предоплатах. Чеки получены с помощью демонстрационной базы 1С:Управление торговлей 11.4.5.54 (Платформа 8.3.11.3034).

30.07.2018    35691    vasilievil    28       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Контроль суммы задолженности при неоперативном проведении документа продажи (Реализации товаров и услуг) 17

Статья Программист Нет файла v8 КА1 УТ10 УПП1 УУ Дебиторская и кредиторская задолженность Оптовая торговля Бесплатно (free) Практика программирования

Когда требуется провести документ неоперативно в текущем или прошлых днях и быть уверенным, что не возникнет дебиторская задолженность, тогда вам подойдёт данное решение. Решение актуально для КА 1.1, УПП 1.3 и УТ 10.3.

15.06.2018    7791    rpgshnik    1       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

История развития 1С:Торговли, что изменилось в архитектуре учета торговых и складских операций за 15 лет 66

Статья no Нет файла v8 Оптовая торговля, дистрибуция, логистика Россия УУ Оптовая торговля Розничная торговля Учет ТМЦ Ценообразование, анализ цен Бесплатно (free) Пользователю системы

В данном обзоре я хочу рассмотреть историю развития учета торговых и складских операций в 1С с точки зрения архитектуры конфигурации. Еще раз повторюсь, именно конфигурации, структуры данных, а не технологических возможностей платформы. Т.е. речь не про управляемые формы и обычные формы, не про преимущество СУБД перед dbf в расшаренной папке, а про справочники, их реквизиты и код, который этим управляет. Конечно, совсем абстрагироваться от изменений платформы не удастся, но я постараюсь.

23.04.2018    18016    monkbest    57       

Решение проблемы автоматического утверждения расчета кадровиком документов. Разграничение прав кадровиков и расчетчиков. ЗУП 3.1 28

Статья Программист Нет файла v8 v8::СПР v8::Права ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Информационная безопасность

Статья посвящена тем, кто столкнулся с проблемой автоматической установки "Расчет утвердил". Также рассматривается решение проблемы с отображением ФОТ и оклада у кадровика. Добавление роли ЧтениеДанныхДляНачисленияЗарплатыРасширенная кадровику без последствий для расчетчика.

04.04.2018    17465    leaderonex    22       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.12.х и УТ 11.4.11.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Информирование об утечке базы 1С 23

Статья Системный администратор Нет файла v8 1cv8.cf Windows Бесплатно (free) Информационная безопасность

Когда работаешь в крупном холдинге, количество сотрудников, имеющих доступ к базам 1С неизменно растет. Рано или поздно появится задача по контролю утечки баз 1С. Конечно мы применим все меры по предотвращению утечки баз, но и информирование о случаях утечки тоже не повредит.

03.03.2018    11949    dima_home    79       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Автоматизация торговой деятельности как путь к лидерству на рынке. Часть 2 11

Статья Программист Бухгалтер Руководитель проекта Нет файла v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Бесплатно (free) Бухгалтерский учет

Продолжаем делиться опытом автоматизации торговой деятельности. В данной части статьи мы рассмотрим такие разделы учетной системы, как Прием заказов от клиентов и Складскую логистику. И постараемся показать, какие плюсы можно получить в результате автоматизации данных областей.

31.01.2018    10531    Апрель-С    6       

Отключаем предупреждения безопасности в 1С 8.3.9 и выше вручную 22

Статья Системный администратор Нет файла v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free) Информационная безопасность

Как включить/выключить механизм защиты от опасных действий реализованный в новой версии платформы 1С:Предприятие 8.3.9. Одним из нововведений новой версии платформы 1С:Предприятие 8.3.9 стал механизм от опасных действий. После установки новой версии платформы 1С (начиная версии 8.3.9.2033) при попытке открыть внешнюю обработку или расширение программа выдает сообщение..

01.11.2017    32222    webresurs    10       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Многофакторная авторизация. Шаблон проектирования для «1С:Предприятие 8». На примере API «Приватбанка» для юр. лиц 10

Статья Программист Нет файла v8 Бесплатно (free) Информационная безопасность Обмен с банком

Многим из читателей знакомы понятия стандартов разработки и шаблонов проектирования. Для платформы «1С:Предприятие 8» на сайте its.1c.ru описаны базовые стандарты оформления кода и некоторые полезные примеры, но отсутствует информация об высокоуровневых абстракциях. Почти у каждого банка есть реализация обмена с конфигурациями «1С:Предприятие 8», но анализировать код, а тем более реализацию без слёз невозможно. Данная статья предлагает использовать некий шаблон оформления кода для многофакторной авторизации.

11.09.2017    11066    pbazeliuk    6       

Как создать свой профиль доступа в пользовательском режиме в 1С:Бухгалтерии 3.0 13

Статья Системный администратор Программист Нет файла v8 БП3.0 Россия Бесплатно (free) Информационная безопасность

Допустим, есть следующая задача. Нужно добавить нового пользователя «Анна» в базу 1С:Бухгалтерия 3.0. При этом Анна должна только выставлять и распечатывать Счета на оплату. При этом все остальные документы и справочники только для просмотра. Т.е. добавлять новую номенклатуру и контрагентов она не может. Обязательное условие - не изменять типовую конфигурацию.

06.09.2017    13876    alfanika    3       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

Оплата банковскими картами в "Управлении торговлей для Украины" 12

Статья Бухгалтер Руководитель проекта Нет файла v8 1cv8.cf Украина УУ Банковские операции Розничная торговля Бесплатно (free) Пользователю системы

Доля безналичных оплат в торговле неуклонно растет, и сегодня уже существует законодательное требование к торговым точкам, согласно которому наличие POS-терминала является обязательным требованием. Процесс оплаты банковскими картами называется «Эквайринг». Для организации оплаты картами в своем магазине необходимо обратиться в банк и заключить с ним договор эквайринга. Существуют различные условия этого договора, но, по сути, они отличаются лишь процентной ставкой. В данной статье описывается порядок работы для конфигурации «Управление торговлей для Украины», если оплата производится с помощью платежных карт.

23.05.2017    19782    pbazeliuk    1       

Сканер штрихкодов на Android смартфоне для 1С 91

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Розничная торговля Бесплатно (free) Сканер штрих-кода

Как сделать сканер штрихкодов из обычного Android телефона и привязать его к 1С.

07.05.2017    48754    tjurikov_ivan    22