Обход запроса по нескольким группировкам

Публикация № 125988

Разработка - Практика программирования

166
Хочу поделиться с вами небольшой "зарисовкой", которая помогает мне обходить выборку запроса, как бы пропуская некоторые группировки.

Хочу поделиться с вами небольшой "зарисовкой", которая помогает мне обходить выборку запроса, как бы пропуская некоторые группировки.
Что я имею в виду. Предположим, у нас есть запрос, который выбирает из регистра движения по номенклатуре в разрезе склада, номенклатуры, характеристики номенклатуры и документа движения. Вот как выглядит "плоская" выгрузка результата этого запроса:

Если в запросе указать итоги по складу, номенклатуре и характеристике номенклатуры и написать следующий код:

то обход будет производиться следующим образом:

Т.е. по первой группировке "Склад" внешний цикл (голубой) совершит одну итерацию, по второй группировке "Номенклатура" ("розовый" цикл) четыре итерации, в каждой из итераций "розового" цикла будет разное количество итераций "зеленого" цикла по группировке "ХарактеристикаНоменклатуры", и в конечном итоге будут выбраны все детальные записи ("серый" цикл), которые на рисунке я отмечать не стал, ибо лениво.

Но иногда хочется выбрать записи вот таким образом:

Т.е. так, чтобы внешний (голубой) цикл выбирал, как и положено, по группировке "Склад", а внутренний (зеленый) выбирал по некой "агрегатной" группировке "Номенклатура+ХарактеристикаНоменклатуры". Ну и дальше по необходимости детальные записи. Это было бы удобно, если бы вы, например, создавали документы по группировке "Склад", а второй "метагруппировкой" заполняли табличную часть каким-либо образом. Конечно, код, который приведен выше, справляется с этой задачей, но лично моя печаль в том, что там есть один вложенный цикл (розовый), который делается совершенно ненужным с точки зрения "изящества кода" как минимум. К тому же, когда таких группировок становится больше, например девять, мы видим совершенно "потрясающую" картину из девяти вложенных циклов.
Еще можно просто пропустить группировку "Номенклатура" и обходить результат запроса по группировкам "Склад - ХарактеристикаНоменклатуры - ДетальныеЗаписи". Но вот беда, в этом случае на уровне характеристики нет самой номенклатуры. Смотрите сами:

 

Получается, что на уровне выборки по складу номенклатуры еще нет, а на уровне выборки по характеристике ее... все еще нет. Бида.

Я точно знаю, что я не один такой, но у меня и у других коллег по несчастью как-то сам собой напрашивается вот такой код:


Код прекрасен всем, кроме того... что он не работает. Если когда-нибудь разгадаю это тайное послание фирмы 1С о "списке группировок", я обязательно с вами поделюсь. Сейчас же я знаю только то, что этот код мне не удалось заставить работать ни под каким соусом.

Но мы не ждем милости от природы и от 1С. А берем и сами делаем. Вот такой код работает нормально вполне:

Пара слов о функциях.
Функция "зфВыбратьПоГруппировкам" применяется вместо "ВыборкаЛалала.Выбрать()". Ей передается выборка, из которой нужно выбирать, и перечень группировок через запятую. При этом она возвращает некую "метавыборку". Ничего военного, просто соответствие с необходимыми данными.
Функция "зфСледующийПоГруппировкам" применяется вместо "ВыборкаОлоло.Следующий()". Ей передается та самая, открытая на предыдущем шаге "метавыборка" и возвращает она истину или ложь, как и штатный метод "Следующий".
Да. Внутри цикла вы можете смело получать родную 1С-овскую выборку нижнего уровня группировок, обратившись к элементу соответствия "Выборка". Вот так:

РоднаяВыборка1С = МетаВыборка["Выборка"];

Естественно, дальше родную выборку 1С можно хоть снова перебирать этими функциями, хоть выбирать штатными средствами.

Также не могу не сказать, что, в принципе, в функциях нет ничего нового и я тут не претендую на оригинальность или что-нибудь в таком духе. Думаю, что многие писали такие же функции, просто хотелось поделиться с уважаемым сообществом.
Они также не убирают вложенные циклы, просто немного иначе их организуют и скрывают. Т.е. в действительности все "лишние" циклы есть, но из кода это не очевидно.
Еще вполне понятно, что их использование будет менее производительным в смысле быстродействия, нежели использование вороха вложенных циклов. Я, конечно, старался написать пооптимальнее, но сами понимаете, накладные расходы будут.
Да, одна функция рекурсивная. По идее глубина рекурсии будет небольшой и равна количеству пропускаемых группировок плюс один, однако рекурсия есть рекурсия.
Ну и конечно, не исключен вариант, что я где-то накосячил. Если обнаружите - пишите, поправим.

Наконец сами функции:


Функция зфВыбратьПоГруппировкам(Выборка, Группировки, СИерархией = Ложь)

      
МетаВыборка = Новый Соответствие;

      
врОбходРезультата = ОбходРезультатаЗапроса.ПоГруппировкам;
       Если
СИерархией Тогда
              
врОбходРезультата = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;
       КонецЕсли;
      
МетаВыборка.Вставить("ОбходРезультата", врОбходРезультата);

      
МассивГруппировок = Новый Массив;
      
врСтрГруппировки = Группировки;
       Пока Истина Цикл
              
Поз = Найти( врСтрГруппировки, "," );
               Если
Поз = 0 Тогда
                      
МассивГруппировок.Добавить(СокрЛП(врСтрГруппировки));
                       Прервать;
               КонецЕсли;
              
МассивГруппировок.Добавить( СокрЛП( Лев(врСтрГруппировки,Поз-1) ) );
              
врСтрГруппировки = Сред( врСтрГруппировки, Поз+1 );
       КонецЦикла;

      
МетаВыборка.Вставить("Группировки", МассивГруппировок);

      
врВыборка = Выборка;
       Для
пц=0 По МассивГруппировок.Количество()-2 Цикл
              
врВыборкаУровня = врВыборка.Выбрать(врОбходРезультата, МассивГруппировок[пц]);
              
МетаВыборка.Вставить("_Выборка"+Строка(пц), врВыборкаУровня);
               Если не
врВыборкаУровня.Следующий() Тогда
                       Прервать;
               КонецЕсли;
              
врВыборка = врВыборкаУровня;
       КонецЦикла;
      
врВыборкаУровня = врВыборка.Выбрать(врОбходРезультата, МассивГруппировок[пц]);
      
МетаВыборка.Вставить("Выборка", врВыборкаУровня);
      
МетаВыборка.Вставить("_Выборка"+Строка(пц), врВыборкаУровня);

       Возврат
МетаВыборка;

КонецФункции
// зфВыбратьПоГруппировкам

Функция зфСледующийПоГруппировкам(МетаВыборка, Уровень = Неопределено)

       Если
Уровень = Неопределено Тогда
              
Уровень = МетаВыборка["Группировки"].Количество()-1;
       КонецЕсли;

       Если
Уровень < 0 Тогда
               Возврат Ложь;
       КонецЕсли;

      
врВыборка = МетаВыборка["_Выборка"+Строка(Уровень)];

       Если
врВыборка.Следующий() Тогда
               Возврат Истина;
       КонецЕсли;

       Если
зфСледующийПоГруппировкам(МетаВыборка, Уровень-1) Тогда
              
МассивГруппировок = МетаВыборка["Группировки"];
              
врВыборкаРодитель = МетаВыборка["_Выборка"+Строка(Уровень-1)];
              
врВыборка = врВыборкаРодитель.Выбрать(МетаВыборка["ОбходРезультата"],МассивГруппировок[Уровень]);
              
МетаВыборка["_Выборка"+Строка(Уровень)] = врВыборка;
               Если
Уровень = МассивГруппировок.Количество()-1 Тогда
                      
МетаВыборка["Выборка"] = врВыборка;
               КонецЕсли;
               Возврат
зфСледующийПоГруппировкам(МетаВыборка, Уровень);
       Иначе
               Возврат Ложь;
       КонецЕсли;

КонецФункции
// зфСледующийПоГруппировкам

Спасибо за внимание, а я желаю вам хорошего дня и хорошего кода.

Оригинал статьи в блоге автора

166

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
1. zfilin 2092 24.04.12 21:50 Сейчас в теме
В основном блоге коллега советует для данного примера применить к полю "Номенклатура" агрегатную функцию МАКСИМУМ.

Не пробовал, но почему ему не работать?
16. i132 115 28.04.12 16:08 Сейчас в теме
(1) Максимум при группировке по Характеристики не поможет, если есть пустые характеристики.
2. Новиков 291 24.04.12 23:44 Сейчас в теме
Непонятно мне, а почему нельзя подготовить текст запроса таким образом чтобы получить простую выборку для простого обхода вот без этих всех квадратных треуголок? )
soci0pat; pavlo; +2 Ответить
3. zfilin 2092 25.04.12 00:01 Сейчас в теме
(2) Новиков, Да, почему ж нельзя? Можно, конечно! Более того, это было бы даже лучше и быстрее.
Но иногда приходится и с треуголками. =)

А предложите свой вариант для такого обхода?
4. Новиков 291 25.04.12 00:06 Сейчас в теме
(3) я признаться, уже забыл, когда руками обходил результат запроса с группировками. Я обычно делаю базовую схему компоновки, и при помощи настроек компоновки (двигаю группировки вверх и вниз) получаю нужный резалт. И уже его как-то обрабатываю. Т.е. даже текст запроса никакого не нужно собирать. А Ваш вариант - он наверное крут, я не спорю. И наверное даже где-то находит применение. Вот и хотелось бы узнать - где! :%)
5. zfilin 2092 25.04.12 00:22 Сейчас в теме
(4) Новиков, А! СКД. Да, я тоже люблю скормить данные СКД, а потом получить их в нужно виде и по ним ходить. Но, вот недавно решил выбрать просто запросом и просто ходить по группировкам без СКД. Как-раз документы создавал. Так и применял.
Глупо было бы утверждать, что это единственный и уникальный способ и я сейчас выдам прям такую исключительную ситуацию, где запрос применить можно, а СКД нельзя.
С другой стороны какое-то внутреннее стремление к простоте протестует против того, чтобы "городить ЦЕЛУЮ СКД", когда надо просто обойти группировки простого запроса. Если бы это было возможно реализовать штатными средствами (как в не работающем примере), это был бы win. А поскольку сами функции получились достаточно "мозгачными", то это, конечно не win, а так - посокрушаться.
15. i132 115 28.04.12 15:34 Сейчас в теме
Если нет пустых характеристик, можно сделать запрос без группирповки итогов и воспользоваться методом Выборка.СледующийПоЗначениюПоля()

Описание метода на ИТС

либо как предложил Новиков в (2) прямой запрос, без группировок остортировать по списку полей шапки:
СтруктураУникальнойШапки = Новый Структура("Поле1,Поле2,Поле3");

Док = Неопределено; //Лучше объявить переменную до цикла, заодно проверим первый вход
Пока выборка.Следующий() Цикл
   ФлНоваяШапка =Ложь;
   Для каждого ПолеШапки из СтруктураУникальнойШапки Цикл
      Если НЕ ПолеШапки.Значение= выборка[ПолеШапки.Ключ] Тогда
		Если Док = Неопределено тогда 
		 	Док.Записать();
		КонецЕсли;	
         ЗаполнитьЗначенияСвойств(СтруктураУникальнойШапки,Выборка);
         Док = СоздатьДокПоШапке(СтруктураУникальнойШапки);
         Прервать;
      КонецЕсли;   
   КонецЦикла;   
   НоваяСтрока = Док.(ТабЧасть).Добавить();
   Док = ЗаполнитьЗначенияСвойств(НоваяСтрока,Выборка);
КонецЦикла;   

Если НЕ Док = Неопределено тогда 
	Док.Записать();
КонецЕсли;
Показать
18. zfilin 2092 28.04.12 18:20 Сейчас в теме
(15) i132, За "СледующийПоЗначениюПоля()" спасибо, нужно будет посмотреть.

А по поводу кода. Мне кажется или у вас там первая строка проглатывается? Когда вы в выборке дважды в подряд "Следующий()" вызываете?
Ну в целом, после первого "Следующий" выборку можно и на начало сбросить, так что принцип понятен.

Но вот именно от такого кода и хочется избавиться в первую очередь. Собственно, эти процедуры я и "затеял", чтобы уйти от "мониторинга момента смены ключа".
Чем мне не нравится такой подход, это во-первых тем, что логика алгоритма несколько "размазывается" по коду. Мы имеем заполнение внутри цикла, создание и запись документа там же, а еще такие же блоки за пределами цикла. Причем, когда мы записываем документ внутри цикла, имеется документ относящийся к предыдущей итерации выборки, а данные в выборке соответствуют уже новому. Все это, что ни говори, повышает сложность кода. Да, что я говорю, думаю все отписавшиеся не раз писали код, который мониторил бы смену одного из полей и в зависимости от этого что-то происходил.
А еще мне очень не нравится то, что код дублируется. Хорошо, когда это одна строка "ЗаполнитьЗначенияСвойств", но когда по смене ключа предусматриваются более обширные действия, блок в начале (до начала цикла) и блок в цикле нужно не забывать обновлять одновременно. Так же как и "Записать()", если нужна не просто запись, а еще какие-то финализирующие действия.
А хочется стройной конструкции, где на одном уровне вложенности документ создавался бы, затем как-то заполнялся (следующая вложенность) и потом на том же уровне и записывался. Без разделения и дублирования.
user597343_netcpv22; i132; +2 Ответить
19. i132 115 28.04.12 19:25 Сейчас в теме
(18) >первая строка проглатывается
упс, спасибо, не заметил действительно обработку первой строки пропустил. старый пост (15) переписал.
6. Yashazz 2859 25.04.12 12:21 Сейчас в теме
Хм, никогда не пользуюсь указанным обходом. Работаю с плоской таблицей значений, можно как угодно выкручивать, сортировать и обходить, безо всяких доп.функций и страшных вложений циклов. В самом хитром случае учреждаются доп.колонки для управления обходом (прям в запросе, или одним обходом таблицы), а дальше рулёжка уже по ним.
Да, и СКД рулит, конечно. Чего её "городить", дело-то простое, а выигрыш иной раз нехилый.
17. Созинов 28.04.12 17:55 Сейчас в теме
(6) Yashazz,
Согласен с вами, но при большом объеме иногда удобнее прогуливаться по иерархии.

Как раз на прошлой неделе столкнулся с такой проблемой, делал перенос с 7.7 на 8.2 (да знаю, что есть куча обработок и Конвертация данных, которую пока не освоил к сожалению), каждый раз делать запросы или сортировать/обходить таблицу со всей номенклатурой, контрагентами и т.д. накладно (хотя какая разница, один раз перенос будет).
Автору + - еще одно интересное решение в копилку, думаю пригодится, хотя использовать буду редко.

(12) romansun,
Спасибо за наводку.
7. dandrontiy 25.04.12 13:00 Сейчас в теме
Круто, но применение непонятно.
И мне почему то удобней не выборками пользоваться, а ТаблицаЗначений = Запрос.Выполнить().Выгрузить();
И мне кажется это к тому же просто быстрее. Как раз применимо для случая, когда надо что-то чем то заполнить, нет разве ?
8. karakozov 25.04.12 13:45 Сейчас в теме
Решение конечно для конкретной задачи, такой подход возможно имеет смысл в ситуации когда таблица имеет очень большой объем.И выбирать ее несколько раз для каждой выборки в рамках одной процедуры очень долго.Может быть конечно так разъяснено что не совсем понятно цель.В общем все от ситуации.
9. Yashazz 2859 25.04.12 16:22 Сейчас в теме
(8) Вопрос знатокам - выборка, полученная из результата запроса методом "Выбрать", или сам результат, кэшируется где-либо или болтается в оперативке? Если да, то в клиентской или где?
10. zfilin 2092 25.04.12 22:18 Сейчас в теме
Друзья, но когда мне нужно обойти плоскую таблицу, мне же нужно понимать момент, когда у меня появляется другой склад в первой колонке, чтобы, если взять уже приведенный пример, создать новый документ с ДРУГИМ складом. Как же это реализовать в плоской выборке?
Т.е. тот случай, когда на разных "уровнях группировок" реализуется разное поведение, разный код.
Gesperid; +1 Ответить
11. zfilin 2092 25.04.12 22:20 Сейчас в теме
Т.е. я сейчас не защищаю свои функции, но интересен сам принцип.
12. romansun 189 26.04.12 11:05 Сейчас в теме
я последнее продолжительное время возвращаю запросом дерево, да, с составным ключом

циклы упрощаются до невозможности

и самое главное масштабирование кода также упрощается в разы! Достаточно изменить состав ключа в запросе - и всё, никакой 1С код в цикле менять не приходится

особенно помогла в этом метода "конвертации" даты в строку прям в запросе для успешного склеивания
veiuper; Gesperid; AllexSoft; invertercant; +4 Ответить
13. MGraf 3 27.04.12 12:14 Сейчас в теме
(12) romansun, напишите пожалуйста публикацию! Хотя бы пару строк с примером :)
AllexSoft; +1 Ответить
20. romansun 189 10.05.12 16:14 Сейчас в теме
(13) ох.. это ж писать надо :)

идея-то, в общем, простая. Вот такой упрощенно пример: есть таблица с кучей колонок (Организация, Контрагент, ДоговорКонтрагента, Номенклатура, Сумма, Количество и т.п.)

Нужно по этим строкам создавать документы, в шапку которых пихать реквизиты (Организация, Контрагент, ДоговорКонтрагента), в ТЧ пихать (Номенклатура, Сумма, Количество).

В запросе создаем поле "Ключ", которое определяем уникальными значениями для соответствующих интересующих нас полей. В нашем примере это "Организация", "Контрагент", "ДоговорКонтрагента". Т.е.

ВЫБРАТЬ
 ВложенныйЗапрос.Организация.Код + ВложенныйЗапрос.Контрагент.Код + ВложенныйЗапрос.ДоговорКонтрагента.Код КАК Ключ
...


(отмечу, что обычно договор это подчиненный справочник к контрагенту со сквозной нумерацией, т.е. все кода уникальны независимо от владельца, посему контрагент в этом ключе не нужен - договора будет достаточно. Но оставим для полноты примера :) )

данное поле "Ключ" будет однозначно уникальным для будущих документов. Т.е. мы получили составной уникальный ключ.

А дальше просто "итожим" по нему

ИТОГИ
   МАКСИМУМ(Организация),
   МАКСИМУМ(Контрагент),
   МАКСИМУМ(ДоговорКонтрагента)
ПО
   Ключ


максимум для этих полей определяем только для того, чтобы получить их в вернем уровне дерева, чтобы потом подставить в наш документ

в 1С-ном коде будет обычный цикл обхода дерева, где по итерации цикла на верхнем уровне создаем новый документ, а по итерациям на втором - заполняем его ТЧ. При этом нам совершенно не надо задумываться создавать ли новый документ на данной итерации цикла, или писать всё еще в предыдущий... и т.п. "приятные" вопросы.

И самое вкусное - если вдруг возникнет необходимость "доразбить" создаваемые документы еще по какому-нить полю, мы просто дописываем его в "Ключ" (например "... + БанковскиеСчета.Код КАК Ключ") и всё.

Таким образом можно делать достаточно сложные ключи. Можно использовать в качестве слагаемых, соответственно, результаты каких-то ВЫБОР КОГДА ТОГДА и т.п.

(14)
Хм. Насколько я понимаю, в запросе можно создать составной ключ склеиванием строк. Но поддерживается ли уникальность при конвертации ссылочных типов в строку? Т.е. вы получаете представление ссылки или просто представление, как наименование, код, НомерДок и т.д?


достаточно просто текстового представления уникального поля (группы полей) - код, наименование и т.п. С числами сложнее, а с датами еще сложнее, ибо их не сложишь как строку, да. А нормальной конвертации в 1С-ных запросах нет. Но числовые коды редко когда бывают, всё-таки. Насчет дат (да и чисел, кстати, тоже) за нас уже всё придумали (23 пост - отлично всё работает)
http://www.forum.mista.ru/topic.php?id=388253

Соответственно, дату (и число) можно представить строкой и приклеить к ключу.
soci0pat; Мах; cheburashka; Liss111; huzden; RadoLex; Daynestro07; MbIwb; 7fortune; Gorr; skalex; Lord_Alexandr; TeMochkiN; slavik_s; python.pm; Mozgolom1988; klinval; DexterMorgan777; MI_HAN; Михаська; YuriFm; swimdog; Angry; AllexSoft; ftm; kayen; DoctorRoza; zfilin; +28 Ответить
14. zfilin 2092 27.04.12 13:43 Сейчас в теме
(12) romansun, Хм. Насколько я понимаю, в запросе можно создать составной ключ склеиванием строк. Но поддерживается ли уникальность при конвертации ссылочных типов в строку? Т.е. вы получаете представление ссылки или просто представление, как наименование, код, НомерДок и т.д?
21. DoctorRoza 17.05.12 09:46 Сейчас в теме
Достаточно интересная статья, написано доходчиво и наглядно, сразу чувствуется высокий уровень автора! Предложенная идея больше смахивает на "лабораторную" раскопку 1С.
22. RainyAugust22 234 12.11.12 07:27 Сейчас в теме
хорошая статья,спасибо за инфу.
23. xomaq 14 12.11.12 08:26 Сейчас в теме
Огромное спасибо автору!!
Как раз сегодня мучился с подобной задачей. С кодом, приведенным автором, у меня все заработало!!
Респект и уважуха!!!
24. kit 69 23.11.12 00:27 Сейчас в теме
Хорошая статья. Тоже сижу разбираюсь с обходом группировок в запросе, а тут как раз в тему.
25. Evgen.Ponomarenko 542 13.08.13 13:01 Сейчас в теме
Действительно, актуально!
26. dimk@a 14.08.13 10:56 Сейчас в теме
Спасибо, хорошая статья. И в обсуждении как всегда много важного!
27. olbu 08.10.15 12:31 Сейчас в теме
А если переделать запрос та вот так:
ВЫБРАТЬ
	ТоварыНаСкладахОстатки.Склад КАК Склад,
	ТоварыНаСкладахОстатки.Номенклатура,
	ТоварыНаСкладахОстатки.ХарактеристикаНоменклатуры,
	ТоварыНаСкладахОстатки.КоличествоОстаток КАК КоличествоОстаток
ИЗ
	РегистрНакопления.ТоварыНаСкладах.Остатки КАК ТоварыНаСкладахОстатки
ИТОГИ
	СУММА(КоличествоОстаток)
ПО
	Склад
Показать


Верхняя группировка будет по складу, а нижняя - по номенклатуре + характеристике.
Или я не верно понял?
28. zfilin 2092 09.10.15 15:46 Сейчас в теме
В таком простом случае, да сработает. Но это все же немного не то.
А если две составных группировки?
Например склад+контрагент и товар+характеристика.
29. EvgeniuXP 04.02.16 23:14 Сейчас в теме
Вот вам применение: есть документы, там 13 реквизитов, надо выявить одинаковые документы, если их два и более то один провести, остальные пометить на удаление. Методом группировок мы отсеиваем одинаковые, оставляем только одинаковые два и более документа, потом группируем по всем 13 реквизитам и на выходе имеем на самом нижнем уровне одинаковые записи двух и более документов. При первом входе проводим, при втором и последующих - метим на удаление.
30. iott 09.01.17 03:29 Сейчас в теме
Полезная статья по группировкам! Мне оказалась полезной!

Получается, что на уровне выборки по складу номенклатуры еще нет, а на уровне выборки по характеристике ее... все еще нет. Бида.

"Бида."....тут опечатка или так задумано? =)
31. zfilin 2092 10.01.17 16:17 Сейчас в теме
32. i.kovtun 150 29.07.17 12:38 Сейчас в теме
Саша, спасибо :) Быстро загуглилось и пригодилось!
33. zfilin 2092 05.08.17 00:34 Сейчас в теме
(32) О, приветствую! Ну, вот, хорошо что пригодилось. Я когда-то полголовы себе об это сломал. Значит не зря.
34. andrey1508 72 26.09.19 09:00 Сейчас в теме
Посмотрите как это реализовано на диске ИТС
https://its.1c.ru/db/pubqlang#content:64:hdoc

&НаСервереБезКонтекста

Процедура ВыполнитьЗапрос()

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПриходнаяНакладнаяСостав.Товар КАК Товар,
| ПриходнаяНакладнаяСостав.Количество КАК Количество
|ИЗ
| Документ.ПриходнаяНакладная.Состав КАК ПриходнаяНакладнаяСостав
|УПОРЯДОЧИТЬ ПО
| Товар
|ИТОГИ
| СУММА(Количество)
|ПО
| Товар ИЕРАРХИЯ";

РезультатЗапроса = Запрос.Выполнить();

СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;
ВыборкаЗапроса = РезультатЗапроса.Выбрать(СпособВыборки);
ВыдатьВсеВложения(ВыборкаЗапроса);

КонецПроцедуры

&НаСервереБезКонтекста

Процедура ВыдатьВсеВложения(ИерархическаяВыборка)

Сообщение = Новый СообщениеПользователю;
Пока ИерархическаяВыборка.Следующий() Цикл
Сообщение.Текст = "Товар: " + ИерархическаяВыборка.Товар.Наименование +
" Количество: " + ИерархическаяВыборка.Количество() +
" Тип записи: " + ИерархическаяВыборка.ТипЗаписи() +
" Уровень: " + ИерархическаяВыборка.Уровень() +
" Группировка: " + ИерархическаяВыборка.Группировка();
Сообщение.Сообщить();

// Продолжим выборку подчиненных записей
СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;
Если ИерархическаяВыборка.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоИерархии Тогда
ДочерняяВыборка = ИерархическаяВыборка.Выбрать(СпособВыборки, ИерархическаяВыборка.Группировка());
Иначе
ДочерняяВыборка = ИерархическаяВыборка.Выбрать(СпособВыборки);
КонецЕсли;

ВыдатьВсеВложения(ДочерняяВыборка);
КонецЦикла;
КонецПроцедуры
35. basuga 25 17.10.19 08:47 Сейчас в теме
Спасибо огромное! Решил задачу над которой мучался несколько часов за 2 минуты!
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста 115

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    6257    HostHost    22       

Агрегатные функции СКД, о которых мало кто знает 321

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    10295    ids79    42       

Три костыля. Сказ про фокусы в коде 122

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7905    YPermitin    68       

Отслеживание выполнения фонового задания 134

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    8493    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 245

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10703    ids79    24       

Фоновое выполнение кода в 1С - это просто 118

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    9949    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    9594    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 136

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8890    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6293    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 195

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17705    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 176

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11627    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17366    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9971    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4891    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7441    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16476    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12824    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12923    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 163

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15642    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12801    ids79    27       

Новый подход к обмену данными EnterpriseData 203

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21592    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 119

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    19014    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19875    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 126

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20959    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20563    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14660    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21409    Rain88    42       

Повышаем эффективность разработки правил обмена 124

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19375    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 153

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24509    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21266    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    17051    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11403    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24570    avfed@rambler.ru    19       

Минимализмы 3 352

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35737    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25913    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21366    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 722

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    138082    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22766    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    21133    unichkin    18       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    24108    json    9       

Работа с Excel 289

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24878    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46979    bugtester    43