Поиск и замена дублирующих элементов (условие по нескольким полям, определение правильных по заполненности реквизитов)

Публикация № 126337

Администрирование - Администрирование данных 1С - Сервисные утилиты

22
Поиск и замена дублирующих элементов (условие по нескольким полям, определение правильных по заполненности реквизитов)

Отличается от типовой:

1. добавлена возможности поиска на равное значение по нескольким реквизитам

2. добавлена возможность вручную дописывать условие текста запроса поиска дублей

3. добавлена возможность определения правильных элементов, не помеченных на удаление

4. добавлена возможность определения правильных элементов, заполненным реквизитом (выбирается в диалоге)

 

Обработка полезна для замены дублей подчиненных справочников (например: "Единицы измерения", так как при использовании стандартной обработки по наименованию найдутся все одинаковые единицы измерения, а необходимо искать в пределах подчинения), а так же других ситуаций.

 

Обработка универсальна и может применятся для любой конфигурации.

 

После установки условия поиска и поиска дублей добавлена возможность установки верным элемент не помеченный на удаление.

Так же добавлено условие установки верным элементом, с условием на равенство реквизита (в примере это реквизит "Управленческий код")

22

Скачать файлы

Наименование Файл Версия Размер
ПоискИЗаменаДублирующихсяЭлементов_Доработанный.epf
.epf 53,78Kb
26.04.12
539
.epf 53,78Kb 539 Скачать
Поиск и замена дублей подчиненных справочников.docx
.docx 563,11Kb
26.04.12
52
.docx 563,11Kb 52 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Artemuch2 26.04.12 13:13 Сейчас в теме
Добрый день! А в обработке вы учли функционал наработанный коллегами в предыдущих версиях или это совсем другая обработка замены значений"
2. sokol_5441 137 27.04.12 08:09 Сейчас в теме
Это обработка взята из "Управление торговлей 10.3", доработана. Она универсальна
3. xrays 25.07.12 16:59 Сейчас в теме
Замечательная обработка. Здорово помогла для исправления ситуации с задвоенной номенклатурой. Спасибо!!!
4. ylyas 25 14.09.12 15:45 Сейчас в теме
доп отборы на сравнение не работают.
проверял на упп справочник договоров.
задав сравнение на орг = орг и контрагент= контрагент и вид договора = вид договора
получил в совпавших группах договора разных организаций.
pechenka1440; +1 Ответить
5. Pim 167 11.01.13 08:30 Сейчас в теме
согласен с (4).

жаль, только поздно понял...

вот "заплатка":
вместо НайтиПоРавенствуРеквизитов надо вставить
вроде больше ничего не менял ( :-P )
------------------------------------------------------------------
///==============================================================================
function CheckAttrsForDifference(vLine, vStructForCompare)

	for each item in vStructForCompare do
		fieldName = item.Key;
		if vLine[fieldName] <> item.value then
			return true;
		endIf;
	endDo;
	return false;
endFunction // CheckAttrsForDifference

///=========================================================­=====================
Процедура НайтиПоРавенствуРеквизитов()
	
	//СоколовЮВ+
	structForCompare        = new Структура;
	attrStr                 = "";
	ПостроительОтчета.Текст = ПолучитьТекстЗапросаДляПостроителя(РежимПоиска);
	Если ЗначениеЗаполнено(ДопУсловие) Тогда
		ПостроительОтчета.Текст = СтрЗаменить(ПостроительОтчета.Текст, "{ГДЕ", ДопУсловие + " {ГДЕ");
		ТекстПоля               = "";
		ТекстСгруппировать      = "";
		Для Каждого ЭлементСписка Из СписокРеквизитовСправочника Цикл
			Если Не ЭлементСписка.Пометка Тогда
				Продолжить;
			КонецЕсли;

			ТекстПоля = ТекстПоля + Символы.ПС + "Спр1." + ЭлементСписка.Значение + ", ";
			structForCompare.Insert(ЭлементСписка.Значение, "-");
			attrStr   = attrStr + ", " + ЭлементСписка.Значение;
		КонецЦикла;
		
		ПостроительОтчета.Текст = СтрЗаменить(ПостроительОтчета.Текст, "СГРУППИРОВАТЬ ПО", " СГРУППИРОВАТЬ ПО " + ТекстПоля);
		ПостроительОтчета.Текст = СтрЗаменить(ПостроительОтчета.Текст, "ВЫБРАТЬ", "ВЫБРАТЬ " + ТекстПоля);
	КонецЕсли;
	//СоколовЮВ-
	
	ПостроительОтчета.Выполнить();
	
	мРезультатыПоиска = ПостроительОтчета.Результат.Выгрузить();
	мРезультатыПоиска.Колонки.Добавить("НомерГруппы");
	мРезультатыПоиска.Колонки.Добавить("Правильный", Новый ОписаниеТипов("Булево"));
	мРезультатыПоиска.Колонки.Добавить("КоличествоСсылок");
	мРезультатыПоиска.Сортировать("ЗначениеРеквизита" + attrStr);
	
	ТаблицаГрупп.Очистить();
	
	ЗначениеРеквизита = Неопределено;
	ТекущаяГруппа = 0;
	ЭлементовВГруппе = 0;
	Для Каждого СтрокаПоиска ИЗ мРезультатыПоиска Цикл
		Если (СтрокаПоиска.ЗначениеРеквизита <> ЗначениеРеквизита) or CheckAttrsForDifference(СтрокаПоиска, structForCompare) Тогда
			for each item in structForCompare do
				structForCompare.Insert(item.Key, СтрокаПоиска[item.Key]);
			endDo;

			ДобавитьНовуюГруппу(ТаблицаГрупп, ТекущаяГруппа, ЭлементовВГруппе, ЗначениеРеквизита);
			ЗначениеРеквизита = СтрокаПоиска.ЗначениеРеквизита;
			ТекущаяГруппа     = ТекущаяГруппа + 1;
			ЭлементовВГруппе  = 0;
		КонецЕсли;
		
		СтрокаПоиска.НомерГруппы = -ТекущаяГруппа;
		ЭлементовВГруппе         = ЭлементовВГруппе + 1;
	КонецЦикла;
	
	ДобавитьНовуюГруппу(ТаблицаГрупп, ТекущаяГруппа, ЭлементовВГруппе, ЗначениеРеквизита);
			
	ТаблицаГрупп.Сортировать("Количество");
	
	ТекущаяГруппа = 1;
	КолвоЭлементовКоллекции = ТаблицаГрупп.Количество();
	Для ОбратныйИндекс = 1 По КолвоЭлементовКоллекции Цикл
		ЭлементКоллекции = ТаблицаГрупп[КолвоЭлементовКоллекции - ОбратныйИндекс];
		
		МассивСтрок = мРезультатыПоиска.НайтиСтроки(Новый Структура("НомерГруппы", -ЭлементКоллекции.НомерГруппы));
		
		Если ЭлементКоллекции.Количество = 1 Тогда
			
			Для каждого СтрокаГруппы ИЗ МассивСтрок Цикл
				мРезультатыПоиска.Удалить(СтрокаГруппы);
			КонецЦикла;			
			ТаблицаГрупп.Удалить(ЭлементКоллекции);
			
		Иначе
			
			Для каждого СтрокаГруппы ИЗ МассивСтрок Цикл
				СтрокаГруппы.НомерГруппы = ТекущаяГруппа;
			КонецЦикла;
			ЭлементКоллекции.НомерГруппы = ТекущаяГруппа;
			ТекущаяГруппа = ТекущаяГруппа + 1;
			
		КонецЕсли;
		
	КонецЦикла;
	
	ТаблицаГрупп.Сортировать("Группа");
	Если мРезультатыПоиска.Количество() > 0 Тогда
		ВывестиГруппу(1);
	КонецЕсли;	
КонецПроцедуры
------------------------------------------------------------------


2-ой нюанс: не до конца исправлен косяк типовой обработки в части замены в регистрах бухгалтерии.
функция ВыполнитьЗаменуЭлементов

				ЭтоДвижениеРегистраБухгалтерии = Метаданные.РегистрыБухгалтерии.Содержит(Движение);
				ЕстьКорреспонденция = ЭтоДвижениеРегистраБухгалтерии и Параметры[Движение.Имя + "Корреспонденция"];
				
				НаборЗаписей  = Параметры.Объект.Движения[Движение.Имя];
				НаборЗаписей.Прочитать();
				НадоЗаписывать = Ложь;
				ТаблицаНабора = НаборЗаписей.Выгрузить();
				Для Каждого Измерение ИЗ Движение.Измерения Цикл
					Если Измерение.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
						Если ЕстьКорреспонденция and (ТаблицаНабора.Columns.Find(Измерение.Имя) = undefined) Тогда
							СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "ДТ");
							Пока СтрокаТабЧасти <> Неопределено Цикл
								СтрокаТабЧасти[Измерение.Имя + "ДТ"] = ПравильныйЭлемент;
								НадоЗаписывать = Истина;
								СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "ДТ");
							КонецЦикла;
							СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "КТ");
							Пока СтрокаТабЧасти <> Неопределено Цикл
								СтрокаТабЧасти[Измерение.Имя + "КТ"] = ПравильныйЭлемент;
								НадоЗаписывать = Истина;
								СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "КТ");
							КонецЦикла;
						Иначе
							
							СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
							Пока СтрокаТабЧасти <> Неопределено Цикл
								СтрокаТабЧасти[Измерение.Имя] = ПравильныйЭлемент;
								НадоЗаписывать = Истина;
								СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
							КонецЦикла;
						КонецЕсли;
					КонецЕсли; 
				КонецЦикла;
Показать


Думаю, мои изменения здесь заметны без комментариев. Вот и ответ, тем кто спрашивает, почему я использую англ. язык.
10. heavymetal 86 07.04.15 11:38 Сейчас в теме
(5) Pim, спасибо, Ваша дописка помогла
6. ylyas 25 13.01.13 06:42 Сейчас в теме
ну использование английского чтобы отличать свой код среди остального - не супер четкий аргумент, скажем так ))
Дмитрий74Чел; +1 Ответить
7. tofree 14 29.04.13 15:46 Сейчас в теме
не работает в УТ 11 в серверном варианте (заупк клиента: обычное приложение)
8. prodines 106 06.05.13 13:36 Сейчас в теме
Привязки в форме не установлены.
9. heavymetal 86 07.04.15 11:32 Сейчас в теме
(0) исправьте ошибку, указанную в 4 комментарии, тогда плюсану
11. shard 251 31.05.17 11:47 Сейчас в теме
В процедуре УстановитьВернымПоЗаполненностиРеквизитаНажатие исправить
			Для Каждого Строка Из МассивСтрок Цикл
				Если ЗначениеЗаполнено(Строка.Ссылка[ИмяРеквизита]) Тогда
					Строка.Правильный = Истина;
					Прервать;
				КонецЕсли;
			КонецЦикла;

на
			Для Каждого Строка Из МассивСтрок Цикл
				Строка.Правильный = ЗначениеЗаполнено(Строка.Ссылка[ИмяРеквизита]);				
			КонецЦикла;
12. shard 251 02.06.17 10:58 Сейчас в теме
(11) а еще лучше эту процедуру заменить на
Процедура УстановитьВернымПоЗаполненностиРеквизитаНажатие(Элемент)
	
	ИмяРеквизита = "";
	ВыбранноеЗначение = ВыбратьИзСписка(СписокРеквизитовСправочника, ЭлементыФормы.УстановитьВернымПоЗаполненностиРеквизита);
	Если ВыбранноеЗначение = Неопределено Тогда
		Предупреждение("Действие отменено");
		Возврат;
	Иначе
		ИмяРеквизита = ВыбранноеЗначение.Значение;
	КонецЕсли;
	
	мРезультатыПоиска.сортировать("КоличествоСсылок убыв");
	Для каждого Стр Из ТаблицаГрупп Цикл
		НомерТекГруппы = Стр.НомерГруппы;
		Если НомерТекГруппы > 0 Тогда
			МассивСтрок = мРезультатыПоиска.НайтиСтроки(Новый Структура("НомерГруппы", НомерТекГруппы));
			ЕстьПравильный=ложь;
			Для Каждого Строка Из МассивСтрок Цикл
				Строка.Правильный = ?(не ЕстьПравильный,ЗначениеЗаполнено(Строка.Ссылка[ИмяРеквизита]),ложь);
				ЕстьПравильный=?(ЕстьПравильный,ЕстьПравильный,Строка.Правильный);
			КонецЦикла;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры
Показать

в предыдущем комментарии возможно некорректное срабатывание алгоритма.
13. Pim 167 02.06.17 13:02 Сейчас в теме
(12). Честно говоря, уже плохо помню о чём речь.
Но если уже говорить об элегантности кода,

ЕстьПравильный=ложь;
            Для Каждого Строка Из МассивСтрок Цикл
                Строка.Правильный = (not ЕстьПравильный and ЗначениеЗаполнено(Строка.Ссылка[ИмяРеквизита]) );
                ЕстьПравильный      = (ЕстьПравильный or Строка.Правильный);
            КонецЦикла;

PS:
Может мне кто-нибудь объяснить поголовную любовь к оператору "НЕ".
Почему пишут
?(не ЕстьПравильный, ЗначениеЗаполнено(Строка.Ссылка[ИмяРеквизита]), ложь);

вместо
?(ЕстьПравильный, ,ложь ЗначениеЗаполнено(Строка.Ссылка[ИмяРеквизита]));
14. shard 251 02.06.17 14:34 Сейчас в теме
(13) наверное вопрос нашей психологии: "если не так, то переделать иначе норм" ближе по духу, нежели "есть так, то все норм, иначе - переделать", другим не могу объяснить. Хотя так на одну логическую операцию больше.
15. ksen 06.09.18 12:33 Сейчас в теме
Исправил ли автор ошибку в сборке или надо будет самому доделывать?
Оставьте свое сообщение

См. также

Блин, мы забыли включить регламентные задания… 51

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Сервисные утилиты

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    6480    10    slozhenikin_com    36       

LicDataDecoder - расшифровка файла программной лицензии 1С 102

Инструменты и обработки Системный администратор Приложение (exe) v8 1cv8.cf Россия Windows Абонемент ($m) Сервисные утилиты

Представляю вашему вниманию утилиту, предназначенную для работы с файлами программных лицензий 1С (*.lic).

1 стартмани

10.02.2019    11763    160    GeraltSnow    42       

Централизованное управление списком доступных баз 1С у пользователей 8

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Стартеры 1С Сервисные утилиты Рабочее место

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    4705    7    RomikR    7       

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек. 32

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v8 1cv8.cf Россия Windows Абонемент ($m) Чистка базы Сервисные утилиты Администрирование данных 1С

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    18220    287    Eugen-S    34       

Go. Разбор лога технологического журнала. Достойная альтернатива perl'у 85

Статья Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Сервисные утилиты Инструментарий разработчика

Началось все с того, что я познакомился с перловыми скриптами для парса ТЖ которые размещены на kb.1c.ru (например в этой статье https://kb.1c.ru/articleView.jsp?id=113). По началу мне дико понравилось то, что перл разбирал гигабайты логов за считанные минуты, но позитив мой угасал обратно пропорционально с тем, насколько глубже я погружался в "кроличью нору" ....

1 стартмани

24.10.2018    9818    4    lazarenko    39       

Автоматическое заполнение графиков в ЗУП 3.1 6

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    8026    14    notserioussam    1       

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1) 17

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::СПР ЗУП3.x БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    14583    45    charivnick    3       

Мониторинг изменений рабочих конфигураций. Часть 1. Сохранение конфигураций из базы SQL без конфигуратора 102

Статья Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты

Выгружаем исходники из SQL напрямую скриптом, собираем CF и контролируем реальные изменения в рабочих базах из браузера.

1 стартмани

28.02.2018    13975    15    user768334    25       

Практика доступа в базу 1С через протокол oData. Чтение данных 276

Статья Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Сервисные утилиты Практика программирования Администрирование данных 1С

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    55050    232    Dementor    42       

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз 45

Инструменты и обработки Системный администратор Приложение (exe) v8 Windows Абонемент ($m) Сервисные утилиты

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    14453    85    bonv    15       

Графическая оболочка для консольной утилиты cnvdbfl.exe 105

Инструменты и обработки Системный администратор Архив с данными v8 Windows Абонемент ($m) Сервисные утилиты

Графическая оболочка для консольной утилиты cnvdbfl.exe предназначенной для преобразования размера внутренней страницы файла базы 1С.

1 стартмани

25.10.2017    29936    215    frkbvfnjh    43       

ОСкрипты для деплоя и копирования базы данных 127

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Сервисные утилиты

Набор оскриптов для деплоя базы 1С через хранилище и копирование через sql-бекап одной базы в другую

1 стартмани

02.05.2017    17447    33    Stepa86    25       

Автокликер для 1С 70

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты

Внешняя обработка, запускаемая в обычном (неуправляемом) режиме для автоматизации действий пользователя (кликер). ActiveX компонента, используемая в обработке, получает события от клавиатуры и мыши по всей области экрана в любом приложении и транслирует их в 1С, получает информацию о процессах, текущем активном приложении, выбранном языке в текущем приложении, умеет сохранять снимки произвольной области экрана, активных окон, буфера обмена, а также, в режиме воспроизведения умеет активировать описанные выше события. Все методы и свойства компоненты доступны при непосредственной интеграции в 1С. Примеры обращения к компоненте представлены в открытом коде обработки.

1 стартмани

03.04.2017    23524    69    slava_1c    49       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 99

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    40000    49    myALKleon    37       

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID) 8

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Поиск данных Универсальные обработки

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    23212    101    Dzenn    8       

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации 128

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    36868    218    BlizD    179       

Организация файлового хранилища на базе MS SQL Server с доступом из 1С 79

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент Сервисные утилиты

Пример реализации хранения файлов в базе MS SQL Server с использованием различных технологий. Подробно рассмотрен потоковый доступ к файлам с использованием технологии FileStream.

1 стартмани

27.07.2016    18126    40    tohandr    23       

Номенклатура (Расширенная форма списка) и Корзина [Расширение] 80

Инструменты и обработки Бухгалтер Пользователь Расширение (cfe) v8 БП3.0 Windows Учет ТМЦ Абонемент ($m) Обработка справочников Рабочее место

Красивая, удобная и эргономичная форма списка номенклатуры. В общем списке номенклатуры отображаются и остатки, и цены. А еще есть возможность быстро создать документы по выбранным позициям через корзину.

5 стартмани

29.02.2016    26493    118    mrXoxot    45       

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) 184

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка документов Обработка справочников Загрузка и выгрузка в Excel

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    49863    373    Tatitutu    49       

Автоматическая загрузка классификатора адресов КЛАДР 9

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия Windows Абонемент ($m) Обработка справочников WEB

Обработка автоматически загружает классификатор с сайта www.gnivc.ru, распаковывает и загружает все регионы в информационную базу.

1 стартмани

02.09.2015    17841    42    kolos    1       

Работа с push сервисами только средствами 1С 8.2 24

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Windows Абонемент ($m) Сервисные утилиты Инструментарий разработчика Универсальные обработки

Обработка для настройки, тестирования и использования с предустановками для 3-х сервисов. Текст модуля для внедрения в конфигурацию или другие обработки. Уведомления на телефон, компьютер, браузер.

1 стартмани

18.08.2015    23672    45    anig99    1       

Telemonitor - объединяем Telegram и 1С 170

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Администрирование данных 1С Мобильная разработка

Не так давно Telegram предоставил API для создания ботов. Telemonitor - программа, позволяющая легко настроить собственного бота для работы с 1С.

1 стартмани

09.08.2015    69360    230    salexdv    175       

Подсистема автоматического удаления дублей в справочниках (управляемые формы, любая конфигурация) 17

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Чистка базы Обработка справочников

Подсистема позволяет проводить автоматическое удаление дублей справочников в соответствии с заданными настройками. Возможно встраивание в любую конфигурацию на управляемых формах. Позволяет задать настройки справочников, в которых ищутся дубли и также поля поиска совпадений. Есть регламентное задание для запуска проверки с заданным периодом. Если в базе найдены ссылки на тот элемент, который будет удален, то они заменяются на тот элемент, который остается. Дублем считается элемент справочника, у которого больше значение кода.

1 стартмани

31.07.2015    28795    94    primat    9       

Конвертация данных. Найдется все! И еще немного... 26

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КД Абонемент ($m) Поиск данных Инструментарий разработчика

Каждый разработчик, применяющий конфигурацию «1С:Конвертация данных», когда-нибудь обязательно сталкивается с проблемой поиска данных в правилах обмена и (или) регистрации данных.

2 стартмани

25.06.2015    22860    40    tomvlad    7       

Отключение назойливых окон и подтверждение легальности обновления(!) для БП 3.0 при помощи расширения 76

Инструменты и обработки no Расширение (cfe) v8 БП3.0 Россия Абонемент ($m) Сервисные утилиты

Отключение назойливых окон и подтверждение легальности обновления(!) для БП 3.0 при помощи расширения

1 стартмани

25.06.2015    40393    284    Йожкин Кот    55       

Завершение работы пользователей (выгонялка) 12

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Сервисные утилиты

Обработка для завершения сеансов пользователей для клиент-серверной базы данных, с возможностью включения монопольного доступа к базе. Разработана на платформе 8.3. Запускается на любой конфигурации, как типовой, так и самописной, как в обычном режиме, так и в управляемом.

1 стартмани

17.06.2015    24699    263    Rusleg    27       

Подсистема проверки контрагентов через сервис ГосРеестра для объединения с любой конфигурацией (или автономной работы) 5

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки Обработка справочников

Еще один вариант для проверки контрагентов через сервис ФНС. Механизм аналогичен проверке в типовой БП 3.0 и полностью автономен, можно объединить с любой конфигурацией. При первом запуске просит ввести логин и пароль для доступа к сайту поддержки 1С.

1 стартмани

06.04.2015    14014    54    Foxes82    12       

Направляем список пользователей, не закрывающих терминальные сессии 1С, на почту ИТ директору 39

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Инструментарий разработчика Email

Пятница - лучший день для аншлагов по 1С. У Лены он начался с того, что у одного нашего московского клиента рухнула база по банальной причине ...

1 стартмани

16.03.2015    26194    23    O-Planet    42       

Загрузка товаров с Яндекс.Маркет 22

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 Windows Абонемент ($m) Обработка справочников WEB

Обработка предназначена для загрузки товаров (их описаний, свойств, изображений) с торговой площадки Яндекс.Маркет в базу Управление Торговлей 11. В отличие от других подобных обработок Вам самим не придется парсить страницы Яндекс.Маркет и решать сопутствующие этому процессу проблемы (бан, капча, поиск прокси-серверов, длительное ожидание результатов при больших объемах данных), так как все данные уже загружены на наш сервер и готовы для использования. Обновление данных осуществляется раз в месяц. Таким образом, все что Вам нужно - подключиться раз в месяц к нашему сервису и получить обновленный ассортимент товаров.

1 стартмани

12.01.2015    29893    182    Sirruf    81       

Универсальный поиск документов 8

Инструменты и обработки no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Поиск данных

Для обычных и управляемых форм. Версия 1.15 Создана на 1С8.3, но в режиме совместимости с 8.2.16. Итоговые таблицы одинаковы на обоих закладках

1 стартмани

06.01.2015    17512    38    nikitin19819    10       

Hasher Pro 1C \ 8.x \ Абсолютная очистка Кэша \ Кеша \ Хеша \ Временных файлов \ Мусора \ Создание гибкого скрипта очистки VBS \ BAT \ Дополнительные возможности \ УФ и Обычные \ Яркие впечатления 107

Инструменты и обработки Системный администратор Программист Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Чистка базы Администрирование данных 1С

Hasher Pro 1C - это новый подход в очистке кэша 1С:Предприятия. В сообществе временные файлы пользователя 1С называют по разному: кэш, кеш, хеш и т.д. Как правило этот мусор хранится годами на вашем компьютере и занимает очень много места - сотни гигабайт могут быть заняты бесполезными файлами. Hasher Pro 1C сочетает в себе ТРИ варианта очистки Кэша: 1) Быстрый и безопасный, подходит для любого пользователя 1С. 2) Полный и более тщательный, для программистов и уверенных пользователей. 3) Агрессивный с дополнительными административными возможностями. * А так же интерактивное создание скрипт файлов VBS или BAT для отложенной очистки или передачи скрипта коллегам. Используйте обработку Hasher Pro 1C как незаменимый инструмент при работе с 1С:Предприятием 8.1, 8.2 и 8.3 в клиент-серверном и файловом варианте. Поддержка толстого клиента, тонкого клиента, управляемых форм, интерфейса Такси. Совместимость: Windows XP/Vista/7/8/10 (x32/x64) + Серверные платформы.

3 стартмани

02.01.2015    39703    541    ya.Avoronov    34       

Проверка контрагентов по ИНН и КПП через веб-сервис ФНС (внешняя) 22

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Обработка справочников WEB

Обработка проверяет контрагентов по ИНН и КПП через веб-сервис ФНС на наличие регистрации в ЕГРН. Может выполняться в любых типовых конфигурациях, при наличии справочника "Контрагенты" и реквизитов "ИНН" и "КПП"

1 стартмани

25.12.2014    32017    297    Willforre    12       

Безопасное копирование файловых баз данных 1С (1Cv8.1CD) 37

Инструменты и обработки Системный администратор Приложение (exe) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Архивирование (backup)

Безопасное копирование файловых баз данных 1С (1Cv8.1CD) При подключенных пользователях!

1 стартмани

22.12.2014    43059    116    BorovikSV    27       

Реестр договоров для 1С:Бухгалтерии 14

Инструменты и обработки Бухгалтер Архив с данными v8 v8::БУ БП3.0 Россия БУ Документооборот и делопроизводство Абонемент ($m) Обработка документов Обработка справочников

Реестр договоров для 1С:Бухгалтерии - дополнительная обработка для конфигурации "Бухгалтерия предприятия", версия 3.0

5 стартмани

28.10.2014    33639    110    RespectSoft    23       

Поиск, восстановление битой ссылки, 8.3, v 0.2 20

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Поиск данных Тестирование и исправление

Обработка для работы с битой ссылкой, 8.3, v 0.1 Позволяет быстро найти и восстановить битую ссылку.

1 стартмани

24.10.2014    30897    306    infostart user    13       

Загрузка курсов валют 4

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка справочников WEB

Загрузка актуальных курсов валют с web - сервиса Сбербанка. На обычных и управляемых формах.

1 стартмани

15.10.2014    10596    27    miller-adm    3       

Быстрое создание характеристик номенклатуры по дополнительным реквизитам в УТ11 + ВИДЕО 7

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 УУ Windows Оптовая торговля Учет ТМЦ Абонемент ($m) Обработка справочников

Обработка позволяет создавать характеристики по всевозможным сочетаниям "дополнительных реквизитов характеристик". На форму выводится дерево дополнительных реквизитов характеристик и их возможных значений. Таблицу можно редактировать. Обработка полным перебором значений этих реквизитов создаст всевозможные характеристики.

1 стартмани

06.09.2014    20838    38    GATTUSO    27       

Скачиваем релизы с сайта users.v8.1c.ru 19

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты

Обработка позволяет настроить список релизов, доступных пользователю, на сайте users.v8.1c.ru, проверять - вышли ли новые обновления и, если вышли, скачивать их и раскладывать по папочкам. Требует установки curl и openssl

10 стартмани

18.08.2014    31854    96    Demonobond    31       

Проверка данных 179

Инструменты и обработки no Архив с данными v8 1cv8.cf БУ НУ УУ Абонемент ($m) Обработка документов Обработка справочников

Простой и удобный инструмент для проверки данных (справочников, документов) сразу в момент записи. Позволяет значительно повысить качество информации, вводимой в любую систему на платформе 1С:Предприятие 8.2-8.3. Прост в освоении и использовании, оптимизирован по быстродействию.

1 стартмани

01.07.2014    36506    329    1c-intelligence    145       

Отладка шаблонов ограничения доступа RLS 129

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Инструментарий разработчика

Если вы не можете разобраться в тексте шаблона ограничений прав доступа RLS - попробуйте воспользоваться этой обработкой!

1 стартмани

25.06.2014    84790    318    VSmirnoff    45       

Загрузка картинок для номенклатуры (google image API) 6

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка справочников WEB

Обработка предназначена для поиска и загрузки картинок номенклатуры.

1 стартмани

04.06.2014    11023    92    OVladius    4       

Смена валют учета в базе 6

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УТ10 УПП1 Windows Абонемент ($m) Обработка справочников

Крымчане столкнулись с проблемой смены валют с гривны на рубль. Эта обработка поможет решить данный вопрос.

1 стартмани

26.05.2014    21798    32    dmbal    4       

Быстрый ввод контрагентов и организаций по данным ФНС 75

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УТ10 УПП1 УНФ Windows Абонемент ($m) Обработка справочников WEB

Обработка для быстрого создания карточки контрагента/организации по данным ЕГРЮЛ/ЕГРИП.

1 стартмани

20.05.2014    35723    743    Sirruf    71