Выявление минусов по товарам

Отчеты - Управленческие

Отчет "Выявление минусов по товарам"  (для конфигурации Торговля+Склад редакция 9.2)

Предназначен для выявления проблемных позиций товаров, по которым за выбранный период были минусы.
Т.е. минусы не на дату конца отчета, а на любой момент времени из выбранного интервала.
Написан по просьбе трудящихся в свой личный выходной :-)

Необходимо указать период отчета, выбрать склад (если не выбран, то по всем складам), выбрать товар или группу товаров (если не выбрана, то по всем товарам).

Сделан на базе регистра "ОстаткиТМЦ"

Скачать файлы

Наименование Файл Версия Размер
J_Minusy_po_tov.rar
.1187440754 7,66Kb
25.09.09
277
.1187440754 7,66Kb 277 Скачать бесплатно

См. также

Комментарии
1. Доржи Цыденов (support) 4533 18.08.07 21:13 Сейчас в теме
2. Julia (juliasoft) 101 18.08.07 21:18 Сейчас в теме
(1) спасибо.. теперь понятно, за что тут плюсы раздают.. за "интерфейс" и за "отзывчивость" :-)
3. Сhe Burashka (CheBurator) 19.08.07 00:10 Сейчас в теме
...нормалек, запихну тут одним любителям косячить...
4. Poppy (poppy) 3320 20.08.07 00:03 Сейчас в теме
> выбрать склад (если не выбран, то по всем складам),

Если склад не выбран, то минусы расчитываются по каждому складу отдельно или по всем вместе?
7. Julia (juliasoft) 101 20.08.07 08:08 Сейчас в теме
(4) - если склад не выбран - по любому, есть группировка по складам.. будет считаться отдельно по каждому складу. Отбор по фирме не учитывала. Кому надо - сам добавит.
(5) - по поводу упрощения кода - правильное замечание, кто захочет - исправит сам. Лучше просто скажите спасибо (если он вам нужен), если не нужен - нет смысла тут писать (или вы каждый код просматриваете: :-) ).
5. Poppy (poppy) 3320 20.08.07 00:07 Сейчас в теме
Традиционное предложение по "упрощению" кода:

вместо кода
Код
   Если ВыбСклад.Выбран() = 1 Тогда
      ТекстЗапроса = ТекстЗапроса + 
      "Условие(Склад = ВыбСклад);
       |";
   КонецЕсли;  
   Если (ВыбНоменклатура.Выбран() = 1) И (ВыбНоменклатура.ЭтоГруппа() = 1) Тогда
      ТекстЗапроса = ТекстЗапроса +
      "Условие(Номенклатура.ПринадлежитГруппе(ВыбНоменклатура) = 1);
       |";
   ИначеЕсли (ВыбНоменклатура.Выбран() = 1) И (ВыбНоменклатура.ЭтоГруппа() = 0) Тогда   
      ТекстЗапроса = ТекстЗапроса +
      "Условие(Номенклатура = ВыбНоменклатура);
       |";    
   КонецЕсли;
    
   Если ВыбСклад.Выбран() = 1 Тогда
      ТекстЗапроса = ТекстЗапроса +
      "Условие(Склад = ВыбСклад);
       |";
   КонецЕсли;     
Показать полностью


достаточно написать следующее:
Код
   ТекстЗапроса = ТекстЗапроса +
   "Условие(Номенклатура в ВыбНоменклатура);
   |Условие(Склад в ВыбСклад);";    
Показать полностью

lenapar; 33lab; +2 Ответить
17. Аркадий Кучер (Abadonna) 3695 30.08.07 06:51 Сейчас в теме
(5) Poppy, как всегда, права ;)
6. Леонид (leonko38) 20.08.07 05:57 Сейчас в теме
8. Евгений Чуркаев (MACTEP) 163 21.08.07 23:10 Сейчас в теме
это делается в двух строчках :-)
DobroProd; +1 Ответить
9. Viacht (viacht) 24.08.07 09:37 Сейчас в теме
В ПУБ для Украины не работает, хотя должно. РУгается:
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Склад = Регистр. <<?>> ОстаткиТМЦ.Склад;
Запрос[3] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Номенклатура = Регистр. <<?>> ОстаткиТМЦ.Номенклатура;
Запрос[4] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Количество = Регистр. <<?>> ОстаткиТМЦ.Количество;
Запрос[5] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Док = Регистр. <<?>> ОстаткиТМЦ.ТекущийДокумент;
Запрос[6] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Группировка Склад <<?>> упорядочить по Склад.Наименование;
Запрос[11] : Переменная 'Склад' не опеределена
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Группировка Номенклатура <<?>> без групп;
Запрос[12] : Переменная 'Номенклатура' не опеределена
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Группировка Док <<?>> ;
Запрос[13] : Переменная 'Док' не опеределена
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Условие(Склад = ВыбСклад <<?>> );
Запрос[14] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Условие(Номенклатура = ВыбНоменклатура <<?>> );
Запрос[15] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Условие(Склад = ВыбСклад <<?>> );
Запрос[16] : Ошибка в условии
10. Poppy (poppy) 3320 24.08.07 12:36 Сейчас в теме
(9)
В твоей конфигурации нет регистра ОстаткиТМЦ, вот и ругается.

С чего ты взял, что должно работать? В описании явно написано, что для конфигурации ТиС 9.2
11. Viacht (viacht) 27.08.07 10:51 Сейчас в теме
Как правило, Тисовские отчеты прекрасно работают в ПУБ для Украины. А насчет регистра ОстаткиТМЦ мне кажется Вы частично не правы, у нас он называется ОстаткиЗапасов.
13. Poppy (poppy) 3320 27.08.07 12:25 Сейчас в теме
(11)
Когда твой регистр ОстаткиЗапасов будет называться ОстаткиТМЦ, вот тогда обработка, возможно, заработает.

Или... обработку дорабатывай напильником. ;)
12. VasilyKushnir (vasilykushnir) 27.08.07 12:09 Сейчас в теме
Ну ей богу, как дети - что не найдут, все в рот тянут... И вообще, это не есть хорошая практика один-к-одному чужие очеты использовать. Используйте как источник идей, подрабатывайте под себя. А идеи у девочки толковые - +1 однозначно.
O-Planet; +1 Ответить
14. Margosha80 (margosha80) 27.08.07 14:01 Сейчас в теме
А для бухгалтерии есть такая обработка?
15. Tiger77 (Tiger77) 66 29.08.07 11:34 Сейчас в теме
Ерунда! Не проще ли выбрать все партии где приходный документ не приходная накладная ????
16. Poppy (poppy) 3320 30.08.07 01:15 Сейчас в теме
(15)
Не проще.
Во-первых, в качестве приходного документа могут выступать "Возврат от покупателя", "Оприходование ТМЦ".
Во-вторых, регистр ПартииНаличие очень чувствителен к положению ГП, но остатки в регистре ОстаткиТМЦ от ГП не зависят.
18. Viacht (viacht) 04.09.07 08:47 Сейчас в теме
13 Как было предложено обработал напильником, и свершилось чудо. ЗАРАБОТАЛА!
Автору гигантский плюс+. Если надо кому могу выложить для конфигурации ПУБ для Украины.
19. VasilyKushnir (vasilykushnir) 04.09.07 11:23 Сейчас в теме
(18) А сам реальный плюс дядя поставит?
20. Олег Пономаренко (O-Planet) 6712 11.10.07 04:31 Сейчас в теме
21. Юрий Португалов (Sprite) 472 18.11.07 17:00 Сейчас в теме
Оказалось нужным именно сегодня.
22. Сhe Burashka (CheBurator) 09.12.07 01:20 Сейчас в теме
> Невозможно обращение к итогам после ТА
ну такие-то проверки надо вставлять...
Оставьте свое сообщение