Акции и праздники в ЧекККМ

Публикация № 158649

Администрирование - Администрирование данных 1С - Обработка документов

1
Для Розницы 1.0 при записи чека просматривается регистр сведений на предмет акций, и вписывается в комментарий чека.

Добрый день, кого заинтересовало.

Накопилось конечно много за годы работы, но вот решил начать с простого.

Понадобилось клиенту в шаблон чека вставлять текст различный. Я предложил ему свое виденье и вот что получилось.

Добавил регистр сведений периодический в день с измерением магазин(справочник.магазин) и ресурсом текстовым(Праздник).

Еще реквизит создатель(справочник.пользователи) для удобства разбора полетов.

 

В Сервис добавил строчку для вызова формы списка регистра сведений.

На форме добавил кнопочку акция для вызова формы, которое облегчает занесение данных в регистр. Не руками ж нам все это вбивать

вбиваем период вручную, или с помощью кнопки период.

Текст акции. и список магазинов. Можно через подбор наколотить.

Затем жмакаем на кнопку создать акцию и проставляются строки в регистре.

Вообщемто реализован пакетный ввод, то есть можно открыть форму и нажать создать акцию, система сама предложит заполнить нужную информацию.

КОД:

" табулиция не вставилась. уж извиняйте. пишите мыло если надо, скину конфу.


Процедура ПериодНажатие()
НастройкаПериода = новый НастройкаПериода;
НастройкаПериода.УстановитьПериод(НачалоАкции, ?(КонецАкции='0001-01-01', КонецАкции, КонецДня(КонецАкции)));
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
Если НастройкаПериода.Редактировать() Тогда
НачалоАкции = НастройкаПериода.ПолучитьДатуНачала();
КонецАкции = НастройкаПериода.ПолучитьДатуОкончания();
КонецЕсли;
КонецПроцедуры

Процедура НачалоАкцииПриИзменении(Элемент)
Если КонецАкции = '00010101' или КонецАкции
НачалоАкции = НачалоДня(НачалоАкции);
КонецАкции = НачалоДня(НачалоАкции);

Иначе
НачалоАкции = НачалоДня(НачалоАкции);

КонецЕсли;
КонецПроцедуры

Процедура СоздатьАкциюЕКНажатие(Элемент)
создаем = Ложь;
Если Стрдлина(сокрлп(праздник))=0 тогда
Предупреждение("Текст АКЦИИ не введен!");

иначе
если Магазины.Количество()=0 тогда
Ответ = КодВозвратаДиалога.Да;
Режим = РежимДиалогаВопрос.ДаНет;

пока Ответ = КодВозвратаДиалога.да цикл
формамагазинов = Справочники.Магазины.ПолучитьФормуВыбора();
ВыбралиМагазин = формамагазинов.ОткрытьМодально();
Если ВыбралиМагазин = Неопределено Тогда
Текст = "ru = ""Нажмите на магазин два раза для выбора! Попробуете еще раз?"";"
+ " en = ""Do you want to continue?""";
Иначе
Магазины.Добавить(ВыбралиМагазин);
Текст = "ru = ""добавить еще магазин?"";"
+ " en = ""Do you want to continue?""";
КонецЕсли;
Ответ = Вопрос(НСтр(Текст), Режим, 0);
конецЦикла;
создаем=?(Магазины.Количество()=0,Ложь,Истина);
Иначе
создаем = Истина;
конецесли;

Если НачалоАкции<>'00010101' и КонецАкции <> '00010101' then

else
Сообщить("Выберите период!");
ПериодНажатие();
КонецЕсли;
Если НачалоАкции<>'00010101' и КонецАкции <> '00010101' then

else
Сообщить("Период не выбран!");
создаем=Ложь;
КонецЕсли;

Если создаем Тогда
Если год(КонецАкции)>Год(НачалоАкции) Тогда
ДнейВАкции = ДеньГода(КонецАкции)-ДеньГода(НачалоАкции)+(ДеньГода(КонецГода(КонецАкции)));
Иначе
ДнейВАкции = ДеньГода(КонецАкции)-ДеньГода(НачалоАкции);
КонецЕСли;

//Для Строка=1 по магазины.количество() Цикл
Для каждого Магазин из магазины.ВыгрузитьЗначения() Цикл
Для ДатаАкции=0 по ДнейВАкции Цикл
ДеньАкции = НачалоАкции + ДатаАкции*24*60*60;
Акции = РегистрыСведений.ПраздниковИАкций;
НаборЗнач = Акции.СоздатьНаборЗаписей();
НаборЗнач.Отбор.Период.Установить(ДеньАкции, Истина);
НаборЗнач.Отбор.Магазин.Установить(Магазин, Истина);
НаборЗнач.Прочитать();
Если НаборЗнач.Количество()=0 Тогда

Запись = НаборЗнач.Добавить();
запись.Магазин = Магазин;
запись.Праздник = Праздник;
запись.Период = ДеньАкции;
запись.Создатель = ПараметрыСеанса.ТекущийПользователь;
ИначеЕсли НаборЗнач.Количество()=1 Тогда
//Запись = НаборЗнач[0];
//запись.Праздник = Праздник;
//запись.Создатель = ПараметрыСеанса.ТекущийПользователь;
НаборЗнач[0].Праздник = Праздник;
НаборЗнач[0].Создатель = ПараметрыСеанса.ТекущийПользователь;
КонецЕсли;
НаборЗнач.Записать(Истина);
НаборЗнач.Очистить();
КонецЦикла;
КонецЦикла;
Иначе
Сообщить("Не все так гладко, проверьте данные.");
КонецЕсли;
КонецЕсли;

КонецПроцедуры

Процедура УдалитьНажатие(Элемент)
создаем = Ложь;
Если сокрлп(праздник)=0 тогда
сообщить("Поле АКЦИЯ пусто!");
иначе
если Магазины.Количество()=0 тогда
Ответ = КодВозвратаДиалога.Да;
Режим = РежимДиалогаВопрос.ДаНет;

пока Ответ = КодВозвратаДиалога.да цикл
формамагазинов = Справочники.Магазины.ПолучитьФормуВыбора();
ВыбралиМагазин = формамагазинов.ОткрытьМодально();
Если ВыбралиМагазин = Неопределено Тогда
Текст = "ru = ""Нажмите на магазин два раза для выбора! Попробуете еще раз?"";"
+ " en = ""Do you want to continue?""";
Иначе
Магазины.Добавить(ВыбралиМагазин);
Текст = "ru = ""добавить еще магазин?"";"
+ " en = ""Do you want to continue?""";
КонецЕсли;
Ответ = Вопрос(НСтр(Текст), Режим, 0);
конецЦикла;
создаем=?(Магазины.Количество()=0,Ложь,Истина);
Иначе
создаем = Истина;
конецесли;
КонецЕсли;
Если НачалоАкции<>'00010101' и КонецАкции <> '00010101' then

else
Сообщить("Выберите период!");
ПериодНажатие();
КонецЕсли;
Если НачалоАкции<>'00010101' и КонецАкции <> '00010101' then

else
Сообщить("Период не выбран!");
создаем=Ложь;
КонецЕсли;
Если создаем Тогда
Если КонецАкции ДнейВАкции = ДеньГода(КонецАкции)-ДеньГода(НачалоАкции)+(ДеньГода(КонецГода(КонецАкции)));
Иначе
ДнейВАкции = ДеньГода(КонецАкции)-ДеньГода(НачалоАкции);
КонецЕСли;

//Для Строка=1 по магазины.количество() Цикл
Для каждого Магазин из магазины.ВыгрузитьЗначения() Цикл
Для ДатаАкции=0 по ДнейВАкции Цикл
ДеньАкции = НачалоАкции + ДатаАкции*24*60*60;
Акции = РегистрыСведений.ПраздниковИАкций;
НаборЗнач = Акции.СоздатьНаборЗаписей();
НаборЗнач.Отбор.Период.Установить(ДеньАкции, Истина);
НаборЗнач.Отбор.Магазин.Установить(Магазин, Истина);
НаборЗнач.Прочитать();
Если НаборЗнач.Количество()=1 Тогда
НаборЗнач.Удалить(0);
НаборЗнач.Записать(истина);
ИначеЕсли НаборЗнач.Количество()>1 Тогда
Для индекс=0 по НаборЗнач.Количество() Цикл
НаборЗнач.Удалить(индекс);
КонецЦикла;
НаборЗнач.Записать(истина);
КонецЕсли;
НаборЗнач.Очистить();
КонецЦикла;
КонецЦикла;
Иначе
Сообщить("Не все так гладко, проверьте данные.");
КонецЕсли;
КонецПроцедуры

 

"

Также реализовано удаление записей по магазину и периоду.

Для перезаписи достаточно указать новое наименование акции период/магазин и нажать создать.

Затем в ЧекККМ при записи создаем код смотрим новый ли это документ и заносим отталкиваясь от даты документа его строчку.

"

Если не этотобъект.проведен Тогда
   Акции = РегистрыСведений.ПраздниковИАкций;
   НаборЗнач = Акции.СоздатьНаборЗаписей();
   НаборЗнач.Отбор.Период.Установить(НачалоДня(этотобъект.дата), Истина);
   НаборЗнач.Отбор.Магазин.Установить(этотобъект.Магазин, Истина);
   НаборЗнач.Прочитать();
   Если НаборЗнач.Количество()=1 Тогда
      этотобъект.Комментарий = НаборЗнач[0].праздник;
   КонецЕсли;
КонецЕсли;

"

1

Скачать файлы

Наименование Файл Версия Размер
конфа с изменениями
.cf 24,06Mb
29.10.12
9
.cf 24,06Mb 9 Скачать
архив с файлами конфигурации(только модуль чека и регистр)
.rar 26,31Kb
29.10.12
2
.rar 26,31Kb 2 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. xdim 6 29.10.12 18:44 Сейчас в теме
Конечно есть вариант решения через СрезПоследних, но что-то в голову сразу так все нарисовалось, да и отвечает всем требованиям. :idea:
Оставьте свое сообщение

См. также

Списание (корректировка) задолженности контрагентов УНФ 1.6 4

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УНФ Украина БУ Дебиторская и кредиторская задолженность Абонемент ($m) Закрытие периода Обработка документов

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    2158    3    DMon    1       

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android 21

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::Mobile Розница УНФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Внешние источники данных Сканер штрих-кода Терминал сбора данных Работа с интерфейсом Мобильная разработка

Простой мобильный терминал сбора данных для iOS и Android, не требующий сложных настроек и установки дополнительных программ. Для выгрузки базы штрихкодов и загрузки собранных штрихкодов в документы учетной системы используется Яндекс Диск или облачный сервис и расширение конфигурации. Работает с конфигурациями Розница 2, УНФ 1.6, УТ 11, ERP, КА2.

3 стартмани

22.04.2019    9820    51    suepifanov    61       

Регистрация документов с измененной суммой 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка документов

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    3463    1    ryan    0       

Трудовой договор, Дополнительное соглашение, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1 17

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    6778    56    Asenka    3       

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации) 6

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 КА1 УПП1 УУ Абонемент ($m) Обработка документов

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    5595    6    stvorl    3       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь полноценный оффлайн (обновление от 15.08.19)! 169

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    19736    208    informa1555    167       

Расширение "Интерфейс Плюс" 40

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    9899    88    RocKeR_13    81       

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом 13

Инструменты и обработки Программист Пользователь Архив с данными v8 КА1 БП2.0 УТ10 УПП1 Windows Абонемент ($m) Печатные формы документов Универсальные функции Email

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    11049    10    stvorl    0       

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    13665    78    asdfgcom    45       

Загрузка файлов/картинок/изображений/фото номенклатуры PRO 16

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница УНФ УТ11 Россия Оптовая торговля Розничная торговля Абонемент ($m) Управленческий учет (прочее)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    7319    61    zannv    18       

ЕГАИС 3 Контролёр для 1С:Розница 7

Инструменты и обработки Системный администратор Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Android Розничная торговля Абонемент ($m) Терминал сбора данных

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    8995    16    kuld    30       

Пробитие чеков через ККМ в офисе (для курьеров) 11

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    17151    27    Kutuzov    12       

Время продаж чеков по магазинам в УТ 11, КА. Аналитический отчет + Диаграмма 7

Отчеты и формы Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ УТ10 УТ11 КА2 Розничная и сетевая торговля (FMCG) УУ Розничная торговля Абонемент ($m) Управленческие

Отчет "Диаграмма по времени продаж чеков" предназначен для планирования графиков работы продавцов-менеджеров, для планирования маркетинговых мероприятий.

2 стартмани

16.03.2018    10417    8    zaika007    12       

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой 26

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.10 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.10 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    29338    498    p.ugrumov    86       

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Розничная торговля Абонемент ($m) Обработка документов

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    16841    5    biz-intel    3       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    21374    21    agent00mouse    0       

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1 35

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    23881    29    mvv1975    5       

Копирование меню в Трактир Management 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Производство готовой продукции (работ, услуг) Абонемент ($m) Обработка документов

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    13348    1    integrator1983    0       

Остатки товаров на складах по выбранным документам 9

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 ERP2 УТ11 УУ Учет ТМЦ Абонемент ($m) Печатные формы документов

Печатная форма подключается к документам. Даёт возможность быстро оценить остатки товара на складе по номенклатуре, указанной в документе, и ответить на вопрос, хватает ли остатков, чтобы отгрузить счет? На каких складах продукция по этому документу?

2 стартмани

09.11.2017    30356    24    A7758735    4       

Счет-фактура+УПД+УКД с 01.10.2017 в редакции Постановления Правительства РФ от 19.08.2017 № 981. Для всех конфигураций на 1С 8 48

Отчеты и формы Бухгалтер Архив с данными v8 БП2.0 УТ10 УПП1 УНФ БП3.0 УТ11 БУ НУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы с автоматической регистрацией для документа "Счет-фактура выданный" в редакции Постановления Правительства РФ №981 от 19.08.2017 года. Новые счета-фактуры № 981 применяются с 01.10.2017 года. Так же для УТ 10 очень старых релизов применяется сч.фактура в файле.

2 стартмани

18.09.2017    66003    1341    Kontakt    90       

Android беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С 78

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf УУ Android Оптовая торговля Розничная торговля Абонемент ($m) Сканер штрих-кода

Бесплатное приложение, превращающее Android-смартфон в беспроводной 1D/2D Bluetooth сканер и терминал сбора данных для 1С и прочих POS систем. Не требует драйверов и доработки конфигураций.

1 стартмани

12.09.2017    26665    24    kuld    43       

БП 2.0 онлайн-касса (ККТ с передачей данных) 54 ФЗ 20

Инструменты и обработки Системный администратор Программист Бухгалтер Конфигурация (md, cf) v8 v8::БУ БП2.0 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Изменения для объединения с конфигурацией "Бухгалтерия предприятия 2.0" с функционалом для работы с ККТ с передачей данных в ОФД (онлайн-касса), сделана согласно методическим указаниям.

3 стартмани

09.07.2017    30722    135    bob_    53       

Внешние печатные формы Счет-фактура, УПД, УКД образца 2017 г. (ПП от 19.08.2017 № 981) для УПП 1.3, КА 1.1, БП 2.0 22

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УПП1 БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы "Счет-фактура", "Универсальный передаточный документ", "Универсальный корректировочный документ" (в редакции постановления Правительства Российской Федерации от 19.08.2017 № 981) для типовых конфигураций УПП 1.3, КА 1.1, БП 2.0.

1 стартмани

30.06.2017    41175    712    Tavalik    63       

Счет-фактура с 01.07.2017 от 25.05.2017 №625 для ВСЕХ конфигураций 1С 8.х (БП 2.0, БП 2.0 КОРП, БАУ 2.0, БАУ 2.0 КОРП, КА 1.1, ПД 1.0, Розница 1.0, УНФ 1.3, УПП 1.3, УТ 11, УТ 10.3) 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ КА1 БП2.0 УТ10 Розница УПП1 УНФ БП3.0 БАУ УТ11 Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

С июля 2017 года применяется новая печатная форма счет-фактуры в редакции Постановления Правительства РФ от 25.05.2017 № 625. В публикации собраны внешние печатные формы для всех популярных конфигураций 1С. Будет актуально для 90% организаций, которые не ведут учет по гос. контрактам, так как новое поле не заполняется, а вместо номера гос. контракта установлен прочерк по умолчанию.

1 стартмани

29.06.2017    34288    455    a.kapustin    43       

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме 3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БУ УУ Дебиторская и кредиторская задолженность Абонемент ($m) Обработка документов Печатные формы документов

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    11571    2    denmax    2       

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол 12

Инструменты и обработки Системный администратор Программист Архив с данными v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    41429    127    Atom74    69       

FR_Atol_Shtrih.exe печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54ФЗ поддержка изменений от 01/07/19). Для 1С (7.7 и:8 УФ, Обычных Формы) есть готовые обработки 68

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Windows Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    50866    173    ah7777777    473       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 99

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    39911    49    myALKleon    37       

Android Штрихкод сканер + драйвер устройства для 1С 135

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 1cv8.cf 1cv7.md Android Розничная торговля Абонемент ($m) Сканер штрих-кода

Драйвер торгового оборудования и приложение для Android, телефон или планшет в качестве стандартного штрихкод сканера для платформы 1С.

3 стартмани

29.11.2016    35513    188    dreamadv    99       

Отчеты для логистов (а также презентация и пояснительная записка) 7

Отчеты и формы Бизнес-аналитик Руководитель проекта Внешний отчет (ert,erf) v8 1cv8.cf УУ Оптовая торговля Розничная торговля Абонемент ($m) Управленческие

Развитие розничных торговых сетей осуществляется благодаря применению логистики, призванной удовлетворять потребности покупателей в качественных товарах и услугах. Предлагаю Вашему вниманию ряд методических положений, связанных с совершенствованием функционирования логистических систем розничных торговых сетей.

1 стартмани

09.10.2016    19589    2    ksnik    4       

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора. 23

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Обработка документов Универсальные обработки Обмен через XML

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    27520    146    Aphanas    4       

Легкий интернет-магазин из УТ 11.2 67

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 УУ Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка создания интернет-магазина из УТ 11. Создается единственный файл html, который содержит все выгруженные товары. Клиент составляет и отправляет заказ вам на e-mail прямо из браузера, не прибегая к использованию стороннего ПО.

11.08.2016    21749    482    hlopik    36       

Неликвиды на складе Pro и Lite версия. Редактирование реквизита в таблице документа. Для конфигурации Управление торговлей 11.2, 11.1 1С Предприятие 8.3 5

Отчеты и формы Бизнес-аналитик Бухгалтер Внешний отчет (ert,erf) v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика УУ Windows Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Управленческие

Внешний отчет для анализа товаров, находящихся на складе без движения. Работает для конфигураций 1С Управление Торговлей 11.2, 11.1. Отчет отображает товары на складах, движения по которым не производились в течении заданного периода дней. Подключается как внешний отчет в конфигурации 1С Управление торговлей 11. В Pro версии можно установить общий реквизит номенклатуры, для дальнейшего включения в отбор в установке цен номенклатуры. Редактирование в табличном документе ускоряет процесс работы с неликвидами номенклатуры на складах. Отчет можно использовать для стоимостной оценки товаров на складах. Полный доступ к тексту модулей и СКД.

1 стартмани

17.06.2016    22254    47    Ликреонский    2       

Загрузка Счета покупателя из PDF 7

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Windows Оптовая торговля Абонемент ($m) Обработка документов Файловые протоколы обмена, FTP

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    4377    10    John_d    0       

Печатная форма Счет-Фактура от 01.10.2017, УПД 01.10.2017, Торг-12, Счет на оплату, ТТН (1-Т) БП 3.0 ОРИГИНАЛЬНЫЕ 10

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Набор внешних печатных форм: Счет-Фактура, УПД, Торг-12, ТТН, Счетна оплату для 1С: БП 3.0. Формы взяты из релиза 3.0.54.20 бухгалтерии предприятия. Печатные формы (УПД и счет-фактуры) приведены в соответствие постановления 625 от 25.05.2017 И В РЕДАКЦИИ ПОСТАНОВЛЕНИЯ 981 ОТ 19.08.2017 в формах выводится "Идентификатор госконтракта" и прочие изменения.

1 стартмани

04.05.2016    36771    378    A7758735    3       

Управление доставкой розничным покупателям 2

Инструменты и обработки Руководитель проекта Конфигурация (md, cf) v8 УТ10 Розничная и сетевая торговля (FMCG) Россия УУ Windows Розничная торговля Абонемент ($m) Обработка документов

Дополнение для УТ 11.1, оформление доставки для розничного покупателя на основании кассового чека в связке с мягким чеком покупателя.

5 стартмани

10.03.2016    16865    6    Denis_Viktorovich    5       

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0 17

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия Windows Абонемент ($m) Обработка документов

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

5 стартмани

25.02.2016    24241    83    SmArtist    8       

ЕГАИС: код алкогольной продукции из штрихкода акцизной марки 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Windows Оптовая торговля Розничная торговля Акцизы Абонемент ($m) Универсальные обработки

В последнее время мне пришлось потратить очень много времени на внедрение и реализацию функционала ЕГАИС. Очень часто, на форумах, я встречал вопрос: "Как из штрих-кода акцизной марки получить код алкогольной продукции ЕГАИС?". Несколько раз видел неверную реализацию этой задачи. Глядя на это, я набросал простую обработку пересчета кода акцизной марки (base36) в понятный нам уникальный ФСРАР ID алкогольной продукции (Base10).

1 стартмани

11.02.2016    46394    153    OrcaMax    29       

Печатные формы для БП 3.0: УПД, ТОРГ-12, Акт, Счет-фактура, Доверенность, Счет 25

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы УПД, ТОРГ-12, Акта об оказании услуг, Счет-фактуры, Доверенности и Счета на оплату покупателю, актуализированы на последний релиз 3.0.71, поддерживают типовые факсимиле (новую галочку "Подпись и печать"), не содержат ошибок с новой ставкой НДС. В публикации также представлены печатные формы для устаревших релизов.

1 стартмани

28.01.2016    55277    762    config    42       

Перечисление НДФЛ в бюджет РФ (13%, 30%) 11

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 БУ НУ Windows Зарплата НДФЛ Абонемент ($m) Обработка документов

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    22044    239    1kashak    16       

Начисление процентов по кредитам и займам для 1С:Бухгалтерии 3.0 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Windows Займы, кредит, лизинг Абонемент ($m) Обработка документов

Универсальная обработка по начислению процентов по кредитам и займам для 1С:Бухгалтерии 3.0 без изменения конфигурации

1 стартмани

22.01.2016    48088    156    algora    27       

Пакетная замена номенклатуры с учетом характеристик 6

Инструменты и обработки Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 УУ Оптовая торговля Учет ТМЦ Абонемент ($m) Обработка документов

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    9403    trendy    1