ЗиК: Шаблон табеля на следующие месяца по графику работы, с цветовым обозначением

Печать - Универсальные печатные формы

Отчет сделан на основе типового отчета  «ЗиК:Табель рабочего времени».
Предназначен для создания шаблона табеля рабочего времени на основании календаря (подойдет только для сотрудников на окладе), как следствие облегчение каторжного труда табельщиков и удобное выявление переработки.

Скачать файлы

Наименование Файл Версия Размер
-
.1223321818 357,00Kb
11.12.14
735
.1223321818 357,00Kb 735 Скачать

См. также

Комментарии
1. Иллона (07_zybkov) 09.10.08 04:25 Сейчас в теме
2. sonylover (sonylover) 09.10.08 13:15 Сейчас в теме
3. GIZmo (GIZmo) 271 09.10.08 13:23 Сейчас в теме
Пипл!! Переименуйте файл в *.ERT (видимо сайт не переваривает длинные названия)
4. Vladimir (Boroda) 90 10.10.08 12:51 Сейчас в теме
Непонятное расширение! ert это или архив какой?! Зачем запихивать файл с таким длинным именем?Достаточно в комментарии рассказать о нём...
5. Рома (dri) 10.12.08 06:29 Сейчас в теме
6. vova56 (vova56) 10.12.08 10:11 Сейчас в теме
Шаблон табеля на следующие.ert
7. vova56 (vova56) 10.12.08 10:23 Сейчас в теме
Много ли надо дописать, чтобы работала в Комплексной?
8. GIZmo (GIZmo) 271 10.12.08 18:53 Сейчас в теме
> Много ли надо дописать, чтобы работала в Комплексной?
мне кажеться по аналогии можно сообразить то , что поправить в типовом отчете от комплексной. Там изменено совсем чуть-чуть.
9. Lady-mo (Lady-mo) 91 29.05.09 13:03 Сейчас в теме
Кадровики в восторге!
Спасибо за обработку
10. Виталий Сысоев (Vital451) 23 20.10.17 08:24 Сейчас в теме
Не работает если система оплаты Повременно-премиальная по окладу согласно табеля
Надо защарить так:
		//Если (ФормаТрудаСотрудника = Перечисление.ФормыТруда.ТабельПодневнОклад) или (ФормаТрудаСотрудника = Перечисление.ФормыТруда.ТабельПочасОклад) или (ФормаТрудаСотрудника = Перечисление.ФормыТруда.ТабельПочасТариф) тогда
		//	Если ПустоеЗначение(ДокументТабель) = 0 тогда
		//		ДокументТабель.ПолучитьСтрокуПоНомеру(НомерВТабеле);
		//		
		//		Если ДокументТабель.ПолнотаВводаДанных = 1 Тогда
		//			//заполнение данных из табеля
		//			Для ДатаКалендаря = НачалоПериода по КонецПериода Цикл           
		//				
		//				ПозицияМассива = ДатаЧисло(ДатаКалендаря);
		//				
		//				Часов = ДокументТабель.ПолучитьАтрибут("КолвоЧасов" + Формат(ПозицияМассива, "Ч(0)2.0"));
		//				Если Часов>0 Тогда
		//					Если ПустоеЗначение(КодЧасов  [ПозицияМассива]) = 1 Тогда
		//						КодЧасов  [ПозицияМассива] = "Я";
		//						КолвоЧасов[ПозицияМассива] = Часов;
		//					ИначеЕсли ((КодЧасов[ПозицияМассива]="РВ")и(КолвоЧасов[ПозицияМассива]=0))Тогда
		//						КолвоЧасов[ПозицияМассива]=Часов;
		//					КонецЕсли;
		//				ИначеЕсли КодЧасов  [ПозицияМассива] <> "РВ" Тогда
		//					
		//					// Попробуем побороться с буквами "В", которые появляются в табеле после увольнения и перед принятием на работу.
		//					// Предусмотрим обработку случая когда сотрудника несколько раз принимали и увольняли в одном месяце.
		//					Если ПустоеЗначение(КодЧасов  [ПозицияМассива]) = 1 Тогда  
		//						ЗначениеСостоянияФизЛица = 0;
		//						ТаблицаРеквизитов.ВыбратьСтроки();
		//						Пока ТаблицаРеквизитов.ПолучитьСтроку() = 1 Цикл
		//							Если ТаблицаРеквизитов.Дата <= ДатаКалендаря Тогда
		//								ЗначениеСостоянияФизЛица = ТаблицаРеквизитов.СостояниеФизЛица;
		//							Иначе
		//								Прервать;
		//							КонецЕсли;
		//						КонецЦикла;	  
		//						
		//						// сотрудник должен быть в штате на эту дату.
		//						Если ПустоеЗначение(ЗначениеСостоянияФизЛица) = 0 Тогда
		//							КодЧасов[ПозицияМассива] = "В";
		//						КонецЕсли;
		//					КонецЕсли;
		//					
		//				КонецЕсли;
		//			КонецЦикла;
		//		КонецЕсли;
		//	КонецЕсли;
		//Иначе
			Если (ЕстьЗаписиПоЖР = 1) или (ТабШАБЛОН = 1)  Тогда            // Ильдар
Показать
Оставьте свое сообщение