Методика упрощения поддержки конфигураций. Переопределение и вызов обработчиков событий для УФ 1С 8.2-8.3

Публикация № 169131

Администрирование - Производительность и оптимизация (HighLoad)

Каждый программист 1С хотя бы раз задумывался над тем, как уменьшить в разы трудозатраты на обновления переписанных конфигураций. Как не забыть добавить некий код, команду, кнопку в форму типовой конфигурации, изменить стандартный обработчик события формы – этот список можно продолжать до бесконечности. В этой статье изложен метод для управляемых форм, который позволяет реализовать эту возможность.

Этот метод появился на свет благодаря публикации //infostart.ru/public/16980/ и внедрения конфигурации «Управление торговлей, редакция 11» в не российской торговой компании, из чего следует, что переписано и изменено было очень многое. С выходом каждого нового обновления, для внесения этих изменений, уходило все больше времени и на пике достигало уже до месяца и выливалось в огромные затраты. Так же при выявлении ошибок их нужно было исправлять оперативно и быстро, что со 100-150 одновременно работающими пользователями составляло огромную проблему. 


Предлагаемый метод состоит в том, чтобы в модуле формы в процедуре «ПриСозданииНаСервере» переопределить обработчики событий для этой формы, которые будут вызывать старые обработчики (если это нужно) и выполнить нужный код до и после этого вызова. Так же обеспечить возможность вносить изменения в поведения программы на лету – без отключения от базы пользователей и без использования динамического обновления конфигурации, то есть изменения уже будут готовы к использованию.

Что же для этого нужно? Рассматриваемый пример работает на конфигурации «Управление торговлей, редакция 11», для любой другой конфигурации адаптировать его не составит большого труда.

1. Нужно создать общий модуль МодульПереназначенияОбработчиков, вот такой он у меня: 

// Общая процедура перед переназначения обработчиков
//
// Параметры:
//  УправляемаяФорма – УправляемаяФорма – Управляемая форма.
//

Процедура ПереназначитьОбработчики(УправляемаяФорма) Экспорт
    Если
ТипЗнч(УправляемаяФорма) = Тип("УправляемаяФорма") Тогда
       
ОбщаяВнешняяОбработка = ПолучитьВнешнийОбъект("Библиотека внешних обработок");

       
ВнешняяОбработкаСерийныеНомера = ПолучитьВнешнийОбъект("Серийные номера");
       
ИмяВнешнейОбработкиСерийныеНомера = ПолучитьИмяВнешнегоОбъекта("Серийные номера");
       
ВнешняяОбработкаСерийныеНомера.ПодготовитьСерийныеНомераКРаботе(УправляемаяФорма, ОбщаяВнешняяОбработка, ИмяВнешнейОбработкиСерийныеНомера);

       
ОбщаяВнешняяОбработка.ПодменитьДействиеУправляемоеПриложение(УправляемаяФорма, "ПриЗакрытии", , "ВыполнитьОткатОбработчиков");

       
//Пример как можно изменить свойства управляемой формы
       
УправляемаяФорма.ПоведениеКлавишиEnter = ТипПоведенияКлавишиEnter.ПереходПоЭлементамФормы;
    КонецЕсли;
КонецПроцедуры


// Получаем внешнюю обработку или внешний отчет.
//
// Параметры:
//  ИмяВнешнегоОбъекта – Строка - имя внешнего объекта;
//  ЭтоОтчет – Булево – Ложь (Внешняя обработка), Истина (Внешний отчет).
//
// Возвращаемое значение:
//             – ВнешняяОбработка или ВнешнийОтчет
//

Функция ПолучитьВнешнийОбъект(ИмяВнешнегоОбъекта, ЭтоОтчет = Ложь) Экспорт
   
Ссылка          = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВнешнегоОбъекта);
    Если
Ссылка = Неопределено Тогда
        ВызватьИсключение
"Внешний объект с именем не найден: " + ИмяВнешнегоОбъекта;
    КонецЕсли;
   
ДвоичныеДанные  = Ссылка.ХранилищеОбработки.Получить();
   
АдресХранилища  = ПоместитьВоВременноеХранилище(ДвоичныеДанные);
   
ИмяВнОбработки  = ?(ЭтоОтчет, ВнешниеОтчеты, ВнешниеОбработки).Подключить(АдресХранилища, , Ложь);
   
ОбработкаОбъект = ?(ЭтоОтчет, ВнешниеОтчеты, ВнешниеОбработки).Создать(ИмяВнОбработки);
    Возврат
ОбработкаОбъект;
КонецФункции


// Получаем имя внешней обработки или внешнего отчета.
//
// Параметры:
//  ИмяВнешнегоОбъекта – Строка - имя внешнего объекта;
//  ЭтоОтчет – Булево – Ложь (Внешняя обработка), Истина (Внешний отчет).
//
// Возвращаемое значение:
//             – Строка - Имя внешней обработки или отчета.
//

Функция ПолучитьИмяВнешнегоОбъекта(ИмяВнешнегоОбъекта, ЭтоОтчет = Ложь) Экспорт
   
Ссылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВнешнегоОбъекта);
    Если
Ссылка = Неопределено Тогда
        ВызватьИсключение
"Внешний объект с именем не найден: " + ИмяВнешнегоОбъекта;
    КонецЕсли;
   
ДвоичныеДанные  = Ссылка.ХранилищеОбработки.Получить();
   
АдресХранилища  = ПоместитьВоВременноеХранилище(ДвоичныеДанные);
    Возврат ?(
ЭтоОтчет, ВнешниеОтчеты, ВнешниеОбработки).Подключить(АдресХранилища, , Ложь);
КонецФункции


// Получаем ссылку на элемент справочника ДополнительныеОтчетыИОбработки.
//
// Параметры:
//  ИмяВнешнегоОбъекта – Строка - имя внешнего объекта;
//
//
// Возвращаемое значение:
//             – СправочникСсылка.ДополнительныеОтчетыИОбработки - ссылка на элемент справочника ДополнительныеОтчетыИОбработки.
//

Функция ПолучитьСсылкуНаВнешнийОбъект(ИмяВнешнегоОбъекта) Экспорт
    Возврат
Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВнешнегоОбъекта);
КонецФункции

 

2. Далее, нужно загрузить общую внешнюю обработку в режиме предприятия. Код обработки:

// Функция добавляет элемент в коллекцию элементов формы и возращает его.
//
// Параметры:
//  ЭлементыФормы – ВсеЭлементыФормы – Содержит коллекцию всех элементов управляемой формы;
//  Параметры – Структура – параметры добавляемого элемента;
//  Родитель – ГруппаФормы, ТаблицаФормы, УправляемаяФорма – родитель добавляемого элемента.
//
// Возвращаемое значение:
//             – ДекорацияФормы, ГруппаФормы, КнопкаФормы, ТаблицаФормы, ПолеФормы – элемент управляемой формы.
//

Функция ДобавитьЭлементВКоллекциюЭлементовФормы(ЭлементыФормы, Параметры, Родитель = Неопределено) Экспорт

    Перем
ИмяЭлемента, ТипЭлемента;

    Если НЕ
ТипЗнч(Параметры) = Тип("Структура") Тогда
        ВызватьИсключение
"Параметры элемента формы не заданы!";
    КонецЕсли;

    Если НЕ
Параметры.Свойство("Имя", ИмяЭлемента) Тогда
        ВызватьИсключение
"Имя элемента формы не задано!";
    КонецЕсли;

    Если НЕ
Параметры.Свойство("ТипЭлемента", ТипЭлемента) Тогда
        ВызватьИсключение
"Тип элемента формы не задан!";
    КонецЕсли;

    Если НЕ
Родитель = Неопределено Тогда
        Если
ТипЗнч(Родитель) <> Тип("ГруппаФормы")
         И  
ТипЗнч(Родитель) <> Тип("ТаблицаФормы")
         И  
ТипЗнч(Родитель) <> Тип("УправляемаяФорма") Тогда
            ВызватьИсключение
"Родитель должен иметь один из перечисленных типов: ГруппаФормы; ТаблицаФормы; УправляемаяФорма.";
        КонецЕсли;
    КонецЕсли;

   
ЭлементФормы = ЭлементыФормы.Добавить(ИмяЭлемента, ТипЭлемента, Родитель);
   
ЗаполнитьЗначенияСвойств(ЭлементФормы, Параметры);
    Возврат
ЭлементФормы;

КонецФункции


// Функция добавляет команду в коллекцию команд формы и возращает его.
//
// Параметры:
//  Команды – КомандыФормы – Содержит коллекцию всех элементов управляемой формы;
//  Параметры – Структура – параметры добавляемой команды.
//
// Возвращаемое значение:
//             – КомандаФормы – команда управляемой формы.
//

Функция ДобавитьКомандуВКоллекциюКомандФормы(Команды, Параметры) Экспорт

    Перем
ИмяЭлемента;

    Если НЕ
ТипЗнч(Параметры) = Тип("Структура") Тогда
        ВызватьИсключение
"Параметры команды не заданы!";
    КонецЕсли;

    Если НЕ
Параметры.Свойство("Имя", ИмяЭлемента) Тогда
        ВызватьИсключение
"Имя команды не задано!";
    КонецЕсли;

   
Команда = Команды.Добавить(ИмяЭлемента);
   
ЗаполнитьЗначенияСвойств(Команда, Параметры);
    Возврат
Команда;

КонецФункции

Процедура
ПереместитьЭлементВКоллекциюЭлементовФормы(ЭлементыФормы, ИмяЭлемента, ИмяРодителя, МестоРасположения) Экспорт
   
ЭлементыФормы.Переместить(ЭлементыФормы.Найти(ИмяЭлемента), ЭлементыФормы.Найти(ИмяРодителя), ЭлементыФормы.Найти(МестоРасположения));
КонецПроцедуры


// Переопределяет обработчик события формы.
// Сохраняет штатный обработчик события внутри формы и устанавливает новый.
//
// Параметры:
//  Форма – УправляемаяФорма – Управляемая форма;
//  ИмяСобытияФормы – Строка – имя события;
//  ПолноеИмяЭлементаФормы – Строка – полное имя элемента формы;
//  НовоеДействие - Строка - имя процедуры обработчика;
//  ОбработкаИсключений – Булево – сообщать о наличии старого обработчика.
//

Процедура ПодменитьДействиеУправляемоеПриложение(Форма, ИмяСобытияФормы = "", ПолноеИмяЭлементаФормы = "", НовоеДействие, ОбработкаИсключений = Ложь) Экспорт

   
Объект = Форма;
   
ИмяЭлементаФормы = "";
    Если НЕ
ПустаяСтрока(ПолноеИмяЭлементаФормы) Тогда

       
МассивФрагментов = РазобратьСтрокуВМассивПоРазделителю(ПолноеИмяЭлементаФормы);
       
ИмяЭлементаФормы = МассивФрагментов[0];
       
Объект = Форма.Элементы.Найти(ИмяЭлементаФормы);
        Если
Объект = Неопределено Тогда
            ВызватьИсключение
"Элемент формы: " + ИмяЭлементаФормы + " не найден!";
        КонецЕсли;

        Если
МассивФрагментов.Количество() > 1 Тогда
           
ИмяЭлементаФормы = ИмяЭлементаФормы + МассивФрагментов[1];
            Если
ТипЗнч(Объект) = Тип("ТаблицаФормы") Тогда
               
Объект = Объект.Колонки[МассивФрагментов[1]].ЭлементУправления;
            ИначеЕсли
ТипЗнч(Объект) = Тип("КоманднаяПанель") Тогда
               
Объект = Объект.Кнопки[МассивФрагментов[1]];
            Иначе
                ВызватьИсключение
"Ошибка на этапе получения элемента формы. Тип значения(" + ТипЗнч(Объект) + ")";
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;

   
СтарыеОбработчики = "OldHandlers";
   
МассивРеквизитов = Форма.ПолучитьРеквизиты();
    Для Каждого
РеквизитФормы Из МассивРеквизитов Цикл
        Если
РеквизитФормы.Имя = СтарыеОбработчики Тогда
           
СтарыеОбработчики = Неопределено;
            Прервать;
        КонецЕсли;
    КонецЦикла;

    Если НЕ
СтарыеОбработчики = Неопределено Тогда
       
МассивНовыхРеквизитов = Новый Массив;
       
МассивНовыхРеквизитов.Добавить(Новый РеквизитФормы(СтарыеОбработчики, Новый ОписаниеТипов("СписокЗначений")));
       
Форма.ИзменитьРеквизиты(МассивНовыхРеквизитов);
    КонецЕсли;

    Если
ТипЗнч(Объект) = Тип("КнопкаФормы") Тогда
       
СтароеДействие = Объект.ИмяКоманды;
    Иначе
       
СтароеДействие = Объект.ПолучитьДействие(ИмяСобытияФормы);
    КонецЕсли;

    Если
ОбработкаИсключений И НЕ СтароеДействие = Неопределено Тогда
        ВызватьИсключение
"Конфликт обработчиков события """ + ИмяСобытияФормы + """ объекта """ + Строка(Объект) + """";
    КонецЕсли;

    Если
ТипЗнч(Объект) = Тип("КнопкаФормы") Тогда
       
Объект.ИмяКоманды = НовоеДействие;
    Иначе
       
Объект.УстановитьДействие(ИмяСобытияФормы, НовоеДействие);
    КонецЕсли;

   
OldHandlers = Форма.OldHandlers;
    Если НЕ
СтароеДействие = Неопределено И НЕ ПустаяСтрока(СтароеДействие) Тогда
       
OldHandlers.Добавить(ИмяЭлементаФормы + "." + ИмяСобытияФормы, СтароеДействие);
    КонецЕсли;
КонецПроцедуры


// Возвращает старый обработчик события формы.
//
// Параметры:
//  Форма – УправляемаяФорма – Управляемая форма;
//  ИмяСобытияФормы – Строка – имя события;
//  ПолноеИмяЭлементаФормы – Строка – полное имя элемента формы;
//  СтароеДействие - Строка - имя процедуры обработчика.
//

Процедура ОткатитьДействиеУправляемоеПриложение(ФормаИмяСобытияФормы = "", ПолноеИмяЭлементаФормы = "", СтароеДействие) Экспорт

   
Объект = Форма;
   
ИмяЭлементаФормы = "";
    Если НЕ
ПустаяСтрока(ПолноеИмяЭлементаФормы) Тогда

       
МассивФрагментов = РазобратьСтрокуВМассивПоРазделителю(ПолноеИмяЭлементаФормы);
       
ИмяЭлементаФормы = МассивФрагментов[0];
       
Объект = Форма.Элементы.Найти(ИмяЭлементаФормы);
        Если
Объект = Неопределено Тогда
            ВызватьИсключение
"Элемент формы: " + ИмяЭлементаФормы + " не найден!";
        КонецЕсли;

        Если
МассивФрагментов.Количество() > 1 Тогда
           
ИмяЭлементаФормы = ИмяЭлементаФормы + МассивФрагментов[1];
            Если
ТипЗнч(Объект) = Тип("ТаблицаФормы") Тогда
               
Объект = Объект.Колонки[МассивФрагментов[1]].ЭлементУправления;
            ИначеЕсли
ТипЗнч(Объект) = Тип("КоманднаяПанель") Тогда
               
Объект = Объект.Кнопки[МассивФрагментов[1]];
            Иначе
                ВызватьИсключение
"Ошибка на этапе получения элемента формы. Тип значения(" + ТипЗнч(Объект) + ")";
            КонецЕсли;
        КонецЕсли;

    КонецЕсли;

    Если
ТипЗнч(Объект) = Тип("КнопкаФормы") Тогда
       
Объект.ИмяКоманды = СтароеДействие;
    Иначе
       
Объект.УстановитьДействие(ИмяСобытияФормы, СтароеДействие);
    КонецЕсли;
КонецПроцедуры


// Возвращает старые обработчики событий формы.
// Сохраняет штатный обработчик события внутри формы и устанавливает новый.
//
// Параметры:
//  Форма – УправляемаяФорма – Управляемая форма.
//

Процедура ВыполнитьОткатОбработчиков(Форма) Экспорт
    Для Каждого
Обработчик Из Форма.OldHandlers Цикл
       
Строка      = Обработчик.Значение;
       
ИндексТочки = Найти(Строка, ".");
       
ОткатитьДействиеУправляемоеПриложение(Форма, Прав(Строка, СтрДлина(Строка)-ИндексТочки), Лев(Строка, ИндексТочки-1), Обработчик.Представление);
    КонецЦикла;
КонецПроцедуры


// Функция разбивает строку разделителем.
//
// Параметры:
//  Строка - Строка - которую разбиваем;
//  Разделитель - Строка - символ-разделитель.
//
// Возвращаемое значение:
//             - Массив - содержащий фрагменты, на которые разбивает строку разделитель.
//

Функция РазобратьСтрокуВМассивПоРазделителю(Строка, Разделитель = ".") Экспорт
   
МассивСтрок = Новый Массив;
   
СтрокаЗамены = СтрЗаменить(Строка, Разделитель, Символы.ПС);
    Для
i=1 По СтрЧислоСтрок(СтрокаЗамены) Цикл МассивСтрок.Добавить(СтрПолучитьСтроку(СтрокаЗамены, i)); КонецЦикла;
    Возврат
МассивСтрок;
КонецФункции

 

На данном этапе, все уже готово для использования. Вот видео-пример использования механизма.

Статья в нашем блоге: www.avtomat.biz


UPDATE (24.03.2014): 
Изменена схема работы метода, проведена оптимизация и исправлены некоторые недочеты. Все это можно посмотреть в новом архиве к статье. Так же сама статья расширена.

 

ОТВЕТЫ НА ВОПРОСЫ:

  1. Для каких конфигураций подходит данный модуль?  механизм предназначен для работы с 1С Предприятие 8.2-8.3, основной режим запуска: "Управляемое приложение", так же конфигурация должна использовать "Библиотеку стандартных подсистем" (БСП), в противном случае нужно будет создать справочник "ДополнительныеОтчетыИОбработки" аналогичный как в БСП;
  2. Какие изменения нужно внести в конфигурацию?  нужно добавить в конфигурацию несколько общих модулей, а так же внести изменения в необходимую управляемую форму (УФ) в конце модуля и для подмены событий этой формы в обработчики ПриСозданииНаСервере() или ПриЧтенииНаСервере(). Реквизиты и табличные части документов можно добавлять, если вам нужно хранить учетные данные;
  3. Как влияет на "быстродействие" использование внешних обработок?  когда используется одна внешняя обработка ничего не заметно для конечного пользователя, когда парк обработок увеличивается скорость запуска формы увеличивается в среднем на ~0.3с с каждой новой обработкой. Не надо паниковать  проблема уже решена;
  4. Как можно вызвать старый обработчик события?  вызвать процедуру ВыполнитьДействиеПоУмолчанию() в которую передать имя события и массив параметров;
  5. Как методика упрощает обновление конфигурации?  после обновления достаточно перенести обработчики переопределения в обновленную конфигурацию и даже если появились новые штатные обработчики событий они будут работать верно в повальном количестве случаев. Управляемые формы не нужно изменять вручную - это все можно сделать с помощью этой методики програмно;
  6. Методика увеличивает время разработки?  да увеличивает время разработки. Если уже несколько форм переделано этим методом – тогда затраты времени ростут незначительно, а затраты на обновление конфигурации уменьшается очень существенно;
  7. Есть критическая ошибка, но пользователей нельзя отключать от базы, что делать? - достаточно внести измения во внешную обработку, изменить ее версию и подключить к базе. После этого, пользователи автоматически уже будут использовать исправленную версию обработки. А ночью обновить общий модуль, который связан с внешней обработкой для более комфортного использования конфигурации.

 

КЛЮЧЕВЫЕ ИЗМЕНЕНИЯ:

  1. У всех общих модулей снято свойство "Вызов сервера", теперь вызов из модуля формы выполняется вот так: &НаКлиенте -> &НаСервере -> ОбщийМодульСервер;
  2. Для сокращения запуска и вызова внешних обработчиков событий, код доработок дублируется в общих модулях. При запуске проверяется версия общего модуля с версией внешней обработки из справочника "ДополнительныеОтчетыИОбработки". Если версии совпадают УФ будет работать с контекстом общего модуля, если версии отличаются вызов процедур и функций будет осуществляется из внешнего объекта;
  3. Переработана работа с контекстом &НаКлиенте  код из форм внешнего объекта дублируется в общем клиентском модуле;
  4. Сам метод переопределения обработчиков событий оформлен так же как внешняя обработка, что добавляет некоторую дополнительную гибкость;
  5. Проверка на дополнительный вызов переназначения обработчиков. 

 

ТАК КАК ЖЕ ЭТО РАБОТАЕТ:

  1. Пользователь открывает документ происходит вызов ПриСозданииНаСервере() или ПриЧтенииНаСервере(). В одну или в обе процедуры мы добавляем наш вызов git_ПереопределениеОбработчиковСервер.ПереопределитьОбработчикиСобытий(ЭтаФорма). Как понять куда добавлять?  нужно посмотреть есть ли переопределение обработчиков в стандартной конфигурации (в УТ 11 оно есть), и добавить перед этим переопределением свой вызов;
  2. Далее идет переход в общий модуль "git_ПереопределениеОбработчиковСервер" в котором определяется первый ли это вызов (на случай, если добавили обработчики в ПриСозданииНаСервере() или ПриЧтенииНаСервере());
  3. Идет проверка версии модуля с версией внешней обработки, если версии одинаковые будет использоваться общий модуль git_ПереопределениеОбработчиковСервер, если версии различные будет использоваться внешняя обработка;
  4. Далее идет такая же проверка для каждой подключаемой внешней обработки (код можно посмотреть в файле .cf) и внутри каждой подключаемой обработки или общего модуля проверяется путь к механизму переопределения для вызова функций и процедур (общий модуль переопределения или модуль внешней обработки, служебные процедуры и функции обозначены комментарием // Только для внутреннего использования); 
  5. Ура! Форма пользовательского документа открылась, теперь так же необходимые функции запускаются из общего модуля (клиент, сервер) или из модуля\формы внешней обработки;
  6. Вызов обработчиков по умолчанию исполняеться с помощь вызова процедуры ВыполнитьДействиеПоУмолчанию();
  7. После закрытия формы все обработчики будут восстанавливаться для избежания проблем с кешированием форм.

Статья в нашем блоге (часть 2): www.avtomat.biz

Скачать файлы

Наименование Файл Версия Размер
cf+epf

.7z 36,30Kb
24.03.14
116
.7z 36,30Kb 116 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Поручик 4406 10.02.13 15:43 Сейчас в теме
Пока не пробовал, но работа хорошая. Жалко, что в управляемых формах нет секции инициализации или операторов основной программы. Тогда не пришлось бы вторгаться в штатную процедуру ПриСозданииНаСервере.
RomanRomans; +1 Ответить
2. MarSeN 975 10.02.13 23:42 Сейчас в теме
Доброе время суток.
Спасибо автору за статью - обязательно скачаю и попробую. Интересный подход в котором надо разобраться.
Плюс в копилку.
Как вариант решения описанной задачи 2 статьи:
http://infostart.ru/public/171514/?fruser=yes#users_raters
http://infostart.ru/public/170935/
Судя по описанию Ваш подход к переопределению обработчиков не требует вставки кода в модуль формы, надо посмотреть как реализовано. Я считал что процедура обработки должна находиться в контексте формы.
Буду признателен, если Вы в 2-х словах опишите механизм
3. pbazeliuk 10.02.13 23:51 Сейчас в теме
(2) MarSeN, Добрый вечер, модуль формы требует изменения в процедуре "ПриСозданииНаСервере" и вставки ваших функций в конец модуля формы. Когда появиться возможность подписки на события формы, этих действий уже не потребуется.

Основной упор делается на то, что изменения в свои обработчики можно вносить без обновления конфигурации - просто обновляя внешнюю обработку, а так же сходство с подходом для 8.1, который описал в свое время tormozit. В видео это продемонстрировано.
4. MarSeN 975 10.02.13 23:55 Сейчас в теме
(3) Baza
Спасибо, получается что в принципе подходы у нас одинаковые ). Хранение кода в разных местах. Потребность диктует решения.
6. plevakin 11.02.13 15:01 Сейчас в теме
(3) Когда появиться возможность подписки на события формы

А когда эта возможность появится?
8. pbazeliuk 11.02.13 16:02 Сейчас в теме
5. alekseies 11.02.13 10:06 Сейчас в теме
Также жалко, что в управляемых формах нет секции инициализации или операторов основной программы. Тогда не пришлось бы вторгаться в штатную процедуру ПриСозданииНаСервере. Так же считаю что процедура обработки должна находиться в контексте формы, легче отслеживать изменения конфигурации ......
RomanRomans; +1 Ответить
7. akomar 437 11.02.13 15:06 Сейчас в теме
(5) Зато очень легко вносить изменения в обоработку, на лету, без отключения пользователей от базы, что критично при большом количестве пользователей.
9. tormozit 5821 12.02.13 10:35 Сейчас в теме
Было бы неплохо указать ссылку и на основу, опубликованную на инфостарте http://infostart.ru/public/16980/ .
10. pbazeliuk 12.02.13 22:38 Сейчас в теме
15. TODD22 19 18.02.13 09:17 Сейчас в теме
(9) Не открывается. Пишет что публикация не активна.
11. Азбука Морзе 85 13.02.13 13:22 Сейчас в теме
Отличная работа. Обязательно приму на вооружение.

п.с. В прошлой жизни так припекло с обновлением переделанной УТ11, что пришлось застрелится:)
12. fr.myha 14.02.13 17:16 Сейчас в теме
13. alekseies 15.02.13 10:54 Сейчас в теме
изменения можно вносить и в модуль формы, и также без отключения пользователей от базы, динамическое обновление, только изменения вносить программно .....
14. pbazeliuk 15.02.13 13:12 Сейчас в теме
(13) alekseies, динамическое обновление в высоконагруженной базе в часто приводит к крашу базы, сама 1С не рекомендует его применять и еще что бы пользователь мог использовать обновления ему нужно перезапустить базу (для каждого сеанса конфигурация кешируеться). В данном методе все безопасно и перезагружать пользователю базу не нужно.
16. ivanov660 2137 16.03.13 09:33 Сейчас в теме
Статья заинтересовала. Буду смотреть, надеюсь это поможет в нашей ситуации.
17. ivanov660 2137 07.05.13 15:56 Сейчас в теме
Посмотрел, кое что понравилось и буду использовать что-то.
Вопрос: А как влияет на "быстродействие" использование внешних обработок? Я бы, к примеру, создал "Библиотека внешних обработок" как внутреннюю обработку.
18. pbazeliuk 10.05.13 09:38 Сейчас в теме
(17) ivanov660, на быстродействие никак особо не влияет.
19. pbazeliuk 19.03.14 15:14 Сейчас в теме
(17) ivanov660, с ростом числа подключенных обработок начало влиять. К понедельнику выкачу новую статью с оптимизацией данного метода.
22. pbazeliuk 23.03.14 03:13 Сейчас в теме
(17) ivanov660, (20) zakov, вот часть 2 - avtomat.biz
zakov; teflon; +2 Ответить
20. zakov 20.03.14 13:27 Сейчас в теме
Спасибо за статью, метод классный. Не пойму только как можно вызвать старый обработчик?
21. pbazeliuk 20.03.14 23:04 Сейчас в теме
(20) zakov, к понедельнику в продолжении статьи все опишу.
23. Andry.Boris 55 25.03.14 00:19 Сейчас в теме
Спасибо за статью,
очень интересная реализация...
24. amon_ra 3 25.03.14 14:25 Сейчас в теме
Отлично. Пожалуй возьму себе на заметку. Огромное спасибо!
25. higs 26.03.14 21:28 Сейчас в теме
Присоединяюсь, интересный подход. И достаточно универсален. Спасибо!!
26. Alex_Japanese_Student 441 30.03.14 07:11 Сейчас в теме
Плюсую, сильная разработка, очень поможет
27. 0vrcr 52 03.03.15 14:37 Сейчас в теме
А не появилось варианта назначения нового обработчика на динамически созданный элемент? И чтобы сам обработчик был в глобальном модуле?

Например, создаем РегистрСведенийНаборЗаписей динамически на форме. Подключаем обработчик ПриИзменении. И чтобы этот обработчик хранился в общем модуле?
28. pbazeliuk 1749 03.03.15 17:45 Сейчас в теме
(27) 0vrcr, появилось что-то похожее, но все равно нужно добавить в форму процедуру\функцию перенаправления на общие модуля\внешние модуля
29. 0vrcr 52 05.03.15 17:49 Сейчас в теме
Ясно. Ну этот метод я знаю, сам использую. Жаль, спасибо! :)
30. CheBurator 3421 05.03.15 19:20 Сейчас в теме
Было бы интересно почитать весьма про "внедрения конфигурации «Управление торговлей, редакция 11» в не российской торговой компании, из чего следует, что переписано и изменено было очень многое." - такие проекты не частые гости...
31. pbazeliuk 1749 06.03.15 03:59 Сейчас в теме
(30) CheBurator, возможно, когда-то. На самом деле реализовано много, что-то более 7000 задач только на разработку, 3000 обращений на поддержку каждый месяц. А конца так и не видно...
32. pbazeliuk 1749 06.03.15 04:04 Сейчас в теме
(30) CheBurator, самое, наверное, интересное - партионная себестоимость, которая полностью за месяц пересчитывается за 1-3 минуты, без перепроведения документов и использования последовательностей.
33. mikhailv 19 02.04.15 14:32 Сейчас в теме
Видео из статьи не воспроизводится: ролик не найден. Почините, пожалуйста.
34. pbazeliuk 1749 03.04.15 09:43 Сейчас в теме
(33) mikhailv, добрый день, к сожалению, видео безвозвратно утеряно. Постараюсь на выходных обновить статью и снять новое видео.
35. Cyberhawk 118 30.05.16 18:23 Сейчас в теме
Я правильно понимаю, что нет возможности размещать ЭУ (элементы управления - например, поле формы) в произвольном месте родителя (группы формы)?
Т.е. программно добавляемые ЭУ всегда размещаются в конце (справа или снизу).

//
Отбой, нашел метод Вставить() вместо Добавить()
36. pbazeliuk 1749 31.05.16 09:46 Сейчас в теме
(35) Cyberhawk, используйте процедуру ПереместитьЭлементВКоллекциюЭлементовФорм, если нужно изменить место расположения.
37. UNIT68RUS 08.05.19 09:29 Сейчас в теме
Коллеги не пойму по поводу обработки? Можно скрин обработки?
38. pbazeliuk 1749 08.05.19 11:52 Сейчас в теме
(37) Статья довольно старая, у вас уже есть возможность использовать "Расширения конфигураций". Мы уже понемногу отказываемся от указанного метода и переносим код в расширения, но в 2012 году без него было очень сложно.
39. tormozit 5821 08.05.19 11:57 Сейчас в теме
40. pbazeliuk 1749 08.05.19 12:02 Сейчас в теме
(39) Согласен. Обычные формы еще лет 10 проживут; смотрю на то как мы все переносим в расширения - этот процес займет еще лет 5 (не приоритет, бизнес на этом денег больше не заработает).
Оставьте свое сообщение

См. также

Еще один тест 1C: Postgres SQL 11 Pro Enterpise против MSSQL 14 под Windows 2012 Server R2 Промо

Производительность и оптимизация (HighLoad) v8 Абонемент ($m)

Проработав 15 лет с MSSQL в 2017 начал активно СУБД Postgres SQL. За два года успел поработать в 9 версии Postgres и в 10-ой. И пришел к выводу, что существуют реальное замедление работы баз после перехода на Postgres. Недавно вышла 11 версия Postgres Pro Enterpise, которая обещает почти 2-х кратное ускорение над 11 Pro Standart и 10-ой версией. Закупив лицензию Postgres 11 Pro Enterpise Это я и решил проверить на 1С.

1 стартмани

05.09.2019    13012    39    Indgo    106    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    14191    17    sapervodichka    41    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    26372    14    HostHost    40    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    16923    11    Dementor    30    

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    29997    10    tormozit    44    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    20688    21    Stepa86    44    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    31389    13    vasilev2015    57    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    26109    76    Evil Beaver    119    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    17167    4    m-rv    86    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    26526    19    Hatson    22    

Баг или фича? Неожиданное поведение платформы

Практика программирования Тестирование и исправление Разработка v8 1cv8.cf Абонемент ($m)

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    21377    0    YPermitin    89    

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Универсальные обработки Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    26524    90    Synoecium    46    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    27491    86    m-rv    57    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    18724    12    RocKeR_13    16    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    25292    25    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    39023    17    kalyaka    16    

Многопоточная обработка данных Промо

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    18181    53    _ASZ_    15    

HTTP Сервисы: Путь к своему сервису. Часть 1

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    73205    23    dsdred    24    

Жизненный цикл управляемой формы. Шпаргалка разработчика

Практика программирования Математика и алгоритмы v8::УФ 1cv8.cf Абонемент ($m)

Прочитав когда-то давно книжку "Разработка управляемых форм", составил для себя такую схемку-напоминалку для обращения в процессе разработки. С тех пор не раз выручала и избавляла от необходимости лезть в гуглы.

1 стартмани

29.06.2018    28863    52    stas_ganiev    26    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    27260    11    SITR-utyos    13    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    25331    19    mvxyz    17    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    40875    33    dsdred    36    

Как выполнить отчет на СКД через COM и получить данные отчета?

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    25584    8    wowik    3    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    40800    85    kalyaka    34    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    24961    66    vasvl123    9    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    33016    54    rpgshnik    48    

Программное создание динамического списка на управляемой форме. (Динамическое создание динамического списка). Готовая процедура + обработка - демонстрационный пример

Практика программирования Универсальные функции v8::УФ 1cv8.cf Абонемент ($m)

Если у вас возникает необходимость на форму влиять динамически и создавать элементы управляемой формы программно, а особенно хотите вывести программно (динамически) динамический список, вам будет интересна эта процедура. Процедура включает также возможность формирования своей командной панели (а-ля снятие галочки "Автозаполнение" у стандартной командной панели списка).

1 стартмани

19.01.2018    53309    60    rpgshnik    27    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    36348    27    agent00mouse    0    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    44604    36    Demanoidos    60    

Практика доступа в базу 1С через протокол oData. Чтение данных

Сервисные утилиты Практика программирования Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    86897    299    Dementor    47    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24741    49    kwazi    6    

Простой бесплатный DashBoard с помощью http сервиса

Практика программирования v8 Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    51668    63    dewersia    32    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    68676    206    ildarovich    117    

Макеты СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    90465    122    json    27    

Интеграция сценарного тестирования в процесс разработки

Практика программирования Инструментарий разработчика v8::УФ Абонемент ($m)

Эта статья является практическим пособием по внедрению тестирования на основе сценариев в процесс разработки программного обеспечения на базе платформы 1С:Предприятие 8.3. Документ отличает прикладная направленность, в нем содержится много кода, подходов и конкретики. Все рассмотренные примеры основаны на использовании бесплатной конфигурации Тестер

1 стартмани

04.07.2017    29145    24    grumagargler    30    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    115776    13    signum2009    46    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    47213    15    DarkAn    86    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    28500    111    romasna    49    

Разбираемся с механизмом Дополнительные отчеты и обработки в БСП

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Чуть более комплексное описание, чем на других ресурсах

1 стартмани

30.10.2016    139780    947    json    66    

Настройка PostgreSQL для работы в связке с 1С 8.х на платформе Windows Server 2012, объём БД более 200 Гб

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 Россия Абонемент ($m)

Настройка бесплатной СУБД PostgreSQL для работы в связке с 1С 8.х на платформе Windows Server 2012 х64. Объём БД более 380 Гб для мощного сервака. Конфигурация КА 1.1.108.2, 50 пользователей. Более 1 млн. проводок при закрытии месяца. Время закрытия месяца сравнимо с MSSQL и составляет в среднем 2 часа. Время отмены закрытия месяца - всего 10 минут! Ликвидированы зависания PostgreSQL. Всё за счет настроек файла postgesql.conf.

1 стартмани

11.10.2016    76627    64    vsasav    46    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    34090    95    json    25    

Простой способ индексирования интервалов

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    38043    38    ildarovich    22