Методика упрощения поддержки конфигураций. Переопределение и вызов обработчиков событий для УФ 1С 8.2-8.3

Публикация № 169131

Администрирование - Производительность и оптимизация (HighLoad)

Каждый программист 1С хотя бы раз задумывался над тем, как уменьшить в разы трудозатраты на обновления переписанных конфигураций. Как не забыть добавить некий код, команду, кнопку в форму типовой конфигурации, изменить стандартный обработчик события формы – этот список можно продолжать до бесконечности. В этой статье изложен метод для управляемых форм, который позволяет реализовать эту возможность.

Этот метод появился на свет благодаря публикации //infostart.ru/public/16980/ и внедрения конфигурации «Управление торговлей, редакция 11» в не российской торговой компании, из чего следует, что переписано и изменено было очень многое. С выходом каждого нового обновления, для внесения этих изменений, уходило все больше времени и на пике достигало уже до месяца и выливалось в огромные затраты. Так же при выявлении ошибок их нужно было исправлять оперативно и быстро, что со 100-150 одновременно работающими пользователями составляло огромную проблему. 


Предлагаемый метод состоит в том, чтобы в модуле формы в процедуре «ПриСозданииНаСервере» переопределить обработчики событий для этой формы, которые будут вызывать старые обработчики (если это нужно) и выполнить нужный код до и после этого вызова. Так же обеспечить возможность вносить изменения в поведения программы на лету – без отключения от базы пользователей и без использования динамического обновления конфигурации, то есть изменения уже будут готовы к использованию.

Что же для этого нужно? Рассматриваемый пример работает на конфигурации «Управление торговлей, редакция 11», для любой другой конфигурации адаптировать его не составит большого труда.

1. Нужно создать общий модуль МодульПереназначенияОбработчиков, вот такой он у меня: 

// Общая процедура перед переназначения обработчиков
//
// Параметры:
//  УправляемаяФорма – УправляемаяФорма – Управляемая форма.
//

Процедура ПереназначитьОбработчики(УправляемаяФорма) Экспорт
    Если
ТипЗнч(УправляемаяФорма) = Тип("УправляемаяФорма") Тогда
       
ОбщаяВнешняяОбработка = ПолучитьВнешнийОбъект("Библиотека внешних обработок");

       
ВнешняяОбработкаСерийныеНомера = ПолучитьВнешнийОбъект("Серийные номера");
       
ИмяВнешнейОбработкиСерийныеНомера = ПолучитьИмяВнешнегоОбъекта("Серийные номера");
       
ВнешняяОбработкаСерийныеНомера.ПодготовитьСерийныеНомераКРаботе(УправляемаяФорма, ОбщаяВнешняяОбработка, ИмяВнешнейОбработкиСерийныеНомера);

       
ОбщаяВнешняяОбработка.ПодменитьДействиеУправляемоеПриложение(УправляемаяФорма, "ПриЗакрытии", , "ВыполнитьОткатОбработчиков");

       
//Пример как можно изменить свойства управляемой формы
       
УправляемаяФорма.ПоведениеКлавишиEnter = ТипПоведенияКлавишиEnter.ПереходПоЭлементамФормы;
    КонецЕсли;
КонецПроцедуры


// Получаем внешнюю обработку или внешний отчет.
//
// Параметры:
//  ИмяВнешнегоОбъекта – Строка - имя внешнего объекта;
//  ЭтоОтчет – Булево – Ложь (Внешняя обработка), Истина (Внешний отчет).
//
// Возвращаемое значение:
//             – ВнешняяОбработка или ВнешнийОтчет
//

Функция ПолучитьВнешнийОбъект(ИмяВнешнегоОбъекта, ЭтоОтчет = Ложь) Экспорт
   
Ссылка          = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВнешнегоОбъекта);
    Если
Ссылка = Неопределено Тогда
        ВызватьИсключение
"Внешний объект с именем не найден: " + ИмяВнешнегоОбъекта;
    КонецЕсли;
   
ДвоичныеДанные  = Ссылка.ХранилищеОбработки.Получить();
   
АдресХранилища  = ПоместитьВоВременноеХранилище(ДвоичныеДанные);
   
ИмяВнОбработки  = ?(ЭтоОтчет, ВнешниеОтчеты, ВнешниеОбработки).Подключить(АдресХранилища, , Ложь);
   
ОбработкаОбъект = ?(ЭтоОтчет, ВнешниеОтчеты, ВнешниеОбработки).Создать(ИмяВнОбработки);
    Возврат
ОбработкаОбъект;
КонецФункции


// Получаем имя внешней обработки или внешнего отчета.
//
// Параметры:
//  ИмяВнешнегоОбъекта – Строка - имя внешнего объекта;
//  ЭтоОтчет – Булево – Ложь (Внешняя обработка), Истина (Внешний отчет).
//
// Возвращаемое значение:
//             – Строка - Имя внешней обработки или отчета.
//

Функция ПолучитьИмяВнешнегоОбъекта(ИмяВнешнегоОбъекта, ЭтоОтчет = Ложь) Экспорт
   
Ссылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВнешнегоОбъекта);
    Если
Ссылка = Неопределено Тогда
        ВызватьИсключение
"Внешний объект с именем не найден: " + ИмяВнешнегоОбъекта;
    КонецЕсли;
   
ДвоичныеДанные  = Ссылка.ХранилищеОбработки.Получить();
   
АдресХранилища  = ПоместитьВоВременноеХранилище(ДвоичныеДанные);
    Возврат ?(
ЭтоОтчет, ВнешниеОтчеты, ВнешниеОбработки).Подключить(АдресХранилища, , Ложь);
КонецФункции


// Получаем ссылку на элемент справочника ДополнительныеОтчетыИОбработки.
//
// Параметры:
//  ИмяВнешнегоОбъекта – Строка - имя внешнего объекта;
//
//
// Возвращаемое значение:
//             – СправочникСсылка.ДополнительныеОтчетыИОбработки - ссылка на элемент справочника ДополнительныеОтчетыИОбработки.
//

Функция ПолучитьСсылкуНаВнешнийОбъект(ИмяВнешнегоОбъекта) Экспорт
    Возврат
Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВнешнегоОбъекта);
КонецФункции

 

2. Далее, нужно загрузить общую внешнюю обработку в режиме предприятия. Код обработки:

// Функция добавляет элемент в коллекцию элементов формы и возращает его.
//
// Параметры:
//  ЭлементыФормы – ВсеЭлементыФормы – Содержит коллекцию всех элементов управляемой формы;
//  Параметры – Структура – параметры добавляемого элемента;
//  Родитель – ГруппаФормы, ТаблицаФормы, УправляемаяФорма – родитель добавляемого элемента.
//
// Возвращаемое значение:
//             – ДекорацияФормы, ГруппаФормы, КнопкаФормы, ТаблицаФормы, ПолеФормы – элемент управляемой формы.
//

Функция ДобавитьЭлементВКоллекциюЭлементовФормы(ЭлементыФормы, Параметры, Родитель = Неопределено) Экспорт

    Перем
ИмяЭлемента, ТипЭлемента;

    Если НЕ
ТипЗнч(Параметры) = Тип("Структура") Тогда
        ВызватьИсключение
"Параметры элемента формы не заданы!";
    КонецЕсли;

    Если НЕ
Параметры.Свойство("Имя", ИмяЭлемента) Тогда
        ВызватьИсключение
"Имя элемента формы не задано!";
    КонецЕсли;

    Если НЕ
Параметры.Свойство("ТипЭлемента", ТипЭлемента) Тогда
        ВызватьИсключение
"Тип элемента формы не задан!";
    КонецЕсли;

    Если НЕ
Родитель = Неопределено Тогда
        Если
ТипЗнч(Родитель) <> Тип("ГруппаФормы")
         И  
ТипЗнч(Родитель) <> Тип("ТаблицаФормы")
         И  
ТипЗнч(Родитель) <> Тип("УправляемаяФорма") Тогда
            ВызватьИсключение
"Родитель должен иметь один из перечисленных типов: ГруппаФормы; ТаблицаФормы; УправляемаяФорма.";
        КонецЕсли;
    КонецЕсли;

   
ЭлементФормы = ЭлементыФормы.Добавить(ИмяЭлемента, ТипЭлемента, Родитель);
   
ЗаполнитьЗначенияСвойств(ЭлементФормы, Параметры);
    Возврат
ЭлементФормы;

КонецФункции


// Функция добавляет команду в коллекцию команд формы и возращает его.
//
// Параметры:
//  Команды – КомандыФормы – Содержит коллекцию всех элементов управляемой формы;
//  Параметры – Структура – параметры добавляемой команды.
//
// Возвращаемое значение:
//             – КомандаФормы – команда управляемой формы.
//

Функция ДобавитьКомандуВКоллекциюКомандФормы(Команды, Параметры) Экспорт

    Перем
ИмяЭлемента;

    Если НЕ
ТипЗнч(Параметры) = Тип("Структура") Тогда
        ВызватьИсключение
"Параметры команды не заданы!";
    КонецЕсли;

    Если НЕ
Параметры.Свойство("Имя", ИмяЭлемента) Тогда
        ВызватьИсключение
"Имя команды не задано!";
    КонецЕсли;

   
Команда = Команды.Добавить(ИмяЭлемента);
   
ЗаполнитьЗначенияСвойств(Команда, Параметры);
    Возврат
Команда;

КонецФункции

Процедура
ПереместитьЭлементВКоллекциюЭлементовФормы(ЭлементыФормы, ИмяЭлемента, ИмяРодителя, МестоРасположения) Экспорт
   
ЭлементыФормы.Переместить(ЭлементыФормы.Найти(ИмяЭлемента), ЭлементыФормы.Найти(ИмяРодителя), ЭлементыФормы.Найти(МестоРасположения));
КонецПроцедуры


// Переопределяет обработчик события формы.
// Сохраняет штатный обработчик события внутри формы и устанавливает новый.
//
// Параметры:
//  Форма – УправляемаяФорма – Управляемая форма;
//  ИмяСобытияФормы – Строка – имя события;
//  ПолноеИмяЭлементаФормы – Строка – полное имя элемента формы;
//  НовоеДействие - Строка - имя процедуры обработчика;
//  ОбработкаИсключений – Булево – сообщать о наличии старого обработчика.
//

Процедура ПодменитьДействиеУправляемоеПриложение(Форма, ИмяСобытияФормы = "", ПолноеИмяЭлементаФормы = "", НовоеДействие, ОбработкаИсключений = Ложь) Экспорт

   
Объект = Форма;
   
ИмяЭлементаФормы = "";
    Если НЕ
ПустаяСтрока(ПолноеИмяЭлементаФормы) Тогда

       
МассивФрагментов = РазобратьСтрокуВМассивПоРазделителю(ПолноеИмяЭлементаФормы);
       
ИмяЭлементаФормы = МассивФрагментов[0];
       
Объект = Форма.Элементы.Найти(ИмяЭлементаФормы);
        Если
Объект = Неопределено Тогда
            ВызватьИсключение
"Элемент формы: " + ИмяЭлементаФормы + " не найден!";
        КонецЕсли;

        Если
МассивФрагментов.Количество() > 1 Тогда
           
ИмяЭлементаФормы = ИмяЭлементаФормы + МассивФрагментов[1];
            Если
ТипЗнч(Объект) = Тип("ТаблицаФормы") Тогда
               
Объект = Объект.Колонки[МассивФрагментов[1]].ЭлементУправления;
            ИначеЕсли
ТипЗнч(Объект) = Тип("КоманднаяПанель") Тогда
               
Объект = Объект.Кнопки[МассивФрагментов[1]];
            Иначе
                ВызватьИсключение
"Ошибка на этапе получения элемента формы. Тип значения(" + ТипЗнч(Объект) + ")";
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;

   
СтарыеОбработчики = "OldHandlers";
   
МассивРеквизитов = Форма.ПолучитьРеквизиты();
    Для Каждого
РеквизитФормы Из МассивРеквизитов Цикл
        Если
РеквизитФормы.Имя = СтарыеОбработчики Тогда
           
СтарыеОбработчики = Неопределено;
            Прервать;
        КонецЕсли;
    КонецЦикла;

    Если НЕ
СтарыеОбработчики = Неопределено Тогда
       
МассивНовыхРеквизитов = Новый Массив;
       
МассивНовыхРеквизитов.Добавить(Новый РеквизитФормы(СтарыеОбработчики, Новый ОписаниеТипов("СписокЗначений")));
       
Форма.ИзменитьРеквизиты(МассивНовыхРеквизитов);
    КонецЕсли;

    Если
ТипЗнч(Объект) = Тип("КнопкаФормы") Тогда
       
СтароеДействие = Объект.ИмяКоманды;
    Иначе
       
СтароеДействие = Объект.ПолучитьДействие(ИмяСобытияФормы);
    КонецЕсли;

    Если
ОбработкаИсключений И НЕ СтароеДействие = Неопределено Тогда
        ВызватьИсключение
"Конфликт обработчиков события """ + ИмяСобытияФормы + """ объекта """ + Строка(Объект) + """";
    КонецЕсли;

    Если
ТипЗнч(Объект) = Тип("КнопкаФормы") Тогда
       
Объект.ИмяКоманды = НовоеДействие;
    Иначе
       
Объект.УстановитьДействие(ИмяСобытияФормы, НовоеДействие);
    КонецЕсли;

   
OldHandlers = Форма.OldHandlers;
    Если НЕ
СтароеДействие = Неопределено И НЕ ПустаяСтрока(СтароеДействие) Тогда
       
OldHandlers.Добавить(ИмяЭлементаФормы + "." + ИмяСобытияФормы, СтароеДействие);
    КонецЕсли;
КонецПроцедуры


// Возвращает старый обработчик события формы.
//
// Параметры:
//  Форма – УправляемаяФорма – Управляемая форма;
//  ИмяСобытияФормы – Строка – имя события;
//  ПолноеИмяЭлементаФормы – Строка – полное имя элемента формы;
//  СтароеДействие - Строка - имя процедуры обработчика.
//

Процедура ОткатитьДействиеУправляемоеПриложение(ФормаИмяСобытияФормы = "", ПолноеИмяЭлементаФормы = "", СтароеДействие) Экспорт

   
Объект = Форма;
   
ИмяЭлементаФормы = "";
    Если НЕ
ПустаяСтрока(ПолноеИмяЭлементаФормы) Тогда

       
МассивФрагментов = РазобратьСтрокуВМассивПоРазделителю(ПолноеИмяЭлементаФормы);
       
ИмяЭлементаФормы = МассивФрагментов[0];
       
Объект = Форма.Элементы.Найти(ИмяЭлементаФормы);
        Если
Объект = Неопределено Тогда
            ВызватьИсключение
"Элемент формы: " + ИмяЭлементаФормы + " не найден!";
        КонецЕсли;

        Если
МассивФрагментов.Количество() > 1 Тогда
           
ИмяЭлементаФормы = ИмяЭлементаФормы + МассивФрагментов[1];
            Если
ТипЗнч(Объект) = Тип("ТаблицаФормы") Тогда
               
Объект = Объект.Колонки[МассивФрагментов[1]].ЭлементУправления;
            ИначеЕсли
ТипЗнч(Объект) = Тип("КоманднаяПанель") Тогда
               
Объект = Объект.Кнопки[МассивФрагментов[1]];
            Иначе
                ВызватьИсключение
"Ошибка на этапе получения элемента формы. Тип значения(" + ТипЗнч(Объект) + ")";
            КонецЕсли;
        КонецЕсли;

    КонецЕсли;

    Если
ТипЗнч(Объект) = Тип("КнопкаФормы") Тогда
       
Объект.ИмяКоманды = СтароеДействие;
    Иначе
       
Объект.УстановитьДействие(ИмяСобытияФормы, СтароеДействие);
    КонецЕсли;
КонецПроцедуры


// Возвращает старые обработчики событий формы.
// Сохраняет штатный обработчик события внутри формы и устанавливает новый.
//
// Параметры:
//  Форма – УправляемаяФорма – Управляемая форма.
//

Процедура ВыполнитьОткатОбработчиков(Форма) Экспорт
    Для Каждого
Обработчик Из Форма.OldHandlers Цикл
       
Строка      = Обработчик.Значение;
       
ИндексТочки = Найти(Строка, ".");
       
ОткатитьДействиеУправляемоеПриложение(Форма, Прав(Строка, СтрДлина(Строка)-ИндексТочки), Лев(Строка, ИндексТочки-1), Обработчик.Представление);
    КонецЦикла;
КонецПроцедуры


// Функция разбивает строку разделителем.
//
// Параметры:
//  Строка - Строка - которую разбиваем;
//  Разделитель - Строка - символ-разделитель.
//
// Возвращаемое значение:
//             - Массив - содержащий фрагменты, на которые разбивает строку разделитель.
//

Функция РазобратьСтрокуВМассивПоРазделителю(Строка, Разделитель = ".") Экспорт
   
МассивСтрок = Новый Массив;
   
СтрокаЗамены = СтрЗаменить(Строка, Разделитель, Символы.ПС);
    Для
i=1 По СтрЧислоСтрок(СтрокаЗамены) Цикл МассивСтрок.Добавить(СтрПолучитьСтроку(СтрокаЗамены, i)); КонецЦикла;
    Возврат
МассивСтрок;
КонецФункции

 

На данном этапе, все уже готово для использования. Вот видео-пример использования механизма.

Статья в нашем блоге: www.avtomat.biz


UPDATE (24.03.2014): 
Изменена схема работы метода, проведена оптимизация и исправлены некоторые недочеты. Все это можно посмотреть в новом архиве к статье. Так же сама статья расширена.

 

ОТВЕТЫ НА ВОПРОСЫ:

  1. Для каких конфигураций подходит данный модуль?  механизм предназначен для работы с 1С Предприятие 8.2-8.3, основной режим запуска: "Управляемое приложение", так же конфигурация должна использовать "Библиотеку стандартных подсистем" (БСП), в противном случае нужно будет создать справочник "ДополнительныеОтчетыИОбработки" аналогичный как в БСП;
  2. Какие изменения нужно внести в конфигурацию?  нужно добавить в конфигурацию несколько общих модулей, а так же внести изменения в необходимую управляемую форму (УФ) в конце модуля и для подмены событий этой формы в обработчики ПриСозданииНаСервере() или ПриЧтенииНаСервере(). Реквизиты и табличные части документов можно добавлять, если вам нужно хранить учетные данные;
  3. Как влияет на "быстродействие" использование внешних обработок?  когда используется одна внешняя обработка ничего не заметно для конечного пользователя, когда парк обработок увеличивается скорость запуска формы увеличивается в среднем на ~0.3с с каждой новой обработкой. Не надо паниковать  проблема уже решена;
  4. Как можно вызвать старый обработчик события?  вызвать процедуру ВыполнитьДействиеПоУмолчанию() в которую передать имя события и массив параметров;
  5. Как методика упрощает обновление конфигурации?  после обновления достаточно перенести обработчики переопределения в обновленную конфигурацию и даже если появились новые штатные обработчики событий они будут работать верно в повальном количестве случаев. Управляемые формы не нужно изменять вручную - это все можно сделать с помощью этой методики програмно;
  6. Методика увеличивает время разработки?  да увеличивает время разработки. Если уже несколько форм переделано этим методом – тогда затраты времени ростут незначительно, а затраты на обновление конфигурации уменьшается очень существенно;
  7. Есть критическая ошибка, но пользователей нельзя отключать от базы, что делать? - достаточно внести измения во внешную обработку, изменить ее версию и подключить к базе. После этого, пользователи автоматически уже будут использовать исправленную версию обработки. А ночью обновить общий модуль, который связан с внешней обработкой для более комфортного использования конфигурации.

 

КЛЮЧЕВЫЕ ИЗМЕНЕНИЯ:

  1. У всех общих модулей снято свойство "Вызов сервера", теперь вызов из модуля формы выполняется вот так: &НаКлиенте -> &НаСервере -> ОбщийМодульСервер;
  2. Для сокращения запуска и вызова внешних обработчиков событий, код доработок дублируется в общих модулях. При запуске проверяется версия общего модуля с версией внешней обработки из справочника "ДополнительныеОтчетыИОбработки". Если версии совпадают УФ будет работать с контекстом общего модуля, если версии отличаются вызов процедур и функций будет осуществляется из внешнего объекта;
  3. Переработана работа с контекстом &НаКлиенте  код из форм внешнего объекта дублируется в общем клиентском модуле;
  4. Сам метод переопределения обработчиков событий оформлен так же как внешняя обработка, что добавляет некоторую дополнительную гибкость;
  5. Проверка на дополнительный вызов переназначения обработчиков. 

 

ТАК КАК ЖЕ ЭТО РАБОТАЕТ:

  1. Пользователь открывает документ происходит вызов ПриСозданииНаСервере() или ПриЧтенииНаСервере(). В одну или в обе процедуры мы добавляем наш вызов git_ПереопределениеОбработчиковСервер.ПереопределитьОбработчикиСобытий(ЭтаФорма). Как понять куда добавлять?  нужно посмотреть есть ли переопределение обработчиков в стандартной конфигурации (в УТ 11 оно есть), и добавить перед этим переопределением свой вызов;
  2. Далее идет переход в общий модуль "git_ПереопределениеОбработчиковСервер" в котором определяется первый ли это вызов (на случай, если добавили обработчики в ПриСозданииНаСервере() или ПриЧтенииНаСервере());
  3. Идет проверка версии модуля с версией внешней обработки, если версии одинаковые будет использоваться общий модуль git_ПереопределениеОбработчиковСервер, если версии различные будет использоваться внешняя обработка;
  4. Далее идет такая же проверка для каждой подключаемой внешней обработки (код можно посмотреть в файле .cf) и внутри каждой подключаемой обработки или общего модуля проверяется путь к механизму переопределения для вызова функций и процедур (общий модуль переопределения или модуль внешней обработки, служебные процедуры и функции обозначены комментарием // Только для внутреннего использования); 
  5. Ура! Форма пользовательского документа открылась, теперь так же необходимые функции запускаются из общего модуля (клиент, сервер) или из модуля\формы внешней обработки;
  6. Вызов обработчиков по умолчанию исполняеться с помощь вызова процедуры ВыполнитьДействиеПоУмолчанию();
  7. После закрытия формы все обработчики будут восстанавливаться для избежания проблем с кешированием форм.

Статья в нашем блоге (часть 2): www.avtomat.biz

Скачать файлы

Наименование Файл Версия Размер
cf+epf

.7z 36,30Kb
115
.7z 36,30Kb 115 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Поручик 4505 10.02.13 15:43 Сейчас в теме
Пока не пробовал, но работа хорошая. Жалко, что в управляемых формах нет секции инициализации или операторов основной программы. Тогда не пришлось бы вторгаться в штатную процедуру ПриСозданииНаСервере.
RomanRomans; +1 Ответить
2. MarSeN 979 10.02.13 23:42 Сейчас в теме
Доброе время суток.
Спасибо автору за статью - обязательно скачаю и попробую. Интересный подход в котором надо разобраться.
Плюс в копилку.
Как вариант решения описанной задачи 2 статьи:
http://infostart.ru/public/171514/?fruser=yes#users_raters
http://infostart.ru/public/170935/
Судя по описанию Ваш подход к переопределению обработчиков не требует вставки кода в модуль формы, надо посмотреть как реализовано. Я считал что процедура обработки должна находиться в контексте формы.
Буду признателен, если Вы в 2-х словах опишите механизм
3. pbazeliuk 10.02.13 23:51 Сейчас в теме
(2) MarSeN, Добрый вечер, модуль формы требует изменения в процедуре "ПриСозданииНаСервере" и вставки ваших функций в конец модуля формы. Когда появиться возможность подписки на события формы, этих действий уже не потребуется.

Основной упор делается на то, что изменения в свои обработчики можно вносить без обновления конфигурации - просто обновляя внешнюю обработку, а так же сходство с подходом для 8.1, который описал в свое время tormozit. В видео это продемонстрировано.
4. MarSeN 979 10.02.13 23:55 Сейчас в теме
(3) Baza
Спасибо, получается что в принципе подходы у нас одинаковые ). Хранение кода в разных местах. Потребность диктует решения.
6. plevakin 11.02.13 15:01 Сейчас в теме
(3) Когда появиться возможность подписки на события формы

А когда эта возможность появится?
8. pbazeliuk 11.02.13 16:02 Сейчас в теме
5. alekseies 11.02.13 10:06 Сейчас в теме
Также жалко, что в управляемых формах нет секции инициализации или операторов основной программы. Тогда не пришлось бы вторгаться в штатную процедуру ПриСозданииНаСервере. Так же считаю что процедура обработки должна находиться в контексте формы, легче отслеживать изменения конфигурации ......
RomanRomans; +1 Ответить
7. akomar 442 11.02.13 15:06 Сейчас в теме
(5) Зато очень легко вносить изменения в обоработку, на лету, без отключения пользователей от базы, что критично при большом количестве пользователей.
9. tormozit 6325 12.02.13 10:35 Сейчас в теме
Было бы неплохо указать ссылку и на основу, опубликованную на инфостарте http://infostart.ru/public/16980/ .
10. pbazeliuk 12.02.13 22:38 Сейчас в теме
15. TODD22 18 18.02.13 09:17 Сейчас в теме
(9) Не открывается. Пишет что публикация не активна.
11. Азбука Морзе 95 13.02.13 13:22 Сейчас в теме
Отличная работа. Обязательно приму на вооружение.

п.с. В прошлой жизни так припекло с обновлением переделанной УТ11, что пришлось застрелится:)
12. fr.myha 14.02.13 17:16 Сейчас в теме
13. alekseies 15.02.13 10:54 Сейчас в теме
изменения можно вносить и в модуль формы, и также без отключения пользователей от базы, динамическое обновление, только изменения вносить программно .....
14. pbazeliuk 15.02.13 13:12 Сейчас в теме
(13) alekseies, динамическое обновление в высоконагруженной базе в часто приводит к крашу базы, сама 1С не рекомендует его применять и еще что бы пользователь мог использовать обновления ему нужно перезапустить базу (для каждого сеанса конфигурация кешируеться). В данном методе все безопасно и перезагружать пользователю базу не нужно.
16. ivanov660 2481 16.03.13 09:33 Сейчас в теме
Статья заинтересовала. Буду смотреть, надеюсь это поможет в нашей ситуации.
17. ivanov660 2481 07.05.13 15:56 Сейчас в теме
Посмотрел, кое что понравилось и буду использовать что-то.
Вопрос: А как влияет на "быстродействие" использование внешних обработок? Я бы, к примеру, создал "Библиотека внешних обработок" как внутреннюю обработку.
18. pbazeliuk 10.05.13 09:38 Сейчас в теме
(17) ivanov660, на быстродействие никак особо не влияет.
19. pbazeliuk 19.03.14 15:14 Сейчас в теме
(17) ivanov660, с ростом числа подключенных обработок начало влиять. К понедельнику выкачу новую статью с оптимизацией данного метода.
22. pbazeliuk 23.03.14 03:13 Сейчас в теме
(17) ivanov660, (20) zakov, вот часть 2 - avtomat.biz
zakov; teflon; +2 Ответить
20. zakov 20.03.14 13:27 Сейчас в теме
Спасибо за статью, метод классный. Не пойму только как можно вызвать старый обработчик?
21. pbazeliuk 20.03.14 23:04 Сейчас в теме
(20) zakov, к понедельнику в продолжении статьи все опишу.
23. Andry.Boris 58 25.03.14 00:19 Сейчас в теме
Спасибо за статью,
очень интересная реализация...
24. amon_ra 23 25.03.14 14:25 Сейчас в теме
Отлично. Пожалуй возьму себе на заметку. Огромное спасибо!
25. higs 26.03.14 21:28 Сейчас в теме
Присоединяюсь, интересный подход. И достаточно универсален. Спасибо!!
26. Alex_Japanese_Student 442 30.03.14 07:11 Сейчас в теме
Плюсую, сильная разработка, очень поможет
27. 0vrcr 52 03.03.15 14:37 Сейчас в теме
А не появилось варианта назначения нового обработчика на динамически созданный элемент? И чтобы сам обработчик был в глобальном модуле?

Например, создаем РегистрСведенийНаборЗаписей динамически на форме. Подключаем обработчик ПриИзменении. И чтобы этот обработчик хранился в общем модуле?
28. pbazeliuk 1801 03.03.15 17:45 Сейчас в теме
(27) 0vrcr, появилось что-то похожее, но все равно нужно добавить в форму процедуру\функцию перенаправления на общие модуля\внешние модуля
29. 0vrcr 52 05.03.15 17:49 Сейчас в теме
Ясно. Ну этот метод я знаю, сам использую. Жаль, спасибо! :)
30. CheBurator 3455 05.03.15 19:20 Сейчас в теме
Было бы интересно почитать весьма про "внедрения конфигурации «Управление торговлей, редакция 11» в не российской торговой компании, из чего следует, что переписано и изменено было очень многое." - такие проекты не частые гости...
31. pbazeliuk 1801 06.03.15 03:59 Сейчас в теме
(30) CheBurator, возможно, когда-то. На самом деле реализовано много, что-то более 7000 задач только на разработку, 3000 обращений на поддержку каждый месяц. А конца так и не видно...
32. pbazeliuk 1801 06.03.15 04:04 Сейчас в теме
(30) CheBurator, самое, наверное, интересное - партионная себестоимость, которая полностью за месяц пересчитывается за 1-3 минуты, без перепроведения документов и использования последовательностей.
33. mikhailv 19 02.04.15 14:32 Сейчас в теме
Видео из статьи не воспроизводится: ролик не найден. Почините, пожалуйста.
34. pbazeliuk 1801 03.04.15 09:43 Сейчас в теме
(33) mikhailv, добрый день, к сожалению, видео безвозвратно утеряно. Постараюсь на выходных обновить статью и снять новое видео.
35. Cyberhawk 127 30.05.16 18:23 Сейчас в теме
Я правильно понимаю, что нет возможности размещать ЭУ (элементы управления - например, поле формы) в произвольном месте родителя (группы формы)?
Т.е. программно добавляемые ЭУ всегда размещаются в конце (справа или снизу).

//
Отбой, нашел метод Вставить() вместо Добавить()
36. pbazeliuk 1801 31.05.16 09:46 Сейчас в теме
(35) Cyberhawk, используйте процедуру ПереместитьЭлементВКоллекциюЭлементовФорм, если нужно изменить место расположения.
37. UNIT68RUS 08.05.19 09:29 Сейчас в теме
Коллеги не пойму по поводу обработки? Можно скрин обработки?
38. pbazeliuk 1801 08.05.19 11:52 Сейчас в теме
(37) Статья довольно старая, у вас уже есть возможность использовать "Расширения конфигураций". Мы уже понемногу отказываемся от указанного метода и переносим код в расширения, но в 2012 году без него было очень сложно.
39. tormozit 6325 08.05.19 11:57 Сейчас в теме
40. pbazeliuk 1801 08.05.19 12:02 Сейчас в теме
(39) Согласен. Обычные формы еще лет 10 проживут; смотрю на то как мы все переносим в расширения - этот процес займет еще лет 5 (не приоритет, бизнес на этом денег больше не заработает).
Оставьте свое сообщение

См. также

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5 Промо

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    5705    21    huxuxuya    11    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    11601    69    sapervodichka    43    

Транслятор запросов 1С в SQL

Производительность и оптимизация (HighLoad) Администрирование СУБД v8 v8::Запросы 1cv8.cf Абонемент ($m)

Инструмент для трансляции запросов платформы 1С в SQL, а также их диагностики.

10 стартмани

07.01.2020    22186    176    YPermitin    89    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    32159    27    Stepa86    46    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    25080    7    m-rv    90    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    21083    12    RonX01    10    

Многопоточная обработка данных

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    26552    93    _ASZ_    17    

Мониторинг показателей систем 1С 8.3 с помощью Zabbix

Внешние источники данных Zabbix v8 1cv8.cf Абонемент ($m)

Опишу свой опыт мониторинга наших систем 1С с помощью Zabbix и ту пользу, которую можно извлечь из этого.

1 стартмани

05.10.2018    49447    65    akimych    49    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    34085    91    m-rv    58    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    25443    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    47939    66    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    33078    31    informa1555    30    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    32117    20    mvxyz    17    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    59946    24    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    37021    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    30636    56    kwazi    6    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    31878    72    vasvl123    9    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    60171    17    swimdog    46    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    38922    143    PLAstic    68    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    26124    21    sasha777666    64    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    52291    36    Demanoidos    60    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    153888    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    36127    120    romasna    52    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    35128    141    kiv1c    18    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    57408    35    ildarovich    41    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    26892    118    Alxby    23    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    31807    17    Anton64    23    

Просмотр заблокированных строк в 1С

Производительность и оптимизация (HighLoad) v8 1cv8.cf Абонемент ($m)

Ввиду своей деятельности, мне часто приходится рассказывать про различные аспекты оптимизации и в том числе про блокировки. Очень часто слушатели задают следующие вопросы: Как посмотреть в реальном времени, какие именно данные сейчас заблокированы? Как понять, что сейчас заблокировано в терминах 1С? Если гранулярность блокировки страница, как увидеть, какие данные в ней находятся? Раньше приходилось отвечать, что инструмента, который показывает все вышеописанное, сейчас просто нет. Но потом мне это надоело, и я решил сделать собственный инструмент, который позволяет ответить на все вышеописанные вопросы.

1 стартмани

25.10.2016    44632    789    Andreynikus    68    

Настройка PostgreSQL для работы в связке с 1С 8.х на платформе Windows Server 2012, объём БД более 200 Гб

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 Россия Абонемент ($m)

Настройка бесплатной СУБД PostgreSQL для работы в связке с 1С 8.х на платформе Windows Server 2012 х64. Объём БД более 380 Гб для мощного сервака. Конфигурация КА 1.1.108.2, 50 пользователей. Более 1 млн. проводок при закрытии месяца. Время закрытия месяца сравнимо с MSSQL и составляет в среднем 2 часа. Время отмены закрытия месяца - всего 10 минут! Ликвидированы зависания PostgreSQL. Всё за счет настроек файла postgesql.conf.

1 стартмани

11.10.2016    92391    75    vsasav    48    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    40142    98    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    31080    146    Stepa86    15    

Использование методов глобального контекста в системе компоновки данных или недокументированные возможности СКД

Практика программирования Математика и алгоритмы v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Прочитал на форуме, что СтрРазделить() и ТекущаяДата() работают в языке выражений системы компоновки данных. Почитал справку, там ничего не нашёл, поэтому не поверил. Посмотрел на практике – и правда работает… В данной статье попытался привести весь перечень методов, работающих в СКД, но не описанных в документации.

1 стартмани

05.08.2016    41434    27    klinval    40    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    31916    95    ZhokhovM    65    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    63944    11    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    69837    207    rozer    67    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    70342    19    arakelyan    24    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    38494    52    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    90496    169    igo1    58    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    21224    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    55769    56    yuraos    18    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    64162    209    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    26319    8    Tatitutu    5