Процедура или Функция?

Публикация № 17097

Разработка - Практика программирования

8
Со временем почему-то перестают устраивать вещи, написанные лишь для того, чтобы они работали. Хочется красоты, стиля.
В тоже время хочется простых и понятных правил для поддержки этой красоты и этого стиля.
Данный вопрос относится к категории "Размышления над стилем".

Представим, что мы пишем некий код, в котором могут быть использованы как процедуры, так и функции. Код содержит участки, в которых могут произойти ошибки, и участки, в который ошибок мы не ожидаем. Вложенность вызовов может быть произвольной. В то же самое время хочется легким способом получить диагностику по ошибке настолько подробной, чтобы все цепочки вызовов были "как на ладони".

Исходя из этих соображений и возникает желание определить чёткие критерии того, в каком случае стоит использовать Процедуры, а в каком случае Функции.


Небольшой опрос среди своих сослуживцев выявил несколько разных подходов к этой проблеме.
Но из позитивных замечаний получилось выделить несколько идей.

Подход 1. Исходя из определения Процедуры и Функции
Тут всё просто, читаешь документацию и, помня, что процедура отличается от функции только возвращаемым значением, решаешь - если возврат значения не нужен, то Процедура, если нужен, то Функция. Тем не менее, процедура может изменять значения параметров, переданных по Ссылке.

Процедура Подход1(Знач вхПарам1, выхПарам2)
КонецПроцедуры


В контексте данного подхода, есть два разветвления на тему, как Фукнция должна возвращать параметры:

Подход 1.1 Функция возвращает один параметр через возврат, остальные через переменные, переданные по ссылке. На выходе процедуры мы включаем некую обработку ошибок, зависящую от возвращаемого значения.

Функция Подход11(Знач вхПарам1, выхПарам2)
КонецФункции

рез = Подход11(вхПарам1, выхПарам2);
// рез - содержит либо нужное значение, либо значение, сигнализирующее об ошибке
// выхПарам - может быть также изменено


Подход 1.2 Функция не может возвращать значения через свои параметры и должна это делать только через значение возврата. Если необходимо вернуть более одного значения, то эти значения необходимо упаковать в массив, список значений, прочее.
Если в ходе работы появилась ошибка, то будет возвращено значение Неопределено.

Функция Подход12(Знач вхПарам1)
КонецФункции

массив = Подход12(вхПарам1);
Если массив = Неопределено Тогда // Ошибка
Иначе
  выхПарам1 = массив[0];
  выхПарам2 = массив[1];
КонецЕсли;


Подход 2. Процедуры - они как МАКРОСЫ
При этом подходе Процедура используется всего лишь для того, чтобы объединить несколько вызовов однотипных действий.
В этом подходе использование Процедуры носит локальный характер - просто для того, чтобы сократить код.

Подход 3. Всё на свете - Функции, но без идиотизма
1. Всегда используются функции, процедуры не используются.
2. Функция возвращает либо "", либо строковое описание ошибки, все изменения данных идут по ссылке через выходные параметры
3. Для исключения идиотизма в применении правила 2, для функций, возвращающих гарантировано одно значение, без ошибок внутри функции, используется передача значения через возврат функции. Например, ЭтоКорректнаяДата(вхДата)

Функция Подход3(Знач вхПарам1, Знач выхПарам2)
КонецФункции

Функция ЭтоИсключениеИзПодхода3()
  Возврат Истина;
КонецФункции

рез = Подход3(вхПарам1, выхПарам2);
Если Не ПустаяСтрока(рез) Тогда
   СообщитьОбОшибке(рез);
КонецЕсли;

Если ЭтоИсключениеИзПодхода3()
  ...
КонецЕсли;


Вот пока что получилось. А какие есть подходы у вас?

8

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Шёпот теней 1752 18.01.08 11:45 Сейчас в теме
Да, уж… тема…?...! Извечная... Пока "ОНИ" существуют...

Извечный вопрос…! И наверное безответный… в смысле чётких рекомендаций… самый правильный диагноз ставит патологоанатом… и в этом смысле надо, что-то одно просто убрать… или процедуру или функцию… и видимо это будет функция… по большому, моему пониманию, функция хороша только для логической красоты написания программы (я её так и использую)… все свойства функции способна выполнить процедура.. .

Во-о-от... такое мнение...

Удачи!...
18. ineoosaki 29.01.08 17:24 Сейчас в теме
2 AlexQC
Как пример:
//=================================================================
// Управление движением по записям документа в режиме работы со строкой
//~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~­~~~~~~~
// Вход   :
//   Направление - строка с направлением "Назад/НаНачало/Вперед/ВКонец/Новая/Удалить"
//   Конт -контекст
//~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~­~~~~~~~
Функция _ДвижениеПоФорматке(Направление,Конт) Экспорт
	Перем ВыбСтрока;
	// сохранить текущую строку
	Если (Направление<>"Обновить") И (Направление<>"Удалить")  Тогда
		Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента"));
		_Вычислить("_ОбменПолямиДокумента(""КопиюВОригинал"",Контекст)");
	КонецЕсли;
	
	Если (Направление="Назад") И (_Вычислить("ТекСтрокаДокумента")<>1) Тогда
		Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента")-1);
	ИначеЕсли (Направление="НаНачало")  Тогда
		Конт.ПолучитьСтрокуПоНомеру(1);
	ИначеЕсли (Направление="Вперед") И (_Вычислить("ТекСтрокаДокумента")<>_Вычислить("КоличествоСтрок()")) Тогда
		Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента")+1);
	ИначеЕсли (Направление="ВКонец")  Тогда
		Конт.ПолучитьСтрокуПоНомеру(_Вычислить("КоличествоСтрок()"));
	ИначеЕсли (Направление="Перейти")  Тогда
		Если ВвестиЧисло(ВыбСтрока,"Введите номер строки для перехода",4,0,)=1 Тогда
			Конт.ПолучитьСтрокуПоНомеру(ВыбСтрока);
		КонецЕсли;
	ИначеЕсли (Направление="Новая")  Тогда
		Конт.НоваяСтрока();
		Для Индекс=1 по _КоличествоЭлементов(_ВычислитьСтроку("СписокРеквизитовДетального")) Цикл
			ИДПоля=_ПолучитьЭлемент(_ВычислитьСтроку("СписокРеквизитовДетального"),Индекс);
			_Вычислить("_ПрисвоениеПоля("+ИДПоля+",0)");
		КонецЦикла;
	ИначеЕсли (Направление="Удалить")  Тогда
		Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента"));
		Конт.УдалитьСтроку();
		
		Для Индекс=1 по _КоличествоЭлементов(_ВычислитьСтроку("СписокРеквизитовДетального")) Цикл
			ИДПоля=_ПолучитьЭлемент(_ВычислитьСтроку("СписокРеквизитовДетального"),Индекс);
			_Вычислить("_ПрисвоениеПоля("+ИДПоля+",0)");
		КонецЦикла;
		
		Если _Вычислить("ТекСтрокаДокумента")>_Вычислить("КоличествоСтрок()") Тогда
			Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента")-1);
		КонецЕсли;
	КонецЕсли;
	
	Если (Направление="Новая") Тогда
		_Вычислить("ОбновитьФорматку(1)");
	ИначеЕсли (Направление<>"Обновить") Тогда
		_Вычислить("ОбновитьФорматку()");
	КонецЕсли;
	
	_Вычислить("Форма.КнопкаНаНачало.Доступность(?(ТекСтрокаДокумента<=1,0,1))");
	_Вычислить("Форма.КнопкаНазад.Доступность(?(ТекСтрокаДокумента<=1,0,1))");
	_Вычислить("Форма.КнопкаВКонец.Доступность(?(ТекСтрокаДокумента=КоличествоСтрок(),0,1))");
	_Вычислить("Форма.КнопкаВперед.Доступность(?(ТекСтрокаДокумента=КоличествоСтрок(),0,1))");
	_Вычислить("Форма.КнопкаПерейти.Доступность(?(КоличествоСтрок()=0,0,1))");
	_Вычислить("Форма.КнопкаУдалить.Доступность(?(КоличествоСтрок()=0,0,1))");
КонецФункции
Показать
2. brix8x 492 18.01.08 12:12 Сейчас в теме
Неожиданно. Это еще один подход ;-)
1. Все на свете - Процедуры!!!
2. Обработка ошибок ... каким образом? Предствить пока себе это не могу ...
3. Шёпот теней 1752 18.01.08 12:24 Сейчас в теме
(2) Может я не прав... есть ЕСЛИ, ПОПЫТК и др. процедуры...

и вообще...:
если есть значение - значит его можно сравнивать...
21. CheBurator 30.01.08 00:29 Сейчас в теме
(2) где есть НОРМАЛЬНЫЙ репозитарий классов?
22. artbear 1155 30.01.08 06:55 Сейчас в теме
(21) Наверное, это мне на (20) :) ?
Раздел Репозитарий в форуме 1С++ http://www.1cpp.ru/forum/YaBB.pl?board=repo
Есть прикрепленная ветка с набором классов внутри одной конфы, которая тебе не очень нравится :), а есть и отдельные ветки под различные классы, программы и т.д.
Почитай.
4. hopter 36 21.01.08 04:03 Сейчас в теме
вопрос больше филосовский чем практический :)
чего неожиданного в подходе "только процедуры", он напрашивается из "только функции" и существует столько же, сколько существует возможность передавать параметры по ссылке
с тех давних пор как в языках появилась возможность вызвать функцию без присваивания, грань между ними сильно размылась.
и вообще, процедура это функция, не возвращающая значение в явном виде.
dj_serega; pavlo; Шёпот теней; +3 Ответить
5. Шёпот теней 1752 21.01.08 08:14 Сейчас в теме
Если я правильно понял то на основной вопрос заданный brix8x: ... Исходя из этих соображений и возникает желание определить чёткие критерии того, в каком случае стоит использовать Процедуры, а в каком случае Функции. (см. историю вопроса)...


мы (в частности) всё таки не отвечаем, в чём и я виноват, переводя разговор в несколько философскую тему...

как мне кажется, сам автор, полностью исследовал вопрос... изложил его в своих "подходах"... и мы теперь можем или только повторяться... или философствовать...

мне всегда было интересен вопрос - процедура или функция... ответ господина borter хоть и повторяет "подходы" но мне очень понравился и сжатостью и конкретностью...

Я восхищён... и вечный для меня вопрос... П или Ф стал для очевиднее...

Именно поютому ставлю плюс и автору вопроса и автору ответа (4)... спасибо! Удачи...
6. vasilykushnir 21.01.08 08:57 Сейчас в теме
>Вот пока что получилось. А какие есть подходы у вас?

А подход один - что в конкретном случае удобнее, то и использую не задумываясь о высших материях. Естественно есть фишки где функция вне конкуренции - каскадный вызов или вложенный вызов, если будет угодно. Да и то не факт - просто через функции это нагляднее и красивее.
7. Abadonna 3833 21.01.08 09:38 Сейчас в теме
Что тут говорить о функциях, если 1С не удосужилась сделать ФС.УдалитьФайл как функцию.
Сиди себе и думай: удалила или нет? Или проверяй через ФС.СуществуетФайл. Маразм 1С-кий
8. brix8x 492 21.01.08 09:46 Сейчас в теме
Я в своей работе использую подход "Все на свете функции".
Это удобно, когда идут вложенные функции и ты можешь получить всю цепочку этих вызовов.
============================================================­====

Функция суперВнутр(вхПар1, вхПар2, выхПар3)
  //{ Блок ошибок выполнения
  Перем рез; // объявление на всякий случай, вдруг внтури функции захочу вызвать другую ж-(
  Перем имяФункции; //
  имяФункции = "суперВнутр"; // жаль, что 1С не имеет команды для получения имени выполняемой функции ...
  //}

  Если ОШИБКА Тогда Возврат имяФункции + ": Нормальное тестовое описание ошибки";

  Возврат ""; // если все хорошо
КонецФункции

Функция Внешняя(вхПар1, вхПар2, выхПар1) // Внешняя, но не интерфейсная функция
  //{ Блок ошибок выполнения
  Перем рез;
  Перем имяФункции;
  имяФункции = "Внешняя";
  //}
  
  рез = суперВнутр(вхПар1, вхПар2, выхПар3);
  Если Не ПустаяСтрока(рез) Тогда Возврат имяФункции + ": Описание ошибки для Внешняя";

  Возврат ""; // если все хорошо
КонецФункции

Процедура ОбработчкикСобытия1С(Отказ) // процедура - показатель обработчика 1С
   Перем Пар1, Пар2, Пар3;
   Перем рез;

   рез = ВнешняяНоНеИнтерфейсная(Пар1, Пар2, Пар3);
   Если Не ПустаяСтрока(рез) Тогда
      СообщитьОбОшибке(рез, Отказ); Возврат;
   КонецЕсли;

КонецПроцедуры
Показать

В случае ошибки мы получаем что-то вроде: "Внешняя: Описание ошибки для Внешняя: суперВнутр: Описание ошибки для суперВнутр"
============================================================­====

Защита от идиотизма состоит в том, что функции, возвращающие булево и не могущие (теоретически) привести к ошибке можно использовать привычным способом, например, ЭтоКорректнаяДата(вхДата).

Имея такой набор правил, я могу создать шаблон и сделать его стандартом и, в будущем, проверить следование этому стандарту.

Этот подход прекрасно работает и на VB, и на VBSctipt. Я бы и дальше использовал этот подход, но он дал "сбой" на языке Jcript :-(. В функции на JScript нельзя передать по ссылке переменные обычного типа (число, дата), т.о. если внутри фукнции изменяется несколько переменных обычного типа, я не смогу работать в том, стиле, который только что описал.

Именно из-за этого и родился этот пост. Как желание увидеть другие подходы, проработанные достаточно глубоко, чтобы их потом можно было отобразить в набор простых правил для "зелёных" студентов ...

Пока же на JScripte я пишу как полная обезьяна - по настроению ... Ж-(((

Склоняюсь к мысли, что либо придется отказаться от JScript, либо для него придумать другой стиль.

Есть стиль, который можно попробовать адаптировать:
1. Все на свете функции, но возвращаемые значения только через Возврат
2. Если их много, что через возвращаемый массив
3. Если есть ошибка, то первый элемент массива - неопределено, а второй - текстовое описание ошибки.

Но тут я опять возвращаюсь к "старой натоптанной дорожке", может чего не вижу?
9. Шёпот теней 1752 21.01.08 13:12 Сейчас в теме
не хочется возвращаться к "белому бычку" но основной вопрос автора : "Исходя из этих соображений и возникает желание определить чёткие критерии того, в каком случае стоит использовать Процедуры, а в каком случае Функции." - остался открытым...?

... и как вывод... критерия нет, вопрос только удобства и крастоты кода... остающиеся на откупе у программиста...

вообщем вопрос остался в плоскости философии... может ещё раз кто-нибудь попробует сформулировать... и даст практические советы когда, что использовать... ?
10. alexqc 21.01.08 13:34 Сейчас в теме
В 7ке плюс ф-ций был еще и в том, что их можно вызвать из любого места где ожидается выражение, как то: табло или формульный калькулятор, выражения в отладчике. Что, естественно, отладку упрощает.
11. ineoosaki 21.01.08 13:47 Сейчас в теме
Была в Украине когда-то комплексная конфа под 7.7 от фирмы Фаворит-С. Практически полностью построенная на функциях. Использовался вызов этих функций, с помощью недокументированных возможностей метода Шаблон().
Статьи Ризванова Олега aka ROMa (автора ROM-Mail.dll) на тему использования функции Шаблон() основаны на опыте исследования этой конфы (возможно Олег являлся сотрудником Фаворита).
Заходим по ссылке и вникаем.
http://rom1c.narod.ru/glob_tmp.html
Также не лишне ознакомиться с этой конфой, но в нете я ее не встречал.
12. alexqc 21.01.08 16:35 Сейчас в теме
почему недокументированных? Вполне себе документированных. Правда, использование шаблона() по возможностям очень ограничено, не говоря уж о том что Шаблон() интерпретируется при каждом выполнении.
А уж с появлением Rainbow и далее 1С++ необходимость в сем изврате отпала.
13. ineoosaki 21.01.08 17:53 Сейчас в теме
AlexQC
почему недокументированных?
-------------------------------------
Ты вообще конфу Фаворита видел?
Если бы видел, то не спрашивал.
17. alexqc 28.01.08 10:17 Сейчас в теме
(13) Нет, не видел. Что там, пример можно?
ИМХО, единственно что явно не документировано (при чем непосредственно к шаблону значения не имеющее) - это то что ф-ции в ГМ выполняются в вызывающем контексте (однако на опыте это быстро узнается). НО - локальные переменные вызывающей ф-ции (не модуля!) при этом все равно недоступны.

Вообще же, насколько я заметил, тем кто пришел на 1С с фокса/клипера, очень не хватало операции макроподстановки, и они довольно быстро находили ей замену в Шаблоне() (хотя, конечно, замену не полную).

14. brix8x 492 22.01.08 09:05 Сейчас в теме
ineoosaki, статья замечательная, спасибо за ссылку. С удовольствием вспомнил собственные изврашения с Шаблоном(). ж-)
Попоробую под итожить нижеописанное:

1. Если некий набор команд (не должен возвращать никаких значений) и (в ошибки в нём теоретически невозможны или некритичны), То можно смело оборачивать этот набор в Процедуру.
2. В остальных случаях используется Функция.
3. Процедура может влиять на ход выполнения программы через изменения своих выходных параметров, Функция в доплнении к этому может влиять на ход выполения программы через возвращаемое значение.
4. Процедура может вызывать завершение работы программы внутри себя, при использовании функции завершение работы программы должна делать вызывающая конструкция.
5. Обработка ошибок в Процедуре должна быть сведена к минимуму, если в ходе разработки оказывается, что внутри процедуры некоторые ошибки становятся критичными, то Процедура преобразовывается в функцию (без потери функционала) и начинает возвращать признак ошибки.

Вроде пока всё. ж-)
15. hopter 36 28.01.08 04:38 Сейчас в теме
Давайте остановимся на том, что "все что удобно, то и красиво" :)
И без фанатизма :)
16. brix8x 492 28.01.08 09:12 Сейчас в теме
С предложением "остановиться" полностью согласен, большое всем спасибо, в этом обсуждении было достаточно ценных идей.

А девиз "все что удобно, то и красиво" не приёмлю всей душой, увы, но это - тема отдельной ветки, и скорее всего очень флеймовой ветки ...
Можем открыть отдельную ветку "Так ли красиво всё, что удобно." ;-) ...

23. hopter 36 30.01.08 14:08 Сейчас в теме
(16) нет, не надо новую ветку :)
а девиз конечно спорный, тем более, что понятия о красоте тоже у всех разные :)
19. ineoosaki 29.01.08 17:28 Сейчас в теме
Функции _Вычислить(), _ВычислитьСтроку() описаны в статьях ROMa.
20. artbear 1155 29.01.08 17:53 Сейчас в теме
Бедные, как вам не хватает фич 1С++ и ФормЕкс :)
Например, в 1С++ есть класс "ВыполняемыйМодуль", который может НАМНОГО больше, чем отстойный Шаблон, подаренный нам гениями от 1С :)
vasilykushnir; 33lab; vip; +3 Ответить
24. ineoosaki 30.01.08 14:43 Сейчас в теме
2 (20)
Код приведенный мной в (18) написан в 1999году.
Какие формексы и 1С++. Тогда даже радуги не было.
25. premierex 24.02.08 23:33 Сейчас в теме
Коллеги, а вам не кажется странным, когда функция (которая, по идее, должна вернуть результат её вычисления) всегда возвращает "пустую строку", 0 и т.д. По моему, если некоторый блок кода выполняет какое-либо действие без проверки результата выполнения - это процедура (есть, кстати, определения процедур и функций), иначе - это функция. НО!!! поскольку мы можем оборачивать свой код в любую оболочку (процедура, функция, метод и т.д.), давайте не забывать их изначального назначения! Вот пример определния функции: "фактически это означает, что изменение ЗНАЧЕНИЯ функции может произойти только вследствие изменения её аргумента (см. http://ru.wikipedia.org/wiki/) Соотвественно, функция, точнее, результат её вычисления - является возвращаемым значением, зависящим от переданных аргументов, тогда как процедура выполняет некотрые действия не связанные с конечным результатом. Примеры: ЗаполнитьНаОсновании(ДокументОснование) - естественно - процедура! Она ничего не должна вернуть. ПолучитьТекущийКурс(Валюта, Дата) - соответственно, функция, т. к. расчитывает и возвращает значение.
Возможно, это - лирика, но меня, если честно, несколько смущает такой код:
Функция Подход11(Знач вхПарам1, выхПарам2)
Возврат "";
КонецФункции
Droonimus; +1 Ответить
26. Abadonna 3833 25.02.08 06:08 Сейчас в теме
(25)>"Соотвественно, функция, точнее, результат её вычисления - является возвращаемым значением, зависящим от переданных аргументов"
Не надо путать определение функции в математике с функцией в программировании.
Например, в 1С ФС.УдалитьФайл() - процедура. Хорошо это? На ничего подобного!, т.к. без дополнительных телодвижений невозможно узнать, удалился-таки файл или нет.
Рассмотрим аналог в WinAPI: DeleteFile() - возвращает TRUE (удалился) или FASLE (не удалился по какой-то причине). Понятно, что это гораздо удобнее... Так что и ЗаполнитьНаОсновании(ДокументОснование) лучше бы выполнить в виде функции (а вдруг не заполнится!)
28. premierex 25.02.08 10:48 Сейчас в теме
Совершенно согласен с (26). В (25) я привёл пример процедуры: ЗаполнитьНаОсновании(ДокументОснование). Естественно, было бы правильней реализовать этот фрагмент кода как функцию. В этом-то, как мне кажется, и есть различие процедур и функций: значение, возвращаемое функцией - есть результат её выполнения. Соответственно, если проверка выполнения не требуется, фрагмент кода вызывается как процедура.

И вообще, мне кажется, автор этой темы уже подвёл завершающую черту (27, абзац 4).
29. anchovy 14 09.06.18 13:05 Сейчас в теме
(25)
(26)Вы пытаетесь обсуждать методы языка через понятия процедур и функций, что само по себе неверно. Результат выполнения метода может быть ложь или истина или некоторым дополнительным состоянием по аналогии с переменной "$?" в шелле линукса. А вот отсутствие какого бы то ни было результата выполнения это уже совсем плохо конечно. Ну а когда в 1С делали все хорошо?
27. brix8x 492 25.02.08 08:57 Сейчас в теме
Скажу больше, в случае ФС.УдалитьФайл() (например) меня даже не устроит ответ, что удаление не произошло, т.к. оно может НЕ произойти по множеству причин.

И чаще нужно видеть именно причины (ведь если Вам говорят "не могу", следующим вопросом будет, а почему не можешь?).

Поэтому TRUE и FALSE превращаются в "" и "текстовое описание ошибки, полученное сразу после вызова УдалитьФАйл"

С другой стороны, это всего лишь прием программирования. Об его применении нужно договаритьваться в начале проекта, документировать этот факт и потом просто следить, чтобы ВРЕМЯ не подменило понятия и новые люди, пришедшие в проект не стали "лепить на русской церкви готический купол" ;-)
30. genayo 09.06.18 13:24 Сейчас в теме
(29) Знатный некропост... уже больше 10 лет прошло...
31. StAlexei 09.06.18 15:09 Сейчас в теме
Это вопрос вечный, т.к. все можно написать через функции или через процедуры (правда не всегда разумно). Жесткие критерии выделять смысла нет, если только давать рекомендации по этому вопросу.
Я стараюсь придерживаться того, что если в результате выполнения метода (процедуры или функции) будут получаться "новые" данные, тогда надо реализовывать метод как функцию, а если необходимо выполнить проверку (например, несколько реквизитов на форме) или преобразование каких-то данных, тогда как процедуру.
А в качестве примера приведу:
- функция получения цены на номенклатуру (+ доп. параметры) - получение "новых" данных
- процедура заполнения цены в табличной части - фактически это преобразование уже имеющихся данных (нет смысла получить новую таблицу и загружать ее в документ)
В остальных случаях выбираю в зависимости от удобства.
P.S. при большой вложенности методов будет лучше использовать параметр "отказ" и сообщения пользователю, а не нагружать деталями.
Вы когда нибудь задумывались, как будет работать процесс записи и проведения документа, если методы ПередЗаписью() (в модуле формы и модуле объекта) и ОбработкаПроведения() сделать функциями?
32. karakymi4 11 03.10.18 11:23 Сейчас в теме
Назрел вопрос, почему при разработке платформы не оставили одни только функции, с возможностью НЕ возвращать значение?
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 315

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9264    ids79    42       

Три костыля. Сказ про фокусы в коде 121

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7482    YPermitin    67       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    7749    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 238

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    9596    ids79    22       

Фоновое выполнение кода в 1С - это просто 117

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    9496    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 125

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    8672    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8215    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6067    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 188

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    16799    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 174

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11220    dmurk    134       

Регистры накопления. Структура хранения в базе данных 172

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    16798    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9468    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4634    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7145    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16002    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 199

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12458    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12540    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 161

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15015    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 125

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12432    ids79    27       

Новый подход к обмену данными EnterpriseData 202

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    20916    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 117

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18335    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19031    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20520    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20165    tormozit    100       

Произвольный код в фоновом режиме 163

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14349    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    20837    Rain88    42       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19083    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24058    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    20987    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16789    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11193    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    23884    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35215    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25649    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21135    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 716

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136230    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22458    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 65

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20893    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23828    json    9       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24198    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46264    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 126

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18010    vardeg    31