Горячая печать реквизитов (их значений ) документов с использованием FormEx

Публикация № 17183

Разработка - Печать - Печатные формы документов

19
Иногда хочется увидеть все реквизиты документа, в том числе и те, которые на форме отсутствуют.
Особенно, если они автоматом понаустанавливались.
Приведенный код позволяет по горячим клавишам CTRL+ALT+P получить распечатку ВСЕХ реквизитов, начиная от общих, заканчивая ТЧ. Код необходимо вставить в Глобальный модуль, или в Дополнительный глобальный модуль, подключенный с помощью Formex
// добавляем в ГМ или допГМ
// предопределенная процедура Formex.dll
Процедура ПриНажатииКнопкиКлавиатуры(Конт, КодКл, Альт, Шифт, Контрол, Символ, ФСО)  
	ФормаРасш = СоздатьОбъект("РасширениеФормы");   
	Попытка
		ФормаРасш.УстановитьФорму(Конт.Форма);
	Исключение
		Возврат;
	КонецПопытки;   
	Тип=ФормаРасш.ТипОбъекта();  
	Если Тип="Документ" Тогда   
		// Распечатка документа по горячим клавишам CTRL+ALT+P   
		//(форма документа должна быть интерактивно открыта)
		Если (Контрол=1) И (Альт=1) И  (КодКл=80)   Тогда   
			Вид=Конт.Вид();  
			Таб=СоздатьОбъект("Таблица");
			Область=Таб.Область(1,1); 
			Область.РазмерШрифта(10);
			Область.Полужирный(1);   
			Область.ВысотаСтроки(12);
			Область.Текст=  Конт.ТекущийДокумент();       
			Область=Таб.Область(2,1); 
			Область.РазмерШрифта(10);
			Область.Полужирный(1);   
			Область.ВысотаСтроки(12);
			Область.РамкаОбвести(3,3,3,3);
			Область.ЦветФона(200,250,225); 
			Область.ШиринаСтолбца(20);    
			Область.Текст=  "ВР";       
			Область=Таб.Область(2,2);
			Область.РазмерШрифта(10);
			Область.Полужирный(1);   
			Область.ВысотаСтроки(12);
			Область.РамкаОбвести(3,3,3,3);
			Область.ЦветФона(200,250,225);
			Область.ШиринаСтолбца(20);    
			Область.Текст=  "Реквизит";       
			Область=Таб.Область(2,3);
			Область.РазмерШрифта(10);
			Область.ВысотаСтроки(12);
			Область.Полужирный(1);   
			Область.РамкаОбвести(3,3,3,3);
			Область.ЦветФона(200,250,225); 
			Область.ШиринаСтолбца(20);    
			Область.Текст=  "Значение";                     
			Стр=2;            
			// Общие реквизиты
			Для А=1 По Метаданные.ОбщийРеквизитДокумента() Цикл 
				Стр=Стр+1;
				ИД=Метаданные.ОбщийРеквизитДокумента(А).Идентификатор;
				Область=Таб.Область(Стр,1);
				Область.РамкаОбвести(3,3,3,3); 
				Область.РазмерШрифта(10);
				Область.Текст=  "ОБЩ"; 
				Область=Таб.Область(Стр,2);
				Область.РамкаОбвести(3,3,3,3);      
				Область.РазмерШрифта(10);
				Область.Текст=  ИД; 
				Область=Таб.Область(Стр,3);
				Область.РамкаОбвести(3,3,3,3);
				Область.РазмерШрифта(10);
				Область.Контроль(2);
				Область.Текст=  Конт.ПолучитьАтрибут(ИД); 
			КонецЦикла;             
			// Реквизиты шапки
			Для А=1 По Метаданные.Документ(Вид).РеквизитШапки() Цикл  
				Стр=Стр+1;
				ИД=Метаданные.Документ(Вид).РеквизитШапки(А).Идентификатор; 
				Область=Таб.Область(Стр,1);
				Область.РамкаОбвести(3,3,3,3);
				Область.РазмерШрифта(10);
				Область.Текст=  "  Ш"; 
				Область=Таб.Область(Стр,2);
				Область.РамкаОбвести(3,3,3,3);
				Область.РазмерШрифта(10);
				Область.Текст=  ИД; 
				Область=Таб.Область(Стр,3);
				Область.РамкаОбвести(3,3,3,3);
				Область.РазмерШрифта(10);   
				Область.Контроль(2);
				Область.Текст=  Конт.ПолучитьАтрибут(ИД); 
			КонецЦикла;  
			Если Конт.КоличествоСтрок()>0 Тогда
				Стр=Стр+1;  
				// выводим заголовки ТЧ (идентификаторы реквизитов)
				Для А=1  По Метаданные.Документ(Вид).РеквизитТабличнойЧасти() Цикл
					ИД=Метаданные.Документ(Вид).РеквизитТабличнойЧасти(А).Идентификатор;    
					Область=Таб.Область(Стр,А); 
					Область.РазмерШрифта(10);
					Область.Полужирный(1);   
					Область.ВысотаСтроки(12);
					Область.РамкаОбвести(3,3,3,3);
					Область.ЦветФона(200,250,225);    
					Область.ШиринаСтолбца(20);    
					Область.Контроль(2);
					Область.Текст=  ИД;       
				КонецЦикла;   
				// Выводим значения реквизитов ТЧ
				Конт.ВыбратьСтроки();
				Пока Конт.ПолучитьСтроку()=1 Цикл
					Стр=Стр+1;
					Для А=1 По Метаданные.Документ(Вид).РеквизитТабличнойЧасти() Цикл 
						ИД=Метаданные.Документ(Вид).РеквизитТабличнойЧасти(А).Идентификатор;  
						Область=Таб.Область(Стр,А);
						Область.РамкаОбвести(3,3,3,3);
						Область.РазмерШрифта(10); 
						Если Найти(ИД,"Номенклатура")=0 Тогда
							Область.Текст=  Конт.ПолучитьАтрибут(ИД);
						Иначе     
							Атр=Конт.ПолучитьАтрибут(ИД);
							Если Атр.НеВключатьВПрайс=1 Тогда
								Область.Текст=  "З:"+Конт.ПолучитьАтрибут(ИД); 
							Иначе
								Область.Текст=  "П:"+Конт.ПолучитьАтрибут(ИД); 
							КонецЕсли;  
						КонецЕсли; 
					КонецЦикла;   
				КонецЦикла;  
			КонецЕсли;
			Таб.Опции(0,0,1,0);
			Таб.Показать("Документ "+Вид); 
		КонецЕсли;            
	КонецЕсли;     
	ФормаРасш ="";     
КонецПроцедуры 
19

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. artbear 1156 14.04.08 10:26 Сейчас в теме
А еще лучше закинуть этот код в класс 1С++ и наслаждаться в любой конфе :)
2. maloi_a 14.04.08 17:54 Сейчас в теме
Внутренний оператор Если
Код
Если (Контрол=1) И (Альт=1) И  (КодКл=80)   Тогда
Показать полностью

надо сделать внешним, т. е. поставить его первым оператором,
и процедура будет эффективной.
3. Abadonna 3833 14.04.08 17:57 Сейчас в теме
>надо сделать внешним, т. е. поставить его первым оператором,
Тут ты неправ, потому как у меня лично на
Если Тип="Документ" Тогда срабатывает еще куча всяких прибамбасов, а это только кусок
4. CheBurator 15.04.08 00:10 Сейчас в теме
..да... только русские с их изощренной фантазией могли назвать включатель выключателем...
5. O-Planet 6974 15.04.08 02:34 Сейчас в теме
Хм... А оно без FormEx-а - никак? Я вообще-то это делаю внешней обработкой...
6. Abadonna 3833 15.04.08 03:04 Сейчас в теме
>А оно без FormEx-а - никак?
>Я вообще-то это делаю внешней обработкой...
А еще можно на корове ездить, а не на лошади.
Ага! Запусти внешнюю обработку, выбери в ней документ... Планет, можно подумать, я до такой фигни не додумался.
Тут как раз весь смысл в горячих клавишах.
8. ADirks 181 15.04.08 12:37 Сейчас в теме
А кстати, на proclub'е есть обработина EditRekv.ert, которая позволяет не только просмотреть все реквизиты, но и отредактировать. Незаменимая вещь иногда.
http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=1081
9. АЛьФ 15.04.08 22:30 Сейчас в теме
2(8) На прошлой моей работе она была подвешена на "клик по пустому месту на тулбаре". Жутко удобно :)
10. GSoft 2849 15.11.08 02:47 Сейчас в теме
Немножко изменил модуль
добавил печать синонима реквизита если он не совпадает с идентификатором и расшифровка

Код
//_____________________________________________________________________________
Процедура ПриНажатииКнопкиКлавиатуры(Конт, КодКл, кнАльт, кнШифт, кнКонтрол, Символ)
   ФормаРасш = СоздатьОбъект("РасширениеФормы");   
   
   Попытка
      ФормаРасш.УстановитьФорму(Конт.Форма);
   Исключение
      Возврат;
   КонецПопытки;   
   
   Тип = ФормаРасш.ТипОбъекта();  
   
   Если Тип = "Документ" Тогда 
      //распечатка ВСЕХ реквизитов документа по горячим клавишам CTRL+ALT+P
      //начиная от общих, заканчивая ТЧ
      //(форма документа должна быть интерактивно открыта)
      Если (кнКонтрол = 1) И (кнАльт = 1) И  (КодКл = 80)   Тогда   
         Вид = Конт.Вид();  
         Таб = СоздатьОбъект("Таблица");
         Область = Таб.Область(1, 1); 
         Область.РазмерШрифта(10);
         Область.Полужирный(1);   
         Область.ВысотаСтроки(36);  
         Область.ВертикальноеПоложение(3);
         Область.Текст = Конт.ТекущийДокумент();       
         
         Область = Таб.Область(2, 1); 
         Область.РазмерШрифта(10);
         Область.Полужирный(1);   
         Область.ВысотаСтроки(12);
         Область.РамкаОбвести(3,3,3,3);
         Область.ЦветФона(200,250,225); 
         Область.ШиринаСтолбца(20);    
         Область.Текст = "ВР";       
         
         Область = Таб.Область(2,2);
         Область.РазмерШрифта(10);
         Область.Полужирный(1);   
         Область.ВысотаСтроки(12);
         Область.РамкаОбвести(3,3,3,3);
         Область.ЦветФона(200,250,225);
         Область.ШиринаСтолбца(20);    
         Область.Текст = "Реквизит";       
         
         Область = Таб.Область(2,3);
         Область.РазмерШрифта(10);
         Область.ВысотаСтроки(12);
         Область.Полужирный(1);   
         Область.РамкаОбвести(3,3,3,3);
         Область.ЦветФона(200,250,225); 
         Область.ШиринаСтолбца(20);    
         Область.Текст = "Значение";                     
         Стр = 2;        
         
         // Общие реквизиты
         Для А = 1 По Метаданные.ОбщийРеквизитДокумента() Цикл 
            Стр = Стр + 1;
            ИД = Метаданные.ОбщийРеквизитДокумента(А).Идентификатор;
            Пред = Метаданные.ОбщийРеквизитДокумента(А).Представление(); 
            Область = Таб.Область(Стр, 1);
            Область.РамкаОбвести(3,3,3,3); 
            Область.РазмерШрифта(10);
            Область.Текст = "ОБЩ"; 
         
            Область = Таб.Область(Стр, 2);
            Область.РамкаОбвести(3,3,3,3);      
            Область.РазмерШрифта(10);

            Если СокрЛП(ИД) = СокрЛП(Пред) Тогда
               Область.Текст = ИД; 
            Иначе
               Область.Текст = СокрЛП(ИД) + " (" + СокрЛП(Пред) + ")"; 
            КонецЕсли;
            
            Область = Таб.Область(Стр, 3);
            Область.РамкаОбвести(3,3,3,3);
            Область.РазмерШрифта(10);
            Область.Контроль(2);
            Область.Текст = Конт.ПолучитьАтрибут(ИД); 
            
            ТипЗначРекв = ТипЗначенияСтр(Конт.ПолучитьАтрибут(ИД));
            
            Если (ТипЗначРекв = "Справочник") или (ТипЗначРекв = "Документ") Тогда
                Область.Расшифровка(Конт.ПолучитьАтрибут(ИД)); 
            КонецЕсли;
         КонецЦикла;         
         
         // Реквизиты шапки
         Для А = 1 По Метаданные.Документ(Вид).РеквизитШапки() Цикл  
            Стр = Стр + 1;
            ИД = Метаданные.Документ(Вид).РеквизитШапки(А).Идентификатор; 
            Пред = Метаданные.Документ(Вид).РеквизитШапки(А).Представление(); 
            Область = Таб.Область(Стр, 1);
            Область.РамкаОбвести(3,3,3,3);
            Область.РазмерШрифта(10);
            Область.Текст = "  Ш"; 
            
            Область = Таб.Область(Стр, 2);
            Область.РамкаОбвести(3,3,3,3);
            Область.РазмерШрифта(10);
            
            Если СокрЛП(ИД) = СокрЛП(Пред) Тогда
               Область.Текст = ИД; 
            Иначе
               Область.Текст = СокрЛП(ИД) + " (" + СокрЛП(Пред) + ")"; 
            КонецЕсли;
            
            Область = Таб.Область(Стр, 3);
            Область.РамкаОбвести(3,3,3,3);
            Область.РазмерШрифта(10);   
            Область.Контроль(2);
            Область.Текст = Конт.ПолучитьАтрибут(ИД); 

            ТипЗначРекв = ТипЗначенияСтр(Конт.ПолучитьАтрибут(ИД));
            
            Если (ТипЗначРекв = "Справочник") или (ТипЗначРекв = "Документ") Тогда
                Область.Расшифровка(Конт.ПолучитьАтрибут(ИД)); 
            КонецЕсли;
         КонецЦикла;  
         
         Если Конт.КоличествоСтрок()>0 Тогда
            Стр = Стр + 1;  
            // выводим заголовки ТЧ (идентификаторы реквизитов)
            Для А = 1  По Метаданные.Документ(Вид).РеквизитТабличнойЧасти() Цикл
               ИД = Метаданные.Документ(Вид).РеквизитТабличнойЧасти(А).Идентификатор;    
               Пред = Метаданные.Документ(Вид).РеквизитТабличнойЧасти(А).Представление(); 
               Область = Таб.Область(Стр, А); 
               Область.РазмерШрифта(10);
               Область.Полужирный(1);   
               Область.ВысотаСтроки(12);
               Область.РамкаОбвести(3,3,3,3);
               Область.ЦветФона(200,250,225);    
               Область.ШиринаСтолбца(20);    
               Область.Контроль(2);

               Если СокрЛП(ИД) = СокрЛП(Пред) Тогда
                  Область.Текст = ИД; 
               Иначе
                  Область.Текст = СокрЛП(ИД) + " (" + СокрЛП(Пред) + ")"; 
               КонецЕсли;
            КонецЦикла;         
            
            // Выводим значения реквизитов ТЧ
            Конт.ВыбратьСтроки();
            Пока Конт.ПолучитьСтроку() = 1 Цикл
               Стр = Стр + 1;
               Для А = 1 По Метаданные.Документ(Вид).РеквизитТабличнойЧасти() Цикл 
                  ИД = Метаданные.Документ(Вид).РеквизитТабличнойЧасти(А).Идентификатор;  
                  Область = Таб.Область(Стр, А);
                  Область.РамкаОбвести(3,3,3,3);
                  Область.РазмерШрифта(10); 
                  Область.Текст = Конт.ПолучитьАтрибут(ИД); 

                  ТипЗначРекв = ТипЗначенияСтр(Конт.ПолучитьАтрибут(ИД));
                  
                  Если (ТипЗначРекв = "Справочник") или (ТипЗначРекв = "Документ") Тогда
                     Область.Расшифровка(Конт.ПолучитьАтрибут(ИД)); 
                  КонецЕсли;
               КонецЦикла;   
            КонецЦикла;  
         КонецЕсли;
      
         Таб.Опции(0,0,1,0);                 
           Таб.ТолькоПросмотр(1);
         Таб.Показать("Документ " + Конт.ТекущийДокумент()); 
      КонецЕсли;            
   КонецЕсли;     

   ФормаРасш = "";     
КонецПроцедуры 
Показать полностью
Abadonna; +1 Ответить
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков 147

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    62640    Serginio    104       

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7 11

Статья Программист Нет файла v7.7 1cv7.md Windows Бесплатно (free) Практика программирования Универсальные функции

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    13718    Anzhey    13       

Получение характеристик и управление текущим процессом 1С на основе WMI 36

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Универсальные функции

Функционал для работы из 1С с текущим процессом класса Win32_Process. Пример получает текущее значение ОЗУ занятое процессом 1С. По описанной методике можно получать значения пиковых нагрузок на ОЗУ, время запуска текущей сессии 1С с точностью до миллисекунд. Определять загрузку активного ядра процессом и даже поменять приоритет самого процесса.

09.07.2012    18934    dusha0020    8       

Хитрость. Использование БУЛЕВО при OLE обмене/подключении из 7.7 к 8 17

Статья Системный администратор Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Перенос данных из 1С7.7 в 1C8.X Универсальные функции

Как известно, при OLE обмене доступны только типы СТРОКА, ЧИСЛО, ДАТА. А вот БУЛЕВО (ИСТИНА, ЛОЖЬ) использовать при подключении из 7.7 к 8 не получается. Как же быть? Есть хитрость, как использовать тип булево в семерке при обмене с 1С8! :)

28.09.2011    14025    bsturtle    9       

Регистр учета удержанных и перечисленных сумм по исполнительным документам 1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Печатные формы документов

Заполните банковские реквизиты получателя и выберите способ - перечисление на банковский счет, тогда будут выводится банковские данные. Если в текущем месяце выплачена ЗП, тогда Фактически удержано = Следовало удержать.

04.07.2011    5764    41    fisgen    3       

Транспортная накладная с 25.07.11 для 1С Предприятие 7.7 (Комплексная конфигурация) 26

Отчеты и формы Бухгалтер no Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1С7:Комплекс Россия Учет ТМЦ Бесплатно (free) Печатные формы документов

Печатная форма включенная в 7.70.508 релиз Комплексной конфигурации. Правом использования обладают подписчики диска ИТС. Изменён интерфейс под разрешение экрана 1024х768.

24.06.2011    13682    426    Kurt    24       

Быстрый поиск подчиненного документа, с помощью прямого запроса 1

Статья Программист Нет файла openconf 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

При ситуации, когда необходимо проверить, есть ли у документа подчиненный документ, конкретного вида или нет, если есть, вывести на экран, в этой ситуации будет полезна следующая функция глобального модуля. Работает только в SQL версии и при установленной внешней компоненте 1С++ !

26.05.2011    11461    Vix    1       

Ведомость выдачи материальных ценностей на нужды учреждения (ОКУД 0504210) на 2 листах 14

Отчеты и формы Бухгалтер Архив с данными v77::БУ 1С7:ББУ Россия БУ Учет ТМЦ Бесплатно (free) Печатные формы документов

Бюджетной инструкцией предусмотрена иная форма Ведомости выдачи материальных ценностей на нужды учреждения. Оригинальная форма располагается на двух листах титульном и собственно форма.

03.05.2011    43355    85    ipeg43    5       

Посчитать людей по XML-файлам, выгруженным для ПФ 2010 7

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК БУ НУ Windows Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Обмен через XML Универсальные функции

Обработка считает и выводит людей, которые находятся в xml-файлах для пенсионного фонда. Также может служить "рыбой" для дополнительной обработки данных в файлах пенсионного фонда

24.01.2011    10377    81    kserdyukov    1       

Программное изменение текста в надписях Word 27

Статья Программист Нет файла v7.7 1cv7.md Windows Бесплатно (free) Печатные формы документов Практика программирования

Печатная форма договора в шаблоне Word. Реквизиты в 1С. Заполнение шаблона реквизитами: все стандартно, но в надписях долго получалось. Получилось :) Может кому пригодится.

06.12.2010    15317    АннаШ    10       

Печатные формы приходного и расходного кассового ордера с выводом 26-значного номера бухгалтерского счета 10

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:ББУ Россия БУ Кассовые операции Бесплатно (free) Печатные формы документов

Некоторые бухгалтера не желают распечатывать бухгалтерскую справку к документу ПКО или РКО, а хотят видеть полные номера счетов (с КБК) прямо в печатной форме ПКО и РКО. Выглядит странно, но тем не менее...

21.09.2010    12250    176    ipeg43    6       

Счет-фактура с 02.09.2010 (Бух 7.7) 53

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) Бесплатно (free) Печатные формы документов

Внесены изменения в гл. 21 «Налог на добавленную стоимость» НК РФ, которые вступают в силу со 2 сентября 2010 г.

25.08.2010    11505    1359    coredump    49       

ТОРГ-2 для Производства 7.7 4

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:ПУБ Россия БУ Учет ТМЦ Бесплатно (free) Печатные формы документов

Дополнительная печатная форма ТОРГ-2 "АКТ ОБ УСТАНОВЛЕННОМ РАСХОЖДЕНИИ ПО КОЛИЧЕСТВУ И КАЧЕСТВУ ПРИ ПРИЕМКЕ ТОВАРНО-МАТЕРИАЛЬНЫХ ЦЕННОСТЕЙ" для документа "Возврат поставщику" для конфигурации Производство+услуги+бухгалтерия 7.7. Испробовалось на релизе 7.70.302. Графы заполнены какие возможно заполнить автоматически, остальное вручную.

18.08.2010    7319    202    sib-fin    3       

Универсальный фильтр 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Универсальные функции

Удобный фильтр. Нет необходимости вешать на форму N-ое количество списков значений.

08.07.2010    8710    115    ShEvOvIcH    8       

Мьютексы в 1С 7.7 10

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Файловые протоколы обмена, FTP Универсальные функции

Существует ряд задач, которые требуют строго последовательного исполнения. Чаще всего это возникает при многопоточном программировании, в этом случае используются критические секции, но иногда надо синхронизировать и разные приложения - для этого существуют такие объекты ядра операционной системы как Мьютекс-ы. http://ru.wikipedia.org/wiki/Мьютекс В статье рассказывается как можно сделать аналогичный объект средствами 1С v7.7

02.07.2010    12235    Sk0rp    24       

Обработка для поиска Контрагентов 9

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Поиск данных Обработка справочников Универсальные функции

Не первая и не последняя.. Не лучшая, и не худшая. Просто вариант поиска контрагентов по нескольким словам или их частям в наименовании.

19.05.2010    8653    108    aka AMIGO    7       

Как получить GUID без v7plus.dll в Предприятии 7.7 10

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

Часто в терминальных сессиях у пользователю Windows не хватает прав на регистрацию v7plus.dll. Соответственно нельзя воспользоваться, например методом СоздатьGUID() класса V7SysInfo.

12.05.2010    12216    prolancer    5       

Алгоритм расчета периодов 3

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

Вычисление периодов в формате ГГММДД. Вычисление дат по формуле Дата + ГГММДД. Примечание: Даты передаем в виде 'ДД.ММ.ГГГГ', периоды - "ГГ-ММ-ДД". Пользуйтесь.

10.03.2010    8260    arithmometr    1       

Интервал дат прописью 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Windows Бесплатно (free) Универсальные функции

Иногда возникает необходимость подсчитать количество дней, недель, месяцев или лет в интервале дат и вывести результат прописью. Обработка предназначена для демонстрации работы функции ПолучитьИнтервалДат(Дата1,Дата2,Период) Используется стандартный файл прописи для рублей. Специально не оптимизировал функции, чтобы каждый мог настроить их под свои требования.

15.02.2010    7756    143    Vlan    3       

Печать документа "Расходная накладная" в других (дополнительных) единицах измерения. 1С:Бухгалтерия 7.7 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Windows Учет ТМЦ Бесплатно (free) Печатные формы документов Практика программирования

Печать и редактирование табличной части расходной накладной (Бухгалтерия 7.7) в других единицах (требуется создать в Конфигураторе дополнительный справочник единиц измерения).

04.02.2010    3415    31    AgainSlash    2       

Печать ценников 7

Отчеты и формы Внешняя обработка (ert,epf) v77::БУ 1С7:Бух БУ Windows Розничная торговля Ценообразование, анализ цен Бесплатно (free) Печатные формы документов Ценники

Пытался создать обработку печати ценников для Бухгалтерии 7.7. В моем случае я привязывал её к документу "Перемещение", но это не обязательно. Прекрасно работает и с документами "Поступление" и "Реализация"

12.01.2010    10063    305    Maks_Alexey    22       

Печатная форма приказа на отпуск для Бух. 7.7 21

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия Управление персоналом (HRM) Бесплатно (free) Печатные формы документов

Внешняя печатная форма Приказа на отпуск для Бухгалрерии 7.7 Кто-то просил здесь ... Выкладываю

11.01.2010    11734    338    Доня    16       

1С Предприятие 7.7 и Mozilla Thunderbird. Отправка писем из командной строки 5

Статья Системный администратор Программист Нет файла v77::ОУ v77::БУ 1cv7.md 1С7:Бух Windows Бесплатно (free) Универсальные функции Email

Клиент захотел чтобы у него из 1С формировались письма с вложениями и отправлялись через Mozilla Thunderbird. Из этого вышла маленькая процедура.

30.11.2009    12464    kasperok    15       

Спецификация для Беларуси 0

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия Оптовая торговля Бесплатно (free) Печатные формы документов

Внешняя печатная форма "Спецификация" для документа "Отгрузка товаров, продукции". Конфигурация 1С: Бухгалтерский учет 7.7.

28.11.2009    2728    21    Maruska77    3       

Протокол согласования цен 11

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Windows Документооборот и делопроизводство Бесплатно (free) Печатные формы документов

Протокол согласования цен для документа "Поступление товаров". Платформа 1С Предприятие 7.7. Конфигурация 1С Бухгалтерский учет. Выкладываю первый раз, не совсем моё, переделанное. Надеюсь кому-нибудь пригодится. Позволяет печатать протокол за поставщика. Не судите строго, я просто бухгалтер :-)

27.11.2009    6339    125    kalitwa    14       

Печатная форма Договора для расходной накладной для Бух. 7.7 20

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух БУ Windows Документооборот и делопроизводство Бесплатно (free) Печатные формы документов

Добавляется либо через регистрацию внешних форм для расходной накладной, либо открывается через Меню/Открыть/Файл.

19.11.2009    12372    283    Доня    18       

Транслитерация в латиницу 39

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

При отправке SMSок из 1С столкнулся с тем, что текст отправлялся только латиницей, а данные-то в кириллице. В результате написал функцию перевода текста в латиницу. Может, кому-нибудь пригодится

02.10.2009    24272    yuraer    17       

Акт списания (Приказ) 45

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Учет ТМЦ Бесплатно (free) Печатные формы документов

Акт списания и приказ о назначении комиссии по списанию материалов в одном внешнем отчете

14.09.2009    10998    440    miv    19       

Альтернатива стандартному предупреждению(вопросу) 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Работа с интерфейсом Универсальные функции

Начальство решило, что на предупреждения оформляемые стандартными средствами 1С малоприметны... В результате родилась прикольная штучка... Вывод текста сообщения бАААААльшими буквами, цвет можно задавать. 7 кнопок видимость и текст задаются при вызове Возвращает текст нажатой кнопки..... ВК у нас не применяются...

28.08.2009    9117    59    nikakoy    29       

Печатная форма МБ-2 15

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Учет ТМЦ Бесплатно (free) Печатные формы документов

Печатная форма документа МБ-2 для бухгалтерии 7.7. Прицепляется к документу "Передача материалов в эксплуатацию".

26.08.2009    8938    201    elisabet    19       

Форма Счета-фактуры для ТиС (Внешние печатные формы) 7

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия БУ Оптовая торговля Бесплатно (free) Печатные формы документов

Внешние печатные формы для ТиС ред. 9.2 (С выбором Грузополучателя и ГТД из Справочника Номенклатура).

19.06.2009    6578    126    unpased    8       

Счет-Фактура 2012 г. №1137 с дополнительными возможностями 44

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::ОУ 1С7:Комплекс 1С7:ТиС Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) Бесплатно (free) Печатные формы документов

Данные печатные формы предназначены для печати практически всех форм Счетов-Фактур (СчФ 2000, 2001, 2002, 2004, 2006, 2009, 2010 и 2012 гг.) Чем отличается от типовой? Да ничем. Сервиса побольше. Как то: Выбор подписантов, выбор Грузоотправителя и Грузополучателя (как в бухгалтерии), печать Альбом и Портрет Да опечатки типовой подчистил немного.

18.06.2009    19678    450    ufo58    24       

Счет-фактура с 09.06.2009 (Бух 7.7) 187

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Оптовая торговля Бесплатно (free) Печатные формы документов

09.06.09 вступило в силу постановление Правительства РФ от 26.05.09 № 451. Теперь в строке 2 счет-фактуры указываются 2 наименования продавца - полное и сокращенное. Минфин подтверждает, что в постановлении нет опечатки ( http://www.gazeta-unp.ru/unp.pl?page=newstape&id=10059 ). Это новая форма счет-фактуры в виде внешней печатной формы для типовой 1С:Бухгалтерии 7.7 (проверена в релизе 506). Изменения в конфигурацию вносить не требуется.

11.06.2009    18869    1920    Antia    83       

[ОБМЕН] Формирование файла заказа поставщику 8

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия Windows Монитор заказов Бесплатно (free) Печатные формы документов Загрузка и выгрузка в Excel WEB

1C v.7.7 Внешняя печатная форма, предназначена для формирования файла заказа поставщику и выполнения с ним простейших действий. Подключается как внешняя печатная форма к документу "Заказ поставщику". Обработка простая, представляет интерес для начинающих не особо продвинутых программистов 1С.

29.05.2009    14890    184    CheBurator    2