IE2017

Заполнение документа «Перемещение материалов» либо по остаткам на складе, либо по приходу за период.

Обработки - Обработка документов

В форму документа добавила кнопку «Заполнить», при нажатии на которую выводится меню: 1 По остаткам на складе 2 По приходу за период. Перед заполнением документ должен быть записан.

Для добавления доработки в свою конфигурацию скачанный файл нужно разархивировать, зайти в 1С в режиме конфигуратора, затем в меню Конфигурация – Объединение конфигураций выбираем файл, ставим галочку на документе ТребованиеНакладная, остальные снимаем, приоритет конфигурации выбираем загружаемая конфигурация, метод объединения – замещать объекты и жмем кнопку ОК.

Скачать файлы

Наименование Файл Версия Размер
1CV7.zip
.zip 4,89Mb
27.03.13
37
.zip 4,89Mb 37 Скачать

См. также

Комментарии
1. Дониэла Иванова (Доня) 267 27.03.13 11:58 Сейчас в теме
Спасибо, работает. Удобно и экономит время.
2. Светлана Иванова (Cvetic) 304 27.03.13 13:42 Сейчас в теме
При обновлении программы на новый релиз настройка может слететь. Чтобы этого не произошло нужно при каждом обновлении снимать галочку с документа ТребованиеНакладная.
3. Дониэла Иванова (Доня) 267 27.03.13 14:29 Сейчас в теме
Да. Я это знаю, спасибо.
А как решить задачу, чтобы ТребованиеНакладная заполнялась на основания ПоступлениеМатериалов.
В ПУБ 7.7 решена такая задача, а в Бух.7.7 не могу допетрить.
Куда что дописать ???
Помогите, если можете.
4. Светлана Иванова (Cvetic) 304 27.03.13 17:00 Сейчас в теме
В документе ТребованиеНакладная нажать кнопку Ввод на основании и в левой колонке Вводить на основании поставить галочку напротив ПоступленияМатериалов. Затем писать процедуру ВводНаОсновании().
5. Светлана Иванова (Cvetic) 304 27.03.13 17:06 Сейчас в теме
Процедура ВводНаОсновании(Док)
ДатаДок = Док.ДатаДок;
МестоХранения = Док.МестоХранения;
ВидПеремещения = 0;
ВидПеремещенияМПЗ.ТекущаяСтрока(1);
УправлениеДиалогом();
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку()=1 цикл
Есть=0;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 цикл
Если Материал = Док.Материал тогда
КоличествоЗатребовано = КоличествоЗатребовано + Док.Количество;
КоличествоОтпущено = КоличествоЗатребовано;
Есть=1;
КонецЕсли;
КонецЦикла;
Если Есть=0 тогда
НоваяСтрока();
Материал = Док.Материал;
КоличествоЗатребовано = Док.Количество;
КоличествоОтпущено = КоличествоЗатребовано;
КонецЕсли;
КонецЦикла;
Новый = 1;
КонецПроцедуры
6. Дониэла Иванова (Доня) 267 27.03.13 17:48 Сейчас в теме
Огромное Вам спасибо!
Все формируется и дата, и склад, и материалы, и количество.
Только еще я в "ПоступлениеМатериалов" тоже поставила галочку на "ТребованиеНакладная" ввод на основании, тогда все открылось.
Спасибо!
7. Екатерина Еремичева (superket_12) 27.03.13 19:57 Сейчас в теме
8. Иваныч Иванов (Иваныч) 22 29.03.13 09:29 Сейчас в теме
(3) Доня,
Посмотри поКнопкеДействия добавитьИзДокумента
Я обычно делаю так, потом корректирую ручками данные и вуаля.
9. Светлана Иванова (Cvetic) 304 29.03.13 11:08 Сейчас в теме
(8)Иваныч, у нас 7-ка, а ДобавитьИзДокумента в 8-ке.
10. Ольга Ольга (olga19700101) 20.10.13 18:46 Сейчас в теме
Спасибо! Очень экономит время!
11. Сергей (Che) Коцюра (CheBurator) 3387 23.11.13 23:19 Сейчас в теме
Оценка неудовлетворительно.
Требуемого действия можно добиться без изменения конфигурации, всего лишь подключением внешних печатных форм, выполняющих требуемое.
12. Светлана Иванова (Cvetic) 304 25.11.13 09:12 Сейчас в теме
13. Ольга Устинова (olga_orkom) 20.01.14 21:34 Сейчас в теме
Внешняя обработка конечно хорошо. А в документе бухгалтеру приятнее. Тем более базу изменяем совсем чуть-чуть и при обновлении забудешь, так ничего страшного не произойдет. Просто бухгалтер любимую кнопку потеряет:)
Спасибо.
Оставьте свое сообщение