Универсал 2.7i - универсальный перенос справочников документов констант 1С:7.7 © Шевченко Павел

Обработки - Обработка документов

132
Набор инструментов обмена 7.7-7.7 universal.ert с довесками от друзей проекта

Универсальный обмен данными через OLE

Пофиксен перенос реквизитов типа ВидРасчета и т.п.

132

Скачать файлы

Наименование Файл Версия Размер
Universal 2.7i (bugfix280909)
.zip 166,41Kb
11.01.10
3118
.zip 166,41Kb 3118 Скачать бесплатно

См. также

Комментарии
Сортировка: Древо
1. support 4405 18.02.09 11:04 Сейчас в теме
Шевченко Павел знает об этом?
2. Altez 252 18.02.09 12:15 Сейчас в теме
pavelshev@svitonline.com
Не удалось связаться, если кто поможет - буду рад.
К тому же А.Геринг поучаствовал, не оставив адреса.
И бета как-никак..

цитата из ридми

© Шевченко Павел, pavelshev@svitonline..com, Киев, 2000-2004

Последнюю версию обработки всегда можно найти в разделе репозитария на сайте www.itland.ru

Стоимость полной версии 10$, способ оплаты www.webmoney.ru,
мой ящик № 627369820689
мой кошелёк № Z847190207956

Полная версия отличается от демо только возможностью сохранения правил
настроки. Поэтому перед покупкой убедитесь что демо версия
Вас полностью устраивает.
3. CheBurator 19.02.09 00:16 Сейчас в теме
по поводу переноса операций и проводок - я имел в виду нормально ли переносит ручные операции? в т.ч. с проводками, где субконото в пофигураторе определены как "общего" вида (т.е. типа "Справочник" или "Неопределенный")..???
4. Sk0rp 109 19.02.09 19:33 Сейчас в теме
Заметил только одно отличие от http://infostart.ru/projects/3429/
это добавленную в Universal.ert строку:
Если колОбъектовВтранзакции=0 Тогда колОбъектовВтранзакции=1 КонецЕсли;//+Altez-
Других отличий нет. Здорово было бы это написать в описании, т.к. нифига не ясно почему надо брать ту или эту.
И зачем в архив вложен лог вашей конвертации и настройки от непонятно какой конфигурации?
6. Altez 252 20.02.09 09:31 Сейчас в теме
(4) при апдейте недостерилизовал, поправим.
Брать любую, только 3459 без транзакции в критеррор не вылетает.
5. Altez 252 20.02.09 09:28 Сейчас в теме
Аве Шевченко, сменил тип скт "СтавкаНДС" на "Справочник", операция перенеслось в обе стороны безупречно.

Че, а где тебе встретилось "Неопределено" в качестве типа субконто?
7. Sk0rp 109 20.02.09 14:08 Сейчас в теме
1. Есть возможность переносить документы с новыми номерами?
Т.е. если в приемнике уже есть документ с таким номером - создавать новый документ и переносить данные в него.

2. Есть ли возможность синхронизировать в справочниках только пометки на удаление?

3. Не переносится история периодических реквизитов справочника, это бага или я настройку какую-то не заметил?
8. Altez 252 20.02.09 14:23 Сейчас в теме
(7)1,2,3 Не делал,
Автор грит: Доп.настройки работают не все, надо тестить
50. ВладАн 15.11.11 05:35 Сейчас в теме
по синхронизации...
ПС или это Павел планировал?
ПСПС А вопрос снимается сам нашел цитату
Altez пишет:

(7)1,2,3 Не делал,

Автор грит: Доп.настройки работают не все, надо тестить
9. Altez 252 20.02.09 15:11 Сейчас в теме
реквизит-ключ синхронизации (красный квадрат) для реквизитов спр. и доков выбирается, работает,

1)по 2клику на строку колонки "Соответствие" для доков есть возможность Создавать новые и перезаписывать существующие вроде.
10. Altez 252 20.02.09 15:15 Сейчас в теме
* спр. и доков - только спр.
доки по периоду и номеру синхронизуются
11. CheBurator 20.02.09 16:05 Сейчас в теме
Но! обработка не различает документов, которые лежат в одном дне с одинаковыми номерами... Например: имея в одном дне две счф с одинаковыми номерами - при переносе "сливает" в одну - и имеем последнюю... понятно, что это скорее "бага" базы-источника...
12. Sk0rp 109 20.02.09 19:13 Сейчас в теме
Для чего нужно создание нового документа (пример реальной сегодняшней ситуации):
Оператор , видимо недостаточно проснувшись, утром открыл копию базы для с ночной выгрузкой для отчетов, и пол дня колотил туда документы, параллельно с ним остальные более сознательные работали в основной базе. Номера там и там получались по порядку одни и теже. Когда это вскрылось встал вопрос: "Что делать?". Я решил все же помочь человеку и не заставлять вручную повторять работу, а перенести этой обработкой и наткнулся на то, что документы не переносятся, т.к. с таким номером за эту дату в приемнике уже есть. Пришлось сначала перенумеровать документы в источнике, после этого все прошло замечательно. но идея, что такой функционал был бы полезен - появилась.

Еще не хватает следующего: указывать какие документы тянуть за собой по ссылкам, а какие нет. Сейчас можно ограничить только период.
13. Altez 252 23.02.09 00:01 Сейчас в теме
Чтобы не перезаписывать документы, патчим строки
4157
Код
   Если БазаДок.НайтиПоНомеру(Док.НомерДок,Док.ДатаДок,ИдентДок)=1 
Показать полностью

на
Код
   Если 0=1 
Показать полностью

и
4182
Код
      БазаДок.НомерДок=Док.НомерДок;
Показать полностью

на
Код
      БазаДок.НомерДок=Док.УстановитьНовыйНомер();
Показать полностью


Будет время допишу окно с выбором конкретных доков и спр. для переноса.
14. Altez 252 23.02.09 14:44 Сейчас в теме
*
Код
БазаДок.НомерДок=БазаДок.УстановитьНовыйНомер();
Показать полностью

15. Altez 252 23.02.09 14:44 Сейчас в теме
мдя
Код
БазаДок.УстановитьНовыйНомер();
Показать полностью

Паланик; +1 Ответить
16. Паланик 8 05.03.09 06:32 Сейчас в теме
(15) Обнаружил глюк, не пойму, у меня или у обработки проблемы...
Перенесся документ в приемник. Открываю, счет указан, виды субконто перенеслись, а сами субконто нет. Лечится перевыбром счета и повторной переброской с галочкой "перезаписывать". Но это ж не дело. Наверное, что-то не настроил? Подскажи, плиз...
Muller2306; +1 Ответить
63. Muller2306 26.02.12 18:35 Сейчас в теме
(16) Паланик,

Вместо

Если ТабДокТЛок.ТипСоот="Неопределенный" Тогда
БазаДок.НазначитьТип(ТабДокТЛок.РеквСоот,глТипЗначенияОЛЕ);
КонецЕсли;

попробуйте

Попытка
БазаДок.НазначитьТип(ТабДокТЛок.РеквСоот,глТипЗначенияОЛЕ);
Исключение
КонецПопытки;

и вместо

Если (ТабДокШоЛок.ТипСоот="Неопределенный") Тогда
БазаДок.НазначитьТип(ТабДокШоЛок.РеквСоот,глТипЗначенияОЛЕ);
КонецЕсли;

вот это

Попытка
БазаДок.НазначитьТип(ТабДокШоЛок.РеквСоот,глТипЗначенияОЛЕ);
Исключение
КонецПопытки;
17. Altez 252 05.03.09 20:32 Сейчас в теме
18. Andzhej 19.05.09 13:58 Сейчас в теме
не коректно переносит рекв. типа "Вид расчетов" - 2-е одинаковые базы 7.7 (скуль и дбф): перенос из скуль в дбф
сами выди расчетов сопоставленны коректно
19. Andzhej 19.05.09 13:59 Сейчас в теме
т.е. может ввобще не перенести или перенести частично
20. Andzhej 24.05.09 16:05 Сейчас в теме
21. Andzhej 24.05.09 16:06 Сейчас в теме
PS вообще не переносит реквизита типа "Виды расчетов"
22. Andzhej 25.05.09 10:53 Сейчас в теме
строки 4012 - 4027 (в bugfixed):
ИначеЕсли Типок=13 Тогда
ТипЗначОЛЕ="Календарь";
Возврат ПолучитьКалендарь(Рекв);
ИначеЕсли Типок=14 Тогда
ТипЗначОЛЕ="ВидРасчета";
Возврат ПолучитьВидРасчета(Рекв);
ИначеЕсли Типок=15 Тогда
ТипЗначОЛЕ="Счет";
Возврат ПолучитьСчет(Рекв);
ИначеЕсли Типок=16 Тогда
ТипЗначОЛЕ="ВидСубконто";
Возврат ПолучитьВидСубконто(Рекв);
ИначеЕсли Типок=17 Тогда
ТипЗначОЛЕ="ПланСчетов";
Возврат ПолучитьПланСчетов(Рекв);
КонецЕсли;

добавить "Возврат"и все ОК
23. Andzhej 25.05.09 10:55 Сейчас в теме
24. vasjos 04.08.09 22:22 Сейчас в теме
Не переносит реквизиты документов неопределенного типа :-(
25. Altez 252 04.08.09 23:35 Сейчас в теме
27. CheBurator 3558 18.09.09 18:02 Сейчас в теме
29. Altez 252 26.09.09 22:47 Сейчас в теме
(27)перезалил с учетом (22) и
//Возврат База.ВидРасчета.ПолучитьАтрибут(ИдентРасчетПриемника);
//не возвращет видРасчета
Возврат База.ВидРасчета.GetAttrib(ИдентРасчетПриемника);
30. CheBurator 3558 26.09.09 23:54 Сейчас в теме
(29) Спасибо!!!
.
а насчет 7.7 теряет актуальность - конечно не в первых рядах.. но очень долго будет еще жива...
26. samaragips 31.08.09 11:16 Сейчас в теме
>о-па, пример плз
из ЗИК в ЗИК - документ НачисленияУдержанияСотрудника - реквизит "Расчет"
я так понимаю его и не реализуешь в данной обработке :(
28. Altez 252 23.09.09 23:21 Сейчас в теме
(26),(27) в ЗиК ещё не пригождалась, к тому же актуальность разработки под 7.7 падает, как и смысл тюнить шедевр, теперь в музей
31. Linx 11.10.09 22:51 Сейчас в теме
добавьте в обработку возможность переносить остатки за определенный период (между одинаковыми конфигурациями) через ОЛЕ. Спасиб
32. Altez 252 13.11.09 14:03 Сейчас в теме
так "остатки" надо свернуть в операцию (в документ)
обработкой типа rap.ert c инфостарта или wrap.ert c ИТС
а потом го перенос
33. CheBurator 3558 11.01.10 13:29 Сейчас в теме
А кто скажет - толком разъяснит - Универсал и Универсам - это что? какая из них правильнее???
34. Ёпрст 1027 11.01.10 13:45 Сейчас в теме
35. Altez 252 11.01.10 15:33 Сейчас в теме
(33) форки разных афторофф. Убрал -сам и -сал, оставил 2.7i как более свежий.
36. CheBurator 3558 11.01.10 15:47 Сейчас в теме
(35) а не скинуть ли тебе вариант которым я пользовался - там тоже был ряд багов устранен - сравнить тексты и пополнить текущую версию???
pro100vova; +1 Ответить
37. Altez 252 12.01.10 16:06 Сейчас в теме
(36) с радостью, как найти/опознать этот вариант?
38. CheBurator 3558 12.01.10 17:47 Сейчас в теме
(37) кинь на e.meil@mail.ru свое мыло
отправлю вечером из дома
39. CheBurator 3558 12.01.10 17:48 Сейчас в теме
заголовок разработки поправь: "..- унивеРсальный"
40. maikl73 02.08.10 18:36 Сейчас в теме
Даже не удается запустить :?:

Если База.Метаданные.Перечисление()=0 Тогда
{D:\UNIVERSAL 2.7\UNIVERSAL.ERT(2168)}: Значение не представляет агрегатный объект (Метаданные)
41. andnik78 30.09.10 11:55 Сейчас в теме
Пожалуйста, вышлете мне полную обработку Универсал 2.7 на andnik78@mail.ru
42. Altez 252 30.09.10 21:40 Сейчас в теме
(41)Неужто не скачивается? И мыло спамерам скормил..
43. hungryjam 07.08.11 20:52 Сейчас в теме
если тип реквизита документа не определен и в нем число, то не учитывает размерность и преобразует все числа в целое с 5 знаками.

для исправления кому надо везде по тексту где найдете функцию "НазначитьТип" сделайте подобные правки:
было:
ПериодПерПри.НазначитьТип(глТипЗначенияОЛЕ);

стало:
Если глТипЗначенияОЛЕ="Число" Тогда
ПериодПерПри.НазначитьТип(глТипЗначенияОЛЕ,15,5);
Иначе
ПериодПерПри.НазначитьТип(глТипЗначенияОЛЕ);
КонецЕсли;
44. alfia 30.09.11 06:41 Сейчас в теме
45. 2011b11 05.10.11 09:09 Сейчас в теме
Спасибо вам за обработку
46. baza1978 28.10.11 14:27 Сейчас в теме
спасибо автору, автор пищи еще.
47. Nikola178 7 08.11.11 13:03 Сейчас в теме
Автору большое спасибо, обработка лучшая из всех, которыми доводилось пользоваться при переносе.(конечно не без недостатков, как было писано выше)
48. ВладАн 14.11.11 15:36 Сейчас в теме
Что-то, как-то тюнинг застоялся. Пора-бы уже и доп. настройки доделать:)
49. Altez 252 14.11.11 16:39 Сейчас в теме
(48)8ка не пускает. а что за настройки?
51. post279 21.11.11 09:12 Сейчас в теме
52. T-AleXandr 24.11.11 21:07 Сейчас в теме
Использовал несколько раз на разных базах. Где-то прокатывало, где-то нет. Так что есть и плюсы и минусы.
53. dicwork 16.12.11 17:33 Сейчас в теме
Не пойму как открыть базу источник. При открытии внизу справа базы источника обработка пытается открыть файл с расширением UNI.
А как указать базу откуда копировать?
54. dicwork 19.12.11 15:42 Сейчас в теме
А есть ли где нибудь документация по пользованию этой обработкой. По ReadMe понять как работать довольно сложно. Потратил кучу времени пока выяснил, что база источник это база откуда запускается обработка. Есть ли где-то в природе описание работы с этим мощным инструментом или как всегда нужно осваивать "методом тыка"?
57. Altez 252 21.12.11 23:05 Сейчас в теме
(54) вникал нажимая кнопки слева направо сверху вниз, в тяжелых случаях открывал отладчик,
мы ж не в ЦУПе, а какой случай по-вашему нужно задокументировать или экранизировать?
55. Arico 21.12.11 13:30 Сейчас в теме
Как я могу купить данную обработку, чтобы она сохраняла настройки? По е-майл, указанному в обработке, связаться с Шевченко Павлом не удается
56. Altez 252 21.12.11 22:56 Сейчас в теме
(55) Arico, у меня сохраняла, что из настроек не сохранилось?
58. vas5780 41 28.12.11 05:54 Сейчас в теме
Попробую перенести справочники из Бух Бух, как получится постараюсь отписаться.
59. nkorkin 08.01.12 14:53 Сейчас в теме
Как перенести документы из ТиС в ТиС, справочник единицы не синхронизируется т.к. код и наименование нулевой длины? Ошибка: Для справочника Единицы не установлен ключ синхронизации!
60. Altez 252 09.01.12 14:11 Сейчас в теме
(59) nkorkin, изв. уже не помню как синхронилось, буду рад, если кто недавно переносил решение обубликует
65. trioka 19.03.12 16:51 Сейчас в теме
(59) nkorkin,
ты решил проблему? у меня даже если поставить синхронизацию по ОКЕИ то все равно фигня какаято получается, типа невозможно сохранить.... бла бла бла...
Ругается - переносит. в с базовых единицах пусто.
как перенести справочник только номенклатуры? ну со всеми единицами и штрих-кодами конечно.
если даже не с этой обработкой, то какие есть еще варианты?
68. isaev 100 30.05.12 22:55 Сейчас в теме
(59) То же никак... Правда база приемник очень сильно переписана, но и между двумя "стандартными" ТиС с ошибками. : (
69. MasterCifra 05.12.12 15:23 Сейчас в теме
(59) nkorkin, Добрый день. Подскажите - вы решили проблему или нет? у меня сейчас такая же ошибка не дает перенести еденицу измерения в номенклатуре, а справочник насчитывает порядка 16000 едениц
71. Altez 252 05.12.12 15:43 Сейчас в теме
(69)к сож. обработка давно не поддерживается (хотя возможность перенести вышеупомянутые справочники в ней есть, ибо переносил), конвертация данных в помощь
73. nkorkin 05.12.12 16:46 Сейчас в теме
(69) Нет не решил. Юзал Рокет.
61. Biss81 29.01.12 16:31 Сейчас в теме
Спасибо за обработку, очень выручила при переходе с самописной базы данных
62. corsar4ik 22.02.12 12:29 Сейчас в теме
Это то, что надо! Отличная вещь, давно искал, спасибо! Спасибо автору!
64. dicwork 01.03.12 13:45 Сейчас в теме
Кто нибудь может подсказать как с помощью этой обработки переписать только календари? При нажатии на "Ок" высвечиваются только справочники, документы и константы.
66. corsar4ik 02.04.12 12:13 Сейчас в теме
вопрос есть: при переносе документа его реквизит-справочник, существующий в базе приемнике и источнике с одним кодом, но разным содержимым перезаписывается или пропускается?
67. skilster 40 03.04.12 15:39 Сейчас в теме
Подскажите, как с помощью Universal синхронизировать справочники номенклатуры в Бухгалтерии и ТиС? Если наименование товара совпадает - перезаписать с заменой кода, если нет - создать новый в подходящей для этого группы (группы заведомо названы одинаково). Минут 40 уже бьюсь - номенклатура тупо дублируется вне зависимости от настроек.
70. MasterCifra 05.12.12 15:43 Сейчас в теме
А еще как бороться с такой ошибкой:
Метод ОсновнойЖурналРасчетов не может быть доступен так как компонента Расчет не загружена!

Конфигурация ТиС 9.2 (7.70.963)
72. Altez 252 05.12.12 15:44 Сейчас в теме
(70)нужно просто закомментировать строчку кода, вызывающую исключение
74. try2016 03.02.16 18:14 Сейчас в теме
По поводу единиц...не вдавался подробно...нет времени на это. Но если модифицировать код вот так. То по быстрому получится синхронизировать справочники, если не создаются в приемнике элементы и они там уже есть.
Искать по //Синхронизация
// Синхронизация //\ 
	Если (глТабСприСоот.НайтиЗначение(Строка(СпСправочников.Спр)+"_"+СпСправочников.Ключ,нстр2,"СпрРекв")=0) И (Строка(СпСправочников.Спр) <> "Единицы") Тогда
		Сообщить("Для справочника "+Спр.Вид()+" не установлен ключ синхронизации!");
		Возврат 0;
	КонецЕсли;
	
	Если Строка(СпСправочников.Спр) <> "Единицы" Тогда
		КлючПриемник=глТабСприСоот.ПолучитьЗначение(нстр2,"РеквСоот"); 
		КлючИсточник=СпСправочников.Ключ;
		КоличествоУровнейСоот=СпСправочников.КоличествоУровнейСоот;
		ДлинаКодаСоот=СпСправочников.ДлинаКодаСоот;
		СерииКодовСоот=СпСправочников.СерииКодовСоот;
		ДлинаКодаСоот=СпСправочников.ДлинаКодаСоот;	
		ДлинаНаименованияСоот=СпСправочников.ДлинаНаименованияСоот;
	Иначе
		КлючПриемник="ОКЕИ"; 
		КлючИсточник="ОКЕИ";
		КоличествоУровнейСоот=1;
		ДлинаКодаСоот=3;
		СерииКодовСоот="ВесьСправочник";
		ДлинаНаименованияСоот=25;
    КонецЕсли;	
Показать
75. wap25 20.05.16 09:19 Сейчас в теме
Некоторые проблемы с переносом реквизитов неопределенного типа решает добавление кода в строке номер 2277
		
Для ХХ=1 По ВсегоХХ Цикл
	глТабСпрРеквОЛЕ.НоваяСтрока();
	глТабСпрРеквОЛЕ.Спр_Рекв=глТабСпрОЛЕ.Идентификатор+"_"+База.Метаданные.Справочник(Инд).Реквизит(ХХ).Идентификатор;
	глТабСпрРеквОЛЕ.Спр=глТабСпрОЛЕ.Идентификатор;
	глТабСпрРеквОЛЕ.Идентификатор=База.Метаданные.Справочник(Инд).Реквизит(ХХ).Идентификатор;
	глТабСпрРеквОЛЕ.Представление=База.Метаданные.Справочник(Инд).Реквизит(ХХ).Представление();
	глТабСпрРеквОЛЕ.Периодический=База.Метаданные.Справочник(Инд).Реквизит(ХХ).Периодический;
	глТабСпрРеквОЛЕ.Использование=База.Метаданные.Справочник(Инд).Реквизит(ХХ).Использование;
	// (Строка 2277) Добавим заполнение типа реквизита
	глТабСпрРеквОЛЕ.Тип	= База.Метаданные.Справочник(Инд).Реквизит(ХХ).Тип;
КонецЦикла;
Показать
Оставьте свое сообщение