УНФ 1.5.3 Создание документов Перемещение запасов на основании данных Авансового отчета

Публикация № 347399

Администрирование - Администрирование данных 1С - Обработка документов

Авансовый отчет запасы Перемещение запасов заполнение перемещения запасов обработка заполнения учет ТМЦ распределение по складам логистика АРМ Управление небольшой фирмой 1.5 УНФ Внешняя обработка.

2
Позволяет оперативно "раскидывать" запасы по складам на основании источника запасов - вкладки Запасы документа Авансовый отчет с учетом резервов. Внешняя обработка, являющаяся модификацией обработки заполнения табличной части документа, легко встраивается в типовую конфигурацию УНФ 1.5.3 (работоспособна и на УНФ 1.4 со слов заказчика), добавляя свою команду в документ.
Код обработки открыт. Также объясняется методика отладки внешних обработок на "специфической" конфигурации УНФ 1.5.3

Вначале рассмотрим исходные данные задачи. На рисунках 1 и 2 данные документа Авансовый отчет в конфигураторе и в режиме предприятия с тестовыми данными из типовой демобазы УНФ 1.5.3:

  

Рисунок 1. Документ Авансовый отчет конфигурации Управление небольшой фирмой 1.5.3

 

 Рисунок 2. Документ Авансовый отчет в конфигуработоре

Теперь на рисунках 3 и 4 посмотрим структуру приемника - документа Перемещение запасов:

 Рисунок 3. Документ Перемещение запасов конфигурации Управление небольшой фирмой 1.5.3

Рисунок 4. Документ Перемещение запасов в конфигураторе. 

Видим, что в документе-основании Авансовом отчете в табличной части запасы Склад  (реквизит СтруктурнаяЕдиница) и ячейка могут принимать различные значения, поэтому для упрощения задачи принимаем за исходную информацию первой строки. Конечно, можно усложнить задачу, запрашивая перед созданием формы документа перемещения запасов и склад и (если заполнена) ячейка, но это уже оправдывает себя при очень больших количествах строк документа. Да к тому же тут возможны ошибки. Поэтому проще оприходовать все на склад по умолчанию (возможно введением транзитного "авансового" склада), а уже потом разбираться со спецификой хранения на местах.

Для отладки данной обработки, а также ее возможных модификаций можно воспользоваться одним из отладчиков внешних печатных форм, которые поддерживают управляемых формы по технологии БСП. Здесь может ожидать "подводный камешек" отсутствия в типовой конфигурации УНФ 1.5.3 режима модальности. Можно, конечно поправить данные обработки отладки или все-таки найти нужную, но можно воспользоваться приемом временного снятия корня конфигурации с поддержки и изменением данного признака на "использовать с предупреждением" как показано на рисунке 5.

 

Рисунок 5. Изменение свойств конфигурации УНФ 1.5.3 для облегчения отладки.

Также конфигуарация УНФ имеет свои "особенности" и из-за них многие стандартные внешние обработки не регистрируются в системе или не запускаются. Для решения подобных проблем приходится лезть в конфигурацию и править обработку под особенности данной конфигурации. Тут нужно смотреть код общего модуля "Дополнительные отчеты и обработки" и сопуствующие объекты метаданных еще на входе (см. рисунок 6):

 

Рисунок 6. Виды внешних обработок. 

  

Также основная отработка исполняемого кода начинается с нижеприведенного участка кода стандартного общего модуля УНФ "Дополнительные отчеты и обработки" и код модуля управляемой формы, реализующий всю логику решения:

// Выполняет команду обработки и возвращает результат ее выполнения.
//
// Параметры:
// ПараметрыКоманды - Структура - Параметры, с которыми выполняется команда.
// * ДополнительнаяОбработкаСсылка - СправочникСсылка.ДополнительныеОтчетыИОбработки - Элемент справочника.
// * ИдентификаторКоманды - Строка - Имя выполняемой команды.
// * ОбъектыНазначения - Массив - Ссылки объектов, для которых выполняется обработка. Обязательный для
// назначаемых обработок.
// * РезультатВыполнения - Структура - Необязательный. Дополняет возвращаемое значение.
// См. СтандартныеПодсистемыКлиентСервер.НовыйРезультатВыполнения().
// АдресРезультата - Строка - Необязательный. Адрес временного хранилища по которому будет размещен результат
// выполнения.
//
// Возвращаемое значение:
// * Структура - Результат выполнения, который далее передается на клиент.
// * Неопределено - Если был передан АдресРезультата.
//
// Важно:
// Проверка функциональной опции "ИспользоватьДополнительныеОтчетыИОбработки"
// должна выполняться вызывающим кодом.
//
Функция ВыполнитьКоманду(ПараметрыКоманды, АдресРезультата = Неопределено) Экспорт

Если ТипЗнч(ПараметрыКоманды.ДополнительнаяОбработкаСсылка) <> Тип("СправочникСсылка.ДополнительныеОтчетыИОбработки")
Или ПараметрыКоманды.ДополнительнаяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка() Тогда
Возврат Неопределено;
КонецЕсли;

ВнешнийОбъект = ПолучитьОбъектВнешнейОбработки(ПараметрыКоманды.ДополнительнаяОбработкаСсылка);

ИдентификаторКоманды = ПараметрыКоманды.ИдентификаторКоманды;

РезультатВыполнения = ВыполнитьКомандуВнешнегоОбъекта(ВнешнийОбъект, ИдентификаторКоманды, ПараметрыКоманды, АдресРезультата);

Возврат РезультатВыполнения;

КонецФункции
 
//////////////////////////////////// Код управляемой формы обработки ////////////////////////////////////////////
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
	Если ИдентификаторКоманды = "Создать Перемещение запасов" Тогда		
				
		Для каждого Элемент из ОбъектыНазначенияМассив Цикл
			КлючПоиска = Новый Структура("Ключ", Элемент);					
			Окна = ПолучитьОкна();
			Для каждого Окно из Окна Цикл				
				Рез =  Найти(Окно.Заголовок, СокрЛП(КлючПоиска.Ключ) );				
				Если Рез > 0 Тогда
					ФормаИст = ПолучитьФорму("Документ.АвансовыйОтчет.Форма.ФормаДокумента", КлючПоиска ,,,Окно); // Уже открытую форму.					
					ФормаДок = ПолучитьФорму("Документ.ПеремещениеЗапасов.Форма.ФормаДокумента");									
					ДанныеФормыИст = ФормаИст.Объект;								
					ДанныеФормыДок = ФормаДок.Объект;
					////// проверки ////////////////////
					Отказ1 = Ложь;
					ЗапасыИст     =       ДанныеФормыИст.Запасы;
					Если ЗапасыИст.Количество() = 0 Тогда
						СказатьПользователю("Табличная часть Заказы у документа-основания ПУСТА!");
						Возврат;
					КонецЕсли;
					СкладИст      =       ЗапасыИст[0].СтруктурнаяЕдиница;
					
					Если НЕ ЗначениеЗаполнено(СкладИст) Тогда
						СказатьПользователю("Склад источник пуст!");
						Отказ1 = Истина;
					КонецЕсли;
					
					// Ячейка может быть не задана и быть пустой, а вот склад нет!
					//////ЯчейкаИст     =       ЗапасыИст[0].Ячейка;
					//////
					//////Если НЕ ЗначениеЗаполнено(ЯчейкаИст) Тогда
					//////	СказатьПользователю("Ячейка источника пуста!");
					//////	Отказ1 = Истина;
					//////КонецЕсли;
					
					Если Отказ1 Тогда
						Возврат;               
					КонецЕсли;
															
					//////// Конец проверки ///////////
					ЗаполнитьФормуНаСервере(ДанныеФормыДок, ДанныеФормыИст);
					КопироватьДанныеФормы(ДанныеФормыДок, ФормаДок.Объект);
					ФормаДок.Открыть();
				КонецЕсли;	
			КонецЦикла;
		КонецЦикла;
	КонецЕсли;
КонецПроцедуры



&НаСервереБезКонтекста
Процедура ЗаполнитьФормуНаСервере(ДанныеФормыДок, ДанныеФормыИст)
	ЗапасыИст     =       ДанныеФормыИст.Запасы;
	СкладИст      =       ЗапасыИст[0].СтруктурнаяЕдиница;
	ЯчейкаИст     =       ЗапасыИст[0].Ячейка;	
	ДанныеФормыДок.Комментарий          =   "# Заполнение по основанию Авансовый отчет № "+ДанныеФормыИст.Номер+ " от "+ДанныеФормыДок.Дата;
	ДанныеФормыДок.Организация          =   ДанныеФормыИст.Организация;
	ДанныеФормыДок.СтруктурнаяЕдиница   =   СкладИст; 
	ДанныеФормыДок.СтруктурнаяЕдиницаПолучатель = ""; // Подставлялся по настройкам пользователя для организации что по умолчанию. По ТЗ пуст - сами принимаем решение.
	ДанныеФормыДок.Ячейка               =   ЯчейкаИст;
	
	//... Свойства Авансового отчета (если еще что-то надо)
	
	Запасы = ДанныеФормыДок.Запасы;
	
	Для Каждого СтрИст Из ЗапасыИст Цикл
		Стр = Запасы.Добавить();
		Стр.Номенклатура      =  СтрИст.Номенклатура;
		Стр.Характеристика    =  СтрИст.Характеристика; // Если Есть!
		Стр.Количество        =  СтрИст.Количество;
		Стр.ЕдиницаИзмерения  =  СтрИст.ЕдиницаИзмерения;
		// Есть ли Заказ покупателя. Если есть в таб. части перемещение запасов заполняется колонка РЕЗЕРВ 
		// по данным авансового отчета (если вдруг будут расхождния по количеству авансового и заказа)
		Если ЗначениеЗаполнено(СтрИст.ЗаказПокупателя) Тогда			
			Стр.Резерв = Стр.Количество;
			Стр.ЗаказПокупателя = СтрИст.ЗаказПокупателя;
		КонецЕсли;	
	КонецЦикла;		
	
КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
Процедура СказатьПользователю(текст1)
	СП = Новый СообщениеПользователю;
	СП.Текст = текст1;
	СП.Сообщить();
КонецПроцедуры	
 
2

Скачать файлы

Наименование Файл Версия Размер
Заполнение запасов - Доб. заказ покупателя и резерв по нему если есть. 1.1.0
.epf 8,79Kb
20.04.15
6
.epf 1.1.0 8,79Kb 6 Скачать
Заполнение запасов 1.0.2
.epf 8,61Kb
20.04.15
5
.epf 1.0.2 8,61Kb 5 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. user683755_bachenina_mv 04.07.17 09:39 Сейчас в теме
Оставьте свое сообщение

См. также

Списание (корректировка) задолженности контрагентов УНФ 1.6 4

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УНФ Украина БУ Дебиторская и кредиторская задолженность Абонемент ($m) Закрытие периода Обработка документов

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    2076    3    DMon    1       

Регистрация документов с измененной суммой 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка документов

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    3433    1    ryan    0       

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации) 6

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 КА1 УПП1 УУ Абонемент ($m) Обработка документов

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    5558    6    stvorl    3       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь полноценный оффлайн (обновление от 15.08.19)! 168

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    19587    207    informa1555    167       

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    13593    78    asdfgcom    45       

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Розничная торговля Абонемент ($m) Обработка документов

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    16777    5    biz-intel    3       

Давно обещанная автовесовая 8.Х 7

Инструменты и обработки Программист Архив с данными v8 Россия УУ Windows Учет ТМЦ Абонемент ($m) Производство

Финальная версия автовесовой без оператора.

10 стартмани

02.01.2018    10310    4    Арчибальд    1       

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1 35

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    23768    29    mvv1975    5       

Копирование меню в Трактир Management 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Производство готовой продукции (работ, услуг) Абонемент ($m) Обработка документов

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    13298    1    integrator1983    0       

Остатки товаров на складах по выбранным документам 9

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 ERP2 УТ11 УУ Учет ТМЦ Абонемент ($m) Печатные формы документов

Печатная форма подключается к документам. Даёт возможность быстро оценить остатки товара на складе по номенклатуре, указанной в документе, и ответить на вопрос, хватает ли остатков, чтобы отгрузить счет? На каких складах продукция по этому документу?

2 стартмани

09.11.2017    30309    24    A7758735    4       

Автозаказ для 1С:Управление торговлей 11 21

Отчеты и формы Бизнес-аналитик Внешний отчет (ert,erf) v8 v8::ОУ УТ11 УУ Оптовая торговля Учет ТМЦ Абонемент ($m) Управленческие

Отчет выводит информацию, помогающую принять решение о пополнении товарного запаса.

3 стартмани

26.09.2017    13650    37    The Ded    23       

Контроль учёта спецодежды 22

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v8 v8::БУ БП3.0 Россия БУ Учет ТМЦ Абонемент ($m) Бухгалтерские Анализ учета

Отчет предназначен для выявления ошибок возникших в бухгалтерском учёте специальной одежды в эксплуатации.

8 стартмани

08.09.2017    19449    26    sansys    9       

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме 3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БУ УУ Дебиторская и кредиторская задолженность Абонемент ($m) Обработка документов Печатные формы документов

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    11496    2    denmax    2       

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора. 23

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Обработка документов Универсальные обработки Обмен через XML

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    27463    146    Aphanas    4       

Неликвиды на складе Pro и Lite версия. Редактирование реквизита в таблице документа. Для конфигурации Управление торговлей 11.2, 11.1 1С Предприятие 8.3 5

Отчеты и формы Бизнес-аналитик Бухгалтер Внешний отчет (ert,erf) v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика УУ Windows Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Управленческие

Внешний отчет для анализа товаров, находящихся на складе без движения. Работает для конфигураций 1С Управление Торговлей 11.2, 11.1. Отчет отображает товары на складах, движения по которым не производились в течении заданного периода дней. Подключается как внешний отчет в конфигурации 1С Управление торговлей 11. В Pro версии можно установить общий реквизит номенклатуры, для дальнейшего включения в отбор в установке цен номенклатуры. Редактирование в табличном документе ускоряет процесс работы с неликвидами номенклатуры на складах. Отчет можно использовать для стоимостной оценки товаров на складах. Полный доступ к тексту модулей и СКД.

1 стартмани

17.06.2016    22203    47    Ликреонский    2       

Загрузка Счета покупателя из PDF 7

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Windows Оптовая торговля Абонемент ($m) Обработка документов Файловые протоколы обмена, FTP

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    4328    10    John_d    0       

Остатки на каждый день в запросе 33

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf УУ Windows Учет ТМЦ Абонемент ($m) Практика программирования

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    33799    19    arakelyan    16       

Управление доставкой розничным покупателям 2

Инструменты и обработки Руководитель проекта Конфигурация (md, cf) v8 УТ10 Розничная и сетевая торговля (FMCG) Россия УУ Windows Розничная торговля Абонемент ($m) Обработка документов

Дополнение для УТ 11.1, оформление доставки для розничного покупателя на основании кассового чека в связке с мягким чеком покупателя.

5 стартмани

10.03.2016    16818    6    Denis_Viktorovich    5       

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0 17

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия Windows Абонемент ($m) Обработка документов

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

5 стартмани

25.02.2016    24202    83    SmArtist    8       

Перечисление НДФЛ в бюджет РФ (13%, 30%) 11

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 БУ НУ Windows Зарплата НДФЛ Абонемент ($m) Обработка документов

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    22010    239    1kashak    16       

Начисление процентов по кредитам и займам для 1С:Бухгалтерии 3.0 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Windows Займы, кредит, лизинг Абонемент ($m) Обработка документов

Универсальная обработка по начислению процентов по кредитам и займам для 1С:Бухгалтерии 3.0 без изменения конфигурации

1 стартмани

22.01.2016    47990    156    algora    27       

Пакетная замена номенклатуры с учетом характеристик 6

Инструменты и обработки Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 УУ Оптовая торговля Учет ТМЦ Абонемент ($m) Обработка документов

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    9352    trendy    1       

Перечисление НДФЛ в бюджет: заполнение НДФЛ по расчетной ведомости для ЗУП 2.5 7

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия БУ Зарплата НДФЛ Абонемент ($m) Обработка документов

Внешняя обработка для заполнению сумм НДФЛ для перечисления в бюджет по данным расчетной ведомости для 1С ЗУП 2.5

2 стартмани

30.12.2015    10546    71    Snork    4       

Акт сверки с номерами счетов-фактур, начальными остатками по договорам и заполнением по головному контрагенту [Расширение] 21

Инструменты и обработки Бухгалтер Расширение (cfe) v8 БП3.0 Россия БУ Windows Дебиторская и кредиторская задолженность Абонемент ($m) Обработка документов

Акт сверки взаиморасчетов (БП 3.0): - Вывод начальных и конечных остатков по договорам в печатную форму; - Вывод валютной суммы для договоров в условных единицах; - Заполнение данных счетов-фактур или УПД; - Заполнение данных по головному контрагенту и всем обособленным подразделениям; - Заполнение представителя организации из ответственных лиц; - Факсимильная подпись и печать. Не требует снятия с поддержки и подходит для базовых конфигураций

1 стартмани

15.12.2015    42701    101    mrXoxot    40       

Складские операции на ТСД 9

Инструменты и обработки Пользователь Конфигурация (md, cf) v8 УУ Учет ТМЦ Абонемент ($m) Терминал сбора данных

Складская мобильная программа для терминалов сбора данных.

1 стартмани

15.11.2015    18503    5    JetBrain    8       

Загрузка УПД в Бухгалтерию 3.0 11

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Оптовая торговля Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0, с добавлением номенклатуры, ГТД, стран происхождения.

3 стартмани

20.10.2015    10462    7    teyana    12       

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") 41

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Загрузка и выгрузка в Excel Обработка документов

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    47634    527    primat    27       

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) 184

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка документов Обработка справочников Загрузка и выгрузка в Excel

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    49762    373    Tatitutu    49       

Перепроведение документа по части регистров 8

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка документов

Обработка для перепроведения документов выбранного вида с частичным сохранением движений регистров и проводок.

1 стартмани

16.09.2015    15282    46    NILS2009    6       

УПП. Реализация товаров в у.е. Формирование рублевых сумм проводок и регистров накопления с учетом ранее поступивших авансов : сразу при проведении документа 5

Инструменты и обработки Программист Бухгалтер Архив с данными v8 УПП1 Россия БУ НУ Windows Дебиторская и кредиторская задолженность Закрытие периода Налог на прибыль НДС Абонемент ($m) Обработка документов

Договор с покупателем ведется в условных единицах. Вид взаиморасчетов : по договору. Ведем взаиморасчеты в разрезе документов расчетов. Ранее поступил аванс на 2 000 EUR. Курс был 45 руб Теперь производим отгрузку на 5 000 EUR. Курс изменился и стал : 60 руб. Проводки по отгрузке формируются с учетом ранее поступившего аванса. Сумма реализации должна составить : 2 000 х 45 + 3 000 х 60 = 90 000 + 180 000 = 270 000 руб.е В типовой реализации проведение дает сумму по реализации 270 000 только для регистра накопления "Взаиморасчеты с контрагентами по документам расчетов" После внесения доработок в обработку проведения (процедура "Движения Регистров") данные по другим регистрам тоже выходят на сумму с учетом поступившего ранее аванса. Проверено для вариантов настройки программы: 1.Валюта упр.учета - Рубли 2.Валюта упр.учета НЕ Рубли

2 стартмани

08.09.2015    28082    17    Designer1C    9       

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении 58

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Россия БУ Windows Учет ТМЦ Абонемент ($m) Инструментарий разработчика Универсальные функции

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    38154    167    ekaruk    31       

Обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие 2

Инструменты и обработки Бизнес-аналитик Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 УПП1 УУ Windows Ценообразование, анализ цен Абонемент ($m) Ценообразование, прайсы Обработка документов Загрузка и выгрузка в Excel

Универсальная программа для загрузки Прайс-листов в базу 1С:Предприятия 8. Основные достоинства: простота использования и широкие функциональные возможности поиска товаров для записи цен. Область применения: обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие.

10 стартмани

16.07.2015    23473    4    Destroy    2       

Расчет процентов по займам и кредитам 8

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Windows Займы, кредит, лизинг Абонемент ($m) Обработка документов

В свое время взяла с Инфостарта обработку по расчету процентов по полученным займам и кредитам и переработала ее. Подходит для автоматического расчета исчисленных процентов по полученным займам и кредитам (особенно при большом количестве договоров займа) с нетрудоемким отражением в бухгалтерском и налоговом учете исчисленных процентов. Уточнен налоговый учет расходов по процентам в соответствии с изменениями законодательства в 2015 году. Внесены исправления по техническим ошибкам (в Бухучете расходы отражались по группе счета 91, а также в НУ по Дт счета отражены суммы процентов)

1 стартмани

17.04.2015    10286    96    lvk74    13       

Перепроведение документов только по выбранным регистрам (Управляемые формы, 8.2, 8.3) 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Обработка документов

Проводит движения по выбранным документам и регистрам, работает на 1с 8.2 - 8.3, управляемые формы. Возможно отбирать или не отбирать по периоду, останавливать по ошибке, выполнять прерывание пользователя, выводить ошибки. И главное преимущество - работает по УФ (управляемые формы)!

3 стартмани

03.04.2015    12763    112    Dmitrii D    1       

Акт сверки взаиморасчетов - заполнение документа расчетами по головному контрагенту (Бухгалтерия 3.0) 7

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП3.0 Россия БУ Windows Дебиторская и кредиторская задолженность Абонемент ($m) Обработка документов

Внешняя обработка заполнения табличных частей позволяет заполнить акт сверки в Бухгалтерии 3.0 расчетами по головному контрагенту.

1 стартмани

26.02.2015    10011    54    evg_m    2       

Сверка остатков МПЗ (товаров, материалов, продукции) между планом счетов (БУ) и регистрами (РАУЗ) для КА 1.1, УПП 1.3 26

Отчеты и формы Бизнес-аналитик Бухгалтер Внешний отчет (ert,erf) v8 КА1 УПП1 БУ Учет ТМЦ Абонемент ($m) Бухгалтерские Анализ учета

Контрольный отчет для конфигураций "Комплексная автоматизация 1.1", "Управление производственным предприятием 1.3", позволяющий убедиться в том, что в регистрах регламентированного учета материально-производственных запасов (в варианте расширенной аналитики учета затрат (РАУЗ), раздел МПЗ) и на плане счетов бухгалтерского учета отражены одинаковые значения количества и стоимости МПЗ, а также позволяющий "уловить" другие ошибки учета МПЗ.

1 стартмани

24.02.2015    31493    280    stvorl    7       

Заполнение по остаткам спецодежды и инвентаря по сотрудникам 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 БУ Windows Учет ТМЦ Абонемент ($m) Обработка документов

Обработки для заполнения по остаткам спецодежды и инвентаря по сотрудникам (можно указать список) для документа "Списание материалов из эксплуатации" и "Возврат материалов из эксплуатации"

1 стартмани

04.02.2015    6947    36    portal2011    3       

Расчет зарплаты в типовых конфигурациях 1С "Бухгалтерия предприятия 2.0 и 3.0" 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Windows Зарплата Абонемент ($m) Обработка документов Рабочее место

Как известно, расчет зарплаты в составе типовых конфигураций 1С Бухгалтерия предприятия 2.0 или 3.0 имеет крайне ограниченные возможности. Собственно расчета сумм как таковых не происходит – бухгалтер сам вычисляет и ставит готовую сумму начисления работнику по каждому виду расчета. В связи с этим была разработана Система «Зарплата», которая позволяет проводить расчеты сумм зарплаты сотрудникам организации в бухгалтерской программе 1С в типовых конфигурациях "Бухгалтерия предприятия 2.0" и "Бухгалтерия предприятия 3.0"

1 стартмани

26.01.2015    25599    185    Selivanov    26       

Инвентаризационная опись 0504087 с группировкой по счету для БГУ 1.0 1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БГУ Россия БУ Windows Учет ОС и НМА Учет ТМЦ Абонемент ($m) Печатные формы документов

Внешняя печатная форма предназначена для печати ф. 0504087 с группировкой по счёту учёта для документов:"Инвентаризация ОС (НМА,НПА) на балансовых счетах", "Инвентаризация основных средств (забалансовый учет)", "Инвентаризация ОС в оперативном учете", "Инвентаризация материалов на счете 105", "Инвентаризация материалов (забалансовый учет)".

5 стартмани

22.12.2014    26380    5    agospodarin    2       

Обработка "Удаление номенклатуры в документах" 3

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка документов

Данная обработка обслуживания предназначена для удаления номенклатуры из выбранных типов документов и документов, за заданный период, по отбору номенклатуры.

1 стартмани

31.10.2014    12909    37    Alexsur    14       

Реестр договоров для 1С:Бухгалтерии 14

Инструменты и обработки Бухгалтер Архив с данными v8 v8::БУ БП3.0 Россия БУ Документооборот и делопроизводство Абонемент ($m) Обработка документов Обработка справочников

Реестр договоров для 1С:Бухгалтерии - дополнительная обработка для конфигурации "Бухгалтерия предприятия", версия 3.0

5 стартмани

28.10.2014    33537    110    RespectSoft    23