Счет с QR-кодом (внешняя печатная форма)

Публикация № 384968

Разработка - Печать - Печатные формы документов

QR-код счет на оплату

13
Для удобства работы с терминалами  банка при оплате счета сделана форма счета с QR-кодом (внешняя печатная форма).

Возникла необходимость осуществления оплат через терминалы Сбербанка. Для этого, собственно, и делал печатную форму.

Работа проверена на УТ 10 и БП.2.0

13

Скачать файлы

Наименование Файл Версия Размер
счет на оплату
.epf 13,54Kb
30.07.15
57
.epf 13,54Kb 57 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. TrinitronOTV 31.07.15 05:56 Сейчас в теме
Для самого штрих-кода какие-то внешние компоненты используются или реализовывали средствами 1С?
MherArsh; +1 Ответить
3. mentozavr 33 31.07.15 16:29 Сейчас в теме
(1) TrinitronOTV, все 1с. Силами модуля УпрвлениеПечатью
2. mentozavr 33 31.07.15 16:28 Сейчас в теме
все средствами 1с там есть модули
4. 1v7 184 31.07.15 16:33 Сейчас в теме
Интересная идея. Плюсую.В пользовательском режиме тоже можно текст в QR перевести? Или только в конфигураторе?
6. mentozavr 33 12.08.15 16:35 Сейчас в теме
(4) 1v7, помоему без проблем
(5) simuljakr, прикрепил файл. будут вопросы готов ответить
Прикрепленные файлы:
Стандарт ДШК.pdf
5. simuljakr 171 11.08.15 13:48 Сейчас в теме
А какая информация шифруется в QR-код ?
9. mentozavr 33 22.02.18 22:20 Сейчас в теме
(5)вся необходимая для сбербанка
7. suncho25343 21.02.18 08:33 Сейчас в теме
При считывании кода приложением от Сбера, назначение платежа не формируется, как исправить?
8. mentozavr 33 22.02.18 22:19 Сейчас в теме
(7) Надо смотреть отладчиком. скорее всего какие-то поля не заполняются. В какой конфигурации пробуете. на БП 2.0. работает...планирую переписать ее для УТ и 11-ые версии.
10. suncho25343 23.02.18 11:54 Сейчас в теме
(8) У меня стандартная БП 2.0 редакция 8.2 Не заполняет именно при сканировании из приложения сер онлайн...
11. mentozavr 33 23.02.18 23:07 Сейчас в теме
а когда считываете банкоматом как? ....но таких вопросов мне не задавали...т.к. у моих считывает вроде норм...арендаторы (кот. счета выдают молчат...а что-нибудь в это поле заполняет?
12. suncho25343 24.02.18 13:27 Сейчас в теме
(11) В поле ничего не заполняет, еще в поле услуга вписывает название организации . Напишите в личку, сколько будет стоить исправить?
Прикрепленные файлы:
13. mentozavr 33 25.02.18 22:53 Сейчас в теме
Попробуйте мою. мои с этим работают.
Прикрепленные файлы:
Счет на оплату с кодом для Сбербанка.epf
14. suncho25343 25.02.18 23:05 Сейчас в теме
Так же все... В терминалах не проверял, только сбер онлайн.
15. smax 22.05.18 11:13 Сейчас в теме
Андрей Вадимович, добрый день!
Скачал обработку, проверяю её на УТ10, как у Вас написано в описании. Даёт ошибку. Проверяю причину, в модуле УправлениеПечатью нету вообще процедур для QR кода, которые Вы используете в обработке.

QRСтрока = УправлениеПечатью.ФорматнаяСтрокаУФЭБС(РеквизитыПлатежа)

или

ДанныеQRКода = УправлениеПечатью.ДанныеQRКода(QRСтрока, 1, 120);

В последних релизах УТ10 она вообще работоспособна?
16. mentozavr 33 22.05.18 21:50 Сейчас в теме
(15)Добрый вечер. Если конфу менять не боитесь то в УТ 10 в модуль УправлениеПечатью надо эту процедуру добавить...до недавних релизов данная процедура там была..я ее из ут 10 в БП20 и забирал.



// Печать QR кода

// Возвращает двоичные данные для формирования QR кода
//
// Параметры:
//  QRСтрока         - Строка - данные, которые необходимо разместить в QR-коде.
//
//  УровеньКоррекции - Число - уровень погрешности изображения при котором данный QR-код все еще возможно 100% распознать.
//                     Параметр должен иметь тип целого и принимать одно из 4 допустимых значений:
//                     0(7% погрешности), 1(15% погрешности), 2(25% погрешности), 3(35% погрешности).
//
//  Размер           - Число - определяет длину стороны выходного изображения в пикселях.
//                     Если минимально возможный размер изображения больше этого параметра – код сформирован не будет.
//
//  ТекстОшибки      - Строка - в этот параметр помещается описание возникшей ошибки (если возникла).
//
// Возвращаемое значение:
//  Двоичные данные  - буфер, содержащий байты PNG-изображения QR-кода.
// 
// Пример:
//  
//  //Выводим на печать QR-код, содержащий в себе информацию зашифрованную по УФЭБС
//
//  QRСтрока = УправлениеПечатью.ФорматнаяСтрокаУФЭБС(РеквизитыПлатежа);
//  ТекстОшибки = "";
//  ДанныеQRКода = УправлениеПечатью.ДанныеQRКода(QRСтрока, 0, 190, ТекстОшибки);
//  Если Не ПустаяСтрока(ТекстОшибки)
//      ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки);
//  КонецЕсли;
//
//  КартинкаQRКода = Новый Картинка(ДанныеQRКода);
//  ОбластьМакета.Рисунки.QRКод.Картинка = КартинкаQRКода;
//
Функция ДанныеQRКода(QRСтрока, УровеньКоррекции, Размер) Экспорт
	
	Отказ = Ложь;
	
	ГенераторQRКода = КомпонентаФормированияQRКода(Отказ);
	Если Отказ Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	Попытка
		ДвоичныеДанныеКартинки = ГенераторQRКода.GenerateQRCode(QRСтрока, УровеньКоррекции, Размер);
	Исключение
		ЗаписьЖурналаРегистрации("Формирование QR-кода",УровеньЖурналаРегистрации.Ошибка,,,
								  ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
	КонецПопытки;
	
	Возврат ДвоичныеДанныеКартинки;
	
КонецФункции

// Формирует форматную строку согласно "Унифицированному формату электронных банковских сообщений" для ее отображения в виде QR-кода
// Параметры:
// ДанныеДокумента  - Структура - содержит значения полей документа
//					- Данные документа будут закодированы согласно стандарту 
//						"СТАНДАРТЫ ФИНАНСОВЫХ ОПЕРАЦИЙ Символы двумерного штрихового кода для осуществления платежей физических лиц"
//					- ДанныеДокумента должны содержать информацию в полях, описанных ниже.
//
//					- Обязательные поля структуры
//		* ТекстПолучателя             - Наименование получателя платежа         - Макс. 160 символов;
//		* НомерСчетаПолучателя        - Номер счета получателя платежа          - Макс. 20 символов;
//		* НаименованиеБанкаПолучателя - Наименование банка получателя платежа   - Макс. 45 символов;
//		* БИКБанкаПолучателя          - БИК                                     - Макс. 9 символов;
//		* СчетБанкаПолучателя         - Номер кор./сч. банка получателя платежа - Макс. 20 символов;
//					- Дополнительные поля структуры
//		* СуммаЧислом         - Сумма платежа, в рублях                 - Макс. 16 символов 
//		* НазначениеПлатежа   - Наименование платежа (назначение)       - Макс. 210 символов;
//		* ИННПолучателя       - ИНН получателя платежа                  - Макс. 12 символов;
//		* ИННПлательщика      - ИНН плательщика                         - Макс. 12 символов;
//		* СтатусСоставителя   - Статус составителя платежного документа - Макс. 2 символа;
//		* КПППолучателя       - КПП получателя платежа                  - Макс. 9 символов
//		* КодБК               - КБК                                     - Макс. 20 символов;
//		* КодОКАТО            - Код ОКАТО                               - Макс. 11 символов;
//		* ПоказательОснования - Основание налогового платежа            - Макс. 2 символа;
//		* ПоказательПериода   - Налоговый период                        - Макс. 10 символов;
//		* ПоказательНомера    - Номер документа                         - Макс. 15 символов;
//		* ПоказательДаты      - Дата документа                          - Макс. 10 символ
//		* ПоказательТипа      - Тип платежа                             - Макс. 2 символа
//					- Прочие дополнительные  поля
//		* ФамилияПлательщика               - Фамилия плательщика
//		* ИмяПлательщика                   - Имя плательщика
//		* ОтчествоПлательщика              - Отчество плательщика
//		* АдресПлательщика                 - Адрес плательщика
//		* ЛицевойСчетБюджетногоПолучателя  - Лицевой счет бюджетного получателя
//		* ИндексПлатежногоДокумента        - Индекс платежного документа
//		* СНИЛС                            - № лицевого счета в системе персонифицированного учета в ПФР - СНИЛС
//		* НомерДоговора                    - Номер договора
//		* НомерЛицевогоСчетаПлательщика    - Номер лицевого счета плательщика в организации (в системе учета ПУ)
//		* НомерКвартиры                    - Номер квартиры
//		* НомерТелефона                    - Номер телефона
//		* ВидПлательщика                   - Вид ДУЛ плательщика
//		* НомерПлательщик                  - Номер ДУЛ плательщика
//		* ФИОРебенка                       - Ф.И.О. ребенка/учащегося
//		* ДатаРождения                     - Дата рождения
//		* СрокПлатежа                      - Срок платежа/дата выставления счета
//		* ПериодОплаты                     - Период оплаты
//		* ВидПлатежа                       - Вид платежа
//		* КодУслуги                        - Код услуги/название прибора учета
//		* НомерПрибораУчета                - Номер прибора учета
//		* ПоказаниеПрибораУчета            - Показание прибора учета
//		* НомерИзвещения                   - Номер извещения, начисления, счета
//		* ДатаИзвещения                    - Дата извещения/начисления/счета/постановления (для ГИБДД)
//		* НомерУчреждения                  - Номер учреждения (образовательного, медицинского)
//		* НомерГруппы                      - Номер группы детсада/класса школы
//		* ФИОПреподавателя                 - ФИО преподавателя, специалиста, оказывающего услугу
//		* СуммаСтраховки                   - Сумма страховки/дополнительной услуги/Сумма пени (в копейках)
//		* НомерПостановления               - Номер постановления (для ГИБДД)
//		* НомерИсполнительногоПроизводства - Номер исполнительного производства
//		* КодВидаПлатежа                   - Код вида платежа (например, для платежей в адрес Росреестра)
//		* ИдентификаторНачисления          - Уникальный идентификатор начисления
//		* ТехническийКод                   - Технический код, рекомендуемый для заполнения поставщиком услуг.
//                                           Может использоваться принимающей организацией для вызова соответствующей обрабатывающей ИТ-системы. 
//                                           Перечень значений кода представлен ниже.
//
//	Код назначения			Наименование назначения платежа
//		платежа	
//	
//			01				Мобильная связь, стационарный телефон
//			02				Коммунальные услуги, ЖКХ
//			03				ГИБДД, налоги, пошлины, бюджетные платежи
//			04				Охранные услуги
//			05				Услуги, оказываемые УФМС
//			06				ПФР
//			07				Погашение кредитов
//			08				Образовательные учреждения
//			09				Интернет и ТВ
//			10				Электронные деньги
//			11				Отдых и путешествия
//			12				Инвестиции и страхование
//			13				Спорт и здоровье
//			14				Благотворительные и общественные организации
//			15				Прочие услуги
//
// Возвращаемое значение:
//   Строка - строка данных в формате УФЭБС
//
Функция ФорматнаяСтрокаУФЭБС(ДанныеДокумента) Экспорт
	
	ТекстОшибки = "";
	СтрокаОбязательныхРеквизитов = СтрокаОбязательныхРеквизитов(ДанныеДокумента, ТекстОшибки);
	
	Если ПустаяСтрока(СтрокаОбязательныхРеквизитов) Тогда
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки, , , ,);
		Возврат "";
	КонецЕсли;
	
	СтруктураПредставленийИРеквизитов = СтруктураПредставленийИРеквизитов();
	СтрокаДополнительныхРеквизитов = "";
	ДополнительныеРеквизиты = Новый Структура;
	ДобавитьДополнительныеРеквизиты(ДополнительныеРеквизиты);
	
	Для Каждого Элемент Из ДополнительныеРеквизиты Цикл
		
		Если Не ДанныеДокумента.Свойство(Элемент.Ключ) Тогда
			ДанныеДокумента.Вставить(Элемент.Ключ, "");
			Продолжить;
		КонецЕсли;
		
		Если ЗначениеЗаполнено(ДанныеДокумента[Элемент.Ключ]) Тогда
			Если Элемент.Ключ = "СуммаЧислом" Тогда
				ЗначениеСтрокой = Формат(ДанныеДокумента.СуммаЧислом * 100, "ЧГ=");
			Иначе
				ЗначениеСтрокой = СтрЗаменить(СокрЛП(Строка(ДанныеДокумента[Элемент.Ключ])), "|", "");
			КонецЕсли;
			СтрокаДополнительныхРеквизитов = СтрокаДополнительныхРеквизитов + СтруктураПредставленийИРеквизитов[Элемент.Ключ]
			                                 + "=" + ЗначениеСтрокой + "|";
		КонецЕсли;
	КонецЦикла;
	
	Если Не ПустаяСтрока(СтрокаДополнительныхРеквизитов) Тогда
		ДлинаСтроки = СтрДлина(СтрокаДополнительныхРеквизитов);
		СтрокаДополнительныхРеквизитов = Сред(СтрокаДополнительныхРеквизитов, 1, ДлинаСтроки - 1);
	КонецЕсли;

	ПрочиеДополнительныеРеквизиты = Новый Структура;
	ДобавитьПрочиеДополнительныеРеквизиты(ПрочиеДополнительныеРеквизиты);
	СтрокаПрочихДополнительныхРеквизитов = "";
	
	Для Каждого Элемент Из ПрочиеДополнительныеРеквизиты Цикл
		
		Если Не ДанныеДокумента.Свойство(Элемент.Ключ) Тогда
			ДанныеДокумента.Вставить(Элемент.Ключ, "");
			Продолжить;
		КонецЕсли;
		
		Если ЗначениеЗаполнено(ДанныеДокумента[Элемент.Ключ]) Тогда
			ЗначениеСтрокой = СтрЗаменить(СокрЛП(Строка(ДанныеДокумента[Элемент.Ключ])), "|", "");
			СтрокаПрочихДополнительныхРеквизитов = СтрокаПрочихДополнительныхРеквизитов
			                                       + СтруктураПредставленийИРеквизитов[Элемент.Ключ] + "=" + ЗначениеСтрокой
			                                       + "|";
		КонецЕсли;
	КонецЦикла;
	
	Если Не ПустаяСтрока(СтрокаПрочихДополнительныхРеквизитов) Тогда
		ДлинаСтроки = СтрДлина(СтрокаПрочихДополнительныхРеквизитов);
		СтрокаПрочихДополнительныхРеквизитов = Сред(СтрокаПрочихДополнительныхРеквизитов, 1, ДлинаСтроки - 1);
	КонецЕсли;
	
	ИтоговаяСтрока =  СтрокаОбязательныхРеквизитов
	                 + ?(ПустаяСтрока(СтрокаДополнительныхРеквизитов), "", "|" + СтрокаДополнительныхРеквизитов)
	                 + ?(ПустаяСтрока(СтрокаПрочихДополнительныхРеквизитов), "", "|" + СтрокаПрочихДополнительныхРеквизитов);
	
	Возврат ИтоговаяСтрока;
	
КонецФункции

Функция СтрокаОбязательныхРеквизитов(ДанныеДокумента, ТекстСообщения)
	
	ОбязательныеРеквизиты = Новый Структура();
	СтруктураПредставленийИРеквизитов = СтруктураПредставленийИРеквизитов();
	ДобавитьОбязательныеРеквизиты(ОбязательныеРеквизиты);
	
	Если Не ЗначениеЗаполнено(ДанныеДокумента.СчетБанкаПолучателя) Тогда
		ДанныеДокумента.СчетБанкаПолучателя = "0";
	КонецЕсли;
	
	СлужебныеДанные = "ST00012";
	ОбязательныеДанные = "";
	
	Для Каждого Элемент Из ОбязательныеРеквизиты Цикл
		Если Не ЗначениеЗаполнено(ДанныеДокумента[Элемент.Ключ]) Тогда
			ТекстСообщения = Нстр("ru = 'Не заполнен обязательный реквизит: %1'");
			ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, Элемент.Ключ);
			Возврат "";
		КонецЕсли;
		
		ЗначениеСтрокой = СтрЗаменить(СокрЛП(Строка(ДанныеДокумента[Элемент.Ключ])), "|", "");
		
		ОбязательныеДанные = ОбязательныеДанные + "|" + СтруктураПредставленийИРеквизитов[Элемент.Ключ] + "="
		                     + ЗначениеСтрокой;
		
	КонецЦикла;
	
	Если СтрДлина(ОбязательныеДанные) > 300 Тогда
		Шаблон = НСтр("ru = 'Невозможно создать QR-код для документа %1
		                    |Строка обязательных реквизитов должна быть меньше 300 символов:
		                    |""%2""'");
		ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(Шаблон,
		                                                                         ДанныеДокумента.Ссылка,
		                                                                         ОбязательныеДанные);
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
		Возврат "";
	КонецЕсли;
	
	Возврат СлужебныеДанные + ОбязательныеДанные;
	
КонецФункции

Функция СтруктураПредставленийИРеквизитов()
	
	СтруктураВозврата = Новый Структура();
	
	СтруктураВозврата.Вставить("ТекстПолучателя",             "Name");
	СтруктураВозврата.Вставить("НомерСчетаПолучателя",        "PersonalAcc");
	СтруктураВозврата.Вставить("НаименованиеБанкаПолучателя", "BankName");
	СтруктураВозврата.Вставить("БИКБанкаПолучателя",          "BIC");
	СтруктураВозврата.Вставить("СчетБанкаПолучателя",         "CorrespAcc");
	
	СтруктураВозврата.Вставить("СуммаЧислом",         "Sum");
	СтруктураВозврата.Вставить("НазначениеПлатежа",   "Purpose");
	СтруктураВозврата.Вставить("ИННПолучателя",       "PayeeINN");
	СтруктураВозврата.Вставить("ИННПлательщика",      "PayerINN");
	СтруктураВозврата.Вставить("СтатусСоставителя",   "DrawerStatus");
	СтруктураВозврата.Вставить("КПППолучателя",       "KPP");
	СтруктураВозврата.Вставить("КодБК",               "CBC");
	СтруктураВозврата.Вставить("КодОКАТО",            "OKATO");
	СтруктураВозврата.Вставить("ПоказательОснования", "PaytReason");
	СтруктураВозврата.Вставить("ПоказательПериода",   "ТaxPeriod");
	СтруктураВозврата.Вставить("ПоказательНомера",    "DocNo");
	СтруктураВозврата.Вставить("ПоказательДаты",      "DocDate");
	СтруктураВозврата.Вставить("ПоказательТипа",      "TaxPaytKind");
	
	СтруктураВозврата.Вставить("ФамилияПлательщика",               "lastName");
	СтруктураВозврата.Вставить("ИмяПлательщика",                   "firstName");
	СтруктураВозврата.Вставить("ОтчествоПлательщика",              "middleName");
	СтруктураВозврата.Вставить("АдресПлательщика",                 "payerAddress");
	СтруктураВозврата.Вставить("ЛицевойСчетБюджетногоПолучателя",  "personalAccount");
	СтруктураВозврата.Вставить("ИндексПлатежногоДокумента",        "docIdx");
	СтруктураВозврата.Вставить("СНИЛС",                            "pensAcc");
	СтруктураВозврата.Вставить("НомерДоговора",                    "contract");
	СтруктураВозврата.Вставить("НомерЛицевогоСчетаПлательщика",    "persAcc");
	СтруктураВозврата.Вставить("НомерКвартиры",                    "flat");
	СтруктураВозврата.Вставить("НомерТелефона",                    "phone");
	СтруктураВозврата.Вставить("ВидПлательщика",                   "payerIdType");
	СтруктураВозврата.Вставить("НомерПлательщика",                 "payerIdNum");
	СтруктураВозврата.Вставить("ФИОРебенка",                       "childFio");
	СтруктураВозврата.Вставить("ДатаРождения",                     "birthDate");
	СтруктураВозврата.Вставить("СрокПлатежа",                      "paymTerm");
	СтруктураВозврата.Вставить("ПериодОплаты",                     "paymPeriod");
	СтруктураВозврата.Вставить("ВидПлатежа",                       "category");
	СтруктураВозврата.Вставить("КодУслуги",                        "serviceName");
	СтруктураВозврата.Вставить("НомерПрибораУчета",                "counterId");
	СтруктураВозврата.Вставить("ПоказаниеПрибораУчета",            "counterVal");
	СтруктураВозврата.Вставить("НомерИзвещения",                   "quittId");
	СтруктураВозврата.Вставить("ДатаИзвещения",                    "quittDate");
	СтруктураВозврата.Вставить("НомерУчреждения",                  "instNum");
	СтруктураВозврата.Вставить("НомерГруппы",                      "classNum");
	СтруктураВозврата.Вставить("ФИОПреподавателя",                 "specFio");
	СтруктураВозврата.Вставить("СуммаСтраховки",                   "addAmount");
	СтруктураВозврата.Вставить("НомерПостановления",               "ruleId");
	СтруктураВозврата.Вставить("НомерИсполнительногоПроизводства", "execId");
	СтруктураВозврата.Вставить("КодВидаПлатежа",                   "regType");
	СтруктураВозврата.Вставить("ИдентификаторНачисления",          "uin");
	СтруктураВозврата.Вставить("ТехническийКод",                   "TechCode");
	
	Возврат СтруктураВозврата;
	
КонецФункции

Функция КомпонентаФормированияQRКода(Отказ)
	
	СистемнаяИнформация = Новый СистемнаяИнформация;
	Платформа = СистемнаяИнформация.ТипПлатформы;
	
	ТекстОшибки = НСтр("ru = 'Не удалось подключить внешнюю компоненту для генерации QR-кода'");
	
	Попытка
		Если ПодключитьВнешнююКомпоненту("ОбщийМакет.КомпонентаПечатиQRКода", "QR") Тогда
			QRCodeGenerator = Новый("AddIn.QR.QRCodeExtension");
		Иначе
			ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки, , , , Отказ);
		КонецЕсли
	Исключение
		ПодробноеПредставлениеОшибки = ПодробноеПредставлениеОшибки(ОписаниеОшибки());
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки + Символы.ПС + ПодробноеПредставлениеОшибки, , , , Отказ);
	КонецПопытки;
	
	Возврат QRCodeGenerator;
	
КонецФункции

Процедура ДобавитьОбязательныеРеквизиты(СтруктураДанных)
	
	СтруктураДанных.Вставить("ТекстПолучателя");
	СтруктураДанных.Вставить("НомерСчетаПолучателя");
	СтруктураДанных.Вставить("НаименованиеБанкаПолучателя");
	СтруктураДанных.Вставить("БИКБанкаПолучателя");
	СтруктураДанных.Вставить("СчетБанкаПолучателя");
	
КонецПроцедуры

Процедура ДобавитьДополнительныеРеквизиты(СтруктураДанных)
	
	СтруктураДанных.Вставить("СуммаЧислом");
	СтруктураДанных.Вставить("НазначениеПлатежа");
	СтруктураДанных.Вставить("ИННПолучателя");
	СтруктураДанных.Вставить("ИННПлательщика");
	СтруктураДанных.Вставить("СтатусСоставителя");
	СтруктураДанных.Вставить("КПППолучателя");
	СтруктураДанных.Вставить("КодБК");
	СтруктураДанных.Вставить("КодОКАТО");
	СтруктураДанных.Вставить("ПоказательОснования");
	СтруктураДанных.Вставить("ПоказательПериода");
	СтруктураДанных.Вставить("ПоказательНомера");
	СтруктураДанных.Вставить("ПоказательДаты");
	СтруктураДанных.Вставить("ПоказательТипа");
	
КонецПроцедуры

Процедура ДобавитьПрочиеДополнительныеРеквизиты(СтруктураДанных)
	
	СтруктураДанных.Вставить("ФамилияПлательщика");
	СтруктураДанных.Вставить("ИмяПлательщика");
	СтруктураДанных.Вставить("ОтчествоПлательщика");
	СтруктураДанных.Вставить("АдресПлательщика");
	СтруктураДанных.Вставить("ЛицевойСчетБюджетногоПолучателя");
	СтруктураДанных.Вставить("ИндексПлатежногоДокумента");
	СтруктураДанных.Вставить("СНИЛС");
	СтруктураДанных.Вставить("НомерДоговора");
	СтруктураДанных.Вставить("НомерЛицевогоСчетаПлательщика");
	СтруктураДанных.Вставить("НомерКвартиры");
	СтруктураДанных.Вставить("НомерТелефона");
	СтруктураДанных.Вставить("ВидПлательщика");
	СтруктураДанных.Вставить("НомерПлательщика");
	СтруктураДанных.Вставить("ФИОРебенка");
	СтруктураДанных.Вставить("ДатаРождения");
	СтруктураДанных.Вставить("СрокПлатежа");
	СтруктураДанных.Вставить("ПериодОплаты");
	СтруктураДанных.Вставить("ВидПлатежа");
	СтруктураДанных.Вставить("КодУслуги");
	СтруктураДанных.Вставить("НомерПрибораУчета");
	СтруктураДанных.Вставить("ПоказаниеПрибораУчета");
	СтруктураДанных.Вставить("НомерИзвещения");
	СтруктураДанных.Вставить("ДатаИзвещения");
	СтруктураДанных.Вставить("НомерУчреждения");
	СтруктураДанных.Вставить("НомерГруппы");
	СтруктураДанных.Вставить("ФИОПреподавателя");
	СтруктураДанных.Вставить("СуммаСтраховки");
	СтруктураДанных.Вставить("НомерПостановления");
	СтруктураДанных.Вставить("НомерИсполнительногоПроизводства");
	СтруктураДанных.Вставить("КодВидаПлатежа");
	СтруктураДанных.Вставить("ИдентификаторНачисления");
	СтруктураДанных.Вставить("ТехническийКод");
	
КонецПроцедуры

////////////////////////////////////////////////////////////­////////////////////

Показать

При возможности поправлю ее и все эти функции вставлю в обработку.
17. RegrZ 57 20.07.18 05:56 Сейчас в теме
Протестировал возможность распознавания штрих-кода сформированного этой обработкой в разных мобильных приложениях и терминалах банков. Так вот терминалы сбербанка, как и мобильное приложение сбера, этот штрих-код не распознают. Но у сбера распознаются только те штрих-коды, в которых указаны получатели платежа заключившие договор со сбером. Таким образом, чтобы клиенты сбербанка могли оплачивать по штрих-коду в терминале или мобильном приложении ваши квитанции вашей организации необходимо обратиться в сбер и заключить с ними какой-то особый договор, тогда для ваших счетов будет работать заполнение по штрих-коду, в противном случае получатель платежа не распознается.
Еще у обработки есть отличие в кодировке, здесь используется UTF8 и это указано в штрихкоде в первой строке ST000012, коммунальщики печатают штрихкод в кодировке windows-1251 и указывают в коде: ST000011, возможно еще по этой причине не распознается штрих-код. В приложении альфа-банка, ШК из этой обработки тоже не распознается.
18. mentozavr 33 20.07.18 10:54 Сейчас в теме
(17) Да он писался как раз для сбера и под наши нужды. но у нас 2 организации дочерние тоже заключили договор со сбером о принятии оплаты, и счета с данным штрихкодом тоже работают. На сколько слышал в новых разработках 1с уже в банках задается кодировка и в обработку должны передаваться данные типа ST000011 - Сбер, ST000012 - Бин банк и т.д.. кодировка и всех банкоматов одинаковая и ПО банкоматов распознает ее сама.
19. Koneff 21.03.19 20:21 Сейчас в теме
Возможно ли использование на 1С 8.3 упрощенка?
20. mentozavr 33 22.03.19 08:34 Сейчас в теме
(19)Писался для 8.2 но в принципе под 8.3 переделать ее не проблема будет. главное чтобы модули были. Попробуйте скачайте (13) sm не спишут. Выше в коде указаны модули которые использует форма. Если БП 3.0 (не важно упрощенка или нет) то в ней эти функции есть)) будет время попробую написать ее для 8.3
Оставьте свое сообщение

См. также

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android 22

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::Mobile Розница УНФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Внешние источники данных Сканер штрих-кода Терминал сбора данных Работа с интерфейсом Мобильная разработка

Простой мобильный терминал сбора данных для смартфонов на iOS и Android, не требующий сложных настроек и установки дополнительных программ. Для выгрузки базы штрихкодов и загрузки собранных штрихкодов в документы учетной системы используется Яндекс Диск или облачный сервис и расширение конфигурации. Работает с конфигурациями Розница 2, УНФ 1.6, УТ 11, ERP, КА2.

3 стартмани

22.04.2019    10322    54    suepifanov    61       

Трудовой договор, Дополнительное соглашение, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1 17

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    6993    56    Asenka    3       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь полноценный оффлайн (обновление от 15.08.19)! 169

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    20247    212    informa1555    167       

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом 13

Инструменты и обработки Программист Пользователь Архив с данными v8 КА1 БП2.0 УТ10 УПП1 Windows Абонемент ($m) Печатные формы документов Универсальные функции Email

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    11262    10    stvorl    0       

Загрузка файлов/картинок/изображений/фото номенклатуры PRO 17

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница УНФ УТ11 Россия Оптовая торговля Розничная торговля Абонемент ($m) Управленческий учет (прочее)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    7548    64    zannv    18       

Валовая прибыль в текущем месяце. Актуальная себестоимость (рассчитывается из последней цены закупки с учетом доп.расходов) 12

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ УТ11 УУ Оптовая торговля Учет доходов и расходов Абонемент ($m) Управленческие

Валовая прибыль "Вместо себестоимости - Закупочные цены + Доп. расходы". Дополнительный внешний отчет для конфигурации Управление торговлей 11. Отчет поможет предприятиям, если нет возможности: - закрывать месяц ежедневно; - считать себестоимость вообще по разным причинам. В отчет попадают закупочные цены на *конецпериода* формирования отчета + дополнительные расходы.

7 стартмани

16.03.2018    12345    61    zaika007    41       

Автоматизация отдела продаж - CRM конфигурация для небольшой компании 11

Отчеты и формы Руководитель проекта Конфигурация (md, cf) v8 Россия УУ Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Абонемент ($m) Управленческий учет (прочее)

Вам нужна несложная и многофункциональная автоматизированная система управления продажами для автоматизации отдела продаж? Наша CRM Система поможет Вам! Внедрение займет не более 15 минут. CRM Система - быстрая и безболезненная автоматизация отдела продаж. Без лишних затрат и сложностей. Интеграция с 1С Бухгалтерией 3 и 1С УТ 11.

1 стартмани

05.03.2018    11303    32    user718500    9       

Построение маршрута доставки с расчётом расстояния для любой базы УФ 56

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    18576    36    KorotkovRV    16       

Анализ распределения заказов по предоплатам 6

Отчеты и формы Бизнес-аналитик Внешний отчет (ert,erf) v8 УПП1 УУ Оптовая торговля Абонемент ($m) Статистические

Отчет, в котором предоплаты разделены по интервалам (порогам) предоплат.

1 стартмани

21.02.2018    8728    1    wowik    0       

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой 26

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.10 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.10 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    29539    498    p.ugrumov    86       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    21582    21    agent00mouse    0       

Остатки товаров на складах по выбранным документам 9

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 ERP2 УТ11 УУ Учет ТМЦ Абонемент ($m) Печатные формы документов

Печатная форма подключается к документам. Даёт возможность быстро оценить остатки товара на складе по номенклатуре, указанной в документе, и ответить на вопрос, хватает ли остатков, чтобы отгрузить счет? На каких складах продукция по этому документу?

2 стартмани

09.11.2017    30510    24    A7758735    4       

Автозаказ для 1С:Управление торговлей 11 21

Отчеты и формы Бизнес-аналитик Внешний отчет (ert,erf) v8 v8::ОУ УТ11 УУ Оптовая торговля Учет ТМЦ Абонемент ($m) Управленческие

Отчет выводит информацию, помогающую принять решение о пополнении товарного запаса.

3 стартмани

26.09.2017    13948    37    The Ded    23       

Счет-фактура+УПД+УКД с 01.10.2017 в редакции Постановления Правительства РФ от 19.08.2017 № 981. Для всех конфигураций на 1С 8 48

Отчеты и формы Бухгалтер Архив с данными v8 БП2.0 УТ10 УПП1 УНФ БП3.0 УТ11 БУ НУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы с автоматической регистрацией для документа "Счет-фактура выданный" в редакции Постановления Правительства РФ №981 от 19.08.2017 года. Новые счета-фактуры № 981 применяются с 01.10.2017 года. Так же для УТ 10 очень старых релизов применяется сч.фактура в файле.

2 стартмани

18.09.2017    66228    1341    Kontakt    90       

Android беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С 78

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf УУ Android Оптовая торговля Розничная торговля Абонемент ($m) Сканер штрих-кода

Бесплатное приложение, превращающее Android-смартфон в беспроводной 1D/2D Bluetooth сканер и терминал сбора данных для 1С и прочих POS систем. Не требует драйверов и доработки конфигураций.

1 стартмани

12.09.2017    26900    24    kuld    43       

Внешние печатные формы Счет-фактура, УПД, УКД образца 2017 г. (ПП от 19.08.2017 № 981) для УПП 1.3, КА 1.1, БП 2.0 22

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УПП1 БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы "Счет-фактура", "Универсальный передаточный документ", "Универсальный корректировочный документ" (в редакции постановления Правительства Российской Федерации от 19.08.2017 № 981) для типовых конфигураций УПП 1.3, КА 1.1, БП 2.0.

1 стартмани

30.06.2017    41373    712    Tavalik    63       

Счет-фактура с 01.07.2017 от 25.05.2017 №625 для ВСЕХ конфигураций 1С 8.х (БП 2.0, БП 2.0 КОРП, БАУ 2.0, БАУ 2.0 КОРП, КА 1.1, ПД 1.0, Розница 1.0, УНФ 1.3, УПП 1.3, УТ 11, УТ 10.3) 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ КА1 БП2.0 УТ10 Розница УПП1 УНФ БП3.0 БАУ УТ11 Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

С июля 2017 года применяется новая печатная форма счет-фактуры в редакции Постановления Правительства РФ от 25.05.2017 № 625. В публикации собраны внешние печатные формы для всех популярных конфигураций 1С. Будет актуально для 90% организаций, которые не ведут учет по гос. контрактам, так как новое поле не заполняется, а вместо номера гос. контракта установлен прочерк по умолчанию.

1 стартмани

29.06.2017    34423    455    a.kapustin    43       

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме 3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БУ УУ Дебиторская и кредиторская задолженность Абонемент ($m) Обработка документов Печатные формы документов

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    11772    2    denmax    2       

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол 12

Инструменты и обработки Системный администратор Программист Архив с данными v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    41604    127    Atom74    69       

FR_Atol_Shtrih.exe печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54ФЗ поддержка изменений от 01/07/19). Для 1С (7.7 и:8 УФ, Обычных Формы) есть готовые обработки 68

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Windows Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    51237    173    ah7777777    473       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 99

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    40179    49    myALKleon    37       

Отчеты для логистов (а также презентация и пояснительная записка) 7

Отчеты и формы Бизнес-аналитик Руководитель проекта Внешний отчет (ert,erf) v8 1cv8.cf УУ Оптовая торговля Розничная торговля Абонемент ($m) Управленческие

Развитие розничных торговых сетей осуществляется благодаря применению логистики, призванной удовлетворять потребности покупателей в качественных товарах и услугах. Предлагаю Вашему вниманию ряд методических положений, связанных с совершенствованием функционирования логистических систем розничных торговых сетей.

1 стартмани

09.10.2016    19816    2    ksnik    4       

Легкий интернет-магазин из УТ 11.2 67

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 УУ Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка создания интернет-магазина из УТ 11. Создается единственный файл html, который содержит все выгруженные товары. Клиент составляет и отправляет заказ вам на e-mail прямо из браузера, не прибегая к использованию стороннего ПО.

11.08.2016    21861    482    hlopik    36       

Рабочее место менеджера по продажам 18

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Украина УУ Windows Оптовая торговля Абонемент ($m) Рабочее место

Каждый день менеджеры создают кучу документов. Это и заказы покупателей и сопутствующие документы, которые создаются на основании. Менеджеру всегда необходимо иметь под рукой наиболее эффективный инструмент для формирования заявки от покупателя. Таковым я постарался сделать и эту обработку. Обработка "Рабочее место менеджера продаж" позволяет быстро узнать информацию о товарах на складах, цены товара в различных типах цен номенклатуры, узнать какие цены у поставщиков по выбранному товару и так далее. Много месяцев текущая обработка работает на благо сотрудников и приносит действительно большую пользу. Правда, она более внедрена в работу организации, но даже её модифицированная часть для общества должна принести не менее выгоды в работе с товарами и и заказами покупателей. Так что вот она.

5 стартмани

16.07.2016    20848    50    yarsort    9       

Исправление ошибок при закрытии месяца. Управление Торговлей 11.х для 1С Предприятие 8.3 9

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ11 Россия УУ Windows Закрытие периода Оптовая торговля Абонемент ($m) Закрытие периода

В при работе обработки: Закрытие месяца возникают ошибки расчета себестоимости. Постепенно ошибки накапливаются и при дальнейшей эксплуатации системы количество ошибок лавинообразно растет. Обработка помогает исправить ошибки расчета себестоимости. Полный доступ к коду обработки.

3 стартмани

21.06.2016    31126    88    Ликреонский    28       

Неликвиды на складе Pro и Lite версия. Редактирование реквизита в таблице документа. Для конфигурации Управление торговлей 11.2, 11.1 1С Предприятие 8.3 5

Отчеты и формы Бизнес-аналитик Бухгалтер Внешний отчет (ert,erf) v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика УУ Windows Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Управленческие

Внешний отчет для анализа товаров, находящихся на складе без движения. Работает для конфигураций 1С Управление Торговлей 11.2, 11.1. Отчет отображает товары на складах, движения по которым не производились в течении заданного периода дней. Подключается как внешний отчет в конфигурации 1С Управление торговлей 11. В Pro версии можно установить общий реквизит номенклатуры, для дальнейшего включения в отбор в установке цен номенклатуры. Редактирование в табличном документе ускоряет процесс работы с неликвидами номенклатуры на складах. Отчет можно использовать для стоимостной оценки товаров на складах. Полный доступ к тексту модулей и СКД.

1 стартмани

17.06.2016    22380    47    Ликреонский    2       

Анализ продаж по периодам + оборачиваемость по периодам + средняя стоимость по периодам для УТ10.3 4

Отчеты и формы Бизнес-аналитик Пользователь Внешний отчет (ert,erf) v8 КА1 УТ10 УПП1 Россия УУ Windows Оптовая торговля Абонемент ($m) Управленческие

Отчет позволяет сравнивать такие показатели, как валовая прибыль, рентабельность, эффективность, средняя стоимость товаров, оборачиваемость за разные периоды.

4 стартмани

25.05.2016    12734    7    alnovin    0       

Загрузка Счета покупателя из PDF 7

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Windows Оптовая торговля Абонемент ($m) Обработка документов Файловые протоколы обмена, FTP

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    4558    10    John_d    0       

Печатная форма Счет-Фактура от 01.10.2017, УПД 01.10.2017, Торг-12, Счет на оплату, ТТН (1-Т) БП 3.0 ОРИГИНАЛЬНЫЕ 10

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Набор внешних печатных форм: Счет-Фактура, УПД, Торг-12, ТТН, Счетна оплату для 1С: БП 3.0. Формы взяты из релиза 3.0.54.20 бухгалтерии предприятия. Печатные формы (УПД и счет-фактуры) приведены в соответствие постановления 625 от 25.05.2017 И В РЕДАКЦИИ ПОСТАНОВЛЕНИЯ 981 ОТ 19.08.2017 в формах выводится "Идентификатор госконтракта" и прочие изменения.

1 стартмани

04.05.2016    36910    378    A7758735    3       

Трекинг номеров РПО в Почте России 14

Инструменты и обработки Пользователь Архив с данными v8 Оптовая торговля, дистрибуция, логистика Windows Оптовая торговля Абонемент ($m) WEB

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    16648    37    Smaylukk    3       

ЕГАИС: код алкогольной продукции из штрихкода акцизной марки 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Windows Оптовая торговля Розничная торговля Акцизы Абонемент ($m) Универсальные обработки

В последнее время мне пришлось потратить очень много времени на внедрение и реализацию функционала ЕГАИС. Очень часто, на форумах, я встречал вопрос: "Как из штрих-кода акцизной марки получить код алкогольной продукции ЕГАИС?". Несколько раз видел неверную реализацию этой задачи. Глядя на это, я набросал простую обработку пересчета кода акцизной марки (base36) в понятный нам уникальный ФСРАР ID алкогольной продукции (Base10).

1 стартмани

11.02.2016    46576    153    OrcaMax    29       

Печатные формы для БП 3.0: УПД, ТОРГ-12, Акт, Счет-фактура, Доверенность, Счет 25

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы УПД, ТОРГ-12, Акта об оказании услуг, Счет-фактуры, Доверенности и Счета на оплату покупателю, актуализированы на последний релиз 3.0.71, поддерживают типовые факсимиле (новую галочку "Подпись и печать"), не содержат ошибок с новой ставкой НДС. В публикации также представлены печатные формы для устаревших релизов.

1 стартмани

28.01.2016    55578    762    config    42       

Пакетная замена номенклатуры с учетом характеристик 6

Инструменты и обработки Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 УУ Оптовая торговля Учет ТМЦ Абонемент ($m) Обработка документов

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    9578    trendy    1       

Легкое создание пользователем внешних печатных форм методом Drag & Drop 135

Отчеты и формы Программист Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Универсальные печатные формы Печатные формы документов

Универсальная внешняя печатная форма (ПФ), которая позволяет пользователю, без знаний программирования и не заходя в конфигуратор, создать ПФ любого документа или справочника в Microsoft Word или OpenOffice Writer методом перетаскивания (Drag & Drop). Можно создавать любые ПФ с выводом табличных частей, реквизитов документа, а также вложенных реквизитов и контактной информации. Не требует изменения конфигурации. Работает на версии платформы 8.3 в типовых конфигурациях на управляемых формах (например, Бухгалтерия 3.0, УТ 11, УНФ, Розница, Документооборот), а также и в других конфигурациях на УФ, построенных на БСП.

2 стартмани

04.01.2016    28212    180    CyberCerber    35       

Облачный каталог товаров на 1C 40

Инструменты и обработки Программист Архив с данными v8 УТ10 Розница Windows Оптовая торговля Розничная торговля Абонемент ($m) WEB

Поднимите руки те, кто занимается разработкой на 1С. Спасибо, опустите. Поднимите руки те, кто хоть раз писал загрузку прайса из экселя. Я смотрю, все те же. Ладно, а теперь поднимите руки те, кто хоть раз задумывался о каком-то каталоге мастер-данных по товарам. Чуть меньше. А признайтесь, кто из вас свято убежден, что делать этот каталог должен кто-то другой, например, веб-разработчики? Об этом и пойдет речь.

1 стартмани

28.12.2015    20287    31    skif47    42       

Прайс-лист с картинками в EXCEL из 1С: УТ10, УПП, КА (с формой заказа) 26

Отчеты и формы Руководитель проекта Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 Windows Оптовая торговля Абонемент ($m) Ценообразование, прайсы Загрузка и выгрузка в Excel

Обработка для формирования прайса в EXCEL с формой заказа. Выгрузка картинок, характеристик, нескольких цен, остатков. Расчет заказа прямо в прайсе.

9 стартмани

26.11.2015    26787    61    spy-83    19       

Загрузка УПД в Бухгалтерию 3.0 11

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Оптовая торговля Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0, с добавлением номенклатуры, ГТД, стран происхождения.

3 стартмани

20.10.2015    10667    7    teyana    12       

Внешняя печатная форма «Счет на оплату покупателю» для документа «Реализация товаров и услуг» 2

Отчеты и формы Бухгалтер Архив с данными v8 БП2.0 Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма «Счет на оплату покупателю» для документа «Реализация товаров и услуг»

5 стартмани

07.09.2015    16992    2    trendy    0       

[x1c.ru] MXL Stamps - Печати и подписи в макетах печатных форм в несколько кликов 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Универсальные обработки

Обработка позволяет быстро создавать поля текста из ячеек печатных форм и добавлять "под них" подписи и печати. Работает в конфигурациях на управляемых формах.

1 стартмани

22.08.2015    26734    23    GusevNA    6       

Конструктор трудовых договоров WORD для типовой конфигурации 1C: Зарплата и управление персоналом 3.1 82

Отчеты и формы Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x Россия БУ Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Универсальные печатные формы Пакетная печать Печатные формы документов

Внешняя печатная форма или обработка "Конструктор трудовых договоров на основе документов формата Word". Конструктор автоматически подставляет реквизиты в документ формата Word. Подходит для типовой конфигурации 1С: ЗУП 3.1.

1 стартмани

14.07.2015    46655    581    ni032mas    97       

Счет на оплату покупателю с выбором изображения факсимильной печати и подписей для конфигурации "Бухгалтерия предприятия 3.0" 5

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 БП2.0 Россия Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Как известно, типовая конфигурация предоставляет возможность формирования счета с подписями и печатью. Это удобно, т.к. сразу, без вывода на печать и сканирования можно сохранить факсимильное изображение документа в pdf формате и отправить контрагенту. Создание и добавление картинки производится при редактировании справочника "Организации". Здесь же предлагается шаблон и понятная инструкция по созданию файла картинки. Что же можно улучшить?

1 стартмани

10.07.2015    19105    34    Олег Ящеров    5       

Отчет по продажам "SKU по менеджерам" 10

Отчеты и формы Бизнес-аналитик Пользователь Внешний отчет (ert,erf) v8 КА1 УТ10 Россия УУ Windows Оптовая торговля Абонемент ($m) Управленческие

SKU (Stock Keeping Unit) [skew] — идентификатор товарной позиции, единица учёта запасов, складской номер, используемый в торговле для отслеживания статистики по реализованным товарам/услугам. Подробнее смотрите по ссылке https://ru.wikipedia.org/wiki/SKU Данный отчет показывает оценить работу менеджеров с товарным ассортиментом. Это позволит выделить менеджеров, которые работают со всем ассортиментом продукции, или тех, кто продвигает узкий спектр товаров. Знание о том, какой менеджер каким ассортиментом торгует, позволяет разработать гибкую мотивацию по ассортименту, оценить динамику продаж по месяцам, а также найти иное применение при разработке маркетинговой стратегии компании.

1 стартмани

15.06.2015    29170    19    axelerleo    10