Выбор Адреса контрагента из Контактной информации. Пример работы с "Оповестить о выборе"

Публикация № 435589 16.12.15

Пользовательские инструменты - Адаптация типовых решений

Форма выбора ОповеститьОВыборе() ОповеститьОВыборе оповестить о выборе контактная информация КонтактнаяИнформация Контрагенты БП 3.0 бухгалтерия пропадает строка справочник контрагентов форма контактной

Решение задачи выбора Адреса контрагента из Контактной информации на платформах 8.2, 8.3, на обычных и управляемых формах, Бухгалтерии 2.0 и 3.0

I. Решение задачи для для конфигураций на платформе 8.2, обычных форм, Бухгалтерии 2.0

пример кода для выбора адреса из Контактной информации:

ФормаВыбора = РегистрыСведений.КонтактнаяИнформация.ПолучитьФормуСписка("ФормаСписка", ЭтаФорма);
ФормаВыбора.РежимВыбора = Истина;

ФормаВыбора.РегистрСведенийСписок.Отбор.Объект.Значение = Контрагент;
ФормаВыбора.РегистрСведенийСписок.Отбор.Объект.Использование = Истина;

СтруктураОтбораАдресов = Новый СписокЗначений;
СтруктураОтбораАдресов.Добавить(Перечисления.ТипыКонтактнойИнформации.Адрес);
ФормаВыбора.РегистрСведенийСписок.Отбор.Тип.ВидСравнения = ВидСравнения.ВСписке;
ФормаВыбора.РегистрСведенийСписок.Отбор.Тип.Значение = СтруктураОтбораАдресов;
ФормаВыбора.РегистрСведенийСписок.Отбор.Тип.Использование = Истина;
ФормаВыбора.ЭлементыФормы.РегистрСведенийСписок.Колонки.Тип.Видимость = Ложь;

ВыбранныйАдрес = ФормаВыбора.ОткрытьМодально();

Если ЗначениеЗаполнено(ВыбранныйАдрес) Тогда
    Элемент.Значение = ВыбранныйАдрес;
КонецЕсли;

II. Решение задачи через СписокЗначений для конфигураций на платформе 8.3, управляемых форм, Бухгалтерии 3.0

пример кода:

&НаКлиенте
Процедура ТабличнаяЧасть1НачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    ДанныеВыбора = Новый СписокЗначений;
    ДанныеВыбора.ЗагрузитьЗначения(ТабличнаяЧасть1НачалоВыбораНаСервере());
    
КонецПроцедуры

&НаСервере
Функция ТабличнаяЧасть1НачалоВыбораНаСервере()
    
    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Тип", Перечисления.ТипыКонтактнойИнформации.Адрес);
    НайденныеСтроки = Объект.Контрагент.КонтактнаяИнформация.НайтиСтроки(ПараметрыОтбора);
    МассивВыбора = Новый Массив;
    Для Каждого Строка из НайденныеСтроки Цикл
        МассивВыбора.Добавить(Строка.Представление);
    КонецЦикла;
    Возврат МассивВыбора;
    
КонецФункции

Получившийся выпадающий список адресов:

(мне показалось неудобным искать адрес, если данных в регистре много, поэтому предлагаю другой вариант ниже)

 

III. Решение задачи через ФормуВыбора для конфигураций на платформе 8.3, управляемых форм, Бухгалтерии 3.0

III.1.Что нужно сделать в форме-приемнике (форме Владельца)

У нас есть некая табличная часть. В один из её реквизитов мы хотим добавить адрес контрагента, используя форму выбора адреса. В моем примере это "ТабличнаяЧасть1" с реквизитом "Адрес" типа Строка. Соотвественно в моей обработке есть и сам реквизит "Контрагент" типа СправочникСсылка.Контрагенты. Важно не забыть добавить кнопку выбора.

 

Дальше объявляем у Адреса событие НачалоВыбора. В диалоговом окне выбираем только "на клиенте"

В этом событии должен отработать следующий код:

&НаКлиенте
Процедура ТабличнаяЧасть1АдресНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    //Не забудем отменить Стнадартную обработку
    СтандартнаяОбработка = Ложь;
    
    //Проверим, чтобы был выбран контрагент
    Если Объект.СсылкаКонтрагент.Пустая() Тогда
        ВвестиЗначение(Объект.СсылкаКонтрагент, "Выберите контрагента");
    КонецЕсли;
    
    Если НЕ Объект.СсылкаКонтрагент.Пустая() Тогда
        
        //Откроем форму выбора адреса
        //В параметры можно передать все необходимые данные для формы выбора. Но в нашем случае это только Контрагент
        ПараметрыФормы = Новый Структура();
        ПараметрыФормы.Вставить("СсылкаКонтрагент", Объект.СсылкаКонтрагент);
        
        ОткрытьФорму("ВнешняяОбработка.ПримерРаботыСОповеститьОВыборе.Форма.ВыборАдреса", ПараметрыФормы, ЭтаФорма);
        
    КонецЕсли;
    
КонецПроцедуры

III.2.Что нужно сделать в форме-источнике

Дошли до формы выбора адреса. У меня получилась такая простенькая форма:

Нам понадобятся два реквизита СпрОбъект (тип СправочникОбъект.Контрагенты) и соответственно СсылкаКонтрагент. Вытаскиваем (перетягиваем) на форму Табличную часть "Контактная информация" у СпрОбъект и ничего заполнять не надо, просто в дальнейшем получим объект у СсылкаКонтрагент и информация будет отражаться на форме.

Что необходимо сделать в модуле формы выбора:

Во-первых,

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    // Заполним реквизиты формы из ранее переданных параметров.
    ЗаполнитьЗначенияСвойств(ЭтаФорма, Параметры, "СсылкаКонтрагент");
КонецПроцедуры

Во-вторых, получим объект у Контрагента, чтобы заполнилась табличная часть Контактной информации на форме

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПриОткрытииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
    
    //Заполним таблицу контактной информации
    КонтрагентОбъект = СсылкаКонтрагент.ПолучитьОбъект();
    ЗначениеВРеквизитФормы(КонтрагентОбъект, "СпрОбъект");  
                                                                                
КонецПроцедуры

В-третьих, у табличной части объявляем событие "Выбор" только "на клиенте" и добавляем ОповеститьОВыборе

&НаКлиенте
Процедура СпрОбъектКонтактнаяИнформацияВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    
    //Ключ структуры - имя реквизита формы-владельца
    СтруктураРезультат = Новый Структура();
    СтруктураРезультат.Вставить("Адрес",         Элемент.ТекущиеДанные.Представление);
    СтруктураРезультат.Вставить("АдресЗаполнено", Истина); //чтобы не пропала строка
    ЗаполнитьЗначенияСвойств(СтруктураРезультат, ЭтаФорма);
    ОповеститьОВыборе(СтруктураРезультат);
    
КонецПроцедуры

III.3.Что еще нужно сделать в форме-приемнике


Объявить процедуру ОбработкаВыбора только "на клиенте" и вставить подобный код:

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    
    ДанныеСтроки = Новый Структура("Адрес, АдресЗаполнено"); //имя заполняемого реквизита
    ТекущиеДанные = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
    
    ЗаполнитьЗначенияСвойств(ДанныеСтроки, ВыбранноеЗначение); //заполним структуру
    
    ЗаполнитьЗначенияСвойств(ТекущиеДанные, ДанныеСтроки); //заполним табличную часть
    
    Модифицированность = Истина;
    
КонецПроцедуры

III.4.Как записать изменения Контактной информации из формы выбора

Как видно из рисунка выше, у меня объявлена Команда формы - ЗаписатьИзменения. На ней "висит" следующая процедура:

//Записать изменения
&НаКлиенте
Процедура ЗаписатьИзменения(Команда)
    ЗаписатьИзмененияНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаписатьИзмененияНаСервере()
    
    НовыеДанные = Новый ТаблицаЗначений;
    НовыеДанные = СпрОбъект.КонтактнаяИнформация.Выгрузить();
    
    
    ОбъектКонтрагент = СсылкаКонтрагент.ПолучитьОбъект();
    
    ОбъектКонтрагент.КонтактнаяИнформация.Загрузить(НовыеДанные);
    
    ОбъектКонтрагент.Записать();
    
КонецПроцедуры

 

IV. Вопрос к Знатокам- "Баг или криворук?"

Все замечательно работает. Но есть одно непонятное мне действо. Если в добавленной строке Табличной части источника ничего не заполнено, а мы пользуемся ОповеститьОВыборе(), то только что добавленная строчка исчезает. Причем это проявляется даже в типовой Бухгалтерии. Например, берем документ Реализация(услуги), добавляем строчку в Табличную часть, не выбирая Номенклатуру пытаемся сначала установить Счета учета. Открывается форма выбора, выставляем счета, нажимаем на ОК. В документе появляется строчка. Но стоит щелкнуть мышкой в другом месте, строчка пропадет.

Вопрос очень простой: Что же делать, как же быть в такой ситуации?

Покопавшись самостоятельно, удалось найти, что в самых свежих релизах Бухгалтерии 3.0 такая ошибка не воспроизводится. Разработчики добавили реквизит формы типа "Булево" (у меня это АдресЗаполнено, у них это АналитикаУчетаЗаполнена) и его в ОбработкеВыбора исходной формы заполняют. НО если (с учетом этого добавления) запустить мою обработку на старом релизе - строчка пропадет, если на новом - останется. Платформу при этом не меняем. В связи с этим, всё равно хочется докопаться до сути. КАК при одной платформе, но разных релизах один и тот же код отрабатывает по-разному, учитывая, что никакие общие модули не используем?

Скачать файлы

Наименование Файл Версия Размер
ПримерРаботыСОповеститьОВыборе.epf

.epf 12,89Kb
6
.epf 12,89Kb 6 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. GAVe 10.01.17 17:13 Сейчас в теме
Пора скрывать это к БП 3.0 относится.
ИМХО, у всех уже БП 3.1.
2. spacecraft 10.01.17 17:23 Сейчас в теме
(1) и как оно там в будущем? Коммунизм победит?
3. Designer1C 301 28.11.19 17:54 Сейчас в теме
Благодарю за статью !
Как для меня, так очень доходчиво написано !
Быстро помогло решить одну интерфейсную задачку.
4. ilya4 20.01.21 19:49 Сейчас в теме
Тоже наблюдал баг с исчезновением заполненных реквизитов, когда есть передача данных между переменными типа "объект".
Для исправления мне помогло для передачи данных между объектом-реквизитом формы и объектом-источником воспользоваться командой КопироватьДанныеФормы(ОбъектИсточник,ОбъектНаФорме) , на сервере
Оставьте свое сообщение

См. также

Хранение файлов в томах на диске (для УПП 1.3) Промо

Адаптация типовых решений v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    74821    19    wowik    32    

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений v8 1cv8.cf Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

3 стартмани

05.08.2022    3420    3    sapervodichka    1    

Загрузка банка (дополнительный парсинг)

Обмен с банком Адаптация типовых решений v8 v8::БУ БП3.0 БУ Абонемент ($m)

Данное расширение позволяет производить дополнительное изменение при загрузке банковских документов. Изменение конфигурации - не требуется.

5 стартмани

02.08.2022    604    0    sulig    0    

Просмотр объектов очереди сообщений в 1С:Документооборот

Адаптация типовых решений v8 1cv8.cf Абонемент ($m)

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

1 стартмани

02.08.2022    3404    11    sapervodichka    4    

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11) Промо

Адаптация типовых решений Универсальные функции v8 УТ11 Россия Абонемент ($m)

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11)

1 стартмани

28.03.2013    162145    548    Stradivari    31    

Cчет на оплату выводит шапку "Банковские реквизиты / BANK INFORMATION"

Адаптация типовых решений v8 ERP2 Абонемент ($m)

При печати счета на оплату выводит шапку "ОбразецЗаполненияРеквизитыБанка", причины и пути решения.

1 стартмани

11.07.2022    468    1    osa92    0    

Видимость переключателя Без закрывающих документов

Адаптация типовых решений v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

В 1С:Бухгалтерии в банковских выписках в документах поступление на расчетный счет есть переключатель - Учет без закрывающих документов. Его удобно использовать для УСН доходы или патента. Однако при определённых настройках он не виден на форме. Расширение включает видимость этого переключателя для любых СНО.

1 стартмани

07.07.2022    658    2    de0nis    0    

Исправление ошибки РДИК_0333

Адаптация типовых решений v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Исправление ошибки РДИК_0333 при выгрузке документов в ЕИС.

1 стартмани

05.07.2022    1239    27    oleg-x    6    

Отправка сообщений пользователям Промо

Адаптация типовых решений v8 УТ10 Россия Абонемент ($m)

Предполагаю, что в организациях, где работает больше 10-15 человек, сложно звонить каждому и сообщать пользователям какую-либо информацию. Я обыскал на всех ресурсах, так того, что требуется, не нашел.

1 стартмани

13.01.2012    19181    374    kojinandrej    54    

Добавление строк в регистрации обязательств по договорам с разными ИФО. БГУ 2.0

Адаптация типовых решений v8 v8::БУ БГУ Государственные, бюджетные структуры БУ Госбюджет Абонемент ($m)

Иногда нужно и очень хочется добавить принимаемые обязательства по одному договору, но по нескольким ИФО, но БГУ 2.0 не дает это сделать, а жаль! В результате приходится заводить одинаковые договоры или создавать бухгалтерскую операцию, ну или корректировать проводки вручную - плохо! С помощью расширения решим это и сможем добавлять строки с разными ИФО.

3 стартмани

30.06.2022    531    3    VID1234    0    

Выгрузка документов в формате XML для загрузки в ЭДО операторов СБИС, Диадок и т.п.

Адаптация типовых решений Файловые протоколы обмена (TXT, XML, DBF), FTP v8 ERP2 Россия Абонемент ($m)

Расширение для добавления дополнительного функционала в библиотеку БЭД , добавляет команду для выгрузки данных в формате XML для загрузки в ЭДО из 1С.

3 стартмани

30.06.2022    895    10    osa92    2    

Исправление обработки Подбор номенклатуры в Бухгалтерии для Беларуси, редакция 2.1.42.8

Адаптация типовых решений v8 1cv8.cf Беларусь БУ Абонемент ($m)

В версии 1С 8.3 Бухгалтерия для Беларуси 2.1.42.8 обнаружена ошибка в подборе номенклатуры (из любого документа): независимо от выбранного количества номенклатуры в форму попадает единица.

1 стартмани

15.06.2022    646    1    1v7    2    

Критерии отбора в расширении. 16+

Адаптация типовых решений v8 ERP2 УТ11 КА2 Абонемент ($m)

Связываем критерии отбора расширения с типовой структурой подчиненности в универсальных решениях 1С.

3 стартмани

09.06.2022    1961    5    Ankare    3    

Восстановление возможности удаления сторно-записей. ЗУП 3.1

Зарплата Адаптация типовых решений v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

В актуальных релизах ЗУП/ЗКГУ, веток 3.1.18 и 3.1.22 нет возможности удалять строки перерасчетов за прошлые периоды.

1 стартмани

02.06.2022    862    3    laperuz    0    

Исправление ошибки - не печатается код вида дохода 2, 3, 4, 5 в списках в банк

Зарплата Адаптация типовых решений v8 v8::СПР ERP2 ЗКГУ3.0 КА2 ЗУП3.x Россия БУ Абонемент ($m)

С версии ЗУП минимум 3.1.22.48 в печатной форме "Список перечислений" для ведомостей в банк и ведомостей на счета не печатает код дохода исполнительного производства, если он отличается от единицы. Данное расширение исправляет эту ошибку.

1 стартмани

01.06.2022    892    0    the1    0    

Обезжиривание шрифта в печатной форме (экономим тонер)

Печатные формы Адаптация типовых решений v8 БП3.0 Абонемент ($m)

Код, который убирает полужирное начертание у шрифтов в печатной форме. Тестировалось на конфигурации Бухгалтерия Предприятия 3.0.111.16. Но должно работать на любых конфигурациях с БСП.

1 стартмани

24.05.2022    1001    1    q_i    3    

Присоединение внешней печатной формы в виде файла к объекту-основанию

Печатные формы Адаптация типовых решений v8 1cv8.cf Абонемент ($m)

В данной публикации речь пойдёт о том, как можно присоединить сформированную внешнюю печатную форму в виде файла к тому объекту (справочнику, документу и т.п.), на основании которого она была сформирована.

1 стартмани

20.05.2022    1351    1    delta    0    

Добавление состояния согласования из 1С: Документооборот

Документооборот и делопроизводство Адаптация типовых решений v8 ДО Абонемент ($m)

Добавляем статус согласования из подключенной базы 1С Документооборот в типовые и нетиповые конфигурации с использованием библиотеки интеграции с 1С: Документооборотом. Статусы добавляются в формы списка и формы объектов.

1 стартмани

11.05.2022    1684    0    Free_Danial    0    

Автозаполнение шаблонов файлов MXL в "1С:Документообороте"

Документооборот и делопроизводство Адаптация типовых решений v8 ДО Абонемент ($m)

Добавление возможности создавать автозаполняемые шаблоны файлов в формате MXL в 1С:Документооборот и сохранением заполненного файлы в формате PDF (таблицы, результаты запроса реквизиты...)

1 стартмани

05.05.2022    1874    7    JIEX@    0    

Шаблон этикетки для УНФ (1С:Фреш)

Адаптация типовых решений v8 УНФ Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    1806    0    zemskov    0    

Электронный чек взамен бумажного

Кассовые операции Розничная торговля Адаптация типовых решений v8 УНФ Абонемент ($m)

Упрощаем выдачу электронного чека взамен бумажного в УНФ 1.6.

1 стартмани

19.04.2022    1858    6    the1    0    

Расширения для Бухгалтерии предприятия 3.0 КОРП для работы с ЕИС

Адаптация типовых решений v8 БП3.0 Государственные, бюджетные структуры Россия БУ Абонемент ($m)

Расширения, исправляющие ошибки и дополняющие недостающий функционал.

1 стартмани

10.04.2022    2496    37    anig99    5    

ЗУП: История изменения контактной информации для организации

Адаптация типовых решений v8 ЗУП3.x Россия БУ Абонемент ($m)

История изменения контактной информации для организации в конфигурации ЗУП.

1 стартмани

23.03.2022    1764    1    MaxxiMiliSan    0    

Внутренний оборот тары при перемещениях. УТ 11.4

Оптовая торговля Розничная торговля Склад и ТМЦ Адаптация типовых решений v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Внутренний оборот тары при перемещениях для Управления торговлей 11.4, которого почему-то нет в конфигурации из коробки.

2 стартмани

16.03.2022    1842    0    13D    0    

Отключение системных команд "Печать, Предварительный просмотр, Сохранить", которые по умолчанию отображаются с релиза 8.3.15

Универсальные функции Адаптация типовых решений v8 УТ11 Россия Абонемент ($m)

В УТ 11 возникла необходимо при печати чека отключить системные команды Печать, Предварительный просмотр, Сохранить. Задача: отключить возможность у пользователя (кассира) печатать документы реализации (Товарный чек или Реализацию) в количестве более 1 экземпляра.

1 стартмани

16.02.2022    2661    1    whitevolta    0    

Моментальный поиск документов при сканировании штрих-кода, замена штрих-кода на QR код, QR-кодирование печатных форм в 1С: Управление нашей фирмой (УНФ)

Адаптация типовых решений Обработка документов Поиск данных v8 УНФ Россия Абонемент ($m)

Моментальный поиск документов при сканировании штрих-кода, замена штрих-кода на QR код, QR-кодирование печатных форм в 1С: Управление нашей фирмой (УНФ) для мобильного приложения.

1 стартмани

11.02.2022    2002    0    1c-krund    2    

Исправление ошибки с аналитиками в бюджетировании ERP 2.4

Адаптация типовых решений Бюджетирование и планирование v8 ERP2 Абонемент ($m)

В случае когда у статьи бюджета больше одного правила получения фактических данных, происходит некорректное поведение программы при подстановке конкретных значений аналитик, данное расширение исправляет эту ситуацию.

1 стартмани

17.01.2022    2454    0    bob_    0    

Программное создание и расчет документов начисления зарплаты в конфигурации ЗУП 3.1 и ERP (по подразделениям)

Зарплата Адаптация типовых решений v8 v8::СПР ERP2 ЗУП3.x БУ Абонемент ($m)

Краткое описание типового механизма расчета зарплаты в конфигурации ЗУП 3.1 и ERP и описание разработанной обработки по программному расчету документов зарплаты в разрезе подразделений. Т.к. формирование документов происходит полностью программно, с минимумов параметров, его можно брать за основу для расчета документов по своим условиям, вплоть до создания по расписанию при необходимости.

10 стартмани

27.12.2021    4326    7    maraty    39    

БСП 3.1.5 Форма отчета. Быстрый вызов редактирования варианта

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

В последних релизах современных конфигураций, основанных на БСП версии 3.1.5, спрятали кнопку настройки варианта в дебри вложенных форм. Вернём всё как было, и даже лучше.

1 стартмани

20.12.2021    3615    1    the1    0    

Доработка документа для формирования проводок в регламентированном учете ERP

Адаптация типовых решений v8 ERP2 УТ11 БУ Абонемент ($m)

Статья о том, как включить разработанный документ в подсистему формирования проводок в конфигурации ERP

1 стартмани

17.12.2021    5314    5    maraty    6    

Обновление МДЛП - проблемы с перемещением (431 сообщение)

Склад и ТМЦ Адаптация типовых решений v8 1cv8.cf Фармацевтика, аптеки Россия УУ Абонемент ($m)

Исправление ошибки с получением квитанции о перемещении МДЛП ("Мониторинг движения лекарственных препаратов для медицинского применения от производителя до конечного потребителя").

1 стартмани

24.11.2021    3826    2    Vladimir45    7    

Отображение ОГРН в карточке контрагента. УТ 11

Обработка справочников Адаптация типовых решений v8 УТ11 Россия Абонемент ($m)

Возможность заполнения и отображения уже заполненного ОГРН из сервиса 1С:Контрагенты (расширение).

1 стартмани

11.11.2021    1885    4    pridecom    0    

Настраиваемый комплект документов по Грузополучателю/Контрагенту Расходной накладной. 1С: УНФ 1.6

Адаптация типовых решений Пакетная печать v8 УНФ Россия Абонемент ($m)

Расширение сохраняет настройки "Настраиваемого комплекта документов" по Грузополучателю или Контрагенту Расходной накладной.

1 стартмани

08.11.2021    2737    2    DimanZ    0    

Вывод веса и объема товаров на формы документа и списка документов Заказ клиента, Заказ поставщику, Приобретение товаров и услуг и Реализация товаров и услуг (ERP 2, КА 2, УТ 11)

Оптовая торговля Склад и ТМЦ Работа с интерфейсом Адаптация типовых решений v8 ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Расширение для вывода на формы документа и списка документов Заказ клиента, Заказ поставщику, Приобретение товаров и услуг и Реализация товаров и услуг веса и объема товаров (ERP 2, КА 2, УТ 11).

3 стартмани

25.10.2021    2681    8    Spektr    1    

Коррекция считывания нечитаемой маркировки для сканеров штрихкода с проблемами настройки или в терминальной сессии (Розница 2)

Розничная торговля Адаптация типовых решений v8 Розница Россия Абонемент ($m)

Расширение корректирует "на лету" считанные марки маркированной продукции, позволяя им быть корректно прочитанными, даже при неправильно настроенном сканере или в терминальной сессии.

2 стартмани

25.10.2021    2573    3    denmax    0    

Удаление подчиненных документов, по структуре подчиненности 1С 8.3. Расширение.

Адаптация типовых решений Чистка данных Обработка документов v8 1cv8.cf Розница БП3.0 УТ11 Абонемент ($m)

При удалении документов в 1С документы, которые были подчинены удаляемому документу, остаются проведенными, что не всегда удобно.

2 стартмани

22.10.2021    2984    6    ClickUp    0    

Контроль остатков раздельно по организациям

Склад и ТМЦ Адаптация типовых решений v8 УНФ Абонемент ($m)

Расширение добавляет возможность раздельного контроля остатков по организациям для УНФ 1.6

1 стартмани

22.10.2021    2696    3    the1    2    

Автоматическая установка времени в документах

Обработка документов Адаптация типовых решений Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Расширение позволяет настроить, чтобы тот или иной документ записывался в базе строго с определённым временем. Более того, имеется возможность настроить несколько условий для одного типа документов.

3 стартмани

22.10.2021    2776    5    RSConsulting    0    

Модуль для интеграции 1С с бесплатным файлообменником FilesFM (аналог DropMeFiles) с возможностью работы без регистрации

Документооборот и делопроизводство Файловые протоколы обмена (TXT, XML, DBF), FTP Внешние источники данных WEB Адаптация типовых решений Облачные сервисы, хостинг v8 1cv8.cf Абонемент ($m)

Модуль позволяет автоматически выгружать любой файл в бесплатный файлообменник "Files.fm" без регистрации и получить ссылку для его загрузки. В качестве примера описан способ интеграции модуля с типовой конфигурацией. Также описаны функции модуля, доступные для разработчика и методы работы с ними!

1 стартмани

09.10.2021    4120    4    Nabi    5    

Новые акцизные марки (Украина)

Розничная торговля Адаптация типовых решений v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Украина Акцизы Абонемент ($m)

C 01.10.2021 в Украине вступил в силу закон, который регламентирует работу с алкогольной продукцией. Все организации, торгующие алкоголем, должны указывать в чеке список акцизных марок и штрихкод товара. Предлагаю рабочую доработку типовой конфигурации BAS Роздрібна торгівля, 2.2, которая учитывает все нюансы по работе с новыми акцизными марками.

10 стартмани

09.10.2021    3492    5    Bor_ka    0    

Исправление загрузки словарей ФРМР

Зарплата Адаптация типовых решений Файловые протоколы обмена (TXT, XML, DBF), FTP v8 v8::СПР ЗКГУ3.0 Госбюджет Абонемент ($m)

Исправление ошибки, возникающей при загрузке словарей ФРМР (федеральный регистр медицинских работников).

1 стартмани

09.09.2021    3738    7    the1    4    

Заполнение реализации и поступления из Excel

Загрузка и выгрузка в Excel Адаптация типовых решений v8 БП3.0 Россия БУ Абонемент ($m)

Расширение конфигурации позволяет заполнять документы: реализация товаров и поступление товаров данными из файла Excel, а также убирает рекламу от 1С при начале работы. Тестировалось на платформе 1С:Предприятие 8.3 (8.3.16.1814) / Конфигурация: Бухгалтерия предприятия, редакция 3.0 (3.0.95.29)

1 стартмани

01.09.2021    2644    7    Adept1C    2