До старта конференции

Правила Обмена ЗУП 3.0 --> УПП 1.3

Обмен - Перенос данных из 1C8 в 1C8

Комплект правил автоматического обмена ЗУП 3.0 УПП 1.3 или выгрузки из ЗУП в УПП стандартной обработкой

Для настройки автоматического обмена в УПП нужно добавить узел ОбменЗарплата3Бухгалтерия3 и загрузить комплект правил в ЗУПе в настройку  обмена с бухгалтерией через прямое подключение к УПП.

Правила выгружают документы:

  • "Отражение зарплаты в регл учете"
  • "Ведомость в банк"
  • "Начисление оценочных обязательств".

Поиск счетов идет по наименованию способа отражения, а также поиск способа отражения в УПП идет по подразделению, после загрузки автоматически заполнятеся налоговый учет. В правилах реализована зарплата на 44,20,26 счете (при желании можете доделать под свой учет).

Скачать файлы

Наименование Файл Версия Размер
Комплект правил ЗУП 3.0-УПП1.3
.zip 9,89Kb
08.04.16
101
.zip 9,89Kb 101 Скачать

См. также

Комментарии
1. Александр Щербаков (CAV) 11.07.16 09:46 Сейчас в теме
Добрый день!
При загрузке комплекта правил в ЗУПе в настройку обмена с бухгалтерией через прямое подключение к УПП выдает ошибку:
Не верный формат комплекта правил. Ожидаемое количество файлов в архиве - три. Ожидаются файлы:
ExchangeRules.xml - правила конвертации для текущей программы
CorrespondentExchangeRules.xml - правила конвертации для программы-корреспондента
RegistrationRules.xml - правила регистрации для текущей программы
Прикрепленные файлы:
2. Сергей Нувальцев (nusv) 24 11.07.16 14:03 Сейчас в теме
(1) CAV, Загрузи только правила конвертации, без регистрации, регистрации типовой достаточно(Параметры синхронизации данный->Загрузить правила конвертации)
3. Сергей Аверьянов (saver77) 9 07.02.17 17:45 Сейчас в теме
Добрый день.
Правильно я понимаю, что переносится документ Отражение зарплаты в бухучете?
Тогда не понятно, где настраиваются проводки?
4. Petr (sevipa) 18.02.17 18:21 Сейчас в теме
Подскажите как правильно создать узел в УПП, я сделал по умолчанию, подставил имя узла, настройка прошла успешно, но при попытке обмена в ошибках пишет вот такую вещь: Один из узлов обмена имеет пустой код. Обмен отменен.
5. Сергей Нувальцев (nusv) 24 18.02.17 20:52 Сейчас в теме
(4)просто скопируй весь узел из конфигурации в кофигурацию. Могу cf файл тебе выгрузить завтра. Напиши почту дам ссылку
6. Petr (sevipa) 18.02.17 21:19 Сейчас в теме
Нашел проблему с кодом, но вот теперь следующая штука:

Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(17291)}: Ошибка при отправке данных: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(3867)}: Ошибка в базе-корреспонденте: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(9489)}: Ошибка при записи документа: Зарплата к выплате организаций КВЗК-000001 от 18.02.2017 18:45:14. Описание ошибки: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(1524)}: Ошибка записи объекта
ТипОбъекта = Зарплата к выплате организаций
Объект = Зарплата к выплате организаций КВЗК-000001 от 18.02.2017 18:45:14
ОписаниеОшибки = Ошибка при вызове метода контекста (Записать)
НаборЗаписей.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{РегистрСведений.СоответствияОбъектовИнформационныхБаз.МодульНабораЗаписей(33)}: Ошибка при вызове метода контекста (Добавить)
НаборЗаписей.Записать();
по причине:
Несоответствие типов (параметр номер '1')
ПозицияМодуля = ОбщийМодуль.ОбменДаннымиСервер.Модуль(7652)
КСообщенияОбОшибках = 26
ВызватьИсключение СтрокаСообщения;
ВызватьИсключение(НСтр("ru = 'Ошибка при отправке данных'") + ": " + ОписаниеОшибки());
7. Сергей Нувальцев (nusv) 24 18.02.17 22:51 Сейчас в теме
Это уже что то с данными. Посмотри в отладке
8. Сергей Нувальцев (nusv) 24 19.02.17 00:34 Сейчас в теме
(6)способ отражения называется как счет? 26.01 44.01? Какой счет затратный?
9. Petr (sevipa) 27.02.17 20:46 Сейчас в теме
Выгрузка отражения в учете странно формирует проводки, не выгружаются подразделения, счета учета, и аналитика вообще... странно... есть закоментированные блоки, как я понимаю эти правила были написаны под конкретную аналитику, так как используется везде поиск по Наименованию, а нет ли возмодности выдать что-то более универсальное?
по сути заплатил 3 см за шаблон который приходится полностью перепиливать, вплоть до загрузки новых описаний конфы, писать выгрузку документов в кассу, на рассчетные счета, отражение резервов тоже нужно делать... за шаблон дорого... 1см максимум
10. Petr (sevipa) 27.02.17 21:26 Сейчас в теме
11. Компания Ситек (sitec) 04.04.17 08:54 Сейчас в теме
Добрый день, данная обработка подходит только для ЗУП 3,0 или для ЗУП 3,1 она тоже будет работать?
12. Сергей Нувальцев (nusv) 24 04.04.17 11:19 Сейчас в теме
(11)На данный момент работает на последнем релизе 3.1
15. Алексей Тузов (kelgor) 29.05.17 11:56 Сейчас в теме
Добрый день. Можно узнать, подойдут ли данные правила для КА 1.1?
16. Сергей Нувальцев (nusv) 24 29.05.17 16:17 Сейчас в теме
Если структура отражения ЗП и Ведомостей одинаковая с УПП, то да. Вероятнее всего нужно будет немного допилить.(При наличии определенных знаний там все достаточно просто)
18. Фирсов Алексей (AlexF1983) 31.05.17 12:01 Сейчас в теме
Доброго времени суток. Использую правила для выгрузки отражения ЗП из ЗУП 3.1 в КА 1.1 (после небольших доработок). Все ОК, но не выгружаются алименты (76 счет). Судя по правилам, такого не предусмотрено...
Еще момент. У нас из ЗУП есть выгрузка по части организаций в БП 3.0 а по части - в КА 1.1. Правила обмена грузятся для плана обмена (общие для всех узлов). Если загрузить в ЗУП 3 эти правила перестает работать типовой обмен с БП 3. И наоборот. Есть какие-то мысли как победить эту беду?
19. Сергей Нувальцев (nusv) 24 31.05.17 12:33 Сейчас в теме
ОбменДаннымиXDTOСервер.ВерсииФорматаОбмена()
	Если ЗначениеЗаполнено(УзелИнформационнойБазы) Тогда
		МенеджерПланаОбмена(УзелИнформационнойБазы).ПолучитьВерсииФорматаОбмена(ВерсииФорматаОбмена);
		// ============================================================­===================================

		ПолучитьВерсииФорматаОбмена(ВерсииФорматаОбмена,УзелИнформационнойБазы);

		// ============================================================­===================================
	Иначе
		ОбменДаннымиПереопределяемый.ПриПолученииДоступныхВерсийФормата(ВерсииФорматаОбмена);
	КонецЕсли;

Процедура ПолучитьВерсииФорматаОбмена(ВерсииФормата,УзелИнформационнойБазы = Неопределено) Экспорт
	
	ВерсииФормата.Очистить();
	
	Запрос = Новый Запрос(
	"ВЫБРАТЬ
	|	СинхронизацияДанныхЧерезУниверсальныйФормат.ПутьКМенеджеруОбмена
	|ИЗ
	|	ПланОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат КАК СинхронизацияДанныхЧерезУниверсальныйФормат
	|ГДЕ
	|	СинхронизацияДанныхЧерезУниверсальныйФормат.ПутьКМенеджеруОбмена <> """"
	|	" + ?(УзелИнформационнойБазы <> Неопределено," И СинхронизацияДанныхЧерезУниверсальныйФормат.Ссылка = &УзелИнформационнойБазы", "")  + "");
	
	Запрос.УстановитьПараметр("УзелИнформационнойБазы",УзелИнформационнойБазы); 
	
	Выборка = Запрос.Выполнить().Выбрать();
	
	Если Выборка.Следующий() Тогда
		МенеджерОбмена = ВнешниеОбработки.Создать(Выборка.ПутьКМенеджеруОбмена);
	Иначе
		МенеджерОбмена = МенеджерОбменаЧерезУниверсальныйФормат;
	КонецЕсли;
	
	ВерсииФормата.Вставить("1.0.beta", МенеджерОбмена);
	ВерсииФормата.Вставить("1.0",      МенеджерОбмена);
	ВерсииФормата.Вставить("1.1",      МенеджерОбмена);
	ВерсииФормата.Вставить("1.2",      МенеджерОбмена);
	ВерсииФормата.Вставить("1.3",      МенеджерОбмена);
	
КонецПроцедуры
...Показать Скрыть
20. Dmitriy Radovskiy (myoff) 195 11.07.17 17:55 Сейчас в теме
Попробовал обмен ЗУП 3.1 (3.1.2.294) УПП 1.3 (1.3.89.2)
В конфигурацию УПП скопировал из ЗУП 3.1 план обмена "ОбменЗарплата3Бухгалтерия3", и поправил в УПП модуль этого плана обмена (добавил функцию СтрСоединить). У ЗУП 3.1 в настройках синхронизации для "Синхронизация данных с Бухгалтерия Предприятия ред. 3" загрузил Правила конвертации объектов

При обмене ЗУП -УПП происходят ошибки:
---------------------------------------------------------------------------------------------
Событие:Обмен данными.ОбменЗарплата3Бухгалтерия3.Отправка данных
Комментарий:Ошибка в базе-корреспонденте: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(3593)}: Ошибка в обработчике события ПослеЗагрузкиОбъекта
ИмяПКО = ОтражениеЗарплатыВРеглУчете
ТипОбъекта = Отражение зарплаты в регл учете
Объект = Отражение зарплаты в регл учете АБЗП-000001 от 31.01.2017 0:00:00
Обработчик = ПослеЗагрузкиОбъекта
ОписаниеОшибки = Поле объекта не обнаружено (дОбособленноеПодразделение)
ПозицияМодуля = (41)
КСообщенияОбОшибках = 21
ВызватьИсключение СтрокаСообщенияОбОшибке;
---------------------------------------------------------------------------------------------
Событие:Обмен данными.ОбменЗарплата3Бухгалтерия3.Отправка данных
Комментарий:{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(17293)}: Ошибка при отправке данных: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(3867)}: Ошибка в базе-корреспонденте: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(3593)}: Ошибка в обработчике события ПослеЗагрузкиОбъекта
ИмяПКО = ОтражениеЗарплатыВРеглУчете
ТипОбъекта = Отражение зарплаты в регл учете
Объект = Отражение зарплаты в регл учете АБЗП-000001 от 31.01.2017 0:00:00
Обработчик = ПослеЗагрузкиОбъекта
ОписаниеОшибки = Поле объекта не обнаружено (дОбособленноеПодразделение)
ПозицияМодуля = (41)
КСообщенияОбОшибках = 21
ВызватьИсключение СтрокаСообщенияОбОшибке;
ВызватьИсключение(НСтр("ru = 'Ошибка при отправке данных'") + ": " + ОписаниеОшибки());
21. Сергей Нувальцев (nusv) 24 11.07.17 19:51 Сейчас в теме
Посмотри в ПКО реквизит "дОбособленноеПодразделение" и сравни со своей структурой, может называется по другому или нет вовсе, там поправить 2 минуты
22. Сергей Нувальцев (nusv) 24 11.07.17 19:53 Сейчас в теме
(18)использовать в макете типовые правила, на узле для УПП документы будут регистрироваться, потом обработкой выгрузка загрузка xml прочитать правила выбрать узел и выгрузить файл, в другой базе загрузить(чтобы обойтись малой кровью только так, или пилить, но смысла не вижу в этом)
23. Фирсов Алексей (AlexF1983) 12.07.17 18:29 Сейчас в теме
(22) Суть в том что нужно было организовать автоматический обмен близкий к режиму "онлайн" (раз в минуту), притом работать должно 2 варианта выгрузки: ЗУП 3 - КА 1.1 для части организаций, и ЗУП 3 - БП 3 для другой части. Пришлось "пилить". Организовал в ЗУП фоновое задание которое грузит нужные правила в зависимости от узла, формирует xml, а в КА 1.1 и БП 3 - http-сервис который принимает этот файл и грузит, формирует ответный файл, и возвращает в теле ответа в ЗУП, ну а там уже он грузится и тем самым снимает регистрацию в случае успеха. Доработка не мешает обновлениям, но работает не очень быстро - загрузка правил обмена занимает очень много времени, файл получается большим. Ну да это общая беда обменов на КД 2.0.
В будущем планируем "самопальный" обмен через XDTO - будет явно быстрее (по опыту, на порядок). Ну а пока спасибо хотя-бы за такое решение.
24. Сергей Нувальцев (nusv) 24 12.07.17 19:35 Сейчас в теме
(23)подключи обработку регламентно и все
25. Сергей Нувальцев (nusv) 24 12.07.17 19:36 Сейчас в теме
(23)через xdto может сделаю, пока времени нет, если что напишу
26. Фирсов Алексей (AlexF1983) 13.07.17 06:51 Сейчас в теме
(25) Аналогичная беда, пока времени нет ) Если сделаю раньше, постараюсь выложить решение
27. Лазиз Эрматов (user747113) 28.08.17 15:30 Сейчас в теме
(20)
СтрСоединить
Подскажите пожалуйста как решить вопрос с "СтрСоединить" , режим совместимости отключал, менял, не помогло) Спасибо!
28. Сергей Нувальцев (nusv) 24 28.08.17 19:04 Сейчас в теме
(27)
СтрСоединить

Замените на те строковые функции которые работают в Вашей версии БСП
29. Лазиз Эрматов (user747113) 29.08.17 11:23 Сейчас в теме
(28)Спасибо! Не сразу понял как это сделать, но думать начал в правильном направлении и разобрался)
30. Сергей Нувальцев (nusv) 24 29.08.17 12:21 Сейчас в теме
31. Лазиз Эрматов (user747113) 29.08.17 16:06 Сейчас в теме
(30)Подскажите что здесь править? Если удаляю эту функцию полностью в модуле объекта,
то при синхронизации не выгружает ни одного объекта в УПП,
при этом без ошибок показывает статус "Cинхронизация завершена"

{ПланОбмена.ОбменЗарплата3Бухгалтерия3.МодульОбъекта(5,7)}: Переменная не определена (ЗарплатаКадры)
Если <<?>>ЗарплатаКадры.ОтключитьБизнесЛогикуПриЗаписи(ЭтотОбъект) Тогда (Проверка: Толстый клиент (обычное приложение))

Спасибо!
Процедура ПередЗаписью(Отказ)
	
	Если ЗарплатаКадры.ОтключитьБизнесЛогикуПриЗаписи(ЭтотОбъект) Тогда
		Возврат;
	КонецЕсли;	
	
	Если НЕ ИспользоватьОтборПоОрганизациям И Организации.Количество() <> 0 Тогда
		Организации.Очистить();
	ИначеЕсли Организации.Количество() = 0 И ИспользоватьОтборПоОрганизациям Тогда
		ИспользоватьОтборПоОрганизациям = Ложь;
	КонецЕсли;
	
	Если НЕ ЗначениеЗаполнено(РежимВыгрузкиПриНеобходимости) Тогда
		РежимВыгрузкиПриНеобходимости = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПриНеобходимости;
	КонецЕсли;
	
	Если НеВыгружатьПерсональныеДанныеФизическихЛиц Тогда
		РежимВыгрузкиПерсональныеДанные = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПриНеобходимости;
	Иначе
		РежимВыгрузкиПерсональныеДанные = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть
32. Сергей Нувальцев (nusv) 24 29.08.17 16:33 Сейчас в теме
33. Лазиз Эрматов (user747113) 29.08.17 16:42 Сейчас в теме
(32)УПП редакция 1.3 (1.3.89.2) ЗуП 3.1 (3.1.2.154)
34. Сергей Нувальцев (nusv) 24 29.08.17 16:50 Сейчас в теме
(33)Гляну как время будет, но не обещаю что быстро, должен быть общий модуль "ЗарплатаКадры"
35. Лазиз Эрматов (user747113) 29.08.17 16:55 Сейчас в теме
Оставьте свое сообщение