Сканирование в справочнике номенклатуры и документах по акцизной марке (Розница 2.2, платформа 8.3.10)

Оборудование - Сканер штрих-кода

7
Сканирование в справочнике номенклатуры и документах по акцизной марке, а так же в обработке отбора номенклатуры.

Сканирование в справочнике номенклатуры и документах по акцизной марке, а так же в обработке отбора номенклатуры.

Доступные документы: Пересчет товаров (позволяет делать инвентаризацию товаров по маркам, правда без проверки повтора сканированных марок), Перемещение товаров, Установка цен номенклатуры, Оприходование товаров, Списание товаров, Реализация товаров.

Запуск расширения: для корректной работы расширения, необходимо снять замок с конфигурации для работы и установить в свойствах конфигурации "Режим совместимости" - "Не использовать"

Использование: После установки расширения, в справочнике номенклатуры сканируете алкоголь не по короткому штрихкоду ( EAN-13), а сканируя алкогольную марку, после чего будет найдена соответствующая номенклатура. В документах, при сканировании марки - будет добавлена найденная номенклатура в раздел Товары.

UPDATE: 1. Добавлен документ Возврат из торгового зала (ЕГАИС), исправлено обнаружение сканирования только на открытой форме.

2.Поддержка 1С Розница 2.2.6.28

7

Скачать файлы

Наименование Файл Версия Размер
Сканирование в справочнике номенклатуры и документах по акцизной марке (Розница 2.2):
.cfe 389,81Kb
14.05.17
17
.cfe 1.3 389,81Kb 17 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. user635667 16.05.17 06:15 Сейчас в теме
Не перестаешь удивлять! Буду тестить. Спасибо.
3. user635667 21.05.17 05:17 Сейчас в теме
А у меня пишет:
Платформа: 1С:Предприятие 8.3 (8.3.9.2170)
Конфигурация: Розница, редакция 2.2 (2.2.5.23)

Расширение конфигурации: Разблокировать реквизиты (2.2.5.23)
Расширение конфигурации: Группировка пива для продажи (1.0)
Расширение конфигурации: Список номенклатуры (1)
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент

Ошибки:
--------------------------------------------------------------------------------
21.05.2017 10:13:56
СканированиеВДокументахПоАкцизнойМарке (1.1): Критичная: Значение контролируемого свойства РежимСовместимости у объекта не совпадает со значением в расширяемой конфигурации
В чем может быть проблема? В несовместимости с другими расширениями?
upd - я отключил все расширения - ошибка осталась. может платформа или версия конфигурации не те?
п.с. и вопрос не в тему - а если я в центральной базе подключаю расширение оно распространится по РИБ само или в каждой точке его вручную ставить придется?
2. coolseo 47 20.05.17 03:14 Сейчас в теме
Здравствуйте, тестирую, в процедуре вы указываете Событие = "Штрихкод", а правильно
Событие = "ПолученШтрихкод", а так же ВводДоступен() всегда возвращает ложь и не заходит в условие, в общем я все это выпилил полетело

1С:Предприятие 8.3 (8.3.9.2233), Розница, редакция 2.2 (2.2.5.25)

&НаКлиенте
Процедура СканМарк_ВнешнееСобытиеВместо(Источник, Событие, Данные)
	
	Если ВводДоступен() И НЕ ЗначениеЗаполнено(Объект.ПодписьЧекаЕГАИС) И СтрДлина(Данные) <> 68 Тогда
		ПодключаемоеОборудованиеРТКлиент.ВнешнееСобытиеОборудования(ЭтотОбъект, Источник, Событие, Данные);
	КонецЕсли;
	
	Если Событие = "ПолученШтрихкод" И СтрДлина(Данные) = 68 Тогда
		РезультатПоиска = СканМарк_АлкогольныеПроцедурыИФункцииКлиент.ДанныеПоискаПоАлкоМаркеКлиент(Данные);
		ДобавлениеНоменклатуры(РезультатПоиска);
	КонецЕсли;
	
КонецПроцедуры
Показать
4. user635667 21.05.17 06:45 Сейчас в теме
Я отключил все расширения и обновил конфигурацию до последней версии и платформу до последней девятой. не помогло(
Платформа: 1С:Предприятие 8.3 (8.3.9.2233)
Конфигурация: Розница, редакция 2.2 (2.2.5.27) (http://v8.1c.ru/retail/)
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент
Локализация: Информационная база: русский (Россия), Сеанс: русский (Россия)
Вариант интерфейса: Версия 8.2

Ошибки:
--------------------------------------------------------------------------------
21.05.2017 11:42:43
СканированиеВДокументахПоАкцизнойМарке (1.1): Критичная: Значение контролируемого свойства РежимСовместимости у объекта не совпадает со значением в расширяемой конфигурации
6. coolseo 47 21.05.17 12:32 Сейчас в теме
(4)Выключить совместимость с 8.3.8, т.е включить возможность изменения в базе.
Тут использованы новые приему которые только 8.3.9
5. coolseo 47 21.05.17 12:32 Сейчас в теме
7. asdfgcom 188 19.05.18 11:00 Сейчас в теме
Неплохо. Очень помогло. Не пришлось писать самому.
Для 2.2.8 нужно проверить. Сообщает про ошибки об отсутствующих реквизитах.
Проверил после корректировки на 2.2.8.27.
Пересчет - сканирует.
ЧекККМ в обычном режиме и в РМК - сканирует. То, что надо!
8. lenochka-semicova 19.05.18 14:36 Сейчас в теме
(7) В типовой розничке 2.2.8 и просто марки сканирует везде, если они в справочнике штрихкоды упаоквок внесены :)
9. asdfgcom 188 19.05.18 17:46 Сейчас в теме
(8) Да. Но если магазин уже работает и имеет остатки, а Розницу ставит только сейчас, Штрихкоды упаковок еще пусты. А корректировку остатков ЕГАИС сделать надо. А "Корректировки остатков ЕГАИС" больше нету с 2.2.8. И заводские штрихкоды сканировать уже не хочется, раз можно разобрать акцизные марки и по Алкокоду выйти на номенклатуру...
Короче, удобная штука для тех, кто хочет по-быстрому запустить магазин. (т.е. для меня)
В данный момент перевожу несколько магазинов с ТП (Штрих) на Розницу.
10. lenochka-semicova 19.05.18 20:36 Сейчас в теме
(9) Когда
Розницу ставит только сейчас

то и обычные штрихкоды пусты, и номенклатура пуста, и цен нет.
А когда новые ТТН приходят, то штрихкорды упаковок уже создаются.
Хотя да - корректировку 1С зря выпилили.
В общем - никого ни за что не агитирую. Просто поделилась соображениями...
11. asdfgcom 188 20.05.18 09:16 Сейчас в теме
Ну, ситуация теперь решается так:
1. Загрузить остатки по регистрам 1,2.
2. Сопоставить (Создать) Контрагентов, Номенклатуру
3. На основании остатков ЕГАИС - Оприходование - Установка цен.
4. Приказ-Пересчет. (Вот здесь и нужны сканируемые акцизные марки)
5. Оприходование (излишки) - Акт постановки на баланс
6. Списание - Акт списания ЕГАИС.
12. alexandr.samoylenko.ru 27.09.18 22:31 Сейчас в теме
В рознице 2.2 (2.2.9.20) при подключении выдает:

(Критичная) : Не найден объект ОбщаяКартинка.ИсходящийЗапросЕГАИС
(Критичная) : Не найден объект Документ.ВскрытиеТарыЕГАИС
(Критичная) : Не найден объект Документ.ОстаткиЕГАИС.Реквизит.СтатусОбработки
13. alexandr.samoylenko.ru 01.10.18 20:46 Сейчас в теме
Планируете адаптировать обработку под розницу 2.2.9.20?
Оставьте свое сообщение