Расширения конфигураций 1С: учимся перехватывать методы

Публикация № 628422

Разработка - Практика программирования

1С 8.3 расширение конфигурации

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

Если кто не знаком с технологией расширений, то основную информацию можно получить из моих видео-уроков. 7-м уроков по работе с расширениями есть на этой странице.

Все примеры я показываю на демонстрационной конфигурации «Управляемое приложение».

Имейте в виду, что перехват событий и методов работает только тогда, когда режим совместимости установлен в «Не использовать» (так было для платформы 8.3.10.1981), по сути это единственное изменение конфигурации  «Управляемое приложение», которое я сделал…

В расширении можно перехватывать типовые процедуры модуля объекта. Имеется возможность сделать три варианта перехвата «типовой» процедуры: «перехватить» событие перед выполнением метода (с помощью аннотации &Перед), «перехватить» событие после выполнения метода (с помощью аннотации &После), а так же выполнить вместо типовой процедуры процедуру расширения (с помощью аннотации &Вместо).

В задачах ниже мы разберем работу «перехватчиков»

Задача: В расширении создадим собственный макет печати документа «Расход товара». И добавим команду на форму расходной накладной «Печать расходной накладной (расширение)» при выполнении которой будет печататься макет из расширения.

Для этого создадим расширение конфигурации «ДляРасходаТовара», заимствуем в это расширение документ «Расход товара», а так же форму.

Скопируем (именно скопируем, а не заимствуем) из расширяемой конфигурации макет «МакетПечати», переименуем его и изменим сам макет, что бы можно было отличать.

Теперь нам нужно скопировать (тоже именно скопировать, а не заимствовать) команду документа «Печать расходной накладной», но группа, в которую входит команда у нас не скопируется, поэтому перед этим необходимо заимствовать группу «Печать»

После этого копируем команду «Печать расходной накладной», и так же переименовываем, и не забудем указать тип параметра команды – ссылку на документ «Расход товаров»

Если мы на этом этапе сохраним расширение и обновим базу данных, то при открытии формы документа, увидим, что команда добавилась.

Но, если мы сейчас попробуем её выполнить, то выйдет обычная печатная форма, не из расширения. Всё из-за того, что в команде расширения используется метод документа ПечатнаяФорма, в котором и «подтягивается» нужный макет.

Перехватим процедуру ПечатнаяФорма модуля объекта, и переделаем её. Для того что бы понимать, что мы используем табличный документ из расширения, будем, когда вызываем процедуру из команды расширения, передавать в неё структуру с табличным документом. А потом в перехваченной процедуре ПечатнаяФорма в зависимости от типа параметра будем использовать тот или иной макет: если параметр имеет тип ТабличныйДокумент, то будем использовать типовой макет, а если параметр имеет тип Структура, то будем использовать макет из расширения. Для того, что бы перехватить процедуру или функцию в модуле объекта необходимо написать аннотацию &Вместо и после неё в скобочках название перехваченного метода.

Напишем в модуле расширения следующий код:

&Вместо("ПечатнаяФорма")
Процедура РТ_ПечатнаяФорма(ТабличныйДокумент)

КонецПроцедуры // ПечатнаяФорма(ТабличныйДокумент)

Обратите внимание на название метода, он не должен совпадать с основным, поскольку при работе процедуры модулей расширяемой конфигурации и расширений работают в одном контексте. Теперь скопируем код из процедуры ПечатнаяФорма расширенной конфигурации, и переделаем, как описано выше.

 &Вместо("ПечатнаяФорма")
Процедура РТ_ПечатнаяФорма(ТабличныйДокумент)

    Если ТипЗнч(ТабличныйДокумент) = тип("Структура") Тогда
        ТабличныйДокумент = ТабличныйДокумент.ТабДок;
        Макет = Документы.РасходТовара.ПолучитьМакет("РТ_МакетПечати");
    иначе
        Макет = Документы.РасходТовара.ПолучитьМакет("МакетПечати");
    КонецЕсли;
    //—————-основной код из расширенной конфигурации—————///
    // Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    ТабличныйДокумент.Вывести(Область);

    // Шапка
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Шапка.Параметры.Заполнить(ЭтотОбъект);
    ТабличныйДокумент.Вывести(Шапка);

    // Товары
    Область = Макет.ПолучитьОбласть("ТоварыШапка");
    ТабличныйДокумент.Вывести(Область);
    ОбластьТовары = Макет.ПолучитьОбласть("Товары");

    Для каждого ТекСтрокаТовары Из Товары Цикл

        ОбластьТовары.Параметры.Заполнить(ТекСтрокаТовары);
        ТабличныйДокумент.Вывести(ОбластьТовары);

    КонецЦикла;

КонецПроцедуры // ПечатнаяФорма(ТабличныйДокумент)

Нам осталось переделать код в команде расширения РТ_ПечатьРасходнойНакладной:

&НаСервере
Функция ПечатнаяФорма(ПараметрКоманды)
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.ОтображатьСетку = Ложь;
    ТабличныйДокумент.Защита = Ложь;
    ТабличныйДокумент.ТолькоПросмотр = Ложь;
    ТабличныйДокумент.ОтображатьЗаголовки = Ложь;

    Сформирован = Ложь;
    ///создаем струкутур, для передачи в процедуру
    СтруктураПередачи = Новый Структура("ТабДок",ТабличныйДокумент);

    Для каждого Ссылка Из ПараметрКоманды Цикл
        Документ = Ссылка.ПолучитьОбъект();
        Если НЕ Документ.Проведен Тогда
            Сообщение = Новый СообщениеПользователю();
            Сообщение.Текст = "Документ не проведен: " + Строка(Документ);
            Сообщение.КлючДанных = Ссылка;
            Сообщение.Сообщить();
            Продолжить;
        КонецЕсли;

        Документ.ПечатнаяФорма(СтруктураПередачи); //передали структуру
        Сформирован = Истина;
    КонецЦикла;

    Если Сформирован Тогда
        Возврат ТабличныйДокумент;
    Иначе
        Возврат Неопределено;
    КонецЕсли;

КонецФункции

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ТабличныйДокумент = ПечатнаяФорма(ПараметрКоманды);

    Если ТабличныйДокумент <> Неопределено Тогда
        ТабличныйДокумент.Показать();
    КонецЕсли;

КонецПроцедуры

 

Сейчас, после того, как сохраним расширение, то спокойно сможем распечатать макет расширения.

////////////////////

Задача: Перед проведением документа «Расход товара»  будем проверять, внес ли контрагент аванс (должен быть больше суммы продажи), если нет, то не проведем документ.

Для решения этой задачи так же будем использовать аннотацию &Вместо, но в этот раз нам нужно продолжить выполнения основного метода (в нашем случае процедура ОбработкаПроведения). Напишем в модуле документа «Расход товара» следующий код

&Вместо("ОбработкаПроведения")
Процедура РТ_ОбработкаПроведения(Отказ, Режим)

    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ВзаиморасчетыОстатки.СуммаОстаток КАК СуммаОстаток
                   |ИЗ
                   |    РегистрНакопления.Взаиморасчеты.Остатки(
                   |            &МоментВремени,
                   |            Контрагент = &Контрагент
                   |                И Валюта = &Валюта) КАК ВзаиморасчетыОстатки";
    Запрос.УстановитьПараметр("МоментВремени",?(Режим = РежимПроведенияДокумента.Оперативный,ТекущаяДата(),МоментВремени()));
    Запрос.УстановитьПараметр("Контрагент", Ссылка.Покупатель);
    Запрос.УстановитьПараметр("Валюта",Ссылка.Валюта);

    Блокировка = Новый БлокировкаДанных;
    ЭлБлокировки = Блокировка.Добавить("РегистрНакопления.Взаиморасчеты");
    ЭлБлокировки.Режим = РежимБлокировкиДанных.Исключительный;
    ЭлБлокировки.УстановитьЗначение("Контрагент",Ссылка.Покупатель);
    ЭлБлокировки.УстановитьЗначение("Валюта",Ссылка.Валюта);
    Блокировка.Заблокировать();

    Результат = Запрос.Выполнить();

    Выборка = Результат.Выбрать();
    Выборка.Следующий();

    Если Ссылка.Товары.Итог("Сумма") > Выборка.СуммаОстаток Тогда

        СуммаНеДобора = Ссылка.Товары.Итог("Сумма") - Выборка.СуммаОстаток;

        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Авансов у покупателя недостаточно!" + Символы.ПС + "Не хватает " + СуммаНеДобора ;
        Сообщение.Поле = "Покупатель";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        Отказ = Истина;

    КонецЕсли;

    ПродолжитьВызов(Отказ,Режим);

КонецПроцедуры

В этом коде мы получаем остаток по регистру взаиморасчетов по покупателю в разрезе валюты. И если в документе сумма всех товаров больше чем остаток по взаиморасчету, то присваиваем параметру Отказ значение истина и выводим сообщение. А в конце процедуры вызываем метод ПродолжитьВызов с теми же параметрами, что и у нашей процедуры.  Подробно про метод ПродолжитьВызов можно прочитать в синтаксис-помощнике, отмечу только: что бы не путаться, лучше называть параметры в методе-перехватчике, так же как и в методе расширенной конфигурации.

Посмотрим, как сработает наш перехват события

Кроме того, что мы можем написать метод, который сработает взамен метода расширенной конфигурации, мы можем написать процедуру (функцию), которая выполниться перед или после какого-нибудь «типового» метода модуля объекта. Для этого нужно использовать аннотации &Перед и &После.

Решим следующую задачу: в конфигурации «Управляемое приложение» на основании контрагента можно создать документ «Расход товара», в котором заполнится Контрагент и поле «Вид цены». Допустим нам не нужно автоматическое заполнение вида цены, поэтому мы перехватим событие после выполнения процедуры ОбработкаЗаполнения в расширенном модуле документа «Расход товара», где присвоим полю Вид цены пустую ссылку. Получиться вот такой код

&После("ОбработкаЗаполнения")
Процедура РТ_ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)

    Если ТипЗнч(ДанныеЗаполнения) = Тип("СправочникСсылка.Контрагенты") Тогда
          ВидЦен = Справочники.ВидыЦен.ПустаяСсылка();
    КонецЕсли;
КонецПроцедуры

Если мы сейчас создадим на основании контрагента документ «Продажи», то поле «Вид Цены» будет пустое

Теперь перейдем к формам.

Платформа позволяет перехватывать в расширении события формы и элементов формы. Так же как и для модуля объекта существует три варианта перехвата события: перед событием, после события и вместо события. Но задаются они по другому: по средством указания типа вызова при создании обработчика

Разберем работу перехвата событий форм на ряде примеров.

Задача:  В документе «Расход товара» после выбора контрагента в окно «Обоснование отгрузки» будем записывать информацию из реквизита контрагента «Дополнительная информация».

Для этого перехватим событие после изменения поля «Покупатель».  Зайдем в палитру свойств поля «Покупатель» формы документа «Расход товара» нашего расширения. И нажмем на пиктограмму «Лупа» рядом с событием «При изменении», после этого выйдет форма, где по мимо знакомых вариантов клиент, сервер и т.д., появятся варианты вызова события: перед, после и вместо.

Выберем на клиенте и после. После выбора в палитре свойств рядом с созданным событием появилась соответствующая пиктограмма.

В модуле формы создался обработчик, где мы напишем следующий код:

&НаСервереБезКонтекста
Функция ПолучитьДопИнформацию(Контрагент)

    Возврат Контрагент.ДополнительнаяИнформация;

КонецФункции

&НаКлиенте
Процедура РТ_ПокупательПриИзмененииПосле(Элемент)

    Объект.ОбоснованиеОтгрузки = ПолучитьДопИнформацию(Объект.Покупатель);

КонецПроцедуры

Теперь, если мы выберем контрагента, то заполнится информация в поле документа «Обоснование отгрузки»

И последняя задача будет немного поинтереснее: в документе «Расход товара» в табличной части Товары сделаем возможность выбора только номенклатуры с видом Товар. В демонстрационной конфигурации есть товары с видом услуга. Они показаны на этом рисунке

Доработаем расширение конфигурации таким образом, что бы в форме документа «Расход товара» при выборе товара в табличной части, выходила форма выбора справочника «Товары» с отбором по виду товара (исключаем услуги). Для этого я заимствую форму выбора справочника товары в мое расширение.

И у этой формы создам обработчик события ПриСозданииНаСервере, который будет выполняться вместо типового.

Почему вместо типового? Потому что типового обработчика события ПриСозданииНаСервер формы выбора справочника Товары нет, и я решил сделать вместо. Хотя можно сделать после. Теперь напишем код, в котором будем устанавливать отбор на динамический список «Список»  формы выбора.

&НаСервере
Процедура РТ_ПриСозданииНаСервереВместо(Отказ, СтандартнаяОбработка)

    Если Параметры.Свойство("Вид") Тогда
        Отбор = Список.Отбор;
        НовыйЭлОтбора = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        НовыйЭлОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Вид");
        НовыйЭлОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
        НовыйЭлОтбора.ПравоеЗначение = Параметры.Вид;
    КонецЕсли;

КонецПроцедуры

Все. С формой выбора мы покончили, и можем начать работать с формой документа «Расход товара». Первым делом, создадим событие НачалоВыбора поля Товар таблицы Товары, которое будем выполнять в место типового.

В этом обработчике мы напишем код, в результате которого будет открываться формы выбора справочника товары, и при открытии в эту форму будем передавать в качестве параметра вид товара – товар.

&НаКлиенте
Процедура РТ_ТоварыТоварНачалоВыбораВместо(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    //отменим стандартный вызов
    СтандартнаяОбработка = Ложь;

    //передадим параметры на форму
    ПараметрыОткрытия = Новый Структура;
    ПараметрыОткрытия.Вставить("Вид",ПредопределенноеЗначение(«Перечисление.ВидыТоваров.Товар»));

    //опишем оповещение о закрытии
    ОповещениеОЗакрытииВыбораТовара = Новый ОписаниеОповещения("ВыполнитьПослеЗакрытияВыбораТовара",ЭтотОбъект);

    ОткрытьФорму("Справочник.Товары.ФормаВыбора",ПараметрыОткрытия
                                                ,ЭтаФорма
                                                ,
                                                УникальныйИдентификатор
                                                ,,,
                                                ОповещениеОЗакрытииВыбораТовара
                                                ,);

КонецПроцедуры

Не забудем написать процедуру, которая должна сработать после закрытия формы выбора

 &НаКлиенте
Процедура ВыполнитьПослеЗакрытияВыбораТовара(РезультатЗакрытия,ДополнительныеПараметры) Экспорт

    Если Не ЗначениеЗаполнено(РезультатЗакрытия) Тогда
        Возврат;
    КонецЕсли;

    Идентификатор = Элементы.Товары.ТекущаяСтрока;
    СтрТовара = Объект.Товары.НайтиПоИдентификатору(Идентификатор);
    СтрТовара.Товар = РезультатЗакрытия;
КонецПроцедуры

Теперь при выборе товаров из документа «Расход товара» каталог «Услуги» будет пуст.

Но, заметьте, можно будет подобрать услугу, вводя вручную её название в поле товар.

Что бы такого не было, мы перехватим событие формы АвтоПодбор, наше событие будет выполняться вместо события расширенной конфигурации.

В этом обработчике будем накладывать отбор в параметрах получения данных

&НаКлиенте
Процедура РТ_ТоварыТоварАвтоПодборВместо(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)

    Отбор = ПараметрыПолученияДанных.Отбор;
    Отбор.Вставить("Вид",ПредопределенноеЗначение("Перечисление.ВидыТоваров.Товар"))

КонецПроцедуры

Теперь при подборе с клавиатуры услуги не будут выходить.

На этом всё. Надеюсь, эта статья принесла Вам пользу, и помогла понять, как можно перехватывать «Типовые» события при помощи расширений конфигурации.

Источник

Скачать файлы

Наименование Файл Версия Размер
Расширение для конфигурации «Управляемое приложение»

.cfe 31,73Kb
13
.cfe 31,73Kb 13 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Yashazz 3638 01.06.17 13:15 Сейчас в теме
Коллеги, хотите добрый совет? Никогда не связывайтесь с этой дрянью под названием "расширения". Непредсказуемо, нестабильно, глючно. Проще покурочить конфу, нежели тратить время на попытки добиться проку от этой кривой поделки.
dtripleh; Sergex; evg_m; wowik; torg1c; Manticor; alexeyvs77; Rain88; Irwin; +9 10 Ответить
2. vaxhab 13 01.06.17 14:15 Сейчас в теме
(1) Неужели все так плохо ? Собираюсь переходить на расширения .
6. Yashazz 3638 01.06.17 20:57 Сейчас в теме
(2) Ну как сказать... Если у вас парочка безобидных изменений в дизайне формы или перегрузка скромного события элемента формы, то ещё прокатит. А вот замахнётесь на большее - ждёт вас дорога, вымощенная жёлтыми граблями.

После того, как несколько релизов 8.3.9 кряду вообще падали при попытке сохранить изменения в расширении, мне всё стало окончательно ясно.

(3) Ну хватит уже пиариться на ровном месте, а?
user597231_DNorov; evg_m; +2 Ответить
7. signum2009 873 02.06.17 09:26 Сейчас в теме
(6) Лично я и вижу расширения, как возможность делать мелкие допилы клиентам, которые не хотят снимать конфигурацию с поддержки...которые касаются больше удобства работы...
alex_ram87; +1 Ответить
16. Anchoret 43 31.10.17 17:03 Сейчас в теме
(1)
Перенес на расширение изменения типовых ролей, которые раньше были изменены в основной конфигурации. Теперь, при следующем обновлении, мне не нужно будет корячиться с ролями, чтобы перенести все изменения.
zexpress; Borisych; kwazi; +3 Ответить
24. creatermc 4 15.10.18 17:39 Сейчас в теме
(1) ставлю минус, так как именно с помощью расширений можно не теряя полный типовой функционал основного поставщика производить изменения или расширения имеющийся конфигурации
Рамзес; whitedeath; Monte Carlo; +3 2 Ответить
26. Yashazz 3638 16.10.18 23:40 Сейчас в теме
(24) с их помощью можно очень "здорово" нарываться на проблемы в неожиданных местах и заваливать проекты
29. creatermc 4 17.10.18 13:10 Сейчас в теме
(26) Конечно многое зависти от версии платформы и бсп, но курс 1С явно прослеживается в разработке возможностей расширения как независимого изменения типовой конфигурации
42. alexeyvs77 45 15.02.19 11:48 Сейчас в теме
(29) Возможно ли добавить в расширение подписку на событие, если этой подписки нет в основной конфигурации?
44. creatermc 4 05.03.19 16:43 Сейчас в теме
(42) Конечно нет, расширение только позволяет расширить имеющуюся ну никак не заменить основную конфигурацию
45. alexeyvs77 45 05.03.19 17:32 Сейчас в теме
(44) "...с помощью расширений можно не теряя полный типовой функционал основного поставщика производить изменения или расширения имеющийся конфигурации..."
Стало быть, далеко не всегда это утверждение верно
46. user872840 27.08.19 12:31 Сейчас в теме
(44) Документ новый добавить можно, справочник можно, план обмена можно.
А Подписку на событие - нельзя!
Логика 1С.
NeFarT; InJey; +2 Ответить
3. mrXoxot 2533 01.06.17 14:30 Сейчас в теме
Полезные советы для разработки расширения можно посмотреть тут:
http://infostart.ru/public/442003/
4. splxgf 01.06.17 14:45 Сейчас в теме
Да все нормально с расширениями, единственное придется переделывать обработчики УстановитьВыполнениеПослеОбработчиковСобытия у старых расширений, которые под 8.3.7 писались. Иначе система вылетает.
А так расширение пережило три платформы и обновление УТ с 11.1 по ERP 2.2.
AndreyLi9; creatermc; kwazi; smartem; +4 Ответить
5. rozer 279 01.06.17 15:21 Сейчас в теме
(4)
Иначе система вылетает.


да, но не всегда - на когда запустил ДО 2.1 на 8.3.9 после 8.3.8 переделывал только в формах записей регистров сведений ибо ,да,вылетало... в формах же доков и в справочниках - все ок
8. Новиков 292 02.06.17 09:37 Сейчас в теме
Спасибо, хорошая статья!
9. decdmb 02.06.17 10:04 Сейчас в теме
Кто-нибудь пробовал убирать у ERP 2.2 режим совместимости? Как себя ведет база, есть ли глюки?
Получается, что в типовых все равно надо включать изменения в конфу, и некоторые изменения можно сделать без расширений, а через переопределяемые модули модификации конфигураций.
10. Vladimir Litvinenko 02.06.17 15:23 Сейчас в теме
Главная проблема работы с расширениями - необъективная оценка количества предстоящих доработок разработчиками/внедренцами. Исходя из посыла "да нам же всего несколько кнопочек изменить на форме" начинается работа с расширениями. Количество доработок растет, расширения продолжают использоваться исходя из посыла "мы же уже используем расширения, давайте уже через них продолжать".

Потом появляется необходимость добавить новые сущности в базу данных, расширить структуру существующих. Или изменить принцип работы какой-либо типовой подсистемы. Работать с расширениями становится все сложнее или вообще невозможно. В конфигурации включается возможность изменения и начинается "мягкая" или "жесткая" доработка типовой конфигурации, в зависимости от квалификации разработчиков.

Этот тот момент, в который в зоопарке технологий прибывает. Гетерогенность, уже живущая в корпоративной системе, радостно потирает руки, понимая, что отвоевала у понятности и простоты хороший такой плацдарм.

Конечно в этот момент можно избавиться от одного из животных в зоопарке технологий и грамотно перенести все изменения в конфигурацию. Ведь дальше придется "ухаживать" за двумя зверями - и расширениями и доработками в самой типовой конфигурации. Убирать за ними, кормить, как-то мирить друг с другом, чтобы они ничего не сломали в процессе совместной работы, добавлять в вакансии на Хэдхантере еще одну строчку в список требований к разработчикам.

По хорошему так и нужно сделать. Но Гетерогенность знает, что люди ленивые, боятся трогать то, что хоть как-то работает, у них всегда "нет времени", а начальство не способно оценить необходимость рефакторинга в этот критичный для отказа от лишней технологии момент времени. Доработки изменений, произведенных через расширения, продолжают делаться через расширения. Доработки выполненные в конфигурации - продолжают делаться в конфигурации. Главный враг архитектуры корпоративного ПО прочно закрепляется на захваченном плацдарме.


В общем лучше хорошо подумать, прежде чем начинать использовать узкоспециализированную технологию. Если есть риск того, что структуру объектов придется менять или добавлять новые объекты БД, есть необходимость часто и без проблем запускать отладку, есть люди, понимающие как изначально менять конфигурацию без проблем для последующего обновления, то лучше сразу принять решение не плодить зоопарк. Переопределяемые модули, программную модификацию форм и подписки на события никто у нас не забирал. Если компания небольшая и сотрудникам важно чтобы конфигурация обновлялась одной кнопкой и сейчас и всегда в будущем, серьезных изменений точно не будет (действительно уверены?), то зоопарка не будет и с расширениями.

И конечно для небольших плагинов расширения хороши. Есть на ИС примеры хорошего применения, когда вместо cf-файла с инструкцией по сравнению-объединению публикуются расширения. Но это опять же специфичная область и для удобного постоянного использования лучше функционал в конфигурацию переносить, чтобы запуск в режиме предприятия не замедляли.
andron77777; zqzq; TanyTany; AndrewKop; Synoecium; user597231_DNorov; bohdan-k; Designer1C; vladir; AlexLM75; xavi; lmnlmn; neo-ti; e.kogan; Rain88; kivals; RustRR; Bazil; kwazi; Anchoret; fuser; Prikum; Alister; Трофимов_Николай; Svasily; Peltzer; Yashazz; rayastar; Krechet17; +29 Ответить
11. splxgf 02.06.17 16:11 Сейчас в теме
С расширениями конечно зоопарк получается, но у них большой плюс это легкая отделимость от конфигурации.
И также независимость, к примеру фрач месяцами пилит документ, а собственный спец по итогам тестдрайва пилит расширение. К завершению проекта получается полностью обкатанный документ со всеми пожеланиями пользователей.
13. signum2009 873 07.06.17 08:28 Сейчас в теме
(12) У меня есть сценарии к этим видео, если кому интересно, могу выложить в виде отдельного поста...
14. lavrov.online 07.10.17 11:59 Сейчас в теме
Платформа 8.3.10.2580. Почему-то не работает подобный функционал.
В модуле формы при создании на сервере есть процедура ОбновитьИтоги()

В расширении формы в модуле формы пытаюсь "врезаться" в нее и пишу

&Перед("ОбновитьИтоги")
Процедура Тест()
а=1;
КонецПроцедуры


Но не заходит. Аналогичное происходит при попытке врезаться в типовые методы объекта. Я что-то делаю не так?
17. lavrov.online 01.11.17 10:32 Сейчас в теме
(15) Дело было в галочке "Безопасный режим" в настройках расширения.
AloneWolf; wtlz; adrumov; +3 Ответить
18. avk72 74 01.11.17 16:52 Сейчас в теме
Хорошая статья!
Только, по моему, перехват методов работает при совместимости 8.3.9 и выше
Margo462; +1 Ответить
19. sonGodv 42 18.06.18 09:16 Сейчас в теме
Можно как-то быстро проверить последствия отключения режима совместимости?
Пользуюсь расширением уже 2 года. Отлично подходит для мелких доработок, а также при обновлении экономит кучу времени, но не хватает возможности перехватывать все события формы.
УТ11.3
20. EugeneSemyonov 21 13.07.18 11:10 Сейчас в теме
Добрый день. А кто-нибудь перехватывал методы когда нужно параметр добавить? Сейчас в режиме совметимости 8.3.10 получил следующее сообщение от предприятия:
Ошибка применения модуля "РасшИнфСообщенияСАртикулом ОбщийМодуль.НоменклатураКлиентСервер.Модуль". Список параметров метода "РасшИнфСообАрт_ПредставлениеНоменклатуры" не соответствует методу "ПредставлениеНоменклатуры".
в ERP 2.4.
Кто знает как правильно расширять методы, если нужно добавить параметров?
Поделитесь, пожалуйста, опытом.
21. kivals 5 23.07.18 08:43 Сейчас в теме
(20) ИМХО что-то не то с постановкой задачи - зачем Вам добавлять параметры?
Механизм, прописанный в модуле/форме, о Ваших дополнительный параметрах ничего не знает, значит - использовать их не будет, т.е. всегда должно использоваться значение параметра по умолчанию.
Таким образом пишите себе свою процедуру с дополнительным параметром:
Процедура МоеВнутреннее_ПредставлениеНоменклатуры(..., МойНовыйПараметр = Неопределено)
...
КонецПроцедуры

и вызываете его из перехваченного метода - без параметра или с каким-то предопределенным значением:
&Вместо(ПредставлениеНоменклатуры)
Процедура РасшИнфСообАрт_ПредставлениеНоменклатуры(...)
	МоеВнутреннее_ПредставлениеНоменклатуры(..., "ХХХ");
КонецПроцедуры

А в своем коде - обращайтесь к своей процедуре, где этот параметр присутсвует:
МоеВнутреннее_ПредставлениеНоменклатуры(..., "ААА");
antonius888; +1 Ответить
22. kivals 5 24.07.18 13:50 Сейчас в теме
(21) Вчера ответил - сегодня столкнулся.
При переходе в режим совместимости 8.3.7 или выше (если конфигурация была ниже) - сталкиваемся с изменением реквизитов у методов ПередЗакрытием (формы) и ПередЗавершениемРаботыСистемы (модуль упр. приложения) в связи вот с этим: https://xn----1-bedvffifm4g.xn--p1ai/news/2017-03-21-how2-correctly-close-forms-and-applications/

Таки действительно вопрос остается открытым...
23. Rain88 320 03.08.18 19:38 Сейчас в теме
Внесу свои пять копеек по поводу использования расширений. Расширения отлично подходят, если нужно добавить новые объекты, либо добавить свои куски кода перед или после выполнения основного кода в процедурах и функциях, однако, если требуется вносить изменения в форму или менять код модулей, используя аннотацию &Вместо, возникают проблемы.
Во-первых, при каждом обновлении приходится проверять, не изменился ли код или форма в основной конфигурации (была такая интересная ситуация, после обновления ошибка в формировании отчета появилась только спустя месяц).
Во-вторых, это проблематичность нахождения изменений в основной конфигурации по отношению к расширению, так как сравнить\объединить cf файл с файлом cfe нельзя (по крайней мере, я не нашла адекватного способа это сделать).
По поводу статьи, все хорошо и доступно изложено, отлично подойдет для ознакомления с расширениями.
bohdan-k; user774630; +2 Ответить
25. Yashazz 3638 16.10.18 23:37 Сейчас в теме
Из последних новостей: решил я после энного перерыва посмотреть - может, случилось чудо и 1С хоть что-то сделало нормально ранее чем через 5 лет после анонса.

И что? И получаю такие чудеса с разделением областей, что словами не описать. Режим разделения по расширению изменить не даёт, обновить не даёт, на реальное наполнение базы (используется ли разделение или нет) плюёт. Глючит всеми мыслимыми способами.
Решил, у меня руки кривые - но нет, в сети звучат вопросы на эту и сходные темы. И все без ответов, что характерно. Один из попавших под руку пруфлинков: https://www.forum.mista.ru/topic.php?id=817891
Релиз был 8.3.12 из последних

Так что несогласных с моим первым утверждением милости просим набивать шишки)))
pogroleg; bohdan-k; +2 Ответить
27. sonGodv 42 17.10.18 12:08 Сейчас в теме
(25) Главное задекларировать возможность, чтобы привлечь внимание. А работает это или нет, вопрос уже третий
28. VmvLer 17.10.18 12:25 Сейчас в теме
При работе с расширениями использую принцип "не использовать в них самые новые возможности минимум полгода".

Например, "сегодня" добавили возможность добавлять регистры оборотов в расширения - великолепно.
Я буду следить за этим ноу-хау, но не использовать его минимум полгода, пока это новшество не "вылижут"
А более "старые" возможности расширения использую без проблем - нытикам привет, вы, по-моему, слишком категоричны.

что касается описанной в этой статье технологии расширения печати, то я считаю, что для таких ситуаций проще и понятнее
использовать механизмы БСП (дополнительные печатные формы) - они дадут тот же результат с меньшими затратами.
30. sonGodv 42 17.10.18 13:27 Сейчас в теме
(28) В 2007 году появилось динамическое обновление. Прошло 11 лет. недавно обновил динамически думал достаточно ждать. В итоге вылез косяк с формой списка справочника номенклатура)
31. VmvLer 17.10.18 13:33 Сейчас в теме
(30) в чем он выражался?

если в том, что пользователи не умеют установить стандартные настройки списка после обновления сами и необходимо бежать к ним и вытирать сопли, то это не косят, а недоработки в управлении компании

динамическое обновление использую часто и густо лет 5 - риски, конечно, есть всегда. Но ведь их можно минимизировать, если включать мозг. тьху тьху тьху
32. sonGodv 42 17.10.18 13:42 Сейчас в теме
(31) Выражался в том, что дерево папок номенклатуры выглядело некорректно, двоилось, троилось, размножалось. Из всего помогало, только удаление папки из профиля пользователя. Через время появлялось снова
33. sonGodv 42 17.10.18 13:44 Сейчас в теме
(31) В составе обновления был только один общий модуль. Как еще тут включить мозг?
43. alexeyvs77 45 15.02.19 12:00 Сейчас в теме
(30) Я в своё время зарёкся использовать динамическое обновление, т.к. пару раз база рушилась так, что приходилось лезть на SQL, и править таблицы вручную. Но последние полтора года динамическое обновление использую каждый день по нескольку раз. И пока что всё ровно.
Правда, база самописная, сущностей немного и пользователей - 40-50 максимум. Платформа 8.3.10 и 8.3.13
34. asdfgcom 325 01.12.18 17:10 Сейчас в теме
Фиг знает что делать с переходом на 8.3.13. В расширении были справочники и регистры. Получился заколдованный круг.
Область действия расширения встала в Разделение данных. Конфигурация пишет, что использовать Разделение данных нельзя. Изменить область действия в режиме совместимости с 8.3.11 нельзя. Снимаю совместимость - "нельзя установить область действия расширения конфигурации в значение РазделениеДанных в иинформационной базе, не используещей разделение данных".
Удалось как-то запустить включив режим совместимости 8.3.11 в расширении и в конфигурации. Получаю потерю таблиц.
Накуролесили с расширениями, короче! Придется писать выгрузку накопленных данных и загрузку.
alexeyvs77; simgo83; anatolysurkov; +3 Ответить
35. simgo83 69 25.12.18 18:39 Сейчас в теме
(34) Я вышел так из положения. Создал новое расширение с Областью действия Информационная база, и объединил со старой, за исключением свойств.
axl007; asdfgcom; +2 Ответить
36. asdfgcom 325 25.12.18 18:51 Сейчас в теме
(35) Объединял, но не посмотрел на свойства... Спасибо за подсказку. Буду смотреть.
37. axl007 11.01.19 12:51 Сейчас в теме
(35)А можно подробнее про объединение? Тоже столкнулся с такой проблемой - в расширении есть данные и надо как-то изменить область действия без их потери.
38. simgo83 69 11.01.19 16:44 Сейчас в теме
(37) все просто, также как и с конфигурацией, нужное расширение сохраняешь на диск, добавляешь новое и объединяешь как и конфигурацию из внешнего файла, сняв галку только со свойств.
39. axl007 11.01.19 18:06 Сейчас в теме
(38)Я так и делал. При удалении старого расширения, данные пропадают.
40. simgo83 69 12.01.19 06:53 Сейчас в теме
(39) мои расширения не имеют регистров, реквизитов и т.д., поэтому мне проще. Как вариант можно попробовать исправить расширение через редактор XML, "но это не точно".
41. simgo83 69 22.01.19 17:21 Сейчас в теме
47. Niki_Pro 29.08.19 17:00 Сейчас в теме
Платформа 8.3.12

&Вместо ("Функция1")
Функция Расш1_Функция1(парам) экспорт
	Перем1 = ПродолжитьВызов(парам);
	Возврат Перем1;
КонецФункции


Вылетает ошибка
Ошибка при вызове метода контекста (ПродолжитьВызов)
Перем1 = ПродолжитьВызов(Форма);
по причине:
Вызов метода разрешен только в методах с аннотацией "Вместо"

Вот вам и расширения... А самый прикол в том, что один раз отработало нормально
48. Alever 3 30.06.20 06:44 Сейчас в теме
Очень хорошая статья. Много полезного и нужного. Недавно начал ковырять механизм Расширений - очень удобная штука! Спасибо автору за подробное описание!
49. dtripleh 21.08.20 16:09 Сейчас в теме
Если конфигурация сильно изменена, то лучше не использовать расширения, имхо. Лучше потратить больше времени на обновление, зато будет понятно, без глюков и нервов.
50. user654641_yaga_m 4 25.08.20 14:56 Сейчас в теме
Спасибо за статью - начал пользоваться
Оставьте свое сообщение

См. также

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5 Промо

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    3026    14    huxuxuya    11    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    8936    52    sapervodichka    43    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    28790    24    Stepa86    46    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    19332    12    RonX01    10    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    22891    6    m-rv    88    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    23588    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    42735    63    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    30418    26    informa1555    26    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    32158    88    m-rv    57    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    54566    20    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    33987    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    28645    54    kwazi    6    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    30174    20    mvxyz    17    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    53338    14    swimdog    44    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    23539    77    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    35954    137    PLAstic    59    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    29727    71    vasvl123    9    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    24577    21    sasha777666    64    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    33619    117    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    32457    136    kiv1c    18    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    50147    36    Demanoidos    60    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    24651    109    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    22861    99    igel9780    22    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    29055    16    Anton64    22    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    54622    35    ildarovich    41    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    14595    53    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    38409    96    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    28934    143    Stepa86    15    

Использование методов глобального контекста в системе компоновки данных или недокументированные возможности СКД

Практика программирования Математика и алгоритмы v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Прочитал на форуме, что СтрРазделить() и ТекущаяДата() работают в языке выражений системы компоновки данных. Почитал справку, там ничего не нашёл, поэтому не поверил. Посмотрел на практике – и правда работает… В данной статье попытался привести весь перечень методов, работающих в СКД, но не описанных в документации.

1 стартмани

05.08.2016    39419    27    klinval    40    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    30183    90    ZhokhovM    64    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    60729    11    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    65963    194    rozer    66    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    64893    19    arakelyan    20    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    36518    51    ildarovich    23    

Вывод печатных форм с запросом данных в форму "Печать документов" из подсистемы БСП "Печать".

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму "ПечатьДокументов". Эта форма входит в состав подсистемы "Печать" из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму "Печать документа". В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы "Печать", в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы "Дополнительные отчеты и обработки" и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

1 стартмани

29.03.2016    98798    191    lopatin    14    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    85989    164    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    19651    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    52936    54    yuraos    18    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    59714    197    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    24760    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    41165    20    milkers    4