Ошибки партионного учета (для Украины)

Отчеты - Анализ учета

6
Данный отчет показывает ошибки ведения партионного учета, то есть неверную принадлежность партии владельцу. Предназначено для Украины.

Предлагаю простенький отчетик, который показывает, есть ли ошибки в базе по ведению партионного учета.

Очень часто бухи любят копировать строки в документах, но забывают перещелкивать партии. Вот и получается, что на элементе может висеть 2, а то и 3 "партии по умолчанию", или партия принадлежит другому элементу справочника.

Данный отчет как раз и показывает эти ошибки.

Писалось  и проверялось на конфе "Бух для Украины" , код открытый, поэтому можно без проблем переделать и под себя.

Кому помогло, не поскупитесь поблагодарить "+ ".

 

Описание работы:

Выбираем дату, на которую делать проверку, жмем  "Сформировать".

Если есть ошибки в принадлежности партий, то програма сообщит их.

20.01.2010 - Обновил. Просто добавил сообщение, что обработка завершена.

6

Скачать файлы

Наименование Файл Версия Размер
Ошибки партий
.ert 456,00Kb
20.01.10
57
.ert 456,00Kb 57 Скачать

См. также

Комментарии
Сортировка: Древо
1. Romarius 13 19.01.10 12:35 Сейчас в теме
В таком случае лучше прописать контроль партий при копировании
2. dobraleks 137 19.01.10 12:43 Сейчас в теме
(1) над этим уже задумался, вот решил год закрою и сделаю условие такое.. :)
3. stagov 7 19.01.10 12:51 Сейчас в теме
"...Кому помогло не поскупитесь поблагодарить "+ "...."
а кому это может помочь???
в смысле - этот список ошибок.
kompas-dm; +1 Ответить
5. dobraleks 137 19.01.10 14:08 Сейчас в теме
(3) если вам не подходит, это не значит что другим не нужно..
на каждый товар найдется свой покупатель...
4. stagov 7 19.01.10 12:55 Сейчас в теме
а таблицу значений создать ???
загнать туда доки с багами, с возможностью открыть и т.д....
6. stagov 7 19.01.10 14:21 Сейчас в теме
ага навоз то же селяне покупают поля удобрять... это к тому, что "на каждый товар найдется свой покупатель..."
мне больше нравится девиз "сделай как я, сделай лучше меня..."
7. dobraleks 137 19.01.10 15:21 Сейчас в теме
(6) "Сделай как я" -это так ....
Я должен последовать Вашему примеру, создать щас нового юзера на этом сайте и начать придираться к публикациям??.
Я правильно понял Вас??
8. stagov 7 19.01.10 15:33 Сейчас в теме
1.Бух.учет для Украины от захода не позволяет делать подобные вещи "копировать строки в документах, но забывают перещелкивать партии. Вот и получается что на елементе может висеть 2 ,а то и 3 "партии по умолчанию", или партия принадлежит другому елементу справочника"
2.Если это все таки возможно...
Пример. предприятие с оборотом 300 доков в день. штат операторов-менеджеров набивающих доки.
КАК вашим отчетом можно это исправить???
Вы представляете сколько на это нужно времени??? При вышеуказанном объеме.
см. п.4
9. dobraleks 137 19.01.10 15:51 Сейчас в теме
(8) че вы мне будете расказывать что "невозможно", возмите последний релиз бухни для Украины (на данный момент если вы в курсе 277) и смодулируйте ситуацию!! например на доке операция №5...
Если вы не знаете, то это уже другой вопрос..
У меня бухи (их больше 18), хитрые и "умные", они еще и не такое умудряются сотворить..

Данный отчет реализован пока именно как "ошибки партионного учета" , а если позволит свободное время далее в планах реализовать именно ИСПРАВЛЕНИЕ АВТОМАТОМ..

P/S/ Вы хоть пробовали у себя запускать??
на ваш 2 пункт, хороший совет дал (1), себе с нового года буду реализовывать чтоб не было подобных ситуаций..
10. Vladal 20.01.10 09:17 Сейчас в теме
Всем: Ну и чего ругать? Это же не очередной перенумератор.
11. stagov 7 20.01.10 15:22 Сейчас в теме
я даже в курсе, что Выпущен релиз 7.70.015 конфигурации " Торговля+Склад для Украины". и релиз 7.70.031 конфигурации "Бухгалтерия + Торговля + Склад + Зарплата + Кадры для Украины".
Отчет запускал и в ООО "Добро" и еще в 20 базах - никакого результата.
а что такое "...например на доке операция №5... "
пытался нагло допустить подобную ошибку - не дает данная процедура накосячить
Процедура ИзмТМЦ()
Если ТМЦ.Выбран()=1 Тогда
глУстановкаБазЕд(Контекст,ТМЦ);
// если партия этого ТМЦ уже есть, не будем ее трогать
Если Партия.Выбран() = 1 Тогда
Если Партия.Владелец <> ТМЦ Тогда
глПолучитьПартиюПоУмолчанию(Партия,ТМЦ);
КонецЕсли;
Иначе
глПолучитьПартиюПоУмолчанию(Партия,ТМЦ);
КонецЕсли;
УстЦенаБезНДС();
ИзмЦенаБезНДС();
КонецЕсли;
КонецПроцедуры
или
Обнаружены одинаковые ТМЦ (партии) в строках 1 и 2

13. dobraleks 137 20.01.10 16:23 Сейчас в теме
(11) пример допускания наглой ошибки!.
только что взял 277 демку и тупо допустил ошибку следующим образом.
1. Запустил отчет понятно что ошибок нету.
(рис1.) (рисунки смотри выше 3,4 и 5 миниатюры).
2. Док операция №5. Добавляю стоку Дт 201 Главный магазин- Авансовый платеж - партия по умолчанию (партия принадлежит авансовому платежу).
3. Добавляю еще одну проводку по Кт 201, Главный магазин-Авансовый платеж-партия по умолчанию. (партия принадлежит Авансовому платежу), !!!! Потом меняю авансовый платеж на "АРЕНДУ""" партию не перещелкиваю. (рис2)
4. Запускаю отчет, внизу сообщает что партия по Умолчанию в аренде принадлежит Авансовому отчету!!
(рис3.)
Показал чтоб было видно Дт и Кт, также само происходит когда копируют строки например по Дт201, Тмц-поменяли, а партию забывают перещелкнуть, вот и получаются такие ошибки.
12. stagov 7 20.01.10 15:25 Сейчас в теме
еще пока ни кто и не ругал.
14. stagov 7 20.01.10 18:21 Сейчас в теме
"Очень часто бухи любят копировать строки в документах,...."
копировать строки в документах и проводку в Операции это принципиально разные вещи по ходу
По терминам в документе операция копируется не строка а проводка.
15. dobraleks 137 20.01.10 19:51 Сейчас в теме
да меня больше волнует найти и исправить ошибки, а не то что они там любят..
Вывод один. Проблема такая бывает, решать ее как то надо, а кто как копирует это уже второстепенное.. :)
16. stagov 7 22.01.10 14:47 Сейчас в теме
Я улучшил Вашу обработку и если Вы не против (т.к. интерфейс и часть кода Вашего создания) - могу выложить.!?
17. dobraleks 137 22.01.10 15:15 Сейчас в теме
да без проблем! одна голова хорошо а 2 лучше..
За идею хотя б поблагодарили.. ;)
18. stagov 7 22.01.10 15:26 Сейчас в теме
я как практикующий бухгалтер не вижу пользы в этой идее, т.к. случай сугубо уникальный и у нормальных специалистов не имеющий место быть
19. dobraleks 137 22.01.10 15:40 Сейчас в теме
а я вам скажу как практикующий програмер и бух в одном лице..
вопрос не в том хорошие спецы или нет, а в человеческом факторе..
20. stagov 7 22.01.10 18:17 Сейчас в теме
Я еще более апгрейдил Ваш отчет.
Если есть возможность - проверьте функциональность кнопки "Выполнить"
http://infostart.ru/public/64439/?PAGEN_1=1#comm345021
21. tmm 30.11.11 16:27 Сейчас в теме
Как бы ещё научиться в нём работать.
Оставьте свое сообщение