Единый семинар «1С» для бухгалтеров и руководителей

Подключение весов "Масса-К" к 1С без драйверов и обработок

Оборудование - Весы

Для весов серии "Масса-К", имеющих интерфейс RS-232 для связи весов с ПК, возможна простая процедура подключения к 1С.

Для этого используется программа поддержки весов "МАССА-К" от разработчика (massa-k.exe - 794кб) 

http://massa.ru/help/drivers.php

Программа запускается при старте операционной системы стандартными способами. 

Далее необходима разовая начальная настройка программы на номер COM-порта и порядок (коэффициент веса).  При появлении груза на площадке весов, программа отправляет вес в активное окно на экране ПК. Это может быть, к примеру, блокнот, либо что-то другое.

На примере конфигурации "Розница" версия 1.х показан процесс передачи веса в чек.

При продаже весового товара, выбирается товар, затем нажимается кнопка "Получить вес" в меню РМК (рабочее место кассира).

Далее на весы помещается товар, и вес передается в окно вызанное функцией "ВвестиЧисло".

После передачи значения веса идёт пересчет по стоимости за единицу веса.

Процедура для кнопки "Получить вес" на панели РМК

/////////////////////////////////////////////////////////////////////////////////////////////

Процедура КнопкаПолучитьВесНажатие(Элемент)
        ПолученныйВес = 0;
        Если ВвестиЧисло(ПолученныйВес, "Положите товар на весы!", 10, 3) Тогда
                ПолученныйВес =ПолученныйВес * 0,01; // перевод граммы в килограммы и т.д.
        КонецЕсли;
        
        ТекущиеДанные = ЭлементыФормы.Товары.ТекущиеДанные;
        Если ПолученныйВес <> 0 Тогда
                ТекущиеДанные.Количество = ПолученныйВес;
                ТоварыПриИзмененииКоличества(ТекущиеДанные);
        КонецЕсли;
        
        УстановитьАктивныйЭлемент();
          
КонецПроцедуры

Процедура (типовая) определяющая торговое оборудование (весы)

Процедура УстановитьВесы()

       // т.к. процедура в данном случае не используется, то она закомментирована.
       //...
КонецПроцедуры

 

См. также

В этой теме еще нет сообщений.
Оставьте свое сообщение