INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Котов Дмитрий | Программист-разработчик | ООО "Саянскгазобетон"

«Автоматизация обработки потока документов, на примере разработки "Терминала путевых листов" для диспетчерской службы»

Пример возможности разработки полностью автоматизированного места для получения, обработки и возврата документов через терминал на платформе 1С:Предприятие 8.3, без участия оператора. В примере демонстрирую возможность реализации "Терминала путевых листов" в диспетчерской службе компании ООО "Саянскгазобетон". Основное направление компании - производство автоклавного газобетона. Диспетчерская служба не имеет возможности круглосуточной работы, в связи с чем сложилась проблема в своевременным возврате путевых листов от водителей. «Терминал путевых листов», продемонстрированный в докладе, позволяет решит данную проблему путем создания интерфейса прямого доступа в информационную систему с помощью нового режима запуска 1С – "Киоск". Водитель самостоятельно получает и возвращает путевой лист в прикладном решении 1С: Управление автотранспортом 2.1.

Обработка для работы с торговыми весами ВН, ВТА

Оборудование - Весы

1
Обработка для работа с весами (Типы весов описаны ниже). Для корректной работы нужно прочесть "Readme".

Работа с весами:
1. BTA-60/..-5, BTA-60/..-5-A, BTA-60/..-6-A (Торговые весы).
2. BH-..-A-PK, BH-..-1D-A-PK (Блоки ВН- з житко-кристаличний индикатором).
3. BH-..-A-CI, BH-..-1D-A-CI, BH-..- 220B (Блоки ВН- светодиодными индикаторами).

Обработка подходит для любой конфигурации на упр. формах. Для работы на обычных формах нужно доработать обычную форму или установить в конфигурации совместимость с упр. формами.

Данная обработка самодостаточна, необходимость в драйверах отсутствует. В производителей весов был взят "ехе" файл и запакован в обработку в "Макет" - Двоичные данные. Таким образом обработка при взвешивании распаковывает файл из макета, запускает "ехе" и обрабатывает результат.

&НаКлиенте
Процедура Вес(Команда)
	ИмяФайла = ПолучитьМакетНовый();	
	
	WshShell = Новый COMОбъект("WScript.Shell"); 
	WshShell.Run(ИмяФайла+" 3 COM3 9600 1 1", 0, True); 
	
	//КомандаСистемы(ИмяФайла+" 3 COM3 9600 1 1");
	
	ПрочитатьТХТИУдалитьФайлы(ИмяФайла);
КонецПроцедуры

&НаСервере
Функция ПолучитьМакетНовый()
	Об = РеквизитФормыВЗначение("Объект");
	ДвоичныеДанные = Об.ПолучитьМакет("Макет_Драйвер");
	
	//Файл ЕХЕ
	ИмяФайла = КаталогВрем+ФайлЕХЕ;
	
	ФайлНаДиске    = Новый Файл(ИмяФайла);
	КаталогНаДиске = Новый Файл(ФайлНаДиске.Путь);
	
	Если Не КаталогНаДиске.Существует() Тогда
		СоздатьКаталог(ФайлНаДиске.Путь);
	КонецЕсли;
	
	ДвоичныеДанные.Записать(ИмяФайла);
	
	Возврат ИмяФайла;
	
КонецФункции

&НаСервере
Процедура ПрочитатьТХТИУдалитьФайлы(ИмяФайла)
	
	//Файл текстовий
	ТФ = Новый ТекстовыйДокумент;
	ТФ.Прочитать(КаталогВрем+ФайлТХТ);
	КолСтрок = ТФ.КоличествоСтрок();

	К 		 = 4;
	ЗначВеса = 0;
	
	Для Н = 1 По КолСтрок Цикл
		Если Н = К Тогда
			Попытка
				ЗначВеса = ТФ.ПолучитьСтроку(Н);
				Прервать;
			Исключение
			КонецПопытки;
		КонецЕсли;
	КонецЦикла;
	
	Вес = ЗначВеса;
	
	Попытка
		УдалитьФайлы(ИмяФайла);
		УдалитьФайлы(КаталогВрем+ФайлТХТ);
	Исключение
	КонецПопытки;

КонецПроцедуры

П.С. Можно переписать таким образом, чтобы файл создавался на момент открытия формы и удалялся на момент закрытия, таким образом оптимизировать.

1

Скачать файлы

Наименование Файл Версия Размер
Обработка для работы с торговыми весами ВН, ВТА.:
.epf 79,02Kb
22.02.18
1
.epf 79,02Kb 1 Скачать
Файл readme к настройки весов
.rtf 338,42Kb
23.02.18
1
.rtf 338,42Kb 1 Скачать

См. также

Комментарии
Сортировка: Древо
2. raietchie 24.03.18 21:26 Сейчас в теме
Куплю драйвер для подключения весов с печатью этикеток BIZERBA SC II 800



На донный момент:
1) не удается програмировать весов
2) драйвера нету - для свяски 1С с весами

Для подключения весов с печатью этикеток BIZERBA SC II 800 с 1С 8.х, помимо средствами Connect.Brain, может у когото есть длугое решение ?

Спасибо
Оставьте свое сообщение