Сканирование, хранение и печать сертификатов продукции [Обновлено 17.01.2011]

Публикация № 79794

Разработка - Печать - Печатные формы документов

130
Сканирование с использованием WIA, хранение в справочнике Хранилище дополнительной информации и печать из документа реализации. [Обновлено] Добавил загрузку изображения из файла.

I. Сканирование.

 Сканирование происходит с помощью WIA (Windows Image Acquisition). В Windows 7 соответствующие dll уже входят в комплект, а для XP нужно качать и регистрировать (с сайта Microsoft, где в архиве есть инструкция). Код для сканирования из 1с следующий:


    Image = Новый COMОбъект("WIA.ImageFile"); //создаем объект "Изображения" в WIA для дальнейшей работы с ним
   
DevManager = Новый COMОбъект("WIA.CommonDialog"); //а это диалог сканирования
   
Image = DevManager.ShowAcquireImage(); //записываем сканированное изображение
   
IP = Новый COMОбъект("WIA.ImageProcess"); //создаем фильтр для сохранения изображения
   
IP.Filters.Add(IP.FilterInfos("Convert").FilterID);
   
IP1 = IP.Filters(1);
    Для
К = 1 По IP1.Properties.Count Цикл
        Если
IP1.Properties(К).Name = "FormatID" Тогда
           
IP1.Properties(К).Value = "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}"; //конвертируем в PNG
           
Прервать;
        КонецЕсли;
    КонецЦикла;

   
Image = IP.Apply(Image); //применяем фильтр на изображение

 

После этого можно сохранить объект Image на диск и прочитать её уже средствами 1с:


    УдалитьФайлы(ИмяФайла); //удалим старый файл
   
Image.SaveFile(ИмяФайла); //сохраним на жесткий диск объект WIA
   
ЭлементыФормы.СертификатИзображение.Картинка = Новый Картинка(ИмяФайла); // Читаем картинку с жесткого диска

Полученное изображение можно повертеть с помощью того же WIA:


    Если Image = Неопределено Тогда
        Возврат;
    КонецЕсли;

   
IP = Новый COMОбъект("WIA.ImageProcess"); //создаем объект WIA для редактирования изображения
   
IP.Filters.Add(IP.FilterInfos("RotateFlip").FilterID); //создаем WIA-фильтр для поворота
   
IP1 = IP.Filters(1);
    Для
К = 1 По IP1.Properties.Count Цикл
        Если
IP1.Properties(К).Name = "RotationAngle" Тогда
           
IP1.Properties(К).Value = Градусов//вертеть можно на 90,180 и 270 грудосов
            Прервать;
        КонецЕсли;
    КонецЦикла;

   
Image = IP.Apply(Image); //применяем фильтр на изображение

 

II. Сохранение

 Наиболее естественным местом хранения изображения сертификата - это справочник Хранилище дополнительной информации с привязкой к номенклатуре. В зависимости от разных обстоятельств один и тот же сертификат может быть привязан к различным позициям номенклатуры,  к различными характеристиками и сериями одной номенклатуры. Хранилище дополнительных данных не позволяет устанавливать соответствие между списком номенклатуры/характеристиками/сериями. Поэтому алгоритм хранения информации выглядит следующим образом:

1.Для сертификата состаляеся таблица: Номенклатура, характеристика, серия.

2.При записи сертификата изображение сохраняется в хранилище и привязывается к первой по списку номенклатуре.

3.Для каждого номенклатуры по списку ищется связанный элемент справочника Хранилище дополнительной информации под именем ТаблицаДляСертификатов (если его нет, то создается). В этом хранилище помещается таблица Номенклатура, характеристика, серия, ссылка на хранилище изображение сертификата. В эту таблицу добавляются новые данные и она снова записывается в хранилище.

Кроме того, в таблицу добавляется дополнительная информации о сертификате: дата начала, дата окончания и описание.

Таким образом, получаем 2 элемента Хранилища дополнительной информации: сами изображения сертификатов и таблицы, в которых хранится дополнительная  и более подробная о принадлежности сертификатов относительно характеристик и серий.

 

III. Печать.

Печатная форма документа Реализации товаров и услуг. Сначала составляется список номенклатуры и по нему получаются таблицы с данными о сертификатах. Потом проходя по табличной части документа происходит поиск соответствующих сертификатов, которые выводятся в табличный документ.

 

З.Ы. Вот по этим ссылкам можно посмотреть пример, что ещё можно сделать с помощью WIA с картинками.

http://msdn.microsoft.com/en-us/library/ms630819(VS.85).aspx
http://www.codeproject.com/KB/shell/resize_image_script_all.aspx

 

[Обновлено] Добавил кнопку загрузки изображения сертификата из файла.

130

Скачать файлы

Наименование Файл Версия Размер
СканированиеСертификатов. Версия 1.1
.epf 47,05Kb
24.07.13
573
.epf 47,05Kb 573 Скачать
ПросмотрСертификатов.epf
.epf 9,75Kb
24.07.13
148
.epf 9,75Kb 148 Скачать
ПечатьСертификатов.epf
.epf 9,35Kb
24.07.13
199
.epf 9,35Kb 199 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
1. markers 240 27.12.10 09:49 Сейчас в теме
Главный плюс, НЕ жадность автора!
2. anig99 2697 27.12.10 09:52 Сейчас в теме
мммм...(1) а чего жадничать-то? вся используемая информация изначально была в свободном доступе...
69. igorekpanchenko 28.07.15 08:52 Сейчас в теме
Не получается вставить картинку. Выдает ошибку: Поле объекта недоступно для записи (Картинка)

&НаКлиенте
Перем Image;

&НаКлиенте
Перем ЭлементыФормы; 

&НаКлиенте
Перем ИмяФайла;  

&НаКлиенте
Процедура Загрузить(Команда)
	файл = "" ;
	ПоместитьФайл(файл,,,Истина,УникальныйИдентификатор);
	Если файл<>"" Тогда 
		АдресКартинки = файл;
	КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	Если АдресКартинки <> Неопределено Тогда 
		Данные = ПолучитьИзВременногоХранилища(АдресКартинки);
		ТекущийОбъект.Файл = Новый ХранилищеЗначения(Данные);
	КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
	ЭтотОбъект = РеквизитФормыВЗначение("Объект");
	АдресКартинки = ПоместитьВоВременноеХранилище(ЭтотОбъект.Файл.Получить(), Новый УникальныйИдентификатор);	
КонецПроцедуры

&НаКлиенте
Процедура Сканировать(Команда)
	
	Image = Новый COMОбъект("WIA.ImageFile"); 
	DevManager = Новый COMОбъект("WIA.CommonDialog"); 
	Image = DevManager.ShowAcquireImage();
	IP = Новый COMОбъект("WIA.ImageProcess");
	IP.Filters.Add(IP.FilterInfos("Convert").FilterID);
	IP1 = IP.Filters(1);
	Для К = 1 По IP1.Properties.Count Цикл
		Если IP1.Properties(К).Name = "FormatID" Тогда
			IP1.Properties(К).Value = "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}";
			Прервать;
		КонецЕсли;
	КонецЦикла;
	Image = IP.Apply(Image);
	СохранитьИВывестиИзображение();
			
КонецПроцедуры

&НаКлиенте
Процедура СохранитьИВывестиИзображение()
	УдалитьФайлы(ИмяФайла); //удалим старый файл
    Image.SaveFile(ИмяФайла); //сохраним на жесткий диск объект WIA
	Элементы.Картинка = Новый Картинка(ИмяФайла);
КонецПроцедуры

ИмяФайла =  "C:\CurCertificate.png";
Image = Неопределено;
Показать
70. igorekpanchenko 28.07.15 09:31 Сейчас в теме
Заработало, спасибо за помощь.
&НаКлиенте
Процедура Сканировать(Команда)
	
	Image = Новый COMОбъект("WIA.ImageFile"); 
	DevManager = Новый COMОбъект("WIA.CommonDialog"); 
	Image = DevManager.ShowAcquireImage();
	IP = Новый COMОбъект("WIA.ImageProcess");
	IP.Filters.Add(IP.FilterInfos("Convert").FilterID);
	IP1 = IP.Filters(1);
	Для К = 1 По IP1.Properties.Count Цикл
		Если IP1.Properties(К).Name = "FormatID" Тогда
			IP1.Properties(К).Value = "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}";
			Прервать;
		КонецЕсли;
	КонецЦикла;
	Image = IP.Apply(Image);
	СохранитьИВывестиИзображение();
			
КонецПроцедуры

&НаКлиенте
Процедура СохранитьИВывестиИзображение()
	УдалитьФайлы(ИмяФайла); //удалим старый файл
    Image.SaveFile(ИмяФайла); //сохраним на жесткий диск объект WIA		
	АдресВХранилище = ""; //Помещаем картинку в хранилище
	ПоместитьФайл (АдресВХранилище, "C:\CurCertificate.png", , Ложь) ; //Помещаем картинку в хранилище
	АдресКартинки = АдресВХранилище; //Вставляем из хранилища
КонецПроцедуры



ИмяФайла =  "C:\CurCertificate.png";
Image = Неопределено;
Показать
3. markers 240 27.12.10 10:19 Сейчас в теме
Ну не знаю почему некоторые жадничают :) За мелкую обработку и проще этой обработку (В плане что мне проще написать) берут денег...
Спасибо!
4. mirco 72 27.12.10 11:23 Сейчас в теме
"В Windows 7 соответствующие dll уже входят в комплект" - но работать будет только если для сканера есть драйвера twain совместимые, так ?
5. anig99 2697 27.12.10 12:53 Сейчас в теме
(4) нет. wia и twain - это разные стандарты
6. mirco 72 27.12.10 14:04 Сейчас в теме
(5) про твайн я образно...
я имел ввиду что драйвера на сканер должны стоять...
7. anig99 2697 27.12.10 14:28 Сейчас в теме
(6) хотя бы универсальный WIA (в теории, практики такой не было)
8. V_V_V 27.12.10 15:37 Сейчас в теме
Полученное изображение можно повертеть с помощью того же WIA

А обрезать можно? А сохранить с определенным размером? Очень интересует...
9. anig99 2697 27.12.10 16:08 Сейчас в теме
(8) Можно при сканировании обрезать. А можно через WIA согласно

http://msdn.microsoft.com/en-us/library/ms630819(VS.85).aspx
http://www.codeproject.com/KB/shell/resize_image_script_all.aspx

Дерзайте
ilya4; V_V_V; +2 Ответить
10. CheBurator 3400 27.12.10 23:49 Сейчас в теме
паровозом "аналог" для 7.7
http://infostart.ru/public/15355/
.
автору - плюс! порадовал!
11. anig99 2697 28.12.10 00:32 Сейчас в теме
(10) к сожалению scan1c.dll не работает на 8.1 )%
12. lalexrus 03.01.11 12:14 Сейчас в теме
все это хорошо, а если в одном документе продается товар с несколькими сертификатами (например алкоголь, где мб разные даты розлива)?
13. anig99 2697 03.01.11 13:54 Сейчас в теме
(12) для этого существуют Серии, которые данная обработка учитывает. А вот 1с может и не учитывать.
Программисты 1с то ли схалтурили, то ли специально оставили лазейку:

Даже если по номенклатуре не ведется учет по сериям, то в документах поступления и реализации для этой номенклатуры можно указывать серии не вызывая форму выбора, а через поле вода введя часть названия. Сами серии тоже можно вводить не через номенклатуру, а через справочник Серии номенклатуры.

В Вашем случае серии = дата розлива.
14. lalexrus 04.01.11 16:38 Сейчас в теме
(13) собака с датами розлива зарыта в том, что их может быть много для одного товара. Отсюда следует главное неудобство - необходимость в одном документе разбивать одну строку на несколько в соответствии с датами розлива.
15. anig99 2697 04.01.11 16:54 Сейчас в теме
(14) можно копнуть в сторону серийных номеров. В этом случае доработка обработок по сертификации непринципиальна.
А какие будут Ваши предложения? Ведь проблема дат розлива в алкогольки довольна спецефична и вообще требует отдельных конфигураций.
16. lalexrus 04.01.11 17:07 Сейчас в теме
(15) собственно я покажу вашу обработку сертификатам нашим, что они скажут напишу (включая и мои соображения, практика показала, что я могу думать совсем другое :) )
17. VBWEBMAIL 08.01.11 13:25 Сейчас в теме
anig99! спасибо за обработку.. только не могу разобраться в чем может быть ошибка при выполнении метода Image.SaveFile(ИмяФайла), выдается ошибка Произошла исключительная ситуация (WIA.ImageFile.1): Отказано в доступе... очень странно...
Спасибо, если поможете!
18. anig99 2697 08.01.11 13:38 Сейчас в теме
(17) windows 7? Если да, то нужно чуть менять обработку - по умолчанию она пишет на диск C:\, а доступ на него обычно закрыт. Нужно указать или доступную неадминистратору папку, или использовать функцию 1с по получению имени временного файла.
19. VBWEBMAIL 08.01.11 13:45 Сейчас в теме
:) Спасибо! все получилось. с W7 все понятно :) там все автоматом ставится.. а как быть с XP? у Вас был опыт?
20. anig99 2697 08.01.11 17:29 Сейчас в теме
(19) в XP проблем с диском С не возникало
21. VBWEBMAIL 08.01.11 18:36 Сейчас в теме
для XP, как понимаю, нужно скачивать драйвера для WIA 2.0?
22. anig99 2697 08.01.11 19:53 Сейчас в теме
(21) да... но проблем с этим не должно быть. Они лежат в свободном доступе на сайте мелкомягким с инструкцией по регистрации
50. Angeros 13.08.13 12:24 Сейчас в теме
(22) поделитесь ссылкой для xp. я както не могу понять где там искать?! :)
51. anig99 2697 13.08.13 12:40 Сейчас в теме
(50) уже убрали. Вот рабочая ссылка
http://vbnet.mvps.org/files/updates/wiaautsdk.zip
kare; val54321; FaKer1980; Angeros; +4 Ответить
23. x_mih 12.01.11 15:43 Сейчас в теме
Доработайте пожалуйста чтобы можно было просто указать картинку сертификата. Спасибо.
24. anig99 2697 17.01.11 22:55 Сейчас в теме
25. CheBurator 3400 18.01.11 01:38 Сейчас в теме
а не думали ли вы о таком "функционале": есть сканеры с автоподачей - кинул стопку - дивайс их пакетом отсканировал (в папочку).
Потом берем и на вход "обработки" - подаем отсканированный "пакет" - который обрезаем/выравниваем картинки и привязываем к номенклатуре (источник - любой: документ, группа справочника, список значений, массив, ТЗ...). У мну такая задача в свое время нарисовалась - но я ушел из фирмы...
26. anig99 2697 18.01.11 07:29 Сейчас в теме
(25) нет такой потребности.
27. Sk0rp 112 09.02.11 14:19 Сейчас в теме
Как туда добавить, что бы окошко настроек сканирования не появлялось, а можно было все программно настроить и сразу начиналось сканирование?
28. anig99 2697 09.02.11 15:04 Сейчас в теме
(27)Посмотрите ShowAcquireImage.
Точные изменения сейчас не скажу. Нет под времени и сканера под рукой.
http://msdn.microsoft.com/en-us/library/ms630772(VS.85).aspx - вот справка по данной команде
29. Sk0rp 112 09.02.11 15:55 Сейчас в теме
(28) О спасибо! Перебирал методы CommonDialog, а в параметры самого ShowAcquireImage заглянуть не додумался.
30. sdvig 8 03.03.11 04:12 Сейчас в теме
(29) как сделали? пишу: DevManager.ShowAcquireImage(1,4,,,ложь,ложь,); а окно все равно появляется?
31. vdv_4462 05.04.11 14:12 Сейчас в теме
Попробовал обработку. Со сканером все прекрасно (Canoscan Lide 70 с родными драйверами)
Попробовал также с веб-камерой. И вот тут засада - не появляется никакого окошка для настройки. В результате получаются фото с размером 640*480. А камера может намного больше - и хотелось бы именно этого...

Подскажите, если не трудно, как можно получить либо окно настройки, либо (еще лучше) фиксированное разрешение, к примеру 1280*1024...
32. anig99 2697 05.04.11 15:19 Сейчас в теме
(31) не пробовал с камерой.
но где-то здесь
http://msdn.microsoft.com/en-us/library/ms630492(v=VS.85).aspx - ShowAcquisitionWizard
Иначе нужно копаться в командах самого устройства.
33. levran 199 06.04.11 16:33 Сейчас в теме
Одно время работал в торговой компании, активно использующей подобную схему хранения сертификатов. После 1,5 года запуска активной работы, база легла, из-за справочника "Хранилище дополнительной информации". (большой размер базы). Посему обработка сохранения сканов была переписана на внешний каталог. Скорость обработки сканов упала, но не сильно заметно. ИМХО.
34. anig99 2697 06.04.11 20:32 Сейчас в теме
(33) ни того, ни другого в свободном юзабельном виде нигде нет. Никто не запрещает дописать запись и чтение изображений под хранение ссылки на файл во внешнем каталоге.
35. Zen13 16.09.11 14:19 Сейчас в теме
36. Nick5k 24.10.11 01:02 Сейчас в теме
Добрый день! Очень нужна Ваша обработка, но нет возможности скачать, если можно вышлите на nick5k@mail.ru.
Очень надо! А изобретать своё времени нет.
37. RakovskiyK 24.10.11 15:05 Сейчас в теме
уже в который раз автор осчастливливает с нужным продуктом и щедрым подходом!
Огромное спасибо!
38. CaSH_2004 354 06.11.11 22:22 Сейчас в теме
А в формат PDF напрямую можно или только перегонкой через виртуальный принтер и аналоги?
Поискал в нете, нашел намек в документации что можно, но не сказано как
кстати в тему: http://wiki.kint.ru/index.php/Использование_сканера_(1Cv8)
и
как обрабатывать рисунок
39. anig99 2697 08.11.11 08:37 Сейчас в теме
(38) я не искал способа напрямую. не все сканеры поддерживают сканирование сразу в pdf. У меня в более новой версии реализована просто загрузка файлов.
41. RakovskiyK 23.11.11 10:39 Сейчас в теме
поддерживаю (39) на текущий момент не многие организации используют сканирование в PDF, так что обработка более чем актуальна.
40. dindzilin 20.11.11 13:56 Сейчас в теме
Довольно полезная обработка, раньше использовал внешние компоненты, естественно приходилось регистрировать, копировать... А тут воткнул в конфу и все работает )))
42. 404vrn 05.12.11 09:09 Сейчас в теме
Спасибо, очень пригодилась обработочка!
43. raym0n 16.12.11 16:53 Сейчас в теме
Ой, огромное спасибо! Как раз встала задача реорганизации рабочего места сертефикатчиц.

Будем копать, спасибо!
44. ediks 329 16.02.12 17:54 Сейчас в теме
Все отлично сканируется в локале и, к сожалению, не работает через Citrix. Хотя с использованием twain документы сканируются и в Citrix. Это не претензия, просто констатация факта :). Возможно, надо добавлять устройство на сервер, а при нашем зоопарке это несколько затруднительно.
45. soba 28.02.12 16:26 Сейчас в теме
По идее тоже самое и под 7-ку можно прикрутить, только обработку переписать ? только вот предпросмотр неясно как организовать. Что-то из внешних компонент надо
46. Ionmuerto 22.05.12 12:26 Сейчас в теме
Возможно ли эту обработку привязать к заявки на расходования БД денежных средств? в качестве изображений выставленные счета на оплату?
47. K_Tanusik 29.05.12 14:18 Сейчас в теме
Спасибо огромное, скачала очень нужная обработка
48. mmk83 32 09.01.13 19:48 Сейчас в теме
а есть возможность прикрутить сканирование в многостраничный тиф?
49. It-developer 20 30.01.13 14:42 Сейчас в теме
Респект и уважуха! Спасибо, заюзаю у себя
52. val54321 23 28.11.13 10:23 Сейчас в теме
А есть для 64 битной системы?
53. anig99 2697 28.11.13 10:37 Сейчас в теме
(52) В 7ке и выше WIA стоит по умолчанию. Для более старых систем вроде как нет разницы.
54. val54321 23 28.11.13 11:03 Сейчас в теме
Я ставлю на сервер, при установке на 32 битный 2003 сервер, все отлично, при установке на тот же 2003 но 64 не взлетает.
Пробовал взять этут библиотеку из уже установленной вин7 64 битной, не находит процедуру loadlibrary при попытке регистрации.
55. anig99 2697 28.11.13 11:08 Сейчас в теме
56. val54321 23 28.11.13 16:11 Сейчас в теме
Проблема описана в точности как у меня, но так как там описано не взлетает. Точно так же не находит loadlibrary.
57. user_2010 430 12.05.14 12:18 Сейчас в теме
Как изменить размер картинки при сохранении в базу?
Какие методы COMОбъект("WIA.ImageProcess") для этого надо использовать?
Может быть есть пример кода?
58. anig99 2697 12.05.14 12:37 Сейчас в теме
59. pvlunegov 143 05.06.15 21:43 Сейчас в теме
anig99
Я к тебе в гости пожаловал.
Смотрю ты тут тоже крутые статьи пишешь.
А помнишь как ты меня лохом обзывал в моей статье, нахер посылал, угрожал, приказывал прекратить печать статей?

Ну что-ж оценим твои творения!

Ну что-ж, неплохо для старичка. Потянет на пятерку. Но вот скачивать не буду, хотя вещь хорошая.
Жалко мне на тебя тратить свои мани.
Человек ты вроде неплохой, но плохо обзываешься и ведешь себя, я с тобой неиграю!
60. anig99 2697 05.06.15 21:55 Сейчас в теме
(59) pvlunegov, если внимательно и без эмоций прочитаете написанное мною, то личных оскорблений там нет. Есть оценка Вашей работы и моё личное отношение к тем, кто берёт деньги за такое.
61. igorekpanchenko 27.07.15 09:15 Сейчас в теме
Добрый день!
Подскажите как можно сканированную картинку сразу вывести на экран в форму?
63. igorekpanchenko 27.07.15 11:35 Сейчас в теме
Помогите разобраться где я ошибся. Выскакивает ошибка:
{Справочник.ХранилищеДопИнформации.Форма.ФормаЭлемента.Форма(92)}: Поле объекта не обнаружено (Картинка)
Элементы.КартинкаСкан.Картинка = Новый Картинка(ИмяФайла);

Код:

&НаКлиенте
Процедура Сканировать(Команда)
	
	Image = Новый COMОбъект("WIA.ImageFile"); 
	DevManager = Новый COMОбъект("WIA.CommonDialog"); 
	Image = DevManager.ShowAcquireImage();
	IP = Новый COMОбъект("WIA.ImageProcess");
	IP.Filters.Add(IP.FilterInfos("Convert").FilterID);
	IP1 = IP.Filters(1);
	Для К = 1 По IP1.Properties.Count Цикл
		Если IP1.Properties(К).Name = "FormatID" Тогда
			IP1.Properties(К).Value = "{B96B3CAF-0728-11D3-9D7B-0000F81EF32E}";
			Прервать;
		КонецЕсли;
	КонецЦикла;
	Image = IP.Apply(Image);
	СохранитьИВывестиИзображение();
	
КонецПроцедуры

&НаКлиенте
Процедура СохранитьИВывестиИзображение()

	УдалитьФайлы(ИмяФайла);
	Image.SaveFile(ИмяФайла);
	Элементы.КартинкаСкан.Картинка = Новый Картинка(ИмяФайла);
	Элементы.КартинкаСкан.Видимость = Истина;

КонецПроцедуры

ИмяФайла =  "C:\CurCertificate.png";
Image = Неопределено;
Показать
Прикрепленные файлы:
64. igorekpanchenko 27.07.15 11:36 Сейчас в теме
Сканирует, потом выводит ошибку.
65. anig99 2697 27.07.15 13:08 Сейчас в теме
(64) igorekpanchenko, а на форме есть элемент типа картинка с именем КартинкаСкан?
66. igorekpanchenko 27.07.15 13:17 Сейчас в теме
(65) Присутствует.
Вид: поле картинки
Путь К Данным: АдресКартинки
67. igorekpanchenko 27.07.15 13:19 Сейчас в теме
(65) Кнопка загрузки работает таким способом:

&НаКлиенте
Процедура Загрузить(Команда)

	файл = "" ;
	ПоместитьФайл(файл,,,Истина,УникальныйИдентификатор);
	Если файл<>"" Тогда 
		АдресКартинки = файл;
	КонецЕсли;

КонецПроцедуры
Показать

68. anig99 2697 27.07.15 16:15 Сейчас в теме
Элементы.КартинкаСкан.АдресКартинки = Файл
не так должно быть?
71. al_zzz 125 30.09.15 07:41 Сейчас в теме
Подскажите пожалуйста, как сделать сканирование с автоподачей в один файл?
72. info1ctart 03.03.16 03:34 Сейчас в теме
Можно ли как-то задать имя сканера, или сделать выбор? А то их несколько, и сканирует не с того.
Оставьте свое сообщение

См. также

Шаблон разработки печатных форм и подключения к конфигурациям на БСП 2.х и БСП 3.0 79

Инструменты и обработки Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Печатные формы документов БСП (Библиотека стандартных подсистем) Расширения

«Вместо поставки внешних печатных форм в виде внешних обработок рекомендуется вести их разработку с помощью расширений конфигурации.» [ИТС, БСП гл. 3.38 Печать] У меня задачи типа «Требуется разработать печатную форму …» появляются регулярно, но с временными интервалами. Что бы вести разработку единообразно, для конфигураций на БСП, я заготовил шаблон для таких задачек, который позволяет мне сразу приступить к разработке макета и алгоритма формирования печатной формы, а «обертка» из БСП уже готова.

1 стартмани

04.10.2019    3728    11    tolX5    11       

Трудовой договор, Дополнительное соглашение, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1 17

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    6976    56    Asenka    3       

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом 13

Инструменты и обработки Программист Пользователь Архив с данными v8 КА1 БП2.0 УТ10 УПП1 Windows Абонемент ($m) Печатные формы документов Универсальные функции Email

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    11245    10    stvorl    0       

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой 26

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.10 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.10 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    29528    498    p.ugrumov    86       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    21567    21    agent00mouse    0       

Остатки товаров на складах по выбранным документам 9

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 ERP2 УТ11 УУ Учет ТМЦ Абонемент ($m) Печатные формы документов

Печатная форма подключается к документам. Даёт возможность быстро оценить остатки товара на складе по номенклатуре, указанной в документе, и ответить на вопрос, хватает ли остатков, чтобы отгрузить счет? На каких складах продукция по этому документу?

2 стартмани

09.11.2017    30492    24    A7758735    4       

Решение проблемы ПроверитьВывод() для огромных документов 49

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования

Пример того, как я ускорил вывод большого табличного документа(100+ страниц)

2 стартмани

06.11.2017    16136    2    SITR-utyos    17       

Счет-фактура+УПД+УКД с 01.10.2017 в редакции Постановления Правительства РФ от 19.08.2017 № 981. Для всех конфигураций на 1С 8 48

Отчеты и формы Бухгалтер Архив с данными v8 БП2.0 УТ10 УПП1 УНФ БП3.0 УТ11 БУ НУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы с автоматической регистрацией для документа "Счет-фактура выданный" в редакции Постановления Правительства РФ №981 от 19.08.2017 года. Новые счета-фактуры № 981 применяются с 01.10.2017 года. Так же для УТ 10 очень старых релизов применяется сч.фактура в файле.

2 стартмани

18.09.2017    66216    1341    Kontakt    90       

Внешние печатные формы Счет-фактура, УПД, УКД образца 2017 г. (ПП от 19.08.2017 № 981) для УПП 1.3, КА 1.1, БП 2.0 22

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УПП1 БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы "Счет-фактура", "Универсальный передаточный документ", "Универсальный корректировочный документ" (в редакции постановления Правительства Российской Федерации от 19.08.2017 № 981) для типовых конфигураций УПП 1.3, КА 1.1, БП 2.0.

1 стартмани

30.06.2017    41362    712    Tavalik    63       

Счет-фактура с 01.07.2017 от 25.05.2017 №625 для ВСЕХ конфигураций 1С 8.х (БП 2.0, БП 2.0 КОРП, БАУ 2.0, БАУ 2.0 КОРП, КА 1.1, ПД 1.0, Розница 1.0, УНФ 1.3, УПП 1.3, УТ 11, УТ 10.3) 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ КА1 БП2.0 УТ10 Розница УПП1 УНФ БП3.0 БАУ УТ11 Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

С июля 2017 года применяется новая печатная форма счет-фактуры в редакции Постановления Правительства РФ от 25.05.2017 № 625. В публикации собраны внешние печатные формы для всех популярных конфигураций 1С. Будет актуально для 90% организаций, которые не ведут учет по гос. контрактам, так как новое поле не заполняется, а вместо номера гос. контракта установлен прочерк по умолчанию.

1 стартмани

29.06.2017    34415    455    a.kapustin    43       

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме 3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БУ УУ Дебиторская и кредиторская задолженность Абонемент ($m) Обработка документов Печатные формы документов

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    11758    2    denmax    2       

Печатная форма Счет-Фактура от 01.10.2017, УПД 01.10.2017, Торг-12, Счет на оплату, ТТН (1-Т) БП 3.0 ОРИГИНАЛЬНЫЕ 10

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Набор внешних печатных форм: Счет-Фактура, УПД, Торг-12, ТТН, Счетна оплату для 1С: БП 3.0. Формы взяты из релиза 3.0.54.20 бухгалтерии предприятия. Печатные формы (УПД и счет-фактуры) приведены в соответствие постановления 625 от 25.05.2017 И В РЕДАКЦИИ ПОСТАНОВЛЕНИЯ 981 ОТ 19.08.2017 в формах выводится "Идентификатор госконтракта" и прочие изменения.

1 стартмани

04.05.2016    36901    378    A7758735    3       

Печатные формы для БП 3.0: УПД, ТОРГ-12, Акт, Счет-фактура, Доверенность, Счет 25

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы УПД, ТОРГ-12, Акта об оказании услуг, Счет-фактуры, Доверенности и Счета на оплату покупателю, актуализированы на последний релиз 3.0.71, поддерживают типовые факсимиле (новую галочку "Подпись и печать"), не содержат ошибок с новой ставкой НДС. В публикации также представлены печатные формы для устаревших релизов.

1 стартмани

28.01.2016    55557    762    config    42       

Легкое создание пользователем внешних печатных форм методом Drag & Drop 135

Отчеты и формы Программист Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Универсальные печатные формы Печатные формы документов

Универсальная внешняя печатная форма (ПФ), которая позволяет пользователю, без знаний программирования и не заходя в конфигуратор, создать ПФ любого документа или справочника в Microsoft Word или OpenOffice Writer методом перетаскивания (Drag & Drop). Можно создавать любые ПФ с выводом табличных частей, реквизитов документа, а также вложенных реквизитов и контактной информации. Не требует изменения конфигурации. Работает на версии платформы 8.3 в типовых конфигурациях на управляемых формах (например, Бухгалтерия 3.0, УТ 11, УНФ, Розница, Документооборот), а также и в других конфигурациях на УФ, построенных на БСП.

2 стартмани

04.01.2016    28192    180    CyberCerber    35       

Внешняя печатная форма «Счет на оплату покупателю» для документа «Реализация товаров и услуг» 2

Отчеты и формы Бухгалтер Архив с данными v8 БП2.0 Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма «Счет на оплату покупателю» для документа «Реализация товаров и услуг»

5 стартмани

07.09.2015    16978    2    trendy    0       

[x1c.ru] MXL Stamps - Печати и подписи в макетах печатных форм в несколько кликов 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Универсальные обработки

Обработка позволяет быстро создавать поля текста из ячеек печатных форм и добавлять "под них" подписи и печати. Работает в конфигурациях на управляемых формах.

1 стартмани

22.08.2015    26728    23    GusevNA    6       

Конструктор трудовых договоров WORD для типовой конфигурации 1C: Зарплата и управление персоналом 3.1 82

Отчеты и формы Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x Россия БУ Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Универсальные печатные формы Пакетная печать Печатные формы документов

Внешняя печатная форма или обработка "Конструктор трудовых договоров на основе документов формата Word". Конструктор автоматически подставляет реквизиты в документ формата Word. Подходит для типовой конфигурации 1С: ЗУП 3.1.

1 стартмани

14.07.2015    46638    581    ni032mas    97       

Счет на оплату покупателю с выбором изображения факсимильной печати и подписей для конфигурации "Бухгалтерия предприятия 3.0" 5

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 БП2.0 Россия Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Как известно, типовая конфигурация предоставляет возможность формирования счета с подписями и печатью. Это удобно, т.к. сразу, без вывода на печать и сканирования можно сохранить факсимильное изображение документа в pdf формате и отправить контрагенту. Создание и добавление картинки производится при редактировании справочника "Организации". Здесь же предлагается шаблон и понятная инструкция по созданию файла картинки. Что же можно улучшить?

1 стартмани

10.07.2015    19099    34    Олег Ящеров    5       

Инвентаризационные описи 0504087 и 0504086 согласно приказу №139 от 08.03.08 МО РФ 1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Windows Учет ОС и НМА Абонемент ($m) Печатные формы документов

Внешние печатные формы 0504087 и 0504086 от НПЦ Прогтехника 1С:Воинская часть 8 с моими изменениями согласно приказу МО РФ №139

1 стартмани

12.06.2015    20497    13    alfaservice    1       

Товарный чек с логотипом для конфигурации "Бухгалтерия предприятия 3.0.30-3.0.40.27" 4

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 БУ Windows Розничная торговля Абонемент ($m) Печатные формы документов

Печатная форма "Товарный чек" "Бухгалтерия предприятия 3.0", документов "Реализация" и "Отчет о розничных продажах"

1 стартмани

08.06.2015    14785    8    Alexsur    1       

Печатные формы УПД ("Универсальный передаточный документ") и Счета-Фактуры для ЛЮБЫХ версий УТ 10.3 (Управление торговлей ред.10.3) (с изменениями 2017 года) 9

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Печатные формы "УПД" и "Счет-фактура с 2012 года" для документов "РеализацияТоваровУслуг" и "СчетФактураВыданный" для старых и новых версий УТ10.3 (с изменениями 2017 года в июле и октябре)

2 стартмани

01.06.2015    33390    191    aserg    34       

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) 17

Инструменты и обработки Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 БП2.0 КА1 УПП1 УТ10 Россия БУ Windows Оптовая торговля Абонемент ($m) Печатные формы документов Пакетная печать Email

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    40610    3    trendy    18       

УПД за поставщика c подписями и факсимиле для БП 3.0 39

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Документооборот и делопроизводство Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма для печати - "Универсальный передаточный документ" за поставщика. ВПФ (с формой и без) в форме заполняются должности и фамилии и происходит заполнение полей 10,13, 15,18.Так же есть возможность хранить и выводить на печать подписи руководителя и глав.бухгалтера поставщика. Внесены изменения под требования конфигураций выше 3.0.67.38 (НДС20%). Версия 0.2 без формы выбора подписантов(будет полезна тем у кого ответственные лица неизменные).

5 стартмани

19.03.2015    68863    953    kn    96       

Инвентаризационная опись 0504087 с группировкой по счету для БГУ 1.0 1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БГУ Россия БУ Windows Учет ОС и НМА Учет ТМЦ Абонемент ($m) Печатные формы документов

Внешняя печатная форма предназначена для печати ф. 0504087 с группировкой по счёту учёта для документов:"Инвентаризация ОС (НМА,НПА) на балансовых счетах", "Инвентаризация основных средств (забалансовый учет)", "Инвентаризация ОС в оперативном учете", "Инвентаризация материалов на счете 105", "Инвентаризация материалов (забалансовый учет)".

5 стартмани

22.12.2014    26544    5    agospodarin    2       

Внешняя печатная форма "Качественное удостоверение" к 1С:Бухгалтерия 3.0 2

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма "Качественное удостоверение" к 1С:Бухгалтерия 3.0 на управляемых формах без изменения конфигурации с доп. сведениями в номенклатуре: "Сертификат соответствия" и "Срок хранения"

1 стартмани

03.12.2014    20200    42    dialogsoft    3       

Создание внешней печатной формы под УП с возможностью передачи параметров (для конфигураций на БСП) 35

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Печатные формы документов

В статье будет широко рассмотрен вопрос создания внешней печатной формы под управляемым приложением с возможностью передачи параметров. Предложено два способа распечатать ВПФ и передать в нее нужные параметры.

1 стартмани

07.08.2014    40133    118    signum2009    8       

Создание внешних печатных форм под управляемым приложением с нуля 550

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Печатные формы документов

Когда мне пришлось создавать внешние печатные формы под приложения на БСП ("1С: Бухгалтерия предприятия 3.0", "1С: Управление торговлей 11"), я обнаружил, что нет грамотных инструкций. Те, что имелись, использовали так называемые шаблоны: готовые обработки, в которых необходимо выполнять определенные корректировки. Но как создать сам шаблон, конкретных мануалов не было, справочную информацию я нашел на сайте ИТС и, обработав ее, написал статью, где подробно и понятно объясняются все этапы создания внешней печатной формы для управляемого приложения на примере конфигурации "1С: Бухгалтерия предприятия 3.0"

1 стартмани

05.06.2014    227131    557    signum2009    119       

ТОРГ-12 с выбором грузополучателя, печатью КПП и тары отдельными строками для УТ 11 6

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ11 УУ Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма ТОРГ-12 с выбором грузополучателя, с возможностью печати КПП и вывода тары отдельными строками для Управления торговлей 11

2 стартмани

18.04.2014    27709    25    lok78    1       

Счет-фактура в конфигурации Управление торговлей 11.1 2

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешняя печатная форма "Счет-фактура" к документу "Реализация товаров и услуг" Конфигурация Управление торговлей 11.1 (11.1.2.22)

1 стартмани

06.02.2014    19392    65    sdn-1    2       

Шаблон внешней печатной формы в управляемом приложении. Пример создания печатной формы. 71

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 БП2.0 Windows Абонемент ($m) Печатные формы документов Практика программирования

Данная статья посещена для тех, кто пытается сделать внешнюю печатную форму в 1С на основе типовых форм. Отладка печатной формы в клиент-серверном варианте из под тонкого клиента.

1 стартмани

10.01.2014    63062    661    Leoway    25       

Счет на оплату с печатью и подписью к документу "Заказ клиента" в конфигурации Управление торговлей 11.1 9

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма "Счет на оплату" с печатью и подписью для нескольких фирм к документу "Заказ клиента" Конфигурация Управление торговлей 11.1 (11.1.2.10)

1 стартмани

10.01.2014    35876    189    sdn-1    21       

Технология ввода и сохранения нетиповых реквизитов печатных форм документов 49

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 БП2.0 Windows Абонемент ($m) Печатные формы документов Практика программирования

У меня очень часто в работе встречаются пожелания пользователей по доработке печатных форм, в которых нужно заполнять непредусмотренные в конфигурации поля. Из-за таких мелочей "влазить" в конфигурацию не хочется с одной стороны, с другой стороны надо сделать, чтобы операторам было удобно вводить и распечатывать формы. Поэтому начал делать внешние печатные формы и сохранять недостающие данные в свойствах документов. В результате получилась некая технология (стандарт, подход) по созданию таких печатных форм.

1 стартмани

06.12.2013    15387    43    maxx    23       

Внешняя печатная форма "Универсальный передаточный документ(УПД)" для конфигурации 1С:Управление торговлей 10.3(8.2) 38

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Оптовая торговля Абонемент ($m) Печатные формы документов

"Универсальный передаточный документ"(образца 2017 года) для конфигурации 1С:Управление торговлей 10.3. Работает на релизах (10.3.28 и выше).

2 стартмани

02.12.2013    89304    1111    cyberi    54       

[БП 3.0, УТ 11.1] Бизнес-Интеллект: мастер ТТН 48

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП3.0 УТ11 Россия БУ УУ Windows Документооборот и делопроизводство Оптовая торговля Абонемент ($m) Печатные формы документов

Трудности с формированием комплектов сопроводительных документов при перевозках? Много времени отнимает подготовка ТН и ТТН? У Вас несколько перевозок (ТН, ТТН) на одну финансовую реализацию (ТОРГ 12)? Необходимо хранить данные о каждой перевозке в информационной базе? В решении всех этих проблем Вам поможет обработка "Бизнес-Интеллект:мастер ТТН"

1 стартмани

18.11.2013    55832    186    biz-intel    63       

Печать ТТН для Бухгалтерии предприятия 3.0 с сохранением реквизитов 9

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма Бланков ТТН(Для Бухгалтерии 3.0), реализована с сохранением реквизитов и с формой, подобной как на обычных формах.

2 стартмани

08.11.2013    14609    208    jsuh    23       

Внешняя ПФ "Приходная накладная с учетом корректировки" для документа "Поступление товаров и услуг" -1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия УУ Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Ну нет, почему-то, в УТ 10.3 такой печатной формы, которая отражала бы документ Поступление товаров и услуг с учетом документа Корректировка поступления, а у документа Корректировка поступления вообще нет ни одной печатной формы

1 стартмани

11.10.2013    12458    26    andrey1312    6       

Внешняя печатная форма Счет на оплату покупателю для БП 3.0 24

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 БП3.0 Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешняя печатная форма Счета на оплату покупателю. Создана на основе печатной формы из типовой конфигурации Бухгалтерия предприятия 3.0.

1 стартмани

08.09.2013    41963    643    RespectSoft    24       

Печать на принтер чеков для УТ 3.0 (для Украины) при помощи доработки эмулятора ФР (также должно подойти для УТ 11) 47

Отчеты и формы Системный администратор Программист Нет файла v8 УТ11 Windows Розничная торговля Абонемент ($m) Печатные формы документов ККМ Фискальный регистратор

И вот перешла торговля на новый интерфейс (не Такси, а просто на управляемые формы). Многие торговые организации хотят работать не с фискальными регистратором, а с обычным POS-принтером или принтером чеков (в простонародье - кухонником). Но не все так гладко, как раньше. Простым добавлением внешней обработки уже не решить вопрос. Надо дорабатывать. За основу был взят типовой драйвер "1С: Драйвер фискального регистратора (эмулятор)"

1 стартмани

06.08.2013    54349    170    karapuzzzz    45       

УТ Внешняя печатная форма "Чек ККМ" для документа "Реализация товаров и услуг" 8

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Россия Windows Розничная торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма для документа "Реализация товаров и услуг", печатающая чек на ККМ.

1 стартмани

09.04.2013    17707    157    NILS2009    9       

Расходная накладная + Вес + Объем. Полная 7

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия БУ Windows Оптовая торговля Абонемент ($m) Печатные формы документов

Расходная накладная с колонками вес и объем с сохранением всех дополнительных колонок.

1 стартмани

15.03.2013    9925    104    fenimor    8