Протокол действий с документом. Внешняя печатная форма

Администрирование - Журнал регистрации

журнал регистрации

5
В больших коллективах пользователям (бухгалтерам) нужно быстро узнать, кто, когда и какие действия производил с документом. Представляю универсальную внешнюю печатную форму к любой конфигурации на 1С 8.3 (уф). Обработка сама регистрируется ко всем документам конфигурации. Обработка делает отбор по журналу регистраций и выводит краткую печатную форму.

Внешняя печатная форма ко всем документам конфигурации. Обработка подключается к типовым конфигурация стандартным способом через "Дополнительные отчеты и обработки". Проверено на типовых конфигурациях на платформе 1С 8.3 (уф) релизы 8.3.10, 8.3.11

Также можно сделать доработку конфигурации для регистрации событий с документом - "Пометка удаления", "Снятие пометки удаления". Нужно создать подписку на событие - "ПередЗаписью" для всех документов и поместить процедуру:

Процедура ДокументыВсеПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
    
    Если Источник = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Если Отказ Тогда
        Возврат;
    КонецЕсли;    
    
    Если Источник.Ссылка.ПометкаУдаления <> Источник.ЭтотОбъект.ПометкаУдаления Тогда // Изменился статус пометки
        
        Если Источник.Ссылка.ПометкаУдаления Тогда // пометка была - сняли
            // <действия при снятии пометки>
            ТекстСообщения = "Снятие пометки";
        Иначе
            // <действия при установке пометки>
            ТекстСообщения = "Установка пометки";
        КонецЕсли;
        
        ЗаписьЖурналаРегистрации(
        "Данные. Пометка удаления",
        УровеньЖурналаРегистрации.Информация,
        Источник.Метаданные(),
        Источник.Ссылка,
        ТекстСообщения);
    КонецЕсли;
    
КонецПроцедуры

 

5

Скачать файлы

Наименование Файл Версия Размер
Протокол действий с документом. Внешняя печатная форма.
.epf 10,75Kb
02.04.18
11
.epf 1.1 10,75Kb 11 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. DEG156 23 16.05.18 10:37 Сейчас в теме
Некоторые могут заметить почему такой длинный столбец "Комментарий" и он не заполняеться в данной обработке ? Дело в том что в моей базе я отдельно пишу изменения реквизитов документов и справочников и вывожу в этот столбец эти данные.
Оставьте свое сообщение