INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Алексей Тишков | Заместитель начальника отдела ИТ | ПАО "Амурский судостроительный завод"

«Цифровая трансформация процессов судостроительного предприятия на платформе 1С»

В докладе будет рассмотрен пример построения единого информационного пространства на платформе 1С с использованием комплекса конфигураций: - Управление производственным предприятием; - Документооборот КОРП; - Бухгалтерия предприятия с надстройкой "БИТ:Финанс"; Комплекс конфигураций является фундаментом для внедрения процессного подхода к управлению, системы на платформе 1С используются не только в качестве "учетных", а в качестве среды выполнения формализованных процессов. Таким образом, уровень зрелости и функциональности комплекса перешел от "учетного" к "среде жизненного цикла процессов". Реализованы, в том числе, сквозные процессы между конфигурациями и интегрированными внешними системами (концепция "большие процессы", или "большая единая 1С"), сквозной сбор данных стратегического BI-уровня (контрольные отчеты директора). Используемые технологии: - неквалифицированная цифровая подпись согласно 63-ФЗ (используется для согласования договоров, служебок, исходящих писем, приказов, распоряжений и многих других внутренних документов); - интеграция с внешними системами посредством web-сервисов (интеграция с системой СКУД и управление блокировкой прохода на предприятие из кадровой системы); - интеграция между конфигурациями 1С посредством COM-объектов и web-сервисов; - внешние компоненты; - объекты метаданных Бизнес-процессы и Задачи; На сквозном примере будет рассмотрен общий принцип цифровой трансформации отдельного процесса, выполнение следующего комплекса преобразований: 1. Определение возможного уровня цифровизации, возможности реализации в какой-либо информационной системе весь жизненный цикл процесса (все ли участники процесса присутствуют в информационной системе, могут присутствовать потенциально); 2. Описание и формализация, моделирование текущего состояния процесса, выявление проблемных зон и функций, связанных с вещественной формой передачи информации (на примере модели в нотации EPC); 3. Моделирование трансформированного состояния процесса, определение среды жизненного цикла цифровой формы процесса (подсистемы), измененных форм первичных документов; 4. Закрепление трансформированной формы процесса в системе менеджмента качества (актуализация или создание нормативной базы); 5. Изменение соответствующей информационной подсистемы (архитектура прикладных объектов, кодирование, тестирование); 6. Внедрение и обучение пользователей (участников процесса), постановка на эксплуатацию. Доклад будет интересен практикам внедрения на крупных промышленных предприятиях.

Исправление ошибки ЗУП 3.1.6.54 в части Отпуска по уходу за ребенком

Программирование - Ошибки в отраслевых решениях

2
Если вы обновились, не прочитав предупреждения "Не обновляйтесь на релиз ЗУП 3.1.6.54. В релизе ЗУП 3.1.6.54 обнаружена ошибка, которая проявляется, если кадровые данные сотрудников введены документом Начальная штатная расстановка."

При установке обновления по сотрудникам, по которым был зарегистрирован Отпуск по уходу за ребенком, начавшийся до начала эксплуатации программы (месяца в документе Начальная штатная расстановка), состояние ошибочно изменяется на Работает и начинает начисляться заработная плата.

Разработчики сообщили, что исправление выйдет в ближайшем релизе.

Ошибка опубликована на сайте 1С, если не ждать релиза 3.1.7, то можно установить прилагаемое расширение конфигурации.

Потом нужно будет перепровести документ "Начальная штатная установка" (возможно, придется открыть соответствующий период для изменения).

2

Скачать файлы

Наименование Файл Версия Размер
Исправление ошибки ЗУП 3.1.6.54 в части Отпуска по уходу за ребенком:
.cfe 9,49Kb
01.06.18
23
.cfe 9,49Kb 23 Скачать

См. также

Комментарии
Сортировка: Древо
3. Wrols 71 04.06.18 10:44 Сейчас в теме
Добрый день!

Почему-то не помогло...
Должны быть изменения в регистре "Данные состояний сотрудников"? Если да, то после подключения расширения и перепроведения Начальной штатной расстановки изменений нет.
В регистре по сотруднику 2 записи - "Отпуск по уходу за ребенком" и "Работа".

При заполнении табеля - сотруднику ставится "Явка"...
4. Evmil 15 04.06.18 16:11 Сейчас в теме
Добрый день. Конфигуратором можно проверить, запускается ли функция в расширении http://SSMaker.ru/5114611a/ при перепроведении начальной штатной установки.
5. bocharovki 6 05.06.18 08:00 Сейчас в теме
Я применил немного другой вариант в ДанныеДляПроведения() у документа Начальная штатная расстановка.
В этом случае просто состояние на момент начальной штатной расставноки продолжается далее.

Запрос.Текст =
		"ВЫБРАТЬ
		|	Сотрудники.Сотрудник КАК Сотрудник,
		
		// Начало вставки
		//|	ЗНАЧЕНИЕ(Перечисление.СостоянияСотрудника.Работа) КАК Состояние,
		|	ЕСТЬNULL(СостоянияСотрудников.Состояние,ЗНАЧЕНИЕ(Перечисление.СостоянияСотрудника.Работа)) КАК Состояние,
		// Конец вставки		
		
		|	Сотрудники.ДатаСобытия КАК Начало,
		|	ДАТАВРЕМЯ(1, 1, 1) КАК Окончание,
		|	НЕОПРЕДЕЛЕНО КАК ВидВремени
		|ИЗ
		|	ВТСотрудники КАК Сотрудники
		
		// Начало вставки
		|  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостоянияСотрудников КАК СостоянияСотрудников
		|		ПО Сотрудники.Сотрудник = СостоянияСотрудников.Сотрудник
		|			И СостоянияСотрудников.Период <= Сотрудники.ДатаСобытия
		|			И (СостоянияСотрудников.ДействуетДо >= Сотрудники.ДатаСобытия
		|				ИЛИ СостоянияСотрудников.ДействуетДо = ДАТАВРЕМЯ(1, 1, 1)) 
		|
		// Конец вставки		
		
		|ГДЕ
		|	Сотрудники.ВидЗанятости <> ЗНАЧЕНИЕ(Перечисление.ВидыЗанятости.Подработка)";
	
	// Данные состояний
	ДанныеСостояний = Запрос.Выполнить().Выгрузить();
	ДанныеДляПроведения.Вставить("ДанныеСостояний", ДанныеСостояний);
Показать
6. shriogonyok 08.06.18 10:20 Сейчас в теме
//Еще вариант фикса
//ОбщийМодуль ЗарплатаКадры
//Нужно учесть что Отпуск по уходу за ребенком нужно перепровести 2 раза сначала сняв галку "Не начислять зарплату и не выплачивать аванс во время отпуска" а затем снова установив

Функция ВыборкаРассчитанныеПериодыСостояний(ЗначенияИзмерений, ОписаниеРегистра) Экспорт
	
	МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
	СоздатьВТПоТаблицеЗначений(МенеджерВременныхТаблиц, ЗначенияИзмерений, "ВТЗначенияИзмеренийГода"); 
	Запрос = ЗапросВТПервичныеДанные(МенеджерВременныхТаблиц, ОписаниеРегистра, ЗначенияИзмерений);
	Результат = Запрос.Выполнить();
	ОткрытыеИнтервалы = Результат.Выгрузить();
	// {Агроресурсы ogn 2018.06.08 a.ognev@agrores.ru
	//фиксим баг: ошибка сотруднице ставится что она работает хотя она в отпуске по уходу
	ЕстьНачальная = Ложь;
	ЕстьОтпускПоУходуЗаРебенком = Ложь;
	Для Каждого СтрокаОткрытых Из ОткрытыеИнтервалы Цикл
		Если ТипЗнч(СтрокаОткрытых.Регистратор) = Тип("ДокументСсылка.НачальнаяШтатнаяРасстановка") Тогда
			ЕстьНачальная = Истина;
			СтрокаНачальной = СтрокаОткрытых;
			ДатаНачальной = СтрокаОткрытых.Регистратор.Дата;
			НачШтРастановка = СтрокаОткрытых.Регистратор;
		КонецЕсли; 
		Если ТипЗнч(СтрокаОткрытых.Регистратор) = Тип("ДокументСсылка.ОтпускПоУходуЗаРебенком") Тогда
			ЕстьОтпускПоУходуЗаРебенком = Истина;
			ДатаОтпуска = СтрокаОткрытых.Регистратор.Дата;
		КонецЕсли; 
	КонецЦикла; 
	Если ЕстьНачальная И ЕстьОтпускПоУходуЗаРебенком И ДатаНачальной > ДатаОтпуска Тогда
		Запрос.Текст = "Выбрать * Поместить ВТПервичныеДанныеВрем Из ВТПервичныеДанные КАК ПервичныеДанные ГДЕ ПервичныеДанные.Регистратор <> &НачШтРасстановка;
		|Уничтожить ВТПервичныеДанные; 
		|Выбрать * Поместить ВТПервичныеДанные ИЗ ВТПервичныеДанныеВрем;";
		Запрос.УстановитьПараметр("НачШтРасстановка", НачШтРастановка);
		Запрос.Выполнить();
		
		ОткрытыеИнтервалы.Удалить(СтрокаНачальной);
	КонецЕсли; 
	// }Агроресурсы ogn 2018.06.08  
	СоздатьВТЗакрытыеИнтервалы(ОткрытыеИнтервалы, МенеджерВременныхТаблиц, ОписаниеРегистра);
	
	Запрос = ЗапросРассчитанныеДаты(МенеджерВременныхТаблиц, ОписаниеРегистра);
	Результат = Запрос.Выполнить();
		
	Возврат Результат.Выбрать();
	
КонецФункции
Показать
7. salbey 57 09.06.18 11:05 Сейчас в теме
(6)
//Нужно учесть что Отпуск по уходу за ребенком нужно перепровести 2 раза сначала сняв галку "Не начислять зарплату и не выплачивать аванс во время отпуска" а затем снова установив
Внес данные изменения в расширение, все заработало должным образом. Спасибо, дружище... лови плюс.
8. droplet 71 20.06.18 15:24 Сейчас в теме
(6)
Этот способ исправляет ситуацию в РС.Состояния сотрудников, НО он очищает РС.Периоды стажа ПФР.
10. droplet 71 20.06.18 16:24 Сейчас в теме
(8) К тому же если после этого исправления такая сотрудница увольняется, то Состояние сотрудника возвращается к ранее исправленному (Работа)
9. geka-geka 20.06.18 15:49 Сейчас в теме
(0) Попросил 1С в следующий раз выкладывать исправления критических ошибок в виде расширения. Ответили, что в следующий раз так и сделают.
11. boevik 2 02.07.18 17:45 Сейчас в теме
а в 1С почему то ошибка не зарегистрирована
12. Evmil 15 02.07.18 22:26 Сейчас в теме
(11) Ошибка уже исправлена в 3.1.7.
Оставьте свое сообщение