Регламентированный отчет Статистика Форма 2 цены приобретения для УПП

Публикация № 889966

Учет и отчетность - Статистические

Обработка статистика УПП П-2

В редакции № 390 от 05.08.2016

Протестировано на УПП 1.3.105 и выше релизах

 

Для реализации автозаполнения потребуется добавление нового регистра сведений в конфигурацию.

1) Название РС: wНастройкаЗаполненияСтатистикиФорма2ЦеныПриобр

2)Измерения: Номенклатура - тип справочникссылка.Номенклатура
3) Ресурсы:
НаименованиеТовара  строка -500
ЕдиницаИзмерения - строка -200
КодНаименованияТовара - строка -100
Коэффициент  -  число 10.3

4) Копируете макет "Списки2017Кв1" из очета в Регистр сведений.5)Добавляете форму записи со всем измерениями и ресурсами.
6)Далее устанавливаете только просмотр для ресурса "КодНаименованияТовара"
7) Для ресурсов "НаименованиеТовара" и "ЕдиницаИзмерения" в форме записи добавляете события "Начало выбора"
8) для формы записи добавляете событие "При открытии"
9) КОД модуля формы записи:

Перем КоллекцияСписковВыбора;
Процедура ПриОткрытии()
    СформироватьСпискиВыбора();

КонецПроцедуры

Процедура СформироватьСпискиВыбора()
    
    МакетСоставаПоказателей =  РегистрыСведений.wНастройкаЗаполненияСтатистикиФорма2ЦеныПриобр.ПолучитьМакет("Списки2017Кв1");
    
         КоллекцияСписковВыбора = Новый Соответствие;
    Для Каждого Область Из МакетСоставаПоказателей.Области Цикл
        Если Область.ТипОбласти = ТипОбластиЯчеекТабличногоДокумента.Строки Тогда
            ВерхОбласти = Область.Верх;
            НизОбласти = Область.Низ;
            ТаблСписка = Новый ТаблицаЗначений;
            ТаблСписка.Колонки.Добавить("Код",,, МакетСоставаПоказателей.Область(ВерхОбласти, 1, ВерхОбласти, 1).ШиринаКолонки);
            ТаблСписка.Колонки.Добавить("Название",,, МакетСоставаПоказателей.Область(ВерхОбласти, 2, ВерхОбласти, 2).ШиринаКолонки);
            Для НомСтр = ВерхОбласти По НизОбласти Цикл
                КодПоказателя = СокрП(МакетСоставаПоказателей.Область(НомСтр, 1).Текст);
                Если КодПоказателя <> "###" Тогда
                    НовСтрока = ТаблСписка.Добавить();
                    НовСтрока.Код = КодПоказателя;
                    НовСтрока.Название = СокрП(МакетСоставаПоказателей.Область(НомСтр, 2).Текст);
                КонецЕсли;
            КонецЦикла;
            КоллекцияСписковВыбора.Вставить(Область.Имя, ТаблСписка);
        КонецЕсли;
    КонецЦикла;

КонецПроцедуры

Процедура НаименованиеТовараНачалоВыбора(Элемент, СтандартнаяОбработка)
        РезультатВыбора = КоллекцияСписковВыбора["СправочникТоваров"].ВыбратьСтроку("Выбрать товар");
         Если РезультатВыбора = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
Элемент.значение = РезультатВыбора.Название;
КодНаименованияТовара= РезультатВыбора.Код;
КонецПроцедуры

Процедура ЕдиницаИзмеренияНачалоВыбора(Элемент, СтандартнаяОбработка)
    РезультатВыбора = КоллекцияСписковВыбора["СправочникЕдиницИзмерения"].ВыбратьСтроку("Выбрать единицу измерения");
         Если РезультатВыбора = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
Элемент.значение = РезультатВыбора.Название;
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Регламентированный отчет Статистика форма 2 цены приобретения для УПП:

.erf 284,35Kb
21.08.18
1
.erf 284,35Kb 1 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Заполнение категорий статистического учета для формы ЗП-Образование

Зарплата Статистические v8::Запросы ЗКГУ3.0 Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Обработка для ЗГУ, заполняет категории статистического учета для формы ЗП-Образование.

1 стартмани

21.08.2020    1129    4    uchenick    0    

Заполнение и выгрузка статистической формы в формате xml на сайт ФТС

Обмен через XML Внешнеэкономическая деятельность (ВЭД) Статистики Статистические Внешнеэкономическая деятельность (ВЭД) v8 КА1 УПП1 Россия БУ Абонемент ($m)

После не совсем приятных писем от Федеральной Таможенной Службы наша бухгалтерия наконец-то засуетилась и попросила написать обработку для автоматизации заполнения формы на сайте ФТС РФ (https://edata.customs.ru/Stat/) информацией о товарах, реализуемых на экспорт в рамках Таможенного Союза.

1 стартмани

30.03.2018    9846    38    Азверин    15    

Статистическое декларирование участника ВЭД. Загрузка формы статистики из EXCEL-файла.

Загрузка и выгрузка в Excel Статистические Внешнеэкономическая деятельность (ВЭД) Оптовая торговля Производство готовой продукции (работ, услуг) Внешнеэкономическая деятельность (ВЭД) Оптовая торговля Производство готовой продукции (работ, услуг) v8 УПП1 Россия БУ Абонемент ($m)

Обработка служит для выгрузки из 1С:УПП (тестировалось в ней) в файлы эксель данных по проведенным документам "Реализация товаров и услуг" со ставкой НДС = 0%. Формируются два файла: файл с товарами StaticForm.xlsx и файл с перечнем накладных StaticForm_sfDocs.xlsx для последующей загрузки в форму статистики на сайте ФЕДЕРАЛЬНОЙ ТАМОЖЕННОЙ СЛУЖБЫ. Курсы валют берутся на дату документа реализации из регистра базы 1С. Формирование файлов происходит согласно документу: ПОСТАНОВЛЕНИЕ от 29 января 2011 г. N 40 ОБ ОРГАНИЗАЦИИ ВЕДЕНИЯ СТАТИСТИКИ ВЗАИМНОЙ ТОРГОВЛИ РОССИЙСКОЙ ФЕДЕРАЦИИ С ГОСУДАРСТВАМИ - ЧЛЕНАМИ ТАМОЖЕННОГО СОЮЗА В РАМКАХ ЕВРАЗЭС.

2 стартмани

15.09.2015    10087    28    greenlist    7    

Временной график размеров файлов каталога (например, можно смотреть рост архивов)

Сервисные утилиты Статистические v8 1cv8.cf Абонемент ($m)

Рисуется график роста размера файлов, размер файлов + правдоподобная временная шкала + плотность файлов по времени обычный клиент + тонкий клиент + web-клиент (если победите расширение работы с файлами и ActiveX в браузере)

1 стартмани

29.04.2014    7049    5    and_sk    1    

Обработка выгрузки данных по Алкоголю приложение №12 в ДекларантАлко

Внешние источники данных Статистические Регламентированная отчетность v8 1cv8.cf Россия БУ Акцизы Абонемент ($m)

Обработка выгрузки данных по Алкоголю приложение №12 в ДекларантАлко версия 4.20 по контрагенту в целом для Конфигураций КА,БУ,УПП

1 стартмани

27.09.2012    8462    2    dk666dk    3    

Подсчет количества документов в базе

Статистические Статистика базы данных v8 БП2.0 Россия Абонемент ($m)

Подсчет количества документов, введенных пользователями

1 стартмани

26.06.2012    9610    72    Claus32    12    

Статистическая форма учета перемещения товаров в рамках Таможенного союза от 01.07.2011г

Обмен через XML Регламентированная отчетность Статистические Учет ТМЦ Учет ТМЦ v8 БП2.0 1С7:Бух Россия БУ НУ Абонемент ($m)

Статистическая форма учета перемещения товаров в рамках Таможенного союза от 01.07.2011г - ОБНОВЛЕНО. Постановление Правительства РФ от 29 января 2011 года N 40 «Об организации ведения статистики взаимной торговли товарами Российской Федерации с государствами - членами Таможенного союза в рамках ЕврАзЭС»

1 стартмани

28.03.2011    22131    10    gvinas    13