Макеты печатных форм в руках пользователей (обычные формы)

Публикация № 934770

Разработка - Печать - Универсальные печатные формы

шаблон макет печатная форма

15
Как частично избавить себя от низкопрофильного труда по правке печатных форм. Для конфигураций на основе БСП, конечно, не актуально, но для нетиповых вполне. Ну и как в помощь начинающим. У меня реализовано для печати различных "согласие на обработку персональных данных","согласие на медицинские вмешательства", различных анкет. Удобно для печатных форм, которые часто по тем или иным причинам меняются. Чтоб не дергать программиста, пусть пользователи рисуют макеты самостоятельно.

Опишу, как реализовано у меня.

1. Создаем справочник примерно следующего содержания:

реквизит ХранилищеШаблон имеет тип ХранилищеЗначений, в него будем сохранять макет, созданный пользователями.

2. Форма справочника

на форме я добавил две странички и на первой разместил элемент "ТабличныйДокумент", на второй вывели реквизиты по настройке печати.

3. Модуль формы справочника:

процедура при открытии элемента справочника будет получать из хранилища значений макет табличного документа и вставлять в элемент формы, а при записи сохранять макет  в реквизит элемента справочника.


Процедура ПередЗаписью(Отказ)
	ТабДокумент=НОвый ТабличныйДокумент;
	ТабДокумент.Вывести(ЭтаФОрма.ЭлементыФормы.тхтШаблон);
	ХранилищеШаблон=НОвый ХранилищеЗначения(ТабДокумент);
	
КонецПроцедуры

Процедура ПриОткрытии()
	Попытка
	ТабДок=ХранилищеШаблон.Получить();
	Если Не ЭтоНовый() Тогда
		ЭтаФорма.ЭлементыФормы.тхтШаблон.Вывести(ТабДок);
	ИНаче
		ПолеСлева=5;
		ПолеСправа=5;
		ПолеСверху=5;
		ПолеСнизу=5;
		АвтоМасштаб=Истина;   
		Ориентация=Перечисления.ОриентацияСтраницы.Портрет;
	КонецЕсли;
	ИСключение
	сообщить(ОписаниеОшибки());
	КонецПопытки;
КонецПроцедуры

Процедура ОбновлениеОтображения()
	Автомасштаб=(МасштабПечати=0);
КонецПроцедуры

4. Создаем документ

Для удобства указываем ввод на основании, у меня вводится на основании справочника "пациенты"

В табличной части документа добавим реквизит с типом справочника макета печатных форм

 

5. Модуль формы документа

По кнопке печать происходит перебор табличной части документа, для каждого элемента табличной части создается свой табличный документ, в который выводится макет с замененными параметрами. Заменяемые параметры в макете имеют вид [ИмяПараметра].


Процедура ОсновныеДействияФормыПечать(Кнопка)
	ДЛя каждого Стр Из СпискиФорм Цикл  						//Переберем ТЧ документа
		ТабДокумент=Новый ТабличныйДОкумент;
		Макет=Стр.СсылкаНаМакет.ХранилищеШаблон.Получить();   	//получим макет каждой строки
		ПреобразоватьПараметры(Макет);							//заменим параметры реальными данными	
		ТабДокумент.Вывести(Макет);
		ПрименитьНастройкиПечати(Стр.СсылкаНаМакет,ТабДокумент);//настройка печати
		ТабДокумент.Показать();
	КонецЦикла;
КонецПроцедуры
Процедура ПрименитьНастройкиПечати(СсылкаСпр,ТабДокумент)
		ТаБДокумент.МасштабПечати=СсылкаСпр.МасштабПечати;
		ТаБДокумент.АвтоМасштаб=СсылкаСпр.АвтоМасштаб;
		ТаБДокумент.ПолеСверху=СсылкаСпр.ПолеСверху;
		ТаБДокумент.ПолеСлева=СсылкаСпр.ПолеСлева;
		ТаБДокумент.ПолеСнизу=СсылкаСпр.ПолеСнизу;
		ТаБДокумент.ПолеСправа=СсылкаСпр.ПолеСправа;
		ТаБДокумент.ОриентацияСтраницы=?(СсылкаСпр.Ориентация=Перечисления.ОриентацияСтраницы.Ландшавт,ОриентацияСтраницы.Ландшафт,ОриентацияСтраницы.Портрет);
КонецПроцедуры

Процедура ПреобразоватьПараметры(Макет)
	Соответствия=ПодготовимСоответствие(); 						//Заполним соответствие с параметрами замены
		ДЛя каждого СтрСоот Из Соответствия ЦИкл
			ЯчейкаТекст=Макет.НАйтиТекст(СтрСоот.Ключ);
			Если ЯчейкаТекст<>Неопределено ТОгда 
				ЯчейкаТекст.Текст=СтрЗАменить(ЯчейкаТекст.Текст,СтрСоот.Ключ,СтрСоот.Значение);
			КонецЕсли;
		КонецЦИкла;
КонецПроцедуры
Функция ПодготовимСоответствие()
		Соответствие=НОвый Соответствие();
		Соответствие.Вставить("[ФИОПолностью]",""+Пациент.Фамилия+" "+Пациент.Имя+" "+Пациент.Отчество);
		Соответствие.Вставить("[ДатаРождения]",ФОРмат(ПАциент.ДатаРождения,"ДФ=dd.MM.yyyy"));
		СтруктураПаспорта=ПолучимПАспорт();
		Соответствие.Вставить("[ПаспортНомер]",СтруктураПаспорта.НомерПаспорт);
		Соответствие.Вставить("[ПаспортСерия]",СтруктураПаспорта.СерияПаспорт);
		Соответствие.Вставить("[ПаспортКемВыдан]",СтруктураПаспорта.КемВыданПаспорт);
		Соответствие.Вставить("[ПаспортДатаВыдачи]",СтруктураПаспорта.ДатаВыдачиПаспорт);
		Соответствие.Вставить("[ПаспортПредставление]",СтруктураПаспорта.ПредставлениеПаспорт);
		Соответствие.Вставить("[Адрес]",киПолучитьПредставлениеКИ(Пациент,Справочники.ВидыКонтактнойИнформации.АдресФактический,ложь) );
		ФИОКратко=СтрЗаменить(Соответствие.Получить("[ФИОПолностью]")," ",Символы.ПС);
		Если СтрЧислоСтрок(ФИОКратко)>2 ТОгда
			ФиоКратко=СтрПолучитьСтроку(ФИоКРатко,1)+" "+ЛЕв(СтрПолучитьСтроку(ФИоКРатко,2),1)+"."+ЛЕв(СтрПолучитьСтроку(ФИоКРатко,3),1)+"."
		КонецЕсли;
		Соответствие.Вставить("[ФИОКратко]",ФИОКРатко );
		
		ВОзврат Соответствие;
	КонецФункции
	
	ФУнкция ПолучимПАспорт()
		Структура=Новый СТруктура;
		Структура.Вставить("СерияПаспорт","");
		Структура.Вставить("НомерПаспорт","");
		Структура.Вставить("КемВыданПаспорт","");
		Структура.Вставить("ДатаВыдачиПаспорт","");
		Структура.Вставить("ПредставлениеПаспорт","");
		ЗАпрос=НОвый Запрос("ВЫБРАТЬ ПЕРВЫЕ 1
		                    |	ПодтверждающиеДокументы.Серия,
		                    |	ПодтверждающиеДокументы.Номер,
		                    |	ПодтверждающиеДокументы.ДатаВыдачи,
		                    |	ПодтверждающиеДокументы.КемВыдан,
		                    |	ПодтверждающиеДокументы.Представление
		                    |ИЗ
		                    |	Справочник.ПодтверждающиеДокументы КАК ПодтверждающиеДокументы
		                    |ГДЕ
		                    |	ПодтверждающиеДокументы.Владелец = &Владелец
		                    |	И ПодтверждающиеДокументы.ВидПодтверждающегоДокумента = ЗНАЧЕНИЕ(Справочник.ВидыПОдтверждающихДокументов.Паспорт)
		                    |	И ПодтверждающиеДокументы.Текущий
		                    |	И НЕ ПодтверждающиеДокументы.ПометкаУдаления");
		Запрос.УстановитьПараметр("Владелец",Пациент);
		Результат=Запрос.Выполнить().Выбрать();
		Пока РЕзультат.Следующий() ЦИкл
			Структура.Вставить("СерияПаспорт",Результат.Серия);
			Структура.Вставить("НомерПаспорт",Результат.Номер);
			Структура.Вставить("КемВыданПаспорт",Результат.КемВыдан);
			Структура.Вставить("ДатаВыдачиПаспорт",Формат(Результат.ДатаВыдачи,"ДФ=dd.MM.yyyy"));
			Структура.Вставить("ПредставлениеПаспорт",Результат.Представление);
		КонецЦИкла;
	Возврат Структура;		
КОнецФункции

6. Как это выглядит у пользователя:

 

15

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Stim213 373 07.11.18 09:56 Сейчас в теме
Зачем так мучать пользователя в табличном документе? Научите его создавать поля в Ворде и заполняйте ворд при печати
2. fromlion 62 07.11.18 10:11 Сейчас в теме
(1) если брать нашу ситуацию, то работаем в терминальном режиме и ставить офисы на сервер нельзя. Как минимум будут затраты на приобретение лицензий.
jONES1979; +1 Ответить
3. jONES1979 09.11.18 08:51 Сейчас в теме
Вот спасибо, всё расписано! Мне скоро пригодится!
Оставьте свое сообщение

См. также

[СКД] Программное создание схемы компоновки данных 259

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    3244    John_d    14       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

30 задач. Странных и не очень 117

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    7879    YPermitin    71       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Агрегатные функции СКД, о которых мало кто знает 391

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    20396    ids79    45       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Три костыля. Сказ про фокусы в коде 130

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    12817    YPermitin    69       

Отслеживание выполнения фонового задания 154

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    16040    ids79    16       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 294

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    25768    ids79    34       

Фоновое выполнение кода в 1С - это просто 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    16078    avalakh    21       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 153

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    22002    ids79    8       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 160

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    16862    ids79    27       

Регистры сведений. За кулисами 134

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    13215    YPermitin    12       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

"Меньше копипаста!", или как Вася универсальную процедуру писал 185

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    11388    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 226

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    28325    ids79    17       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 180

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    15625    dmurk    144       

Регистры накопления. Структура хранения в базе данных 180

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    24620    YPermitin    27       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Выполнение внешней обработки в фоновом задании 153

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    15661    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    8748    m-rv    2       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    11694    m-rv    16       

О расширениях замолвите слово... 200

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    21211    ellavs    125       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 206

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    17266    ellavs    83       

Трюки с внешними источниками данных 169

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    18823    YPermitin    53       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.