Пропал фокус (активность) элемента формы, ошибка при переходе на платформу 1С:Предприятие 8.3 (8.3.12.1790)

Программирование - Ошибки в отраслевых решениях

фокус активность 8.3.12

3
После перехода на платформу 8.3.12.1790 обнаружилась проблема. При подборе товара в форме подбора номенклатуры на поле ввода количество пропал фокус (активность).

После перехода на платформу 8.3.12.1790 обнаружилась проблема.

При подборе товара в форме подбора номенклатуры на поле ввода количество пропал фокус (активность).

Попробовал так: Добавил событие "ПриОткрытии" написал следующие - "ТекущийЭлемент = Элементы.КоличествоУпаковок;" не помогло;

Поискал в сети упоминание о проблеме, но что то ничего.

В итоге решил проблему так, добавил следующий код в событие при открытии формы.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    Попытка
        wsh = Новый COMОбъект("WSCript.Shell");
        wsh.sendkeys("{TAB}"); 
        wsh.sendkeys("{TAB}"); 
        wsh.sendkeys("{TAB}");
    Исключение
    КонецПопытки;

    ТекущийЭлемент = Элементы.КоличествоУпаковок;
    
КонецПроцедуры

Что делает код:

При открытии программно нажимается 3 раза кнопка "TAB" (переход по элементам) которая и активирует нужное нам поле.

Ну и на всякий случай добавил стандартный код, который надеюсь заработает при следующем обновлении платформы.

3

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. kumi2012 1 09.01.19 20:15 Сейчас в теме
Баг релиза платформы. Тоже самое.
2. ifal 251 09.01.19 21:00 Сейчас в теме
Тогда уж ПодключитьОбработчикОжидания("процедура", 0.3, истина), а в процедуре ТекущийЭлемент = Элементы.КоличествоУпаковок - так универсальней
5. rhtr 65 09.01.19 22:15 Сейчас в теме
(2) Нет, так не работает.
В отладчики ТекущийЭлемент равен нужному элементу, но фокуса так и нет.

Ниже код, который Вы рекомендовали, не работает.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	//	Попытка
	//        wsh = Новый COMОбъект("WSCript.Shell");
	//        wsh.sendkeys("{TAB}"); 
	//        wsh.sendkeys("{TAB}"); 
	//        wsh.sendkeys("{TAB}");
	//   Исключение
	//   КонецПопытки;
	
	//   ТекущийЭлемент = Элементы.КоличествоУпаковок;
	
	ПодключитьОбработчикОжидания("ПроцедураФокус", 0.3, истина);
	
КонецПроцедуры

&НаКлиенте
Процедура ПроцедураФокус()
	ТекущийЭлемент = Элементы.КоличествоУпаковок
КонецПроцедуры
Показать
6. ifal 251 09.01.19 22:53 Сейчас в теме
а если переключится на другой элемент, так как изначально установлен нужный, а потом на КоличествоУпаковок и может 0.5 сек поставить.
7. rhtr 65 10.01.19 07:42 Сейчас в теме
3. kumi2012 1 09.01.19 21:08 Сейчас в теме
4. rhtr 65 09.01.19 22:04 Сейчас в теме
(3) Может я чего то не так делаю, но чистка кэша не помогла.
8. kumi2012 1 10.01.19 10:41 Сейчас в теме
(4) Удалите полностью папку 1С из AppData\Local
9. rhtr 65 10.01.19 14:22 Сейчас в теме
10. kumi2012 1 10.01.19 14:29 Сейчас в теме
(9) Последнее, что мы используем - попробуйте создать нового пользователя 1С и запуститься с этого же рабочего места.
11. GOshaSaveiko 27 10.01.19 15:26 Сейчас в теме
Привет, итого как-нибудь проблема решилась?
Баг подтвержден 1С, или новая "очень удобная" методика? Может 1С так хочет стимулировать пользование своим полнотекстовым поиском?
12. GOshaSaveiko 27 10.01.19 18:44 Сейчас в теме
Итак:
Подтверждена проблема и на 8.3.12.1616
НО
8.3.12.1616 - уже починили. Это была ошибка платформы.
13. rhtr 65 10.01.19 19:25 Сейчас в теме
(12) Спасибо. Попробую обновить платформу.
15. ildary 11.01.19 08:19 Сейчас в теме
Не могли бы Вы внести ясность в номер версии, подверженный ошибке? В шапке написано, что ошибка присутствует в версии 8.3.12.1790. А в (12) сказано, что в 8.3.12.1616 - уже починили? Всё-таки в какой версии ошибки нет?
16. GOshaSaveiko 27 11.01.19 09:51 Сейчас в теме
(15) Ошибся. Сейчас: 8.3.13.1644
Но у меня появилась конфигурация, которая крашится при открытии журнала. Так что испытывайте тестово
17. ildary 11.01.19 09:56 Сейчас в теме
(16) то есть ошибка исправлена в свежей 8.3.13, но в последней 8.3.12 она существует?
19. GOshaSaveiko 27 11.01.19 11:05 Сейчас в теме
(17) Я так понимаю, что сегодня 8.3.12.1790 - крайний релиз 12й платформы и там ошибка присутствует. Дальше уже 8.3.13.1644 - ошибки нет
20. GOshaSaveiko 27 11.01.19 11:10 Сейчас в теме
(16)
Ошибся. Сейчас: 8.3.13.1644
Но у меня появилась конфигурация, которая крашится при открытии журнала

немолодая конфигурация на обычных формах крашится на
ТипЗнч(Журнал);
Где Журнал это ЖурналДокументовСписок.<Имя журнала документов>
18. rhtr 65 11.01.19 10:21 Сейчас в теме
(15) в 8.3.12.1790 ошибка пока есть, сегодня обновил платформу, результат тот же, а версии 8.3.12.1616 видимо починили как пишет 12. GOshaSaveiko
14. rhtr 65 10.01.19 19:25 Сейчас в теме
Но и решение пока оставлю здесь, может кому пригодится.
Оставьте свое сообщение