Полная проверка учета НДС (БП 3.0, БП КОРП 3.0)

Публикация № 982903

Отчеты - Бухгалтерские

отчет НДС раздельный учет проверка сдача книга покупок книга продаж ошибки регистры декларация

8
Набор отчетов для полноценной проверки правильности заполнения документов и регистров НДС, в том числе для режима раздельного учета НДС. Содержит 14 различных проверок.

Покажите эту разработку своему главному бухгалтеру. С большой вероятностью он давно ищет нечто подобное, так как подготовка и сдача НДС в организации со сложным учетом - большая головная боль. Эти отчеты покажут все и сразу, сократят множество часов выверки и поиска.

Открывается как внешняя обработка.

Отчет-расшифровку ("Наличие счет-фактур по реализации.erf") добавить во дополнительные отчеты и обработки базы.

Содержит следующие отчеты (проверки):

1. Наличие счетов – фактур по документам реализации

Для всех документов реализации, в которых ставка НДС не равна «БЕЗ НДС»  по структуре подчиненности необходимо проверить наличие проведенного счета – фактуры. Если счет-фактура не зарегистрирован, то выводить документ реализации в список ошибок.

2. Наличие счетов – фактур по документам поступления

Для всех документов поступления, в которых ставка НДС не равна «БЕЗ НДС»  по структуре подчиненности необходимо проверить наличие проведенного счета – фактуры. Если счет-фактура не зарегистрирован, то выводить документ реализации в список ошибок.

3. Входящая дата документа счет-фактура полученный не должна быть позднее даты регистрации документа в системе и/или более 5 дней  от входящей даты  документа - основания.

А. Сверяются даты счета – фактуры  реквизит  «от» не должен быть позже реквизита «Получен»
Б. Сверяются даты счета – фактуры  и документа основания. Реквизит счета –фактуры «от» должен быть не ранее  реквизита документа основания  входящей даты «от» и не позднее 5  дней от этой даты.

4. Дата счетов – фактур на аванс должна совпадать с датой документа - основания

Сверяются даты  счет-фактуры выданной  с видом счет-фактуры «На аванс»  и документа основания реквизит «от» (системная дата).

5. Системная дата документа основания и системная дата счета – фактуры находятся в разных кварталах

Сверяются системные даты счета –фактуры полученной и ее документа основания. Если даты находятся в разных квартала, то  счета –фактуры выводятся в список предупреждений

6. Наличие помеченных на удаление счетов – фактур по которым есть  записи в РН НДС покупки  и  РН НДС продажи

По документам, которые помечены на удаление проверяется наличие записей в РН НДС покупки  и  РН НДС продажи. Если такие записи присутствуют, то такие документы выводятся в список ошибок

7. Наличие заполненных номеров и дат платежных документов в счетах –фактурах на аванс

Проверяются счета-фактуры выданные с видом счет-фактуры «на аванс». В счетах фактурах проверяется заполненность реквизита  «Платежный документ №  от». Если  реквизит не заполнен, то счет-фактура выводится в список ошибок.

8. Наличие документов со способом учета НДС "Блокируется до подтверждения 0%"

Анализируются обороты/остатки по документам по 19 сч. по способу учета НДС "Блокируется до подтверждения 0%".

9. Соответствие остатков по  РН НДС с авансов и  суммами остатков авансов полученных

Расчетная величина НДС с остатка сумм полученных авансов должна соответствовать остаткам по счету 76.АВ и остаткам в регистре НДС с авансов. Если остатки не совпадают, то документы, по которым найдены расхождения выводятся в список ошибок

10. Проверка отрицательных сумм НДС

Проверяется наличие отрицательных остатков  по счету 19 в регистрах бухгалтерии и РН по НДС. Отрицательные суммы выводятся в список ошибок в разрезе счетов - фактур

11. Проверка отражения НДС не облагаемых операций в РН  необлагаемые НДС операции  и РС Документы по необлагаемым НДС операциям

Проверяется наличие записи в РН  Необлагаемые НДС операции и РС Документы по необлагаемым НДС операциям по документам реализации со ставкой НДС «БЕЗ НДС»

12. Наличие документов со ставкой НДС 0%

Проверяются документы прихода и реализации со ставкой 0%.  Если документы найдены, то они выводятся в список предупреждений

13. Сравнение показателей декларации с ОСВ

Проверяется соответствие строк декларации данным регистров бухгалтерии

14. Налоговый регистр право не применять пункт 4 статьи 170 НК РФ

Для всех документов реализации, в которых ставка НДС не равна «БЕЗ НДС»  по структуре подчиненности необходимо проверить наличие проведенной счет – фактуры. Если счет-фактура не зарегистрирована, то выводить документ реализации в список ошибок. Если счет – фактура зарегистрирована, но не проведена, то выводить документ в список предупреждений.

Готовится большое обновление в которое будут добавлены еще ряд проверок.

Для проверки №13 потребуется подключить обработку в базу как внешнюю.

Тестировалось на БП КОРП 3.0.67.38, а так же на версиях 3.0.64. Скорее всего будет работать и на  более ранних релизах. При необходимости подготовлю версии для конкретного релиза, если текущий вариант выдаст ошибки.

8

Скачать файлы

Наименование Файл Версия Размер
Проверки НДС (БП 3.0, БП КОРП 3.0) v 1.02
.epf 57,11Kb
18.01.19
39
.epf 1.02 57,11Kb 39 Скачать
Отчет-расшифровка для проверок
.erf 32,41Kb
18.01.19
32
.erf 1.0 32,41Kb 32 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Alex_E 2030 18.01.19 13:43 Сейчас в теме
РН НДС с авансов - это где?
Соответствие остатков по  РН НДС с авансов ....
- не могу найти в конфигурации, где посмотреть?
5. Асов 8 18.01.19 16:27 Сейчас в теме
(1) РегистрыНакопления.НДСсАвансов
6. Alex_E 2030 18.01.19 16:29 Сейчас в теме
2. markw 18.01.19 15:21 Сейчас в теме
В модуле формы:
&НаСервере
Процедура ПолучитьСсылкуНаДополнительныйОтчет(ИмяДопОтчета)
	
	  СсылкаНавнешнийОтчет = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяДопОтчета);
	  Если СсылкаНавнешнийОтчет = Неопределено Тогда
		   Сообщить("Что то пошло не так, ссылка на внешний отчет " + ИмяДопОтчета + "не найдена. Обратитесь к администратору");
	  КонецЕсли;
	  
КонецПроцедуры
Показать

СсылкаНавнешнийОтчет = Неопределено может быть только если (СП):
Возвращаемое значение:

Тип: СправочникСсылка.<Имя справочника>; Неопределено.
Ссылка на найденный элемент справочника.
Если не существует ни одного элемента с требуемым наименованием, то будет возвращена пустая ссылка.
Если для справочника наименование не задано (длина = 0) и поиск выполняется по полному соответствию, то будет возвращено Неопределено.

Для данного справочника и вызова - это не так. Т.е. возвращается пустая ссылка на справочник, но это условие не отработано. В итоге валиться уже на строке:
ИмяОбработки = ДополнительныеОтчетыИОбработкиВызовСервера.ПодключитьВнешнююОбработку(ВыполняемаяКоманда.Ссылка);
		Если ВыполняемаяКоманда.ЭтоОтчет Тогда
			ОткрытьФорму("ВнешнийОтчет." + ИмяОбработки + ".Форма", ПараметрыОбработки, Форма);
		Иначе
			ОткрытьФорму("ВнешняяОбработка." + ИмяОбработки + ".Форма", ПараметрыОбработки, Форма);
		КонецЕсли;

В самой публикации, насколько я понял, нет ни одного отчета-расшифровки? Т.е. проверки опубликованы, а отчеты - нет?
3. markw 18.01.19 15:26 Сейчас в теме
Функция ВыполнитьПроверкаПометкаУдалениеПроведение()
В запросе условие:
ГДЕ
| (НЕ СчетФактураПолученныйДокументыОснования.Ссылка.Проведен
| ИЛИ СчетФактураПолученныйДокументыОснования.Ссылка.ПометкаУдаления)
Зачем проверять на пометку удаления? Если он помечен на удаление, то и не проведен? Или были случаи, когда было не так?
4. markw 18.01.19 15:32 Сейчас в теме
&НаКлиенте
Процедура Декорация_надпись_процедура_1Нажатие(Элемент)
	
	ВыполняемаяКоманда = Новый Структура(
		"Ссылка, Представление, 
		|Идентификатор, ВариантЗапуска, ПоказыватьОповещение, 
		|Модификатор, ОбъектыНазначения, ЭтоОтчет, Вид");
	
	ВыполняемаяКоманда.ВариантЗапуска =  ПредопределенноеЗначение("Перечисление.СпособыВызоваДополнительныхОбработок.ОткрытиеФормы");
	ВыполняемаяКоманда.Вид  = ПредопределенноеЗначение("Перечисление.ВидыДополнительныхОтчетовИОбработок.ДополнительныйОтчет");
	ВыполняемаяКоманда.Идентификатор = "ПроверочнаяпроцедураНДСвБП3";
	ВыполняемаяКоманда.Модификатор = "";
	ВыполняемаяКоманда.ОбъектыНазначения = Неопределено;
	ВыполняемаяКоманда.ПоказыватьОповещение = Ложь;
	ВыполняемаяКоманда.Представление = "Наличие счет-фактур по реализации";
	
	ПолучитьСсылкуНаДополнительныйОтчет("Наличие счет-фактур по реализации");
	ВыполняемаяКоманда.Ссылка = СсылкаНавнешнийОтчет;
	
	ВыполняемаяКоманда.ЭтоОтчет = Истина;
	
	// ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьОткрытиеФормыОбработки(ВыполняемаяКоманда, ВладелецФормы, ВыполняемаяКоманда.ОбъектыНазначения);
	ВыполнитьОткрытиеФормыОбработки(ВыполняемаяКоманда, ВладелецФормы, ВыполняемаяКоманда.ОбъектыНазначения);
	
КонецПроцедуры
Показать


Вызывается на любой декорации-расшифровке с захардкоженным ПолучитьСсылкуНаДополнительныйОтчет("Наличие счет-фактур по реализации"); Т.е. расшифровок (отчетов) нет в принципе? Только проверки? Противоречит описанию.
7. Асов 8 18.01.19 16:35 Сейчас в теме
Напишите ваше сообщение
(4) Да, вы правы, мой косяк. Отчеты добавлю в публикацию бесплатно.
12. cartograph 25.04.19 11:54 Сейчас в теме
8. conven 23.01.19 10:40 Сейчас в теме
Не хватает контроля по ГТД
9. esmerdov 27.02.19 12:23 Сейчас в теме
Добрый день, при нажатии на какой-либо пункт выдает ошибку (см. скрин)
Бухгалтерия предприятия, редакция 3.0 (3.0.67.74)
Прикрепленные файлы:
10. esmerdov 27.02.19 12:27 Сейчас в теме
Добрый день, все в порядке, проблема решена )
11. baklanova_in 14.04.19 04:43 Сейчас в теме
Добрый день! Вопрос по отчету №2 - СФ по поступлению. Можно им увидеть ситуацию , когда к одной СФ привязано несколько документов поступления ?
romankoav; +1 Ответить
Оставьте свое сообщение