Возврат рекомендуемых шаблонов и ограничение состава процессов обработки в 1С:Документооборот 2.1.13+

20.01.20

Функциональные - Документооборот и делопроизводство (СЭД)

Как быстро вернуть рекомендуемые шаблоны в помощник отправки начиная с версии 2.1.13.

Начиная с версии 2.1.13 зачем-то убрали рекомендуемые шаблоны. Теперь все в одном списке, и предопределенные, и настроенные для вида документа. Так жить нельзя.

Все три пункта независимы.

  1. Чтобы выделить рекомендуемые шаблоны и вывести их в начало списка помощника отправки, в расширение добавляем процедуру общего модуля ПомощникОтправки
&После("ДобавитьВДеревоОсновныеВариантыСозданияПроцесса")
Процедура рш_ДобавитьВДеревоОсновныеВариантыСозданияПроцесса(Помощник)
	
	// Сдвинем рекомендуемые шаблоны в начало
	Помощник.ДеревоВариантов.Колонки.Добавить("ВыделитьСтроку", Новый ОписаниеТипов("Булево"));
		
	Для каждого элемент из Помощник.РекомендуемыеВариантыСозданияПроцессов	Цикл
		строка = Помощник.ДеревоВариантов.Строки.Найти(элемент.Ключ, "Вариант", Ложь);
		
		Если строка = Неопределено Тогда Продолжить КонецЕсли;
		строка.ВыделитьСтроку = Истина;		
		Помощник.ДеревоВариантов.Строки.Сдвинуть(Строка, -Помощник.ДеревоВариантов.Строки.Индекс(Строка));		
		
	КонецЦикла;
	
КонецПроцедуры

В расширение добавляем процедуру общей формы ПомощникОтправить


&НаСервере
&Перед("ЗаполнитьФормуПоДаннымПомощника")
Процедура рш_ЗаполнитьФормуПоДаннымПомощника(ПомощникНаСервере)
	
	// Выделение строк рекомендуемых шаблонов
	// Колонка дерева ВыделитьСтроку создается в ОбщийМодуль.ПомощникОтправить
	
	// Создаём реквизит формы	
	МассивРеквизитов = Новый Массив;
	МассивРеквизитов.Добавить(Новый РеквизитФормы("ВыделитьСтроку", Новый ОписаниеТипов("Булево"), "ВариантыОтправки"));
	ЭтаФорма.ИзменитьРеквизиты(МассивРеквизитов);	
	
	// УО
	Элемент = УсловноеОформление.Элементы.Добавить();
	
	Поля = Элемент.Поля.Элементы;
	Поля.Добавить().Поле = Новый ПолеКомпоновкиДанных("ВариантыОтправки");
	
	ОтборЭлемента = Элемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
	ОтборЭлемента.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ВариантыОтправки.ВыделитьСтроку");
	ОтборЭлемента.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
	ОтборЭлемента.ПравоеЗначение = Истина;	
	Элемент.Оформление.УстановитьЗначениеПараметра("Шрифт", Новый Шрифт("Arial",12,Истина));
		
КонецПроцедуры


  1. Чтобы убрать из списка все кроме предопределенных и рекомендуемых (т.е. другие варианты), в расширение добавляем процедуру общего модуля ПомощникОтправки
&Вместо("ДобавитьВДеревоОстальныеВариантыОтправки")
Процедура рни_ДобавитьВДеревоОстальныеВариантыОтправки(Помощник)
	// ДРУГИЕ ВАРИАНТЫ недоступны	
КонецПроцедуры
  1. Если нужно ограничить состав возможных процессов обработки документа, в расширение добавляем процедуру общего модуля ПомощникОтправки.

В формировании массива добавляем все нужные шаблоны процессов, которые нужно убрать.

&После("ЗаполнитьДеревоВариантовОтправки")
Процедура рш_ЗаполнитьДеревоВариантовОтправкиПосле(Помощник)
	
	ШаблонЗапроса = "ВЫБРАТЬ
	|	Ссылка КАК Ссылка
	|ИЗ
	|	Справочник.%1 КАК Шаблоны
	|ГДЕ
	|	Ссылка В (&Варианты) %2";  // %2 И Предопределенный
	
	ТекстОбъединения = "
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|";
	
	массив = Новый Массив;		
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныИсполнения", ""));
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныКомплексныхБизнесПроцессов", ""));
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныПоручения", ""));
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныПриглашения", ""));
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныРассмотрения", ""));	
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныРегистрации", ""));
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныСогласования", "И НЕ Предопределенный"));
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныСоставныхБизнесПроцессов", ""));
	массив.Добавить(Новый Структура("Таблица, Предопределенный", "ШаблоныУтверждения", ""));	
		
	Запрос.Текст = "";		
	Для каждого структура из массив Цикл
		Запрос.Текст = ?(ПустаяСтрока(Запрос.Текст), ШаблонЗапроса, Запрос.Текст + ТекстОбъединения + ШаблонЗапроса);
		Запрос.Текст = СтрШаблон(Запрос.Текст, структура.Таблица, структура.Предопределенный);
	КонецЦикла;		
	
	СтрокиДерева = Помощник.ДеревоВариантов.Строки;
	Запрос.УстановитьПараметр("Варианты", СтрокиДерева.ВыгрузитьКолонку("Вариант"));
	Выборка = Запрос.Выполнить().Выбрать();
	
	Пока Выборка.Следующий() Цикл
		СтрокаДерева = СтрокиДерева.Найти(Выборка.Ссылка, "Вариант", Ложь);
		Если СтрокаДерева.ВыделитьСтроку Тогда Продолжить КонецЕсли; // рекомендуемый
		СтрокиДерева.Удалить(СтрокиДерева.Найти(Выборка.Ссылка, "Вариант", Ложь));
	КонецЦикла;
		
	
	
КонецПроцедуры

 

Документооборот КОРП рекомендуемые шаблоны процессы ограничить

См. также

1С:Документооборот - цена на лицензии КОРП, ПРОФ и ДГУ

Документооборот и делопроизводство (СЭД) Типовые Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный оборот документов на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация процессов подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:ДО!

48500 руб.

19.02.2016    107497    106    5    

87

RayCon® Foreign Trade - Документооборот валютного контроля и международных платежей для участников ВЭД

Операции по ВЭД Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Программа предназначена для автоматизации внешнеторговых компаний и обеспечивает документооборот валютного контроля: присвоение Уникального номера контракта (УНК), формирований сведений о валютных операциях (СВО) и справок о подтверждающих документах (СПД), прочих необходимых форм учета и отчетности по валютным операциям согласно действующему валютному законодательству Российской Федерации, документооборот валютных платежей согласно международным стандартам и документооборот купли-продажи валюты, а также выгрузку любых документов 1С в любую систему клиент-банк.

30000 руб.

13.05.2009    67143    3    29    

42

Таймлист (1С:Совещание, Таймлист Лайт)

Документооборот и делопроизводство (СЭД) Конфигурации 1cv8

«Таймлист» – экосистема сервисов («Таймлист Лайт», «1C:Совещание», «Таймлист Recorder»), основанная на искусственном интеллекте Таймлист, который позволяет эффективно работать с легкими поручениями за счет фиксации всех важных идей при расшифровке и последующем формировании автопротокола встречи. Сервисы, в которые интегрирован ИИ, позволяют работать с задачами (поручениями), полученными из автопротокола.

10000 руб.

06.12.2023    1655    0    0    

8

1С:Архив

Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Платные (руб)

"1С:Архив" – это универсальная система, обеспечивающая надежное долговременное хранение документов с гарантией юридической значимости на неограниченный срок. "1С:Архив" разработан на основе нормативно-правовых актов по архивному делу, поддерживает операции хранения документов – от попадания в архив до уничтожения – и не имеет ограничений на объем хранимых данных. "1С:Архив" сопровождается методологической поддержкой в виде организационных документов по хранению, входящих в состав "Комплекта нормативных документов" к "Методике управления документами и совместной работой", разработанной специалистами фирмы "1С". Использование "1С:Архива" позволяет организовать единое хранилище всех бумажных и электронных документов из разных информационных систем, вести архивный учет в соответствии с требованиями Росархива и снизить нагрузку на учетные системы. Продукт подходит для малых, средних, крупных предприятий и учреждений любых отраслей.

90000 руб.

24.10.2022    5026    5    1    

5

SALE! 30%

Распознавание и загрузка сканов в 1С "одним нажатием": УПД, ТОРГ-12, накладные, счета, номенклатура, заказы и т.д.

Загрузка и выгрузка в Excel Документооборот и делопроизводство (СЭД) Учет документов Распознавание документов и образов Управляемые формы 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Универсальная программа для распознавания ЛЮБЫХ СКАНОВ ИЛИ ФОТО ТОВАРНЫХ ДОКУМЕНТОВ в 1С. Не требует указания параметров и предварительной настройки. Просто выбираете файл (PDF, JPG, DOC, XLS, HTML и т.д.) выбираете документ 1С и нажимаете кнопку "Распознать и загрузить".

6000 5520 руб.

04.06.2019    102703    299    173    

315

ЭДО: организация архива оригиналов первичных документов, комплексный отчет по ошибкам

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    44672    60    51    

74

Бесшовная интеграция 1С:Бухгалтерия 3.0 ПРОФ + 1С:Документооборот. Модуль интеграции 1С:БП и 1С:ДО (ПРОФ или КОРП)

Перенос данных 1C Документооборот и делопроизводство (СЭД) Учет документов Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Бесшовная интеграция с 1С:Документооборот (КОРП или ПРОФ) - вот что обеспечит Вам и Вашим сотрудникам оперативный доступ и продуктивную работу с документами в учётной системе 1С на базе "1С:Бухгалтерия предприятия 3.0 ПРОФ". Бесшовный обмен и связь позволяют экономить до 60% времени на поиск и согласование первичной документации (актов, счетов-фактур, накладных), не говоря уже о других полезных функциональных возможностях: создании и запуске бизнес-процессов, работе с электронной почтой, штрихкодировании документов и многом другом.

30000 руб.

23.05.2017    54453    34    67    

41
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. rpgshnik 3660 16.04.21 12:00 Сейчас в теме
Спасибо, полезная статья!

Единственное в первом случае при добавление строки добавил проверку в дереве на наличие уже созданной колонки:
	Если Помощник.ДеревоВариантов.Колонки.Найти("ВыделитьСтроку") = Неопределено Тогда
		Помощник.ДеревоВариантов.Колонки.Добавить("ВыделитьСтроку", Новый ОписаниеТипов("Булево"));
	КонецЕсли;
2. pavlig 65 16.04.21 16:46 Сейчас в теме
(1) может быть, у меня все работало, вроде бы без сбоев
Оставьте свое сообщение