Настройка телефонии 1С:УНФ, Манго

25.11.20

Функциональные - Управление взаимоотношениями с клиентами (CRM)

Настраиваем телефонию Манго в 1С:Управление нашей фирмой. Как это работает и с чем предстоит столкнуться.

Исходные данные

Управление нашей фирмой, редакция 1.6 (1.6.23.86)
1С:Предприятие 8.3 (8.3.18.1208)
Телефонные аппараты:2шт GRANDSTREAM GXP1610, 1шт Yealink SIP-T19 E2
Apache 2.4

 

Настройка в ЛК Манго

Настроили в ЛК Манго группу менеджеров. В группе менеджеров выбрал последовательный алгоритм распределения. По словам техподдержки Манго, этот алгоритм игнорируется для «знакомых» номеров при интеграции с 1С:

Настроили интеграцию, тест пройден:

Настройка в 1С:Управление нашей фирмой

Настроили в разделе телефонии:

Общие настройки:

Сделали отдельную публикацию на веб сервере:

Добавили в default.vrd информацию о пользователе TelephonyService:

После этого система частично заработала. Появилась возможность звонка из 1С:УНФ. В журнал звонков стали попадать звонки:

Проблема

Но не работает адресация звонка в соответствии с ответственным менеджером:

Т.е. если звонит клиент "Вова", он должен попадать на менеджера "Ольга" с внутренним телефоном "11". А попадает на менеджера "Инна", который стоит первым в алгоритме распределения в ЛК Манго.

Смотрим журнал регистрации:

Здесь я вижу входящий звонок, и сразу адресацию на номер менеджера "Инна". Т.е. Манго принимает решенее менее чем за 1сек. Странно. Вот эти два события. Первое:

И сразу Второе.

Через какое то время начинает ругаться 1С, думаю, т.к. коннектор манго уже закрыла:

С этой частью пока разбираемся. Продолжение следует...

Манго УНФ телефония

См. также

Рассылки из 1С через Email, SMS, Telegram - Директ Маркетинг

Управление взаимоотношениями с клиентами (CRM) Мессенджеры и боты SMS рассылки Email рассылки Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Полный набор инструментов для качественных транзакционных и маркетинговых Email, SMS, Telegram рассылок из 1С. Даже простые уведомления об оплате счетов способны существенно упростить сбор дебиторской задолженности. Применение всех возможностей прямого маркетинга выводит коммуникацию с клиентами, уровень сервиса и лояльность на новый уровень.

7788 руб.

07.04.2014    84492    43    193    

129

Бонусная система в 1С для УТ 10.3

Управление взаимоотношениями с клиентами (CRM) Оптовая торговля Розничная торговля Пользователь Платформа 1С v8.3 Оперативный учет Управляемые формы 1С:Управление торговлей 10 1С:Розница 2 Россия Управленческий учет Платные (руб)

Подсистема призвана упростить и автоматизировать процесс расчета и начисления бонусов покупателей. Бонусная система работает с конфигурациями 1С:УТ 10.3, 1С:Розница. Механизм реализован в начале 2013г. и работает до сих пор с постоянными совершенствованиями.

30000 руб.

02.11.2015    110357    97    87    

182

Рабочее место менеджера по продажам для 1С (УТ 11, ERP 2.0, КА 2) - v.2 (оптовая торговля)

Рабочее место Управление взаимоотношениями с клиентами (CRM) Оптовая торговля Розничная торговля Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Данная обработка - удобный инструмент в 1С для менеджеров по продажам для повседневной работы с клиентами. Позволяет упростить весь цикл работы с клиентом: первичная консультация по наличию товара, быстрое оформление нового заказа, контроль исполнения заказов. Обработка будет особенно актуальна для компаний, работающих, в основном, с юридическими лицами.

18000 руб.

08.11.2016    60252    37    22    

60

Интеграция 1С с телефонией и чатами WhatsApp и Telegram

Телефония, SIP Мессенджеры и боты Платформа 1С v8.3 Конфигурации 1cv8 Россия Управленческий учет Платные (руб)

Интеграция 1С с телефонией и чатами WhatsApp и Telegram автоматизирует работу оператора со звонками и чатами и добавит вашей 1С элементы CRM системы. Храните всю историю взаимоотношений в 1С, не теряйте звонки, скачивайте, прослушивайте в любое время из карточки клиента или журнала звонков, держите руку на пульсе, используя блок отчетов по звонкам. Интегрируйте вашу 1С и чатами WhatsApp и Telegram, общайтесь с клиентами с единого номера и в одном окне. Теперь чаты с клиентами хранятся в карточке партнера в 1С, а не в личных мобильных ваших менеджеров.

4100 руб.

28.04.2022    14503    12    9    

38

Виртуальная АТС Ростелеком - интеграция с 1С

Телефония, SIP Облачные сервисы, хостинг Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Продукт интеграции возможностей Виртуальной АТС Ростелеком в систему 1С Предприятие 8. Звонки прямо из программы 1С, уведомления о текущих звонках, регистрация пропущенных и завершенных вызовов, динамическая маршрутизация входящих звонков, ведение журнала, анализ использования связи.

12000 руб.

04.02.2021    19448    18    0    

25
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. untru 13 25.11.20 13:33 Сейчас в теме
1) Ищи в журнале регистрации записи типа ./commands/route эвент, это только то что вы получаете, по ЖР же видно что переадресацию вы не отправляете
2) Я у себя настроил IVR в манго, что бы было время на отработку переадресации.
3) Не знаю работает ли в 1.6.23 маршруты, в 1.6.20 тупо кода небыло на это, писал сам....
вообщем при просмотре конфы я думаю, что они как всегда схалтурили)

МаршрутизироватьВызовМанго() вот процедура, но она не откуда не вызывается, соответственно вам надо напистаь код опреедления ответствеенного и вызов функции. https://prnt.sc/vpqf1i
https://prnt.sc/vpqg01 собственно код переадресации вставлял в блок IVR
ogre2007; +1 Ответить
3. untru 13 25.11.20 13:40 Сейчас в теме
5. ogre2007 299 25.11.20 13:45 Сейчас в теме
(3)Да, читал. Но там переадресация после того как нужный сотрудник не взял трубку. Везде пишется что 1С:Унф классно работает с телефонией, Манго на первом месте. И такой фейл, со стандартной как бы процедурой. Может я что-то не донастроил. Кодить понятно, пока надеюсь найти решение стандартное.
9. Dragonim 140 26.11.20 11:09 Сейчас в теме
(1)
они как всегда схалтурили

Вот именно такие мысли у меня каждый раз когда пытаюсь что-нибудь сделать в УНФ.
2. untru 13 25.11.20 13:39 Сейчас в теме
А что касается последнего скрина, он отображает внизу экрана окошко, что звонят или открывает событие(по настройкам), делается это через систему взаимодействия, нужно понять работает ли она у вас, потому что тут он просто не может добавить получателя сообщения.
Так же надо посмотреть определяется ли пользователь который говорит в регистре "данные звонков"
4. dnikolaev 178 25.11.20 13:41 Сейчас в теме
Да. классно.
полезная статья. я нигде не нашел про файл vrd. - потерял на это кучу времени.
еще от себя добавлю опубликовывать достаточно только http-сервис TelephonyAPI
еще, если будут проблемы с запросом файла записи разговора - тоже не удивляйтесь.
возможно уже поправили, но три месяца назад, в УНФ было неверное обращение к серверу Манго.
я запрашивал у манго описание API
6. ogre2007 299 25.11.20 13:49 Сейчас в теме
Может кто пробовал не с Манго, и нормально работает?
7. ogre2007 299 25.11.20 14:18 Сейчас в теме
С официального сайта: v8.1c.ru
Телефония
Используйте IP-телефонию: работайте с входящими и исходящими телефонными звонками. Интеграция с 60+ операторами виртуальных АТС, в том числе Mango Office, Дом.ru Бизнес, Яндекс.Телефония, Мегафон, МГТС.

1С:УНФ узнает Вашего клиента по номеру телефона, переведет звонок на ответственного менеджера и сразу откроет карточку клиента.
8. untru 13 25.11.20 16:56 Сейчас в теме
(7)стандартного функционала нет и я написал как в этом убедится, эта процедура тупо нигде не вызывается.
11. ogre2007 299 27.11.20 13:40 Сейчас в теме
(8)Функционал есть. Вот блок на котором я вижу затык, Функция mangoEventsCallPOST(Запрос) в TelephonyApi:
Если НРег(ПараметрыЗапроса.location) = "abonent" Тогда
		
			Если ПараметрыЗапроса.call_state = "Appeared" Тогда
				
				Если ПараметрыЗапроса.from.Свойство("extension") И ПараметрыЗапроса.to.Свойство("number") Тогда
					
					ДанныеЗвонка = ТелефонияСервер.НовыйДанныеЗвонка();
					ДанныеЗвонка.ИдентификаторЗвонкаВАТС = ПараметрыЗапроса.entry_id;
					ДанныеЗвонка.НомерКонтакта = ПараметрыЗапроса.to.number;
					ДанныеЗвонка.Пользователь.ВнутреннийНомер = ПараметрыЗапроса.from.extension;
					ДанныеЗвонка.ДатаНачалаЗвонка = ПараметрыЗапроса.timestamp;
					
					ТелефонияСервер.ОбработатьИсходящийЗвонок(ДанныеЗвонка);
					
				ИначеЕсли ПараметрыЗапроса.from.Свойство("number") И ПараметрыЗапроса.to.Свойство("extension")
					И НЕ ПараметрыЗапроса.Свойство("command_id") Тогда
					
					ДанныеЗвонка = ТелефонияСервер.НовыйДанныеЗвонка();
					ДанныеЗвонка.ИдентификаторЗвонкаВАТС = ПараметрыЗапроса.entry_id;
					ДанныеЗвонка.НомерКонтакта = ПараметрыЗапроса.from.number;
					ДанныеЗвонка.Пользователь.ВнутреннийНомер = ПараметрыЗапроса.to.extension;
					ДанныеЗвонка.ДатаНачалаЗвонка = ПараметрыЗапроса.timestamp;
					Если ПараметрыЗапроса.to.Свойство("line_number") Тогда
						ДанныеЗвонка.НомерОрганизации = ПараметрыЗапроса.to.line_number;
					КонецЕсли;
					
					ТелефонияСервер.ОбработатьВходящийЗвонок(ДанныеЗвонка, Истина);
					
				КонецЕсли;
				
			ИначеЕсли ПараметрыЗапроса.call_state = "Connected" Тогда
				
				Если ПараметрыЗапроса.to.Свойство("extension") Тогда
					Пользователь = ПараметрыЗапроса.to.extension;
				ИначеЕсли ПараметрыЗапроса.from.Свойство("extension") Тогда
					Пользователь = ПараметрыЗапроса.from.extension;
				КонецЕсли;
				
				ДанныеЗвонка = ТелефонияСервер.НовыйДанныеЗвонка();
				ДанныеЗвонка.ИдентификаторЗвонкаВАТС = ПараметрыЗапроса.entry_id;
				ДанныеЗвонка.Пользователь.ВнутреннийНомер = Пользователь;
				ДанныеЗвонка.ДатаНачалаРазговора = ПараметрыЗапроса.timestamp;
				
				ТелефонияСервер.ОбработатьИзменениеЗвонка(ДанныеЗвонка);
				
			ИначеЕсли ПараметрыЗапроса.call_state = "Disconnected" Тогда
				
				Пользователь = Неопределено;
				Если ПараметрыЗапроса.to.Свойство("extension") Тогда
					Пользователь = ПараметрыЗапроса.to.extension;
				ИначеЕсли ПараметрыЗапроса.from.Свойство("extension") Тогда
					Пользователь = ПараметрыЗапроса.from.extension;
				КонецЕсли;
				
				ДанныеЗвонка = ТелефонияСервер.НовыйДанныеЗвонка();
				ДанныеЗвонка.ИдентификаторЗвонкаВАТС = ПараметрыЗапроса.entry_id;
				ДанныеЗвонка.Пользователь.ВнутреннийНомер = Пользователь;
				ДанныеЗвонка.ДатаЗавершенияРазговора = ПараметрыЗапроса.timestamp;
				ДанныеЗвонка.ОпределятьНеотвеченный = Истина;
				
				ТелефонияСервер.ОбработатьЗавершениеЗвонка(ДанныеЗвонка);
				
			КонецЕсли;
			
		КонецЕсли;
Показать

Они в уведомлении вызова пишут "location"="ivr", а 1с кушает только "abonent". Написал в техподдержку, жду ответа. Наверное что-то не так настраиваю в ЛК манго.
14. untru 13 27.11.20 17:07 Сейчас в теме
(11) Блин, я же тебе говорю как оно есть, у нас давно все настроено, я этот модуль взад и поперек протестировал, и проработал.
16. ogre2007 299 30.11.20 08:16 Сейчас в теме
(14)Грустно, но похоже ты прав. Просто не верится, что они так нагло брешут :). На сайте есть заявленный функционал, а в конфигураторе нет. Наверное напишу письмо в 1С. Глубже посмотрел, да похоже на обрубки, которые потом сделают. Модуль MangoApi:
Функция ResultCallbackPOST(Запрос)
	
	ИмяСобытияДляЖурналаРегистрации = "/result/callback";
	
	Если Не ПолучитьФункциональнуюОпцию("ИспользоватьОблачнуюТелефонию") Тогда
		Возврат СообщениеОбОшибке(
			500,
			ИмяСобытияДляЖурналаРегистрации,
			НСтр("ru='Использование телефонии отключено в настройках'"));
	КонецЕсли;
	
	Ответ = Новый HTTPСервисОтвет(501); // Not implemented (не реализовано)
	Возврат Ответ;
	
КонецФункции

Функция ResultStatsPOST(Запрос)
	
	ИмяСобытияДляЖурналаРегистрации = "/result/stats";
	
	Если Не ПолучитьФункциональнуюОпцию("ИспользоватьОблачнуюТелефонию") Тогда
		Возврат СообщениеОбОшибке(
			500,
			ИмяСобытияДляЖурналаРегистрации,
			НСтр("ru='Использование телефонии отключено в настройках'"));
	КонецЕсли;
	
	Ответ = Новый HTTPСервисОтвет(501); // Not implemented (не реализовано)
	Возврат Ответ;
	
КонецФункции

Функция ResultRoutePOST(Запрос)
	
	ИмяСобытияДляЖурналаРегистрации = "/result/route";
	
	Если Не ПолучитьФункциональнуюОпцию("ИспользоватьОблачнуюТелефонию") Тогда
		Возврат СообщениеОбОшибке(
			500,
			ИмяСобытияДляЖурналаРегистрации,
			НСтр("ru='Использование телефонии отключено в настройках'"));
	КонецЕсли;
	
	Ответ = Новый HTTPСервисОтвет(501); // Not implemented (не реализовано)
	Возврат Ответ;
	
КонецФункции

Показать

Сделал расширение как по ссылке выше и вроде заработало, пока тестирую. Позже прикреплю его в теме.
17. paramedic 02.12.20 09:38 Сейчас в теме
(11)"ivr" означает, что вызывающий абонент находится в голосовом меню. Надо настроить Манго так, чтобы одновременно с голосовым меню шел вызов на телефоны сотрудников. Тогда сразу появляются события с location="abonent" или "queue". Вот как раз "queue" и не обрабатывается. А обрабатывать событие "ivr" нужно разве что для аналитики сколько человек задолбались слушать "Здравсвуйте! Вас приветствует фирма "Пепкин"....."
12. ogre2007 299 27.11.20 14:14 Сейчас в теме
(8)Функция, которая формирует переадресацию на нужного сотрудника, общий модуль ТелефонияПереопределяемый:
Процедура ПриСозданииИсходящегоВызоваMangoOffice(НомерАбонента, ДанныеПользователяАТС, НастройкиТелефонии, ПараметрыОтправки, Ошибка)
	
	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет));
	ЗаписьJSON.ЗаписатьНачалоОбъекта();
	
	ЗаписьJSON.ЗаписатьИмяСвойства("command_id");
	ЗаписьJSON.ЗаписатьЗначение(Строка(Новый УникальныйИдентификатор));
	
	ЗаписьJSON.ЗаписатьИмяСвойства("from");
	ЗаписьJSON.ЗаписатьНачалоОбъекта();
	ЗаписьJSON.ЗаписатьИмяСвойства("extension");
	ЗаписьJSON.ЗаписатьЗначение(ДанныеПользователяАТС.ВнутреннийНомер);
	ЗаписьJSON.ЗаписатьКонецОбъекта();
	
	ЗаписьJSON.ЗаписатьИмяСвойства("to_number");
	ЗаписьJSON.ЗаписатьЗначение(НомерАбонента);
	
	ЗаписьJSON.ЗаписатьКонецОбъекта();
	json = ЗаписьJSON.Закрыть();
	
	sign = ПолучитьSign(НастройкиТелефонии.vpbx_api_key, json, НастройкиТелефонии.vpbx_api_salt);
	
	ПараметрыОтправки.URL = ПараметрыОтправки.URL + "commands/callback";
	ПараметрыОтправки.ПараметрыТела.Вставить("vpbx_api_key", НастройкиТелефонии.vpbx_api_key);
	ПараметрыОтправки.ПараметрыТела.Вставить("sign",         sign);
	ПараметрыОтправки.ПараметрыТела.Вставить("json",         json);
	
КонецПроцедуры
Показать
13. untru 13 27.11.20 17:04 Сейчас в теме
(12) https://prnt.sc/vr9oaj это не так, эта функция инициирует звонок из 1с, никакого отношения к переадресации она не имеет
10. Riphius 26.11.20 13:27 Сейчас в теме
На днях тестил АТС Манго и Мегафон. База была на 1C:Фреш. Все взлетело с первого раза. Отрабатывает функционал полностью, вплоть до прослушки записей разговоров из унф. В случае публикации базы через 1С.Линк или Апач - балалайка.
15. untru 13 27.11.20 17:08 Сейчас в теме
(10) А разве во фреше не тот же релиз? И что хочешь сказать что переадресация на сотрудника работала?
18. Comradesh 05.12.20 19:46 Сейчас в теме
А в веб клиенте телефония должна работать ? все установил согласно всех доступных описаний . Из УНФ звонок идет . При входе в базу через веб клиента выдает ошибку :

"Ошибка преобразования данных XDTO: Чтение объекта типа: {http://v8.1c.ru/8.2/virtual-resource-system}Point - [9,3] Проверка дополнительного свойства: форма: Текст имя:"
19. Vodi4kin 9 07.12.20 02:06 Сейчас в теме
Этой проблеме 2 или 3 года) похоронил интеграцию телефонии манго и УНФ именно из-за этого))
20. seducer 83 10.12.20 21:28 Сейчас в теме
Вопрос не совсем в тему. Столкнулся сейчас. Телефония включена, в default.vrd строка с подключением служебного пользователя добавлена. А как теперь с удаленки по тонкому клиенту подключаться? Сейчас попробовал, пользователя и пароль не запрашивает, сразу пытается войти под служебным пользователем. Не сталкивался с таким раньше.
22. ogre2007 299 21.12.20 16:41 Сейчас в теме
(20)Сделайте отдельно публикацию для телефонии и отдельно публикацию для пользователей.
21. a.fesenko 21.12.20 13:41 Сейчас в теме
Добрый день.
Подключили телефонию в 1С УНФ оператора ДОМ.РУ, когда в файле vrd указываем системного пользователя логин и пароль, то не получается зайти через браузер, сразу пишет Нет прав. Кто нибудь знает, как это решить? Кстати у нас при подключении телефонии сразуже база начинает жутко тормозить, особенно если кто то звонит и менеджер взял трубку, то секунд 10 ни кто ни чего не может сделать. Это нормально?
23. user1522889 13.04.22 10:23 Сейчас в теме
(21)

21. a.fesenko 21.12.20 13:41
Добрый день.
Подключили телефонию в 1С УНФ оператора ДОМ.РУ, когда в файле vrd указываем системного пользователя логин и пароль, то не получается зайти через браузер, сразу пишет Нет прав. Кто нибудь знает, как это решить? Кстати у нас при подключении телефонии сразуже база начинает жутко тормозить, особенно если кто то звонит и менеджер взял трубку, то секунд 10 ни кто ни чего не может сделать. Это нормально?


не нашли решение по поводу тормозов в 1ске?
24. LineykaSBK 6 28.06.23 16:16 Сейчас в теме
Подскажите пож-та, кто нибудь сталкивался с задачей по подключению сразу двух и более телефонных линий к одной базе?
25. LineykaSBK 6 28.06.23 16:26 Сейчас в теме
(24) уточню, что вторая линии тоже от ростелекома. вот стоит задача подключить обе линии к унф.
26. user1740553 17.07.23 10:52 Сейчас в теме
(24)
Подскажите пож-та, кто нибудь сталкивался с задачей по подключению сразу двух и более телефонных линий к одной базе?

Есть простой, но платный способ. Завести одну АТС в другую через sip-регистрацию внешнего номера (тогда звонки с линии ростелеком будут переадресовываться на дом.ру и управляться АТСкой Дом.ру). Цена вопроса варьируется от региона - уточняйте у своего менеджера дом.ру.

Кстати в интеграции с УНФ кое-что сломалось, конкретно адресация на ответственного менеджера из карточки УНФ. У 1С ошибка зарегистрирована, пока что есть временное решение до релиза/обновления https://delopora.ru/programs/ispravlenie-problemy-adresaczii-zvonkov-dom-ru/
Оставьте свое сообщение