Исправление вывода списка процессов в 1С:Документооборот с группировкой

Публикация № 1446957 24.05.21

Управление - Документооборот и делопроизводство

Процессы шаблоны Документооборот

Начиная с версии 2.1.13.28 разработчики 1С:Документооборот изменили порядок отправки документа в обработку. Запуск процесса начинается с одной кнопки Отправить. Это здорово, так как не надо гадать, какой тип процесса настроен для документа, но список процессов неинтуитивный. Особенно, когда количество настроенных процессов более 1000. Все процессы выводятся в один список и сортируются по наименованию.

Предлагаемое решение выполнено на версии 1С:Документооборот 2.1.27.1

Список процессов разделен на группы:

  1. Рекомендованные (назначенные для документа)
  2. Произвольные (без шаблонов)
  3. Общие (все остальные, доступные пользователю)

Есть 2 места, которые нужно учесть при внесении изменений:

  1. Работа непосредственно в 1С:Документооборот
  2. Работа с 1С:Документооборот через бесшовную интеграцию (проверено на интеграции с ЗУП и УПП)

1. Работа в 1С:Документооборот 

Для исправления списка предлагаю группировку шаблонов процессов по логике разработчиков, но с явным разделением по настройкам (назначенные для запуска по документу, произвольные и все остальные).

Чтобы вывести группировку нужно в общий модуль ПомощникОтправить внести изменения.

Добавить Новую процедуру и заменить вызов типовой процедуры ДобавитьВДеревоОсновныеВариантыСозданияПроцесса на новую процедуру 


    //ДобавитьВДеревоОсновныеВариантыСозданияПроцесса(Помощник);
    рвк_ДобавитьВДеревоОсновныеВариантыСозданияПроцесса(Помощник);
    

Процедура рвк_ДобавитьВДеревоОсновныеВариантыСозданияПроцесса(Помощник)
    
    УстановитьПривилегированныйРежим(Истина);
    
    // Формируем общий список вариантов, добавляемых в корень дерева, из:
    // шаблонов по умолчанию, общих и рекомендуемых шаблонов.
    
    ВариантыСозданияПроцессаТ = Новый ТаблицаЗначений;
    ВариантыСозданияПроцессаТ.Колонки.Добавить("Представление");
    ВариантыСозданияПроцессаТ.Колонки.Добавить("Значение");
    ВариантыСозданияПроцессаТ.Колонки.Добавить("Группа");
    
    ЕстьПредметы = ЗначениеЗаполнено(Помощник.ПредметыПроцесса);
    
    Для Каждого КлючЗначение Из Помощник.РекомендуемыеВариантыСозданияПроцессов Цикл
        
        Если Не ВозможноДобавлениеВарианта(Помощник, КлючЗначение.Ключ)
            И Не ВозможноДобавлениеВарианта(Помощник, КлючЗначение.Значение) Тогда
            
            Продолжить;
        КонецЕсли;
        
        Если ЕстьПредметы И Помощник.ДопустимыеТипыВариантовДляПредметов[
            КлючЗначение.Значение] = Неопределено Тогда
            
            Продолжить;
        КонецЕсли;
        
        Если ЭтоВариантСозданияПроцессаОбработки(КлючЗначение.Значение)
            И Не ВозможноДобавлениеВариантовСозданияПроцессаОбработкиДокументов(Помощник) Тогда
            
            Продолжить;
        КонецЕсли;
        
        Строка = ВариантыСозданияПроцессаТ.Добавить();
        Строка.Значение = КлючЗначение.Ключ;
        Строка.Представление = Строка(КлючЗначение.Ключ);
        Строка.Группа = "!Рекомендуемые";
    КонецЦикла;
    
    Для Каждого КлючЗначение Из Помощник.ОбщиеВариантыСозданияПроцессов Цикл
        
        Если Не ВозможноДобавлениеВарианта(Помощник, КлючЗначение.Ключ)
            И Не ВозможноДобавлениеВарианта(Помощник, КлючЗначение.Значение) Тогда
            
            Продолжить;
        КонецЕсли;
        
        Если ЕстьПредметы И Помощник.ДопустимыеТипыВариантовДляПредметов[
            КлючЗначение.Значение] = Неопределено Тогда
            
            Продолжить;
        КонецЕсли;
        
        Если ЭтоВариантСозданияПроцессаОбработки(КлючЗначение.Значение)
            И Не ВозможноДобавлениеВариантовСозданияПроцессаОбработкиДокументов(Помощник) Тогда
            
            Продолжить;
        КонецЕсли;
        
        Строка = ВариантыСозданияПроцессаТ.Добавить();
        Строка.Значение = КлючЗначение.Ключ;
        Строка.Представление = Строка(КлючЗначение.Ключ);
        Строка.Группа = "Общие";
    КонецЦикла;
    
    Для Каждого КлючЗначение Из Помощник.ВариантыСозданияПроцессовПоУмолчанию Цикл
        
        Если Не ВозможноДобавлениеВарианта(Помощник, КлючЗначение.Ключ)
            И Не ВозможноДобавлениеВарианта(Помощник, КлючЗначение.Значение) Тогда
            
            Продолжить;
        КонецЕсли;
        
        Если ЕстьПредметы И Помощник.ДопустимыеТипыВариантовДляПредметов[
            КлючЗначение.Значение] = Неопределено Тогда
            
            Продолжить;
        КонецЕсли;
        
        Если ЭтоВариантСозданияПроцессаОбработки(КлючЗначение.Значение)
            И Не ВозможноДобавлениеВариантовСозданияПроцессаОбработкиДокументов(Помощник) Тогда
            
            Продолжить;
        КонецЕсли;
        
        Представление = ПредставлениеВариантаСозданияПроцессаПоУмолчанию(
            КлючЗначение.Ключ, Помощник);
        
        Строка = ВариантыСозданияПроцессаТ.Добавить();
        Строка.Значение = КлючЗначение.Ключ;
        Строка.Представление = Представление;
        Строка.Группа = "Произвольные";
    КонецЦикла;
    
    ВариантыСозданияПроцессаТ.Сортировать("Группа, Представление");
    
    Группа = "";
    Для Каждого ВариантСозданияПроцесса Из ВариантыСозданияПроцессаТ Цикл
        Если Группа <> ВариантСозданияПроцесса.Группа Тогда
            Группа = ВариантСозданияПроцесса.Группа;
            СтрокаГруппы = Помощник.ДеревоВариантов.Строки.Добавить();
            СтрокаГруппы.Представление = Группа;
            СтрокаГруппы.Вариант = Группа;
        КонецЕсли;
        Если ЗначениеЗаполнено(СтрокаГруппы) Тогда
            СтрокаВарианта = СтрокаГруппы.Строки.Добавить();
        Иначе
            СтрокаВарианта = Помощник.ДеревоВариантов.Строки.Добавить();
        КонецЕсли;
        СтрокаВарианта.Вариант = ВариантСозданияПроцесса.Значение;
        СтрокаВарианта.Представление = ВариантСозданияПроцесса.Представление;
    КонецЦикла;
    
КонецПроцедуры



2. Для изменения вывода в рамках бесшовной интеграции необходимо внести изменения в общий модуль ОбработкаЗапросовXDTOБизнесПроцессыИЗадачи в функцию ПолучитьДеревоШаблоновБизнесПроцессов

Есть один нюанс в реализации. При большом количестве процессов бесшовная интеграция не успевал формироваться список процессов за отведенное время и по таймауту отваливался. Поэтому в данном решении будут выводиться только Произвольные (без шаблона) и Рекомендованные процессы (назначенные для документа)

Полный текст функции ПолучитьДеревоШаблоновБизнесПроцессов ниже

// Получает дерево шаблонов бизнес-процессов, удовлетворяющих условиям отбора
//
// Параметры:
//   Сообщение - ОбъектXDTO типа DMGetBusinessProcessTemplatesTreeRequest
// Возвращаемое значение:
//   ОбъектXDTO типа DMGetBusinessProcessTemplatesTreeResponse 
//
Функция ПолучитьДеревоШаблоновБизнесПроцессов(Сообщение) Экспорт
    
    Ответ = СоздатьОбъектXDTO("DMGetBusinessProcessTemplatesTreeResponse");
    
    ПредметБП = Неопределено;
    Если Сообщение.Установлено("businessProcessTargetId") Тогда
        ПредметБП = ОбработкаЗапросовXDTO.ПолучитьСсылкуПоObjectID(Сообщение.businessProcessTargetId);
    КонецЕсли;
    
    Объекты = Новый Массив;
    Если ЗначениеЗаполнено(ПредметБП) Тогда
        Объекты.Добавить(ПредметБП);
    КонецЕсли;
    ВариантыОтправки = ВариантыОтправки(Объекты, Ответ);
    
    ГруппаРекомендованныеШаблоны = СоздатьОбъектXDTO("DMBusinessProcessTemplatesTreeGroup");
    ГруппаРекомендованныеШаблоны.name = НСтр("ru = 'Рекомендованные шаблоны'");
    ГруппаРекомендованныеШаблоны.hint =
        СформироватьСводкуПоГруппеЭлементов(ГруппаРекомендованныеШаблоны.name, Неопределено);
    ОстальныеГруппыШаблонов = Новый Массив;
    //rvk eryabova upd+ Было
    //Для Каждого Строка Из ВариантыОтправки.Строки Цикл
    //    Если Строка.Недоступен = Истина Тогда
    //        ГруппаДругиеВарианты = СоздатьОбъектXDTO("DMBusinessProcessTemplatesTreeGroup");
    //        ГруппаДругиеВарианты.name = Строка.Представление;
    //        ГруппаДругиеВарианты.hint = НСтр("ru = 'Группа шаблонов процессов.'");
    //        ГруппаДругиеВарианты.hintHTML = ПомощникОтправить.ОписаниеВарианта(Строка.Вариант);
    //        Для Каждого Подстрока Из Строка.Строки Цикл
    //            СтрокаШаблонов = СоздатьОбъектXDTO("DMBusinessProcessTemplatesTreeElement");
    //            СтрокаШаблонов.name = Подстрока.Представление;
    //            СтрокаШаблонов.hint = СформироватьСводкуПоШаблону(Подстрока.Вариант);
    //            СтрокаШаблонов.hintHTML = ПомощникОтправить.ОписаниеВарианта(Подстрока.Вариант);
    //            СтрокаШаблонов.businessProcessType = ПолучитьТипПроцессаXDTOПоШаблону(Подстрока.Вариант);
    //            
    //            ОбъектШаблонXDTO = СоздатьОбъектXDTO("DMBusinessProcessTemplate");
    //            ОбъектШаблонXDTO.name = Подстрока.Представление;
    //            ОбъектШаблонXDTO.objectId = ОбработкаЗапросовXDTO.ПолучитьObjectIDПоСсылке(Подстрока.Вариант);
    //            СтрокаШаблонов.template = ОбъектШаблонXDTO;
    //            
    //            ГруппаДругиеВарианты.elements.Добавить(СтрокаШаблонов);
    //        КонецЦикла;
    //        ОстальныеГруппыШаблонов.Добавить(ГруппаДругиеВарианты);
    //    ИначеЕсли ТипЗнч(Строка.Вариант) <> Тип("Строка") Тогда
    //        СтрокаШаблонов = СоздатьОбъектXDTO("DMBusinessProcessTemplatesTreeElement");
    //        СтрокаШаблонов.name = Строка.Представление;
    //        СтрокаШаблонов.hint = СформироватьСводкуПоШаблону(Строка.Вариант);
    //        СтрокаШаблонов.hintHTML = ПомощникОтправить.ОписаниеВарианта(Строка.Вариант);
    //        СтрокаШаблонов.businessProcessType = ПолучитьТипПроцессаXDTOПоШаблону(Строка.Вариант);
    //        
    //        ОбъектШаблонXDTO = СоздатьОбъектXDTO("DMBusinessProcessTemplate");
    //        ОбъектШаблонXDTO.name = Строка.Представление;
    //        ОбъектШаблонXDTO.objectId = ОбработкаЗапросовXDTO.ПолучитьObjectIDПоСсылке(Строка.Вариант);
    //        СтрокаШаблонов.template = ОбъектШаблонXDTO;
    //        
    //        ГруппаРекомендованныеШаблоны.elements.Добавить(СтрокаШаблонов);
    //    КонецЕсли;
    //КонецЦикла;
    
    //Ответ.businessProcessTemplatesTree.Добавить(ГруппаРекомендованныеШаблоны);
    //Для Каждого Группа Из ОстальныеГруппыШаблонов Цикл
    //    Ответ.businessProcessTemplatesTree.Добавить(Группа);
    //КонецЦикла;
    ////rvk eryabova upd- Было
    
    ////rvk eryabova upd+ Стало
    Группа = "";
    ГруппаВарианты = Неопределено;
    Отбор = Новый Структура("Вариант","!Рекомендуемые");
        
    Для Каждого Строка Из ВариантыОтправки.Строки Цикл
        Если Строка.Уровень() = 0 и ТипЗнч(Строка.Вариант) = Тип("Строка") Тогда
            Если Строка.Вариант = "!Рекомендуемые" или Строка.Вариант = "Произвольные" Тогда
            Иначе
                Если ПредметБП <> Неопределено Тогда
                    Продолжить;
                КонецЕсли;
            КонецЕсли;
            ГруппаВарианты = СоздатьОбъектXDTO("DMBusinessProcessTemplatesTreeGroup");
            ГруппаВарианты.name = Строка.Представление;
            ГруппаВарианты.hint = НСтр("ru = '"+ Строка.Представление + "'");
            Ответ.businessProcessTemplatesTree.Добавить(ГруппаВарианты);
            Для Каждого Подстрока Из Строка.Строки Цикл
                СтрокаШаблонов = СоздатьОбъектXDTO("DMBusinessProcessTemplatesTreeElement");
                СтрокаШаблонов.name = Подстрока.Представление;
                СтрокаШаблонов.hint = СформироватьСводкуПоШаблону(Подстрока.Вариант);
                СтрокаШаблонов.hintHTML = ПомощникОтправить.ОписаниеВарианта(Подстрока.Вариант);
                СтрокаШаблонов.businessProcessType = ПолучитьТипПроцессаXDTOПоШаблону(Подстрока.Вариант);
                
                ОбъектШаблонXDTO = СоздатьОбъектXDTO("DMBusinessProcessTemplate");
                ОбъектШаблонXDTO.name = Подстрока.Представление;
                ОбъектШаблонXDTO.objectId = ОбработкаЗапросовXDTO.ПолучитьObjectIDПоСсылке(Подстрока.Вариант);
                СтрокаШаблонов.template = ОбъектШаблонXDTO;
                Если ТипЗнч(ГруппаВарианты) = Тип("ОбъектXDTO") Тогда
                    ГруппаВарианты.elements.Добавить(СтрокаШаблонов);
                КонецЕсли;
            КонецЦикла;

            //ГруппаДругиеВарианты.hintHTML = ПомощникОтправить.ОписаниеВарианта(Строка.Вариант);
        КонецЕсли;
    КонецЦикла;
    ////rvk eryabova upd- Стало
    
    Возврат Ответ;
    
КонецФункции

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. rpgshnik 2590 25.05.21 04:02 Сейчас в теме
Подобное уже встречал на инфостарте, но там было выделение жирным начертанием рекомендуемых и вывод их на самый верх, в целом как альтернатива тоже не плохо. Спасибо за публикацию. Не понимаю, почему 1С ушла от рекомендуемых процессов и не дала возможность пользователю самостоятельно на это влиять.
2. Xleo777 37 25.05.21 11:32 Сейчас в теме
(1) Добрый день!
Спасибо за отзыв!

Да. Видела публикацию про выделение рекомендуемых шаблонов жирным шрифтом. Но пошла по пути наименьшего изменения типового кода.
И не стала выносить в расширение, так как при обновлении также можно получить вопросы по адаптации.

Причем в результате используется типовое разделение процессов по смыслу. Непонятно, почему 1С не довели визуализацию процессов.
За 4 года, я думала, что исправят. Но нет. Пришлось делать самим. Процессов много.
3. Flyerink 18 25.05.21 18:07 Сейчас в теме
Елена, спасибо большое за такую полезную статью! Помогли сэкономить прилично времени. Обновились со старой версии (живу по принципу - лучшее враг хорошего, а тут из-за ЭДО пришлось обновляться). Пользователи кучу процессов позапускали неправильных, т.к. привыкли нажимать верхние рекомендуемые..
На релизе 2.1.28.14 ваш код работает без изменений!
4. Xleo777 37 26.05.21 09:43 Сейчас в теме
(3) Спасибо за отзыв! Рада, что пригодилось решение!
Оставьте свое сообщение

См. также

Как настроить правильную техподдержку (helpdesk, service desk на коленке) Промо

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени v8 УУ Бесплатно (free)

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    26949    siddy    0    

Как вносить изменения в новое ЭДО от 1С в БП 3? Июнь 2021, БП 3.0.93.20

Документооборот и делопроизводство Обмен через XML v8 v8::БУ БП3.0 БУ Бесплатно (free)

Обновились на 3.0.93.20, и все мои расширения под ЭДО перестали работать. Разберем, где вообще искать код, который выводит данные электронного документа в XML, где вмешиваться в ход этого вывода?

03.06.2021    3549    fixin    21    

Диадок, модуль 1С - заполнение полей с дополнительной информацией

Документооборот и делопроизводство v8 Россия Бесплатно (free)

Некоторые контрагенты для настройки электронного обмена документами требуют заполнения специальных полей  ИнфПолФХЖ1 и ИнфПолФХЖ2 дополнительной информацией.

21.05.2021    1281    _Vovik    9    

Иной подход к схемам комплексных процессов (возможность пользователям в удобном формате видеть участников процесса до его запуска) в 1С: Документооборот

Документооборот и делопроизводство Документоборот 2 v8 ДО УУ Бесплатно (free)

Предлагаю решение, как несложным образом переработать шаблоны комплексных процессов, чтобы пользователи могли видеть исполнителей процесса еще до запуска, а ответственные за ввод шаблонов упростили себе задачу при работе со сложными маршрутами.

30.03.2021    1324    Capitullo    0    

Права доступа в 1С:Документооборот 2.1 Промо

Информационная безопасность Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Бесплатно (free)

В программе 1С:Документооборот ред 2.1 механизм системы прав доступа сильно изменился. С одной стороны, права доступа в данной версии стали проще и быстрее, с другой стороны - права по рабочим группам объектов теперь могут противоречить политикам доступа. Разберемся в данной статье как работает механизм прав доступа в 1с документообороте 2.1.

16.09.2016    84664    vlush78    0    

Доступность процессов и задач по предмету всем участникам рабочей группы документа

Документооборот и делопроизводство Практика программирования v8 ДО Бесплатно (free)

Простой способ сделать задачи и процессы доступными всем участникам рабочей группы документа. Для этого нужно добавить дополнительный обработчик бизнес-события, который будет срабатывать по виду события "Старт процесса". Актуально, если используете комплексные процессы, и не все участники видят задачи друг друга.

15.02.2021    494    Capitullo    0    

Новое в 1С:Документооборот 3.0

Документооборот и делопроизводство v8 ДО УУ Бесплатно (free)

Под новый год фирма 1С сделала нам всем подарок – вышла ознакомительная версия долгожданного 1С:Документооборот 3.0! По традиции новая версия кардинально отличается от предшественника как в плане интерфейса, так и по “начинке”. В данной статье рассмотрим самые интересные нововведения. Приступим к обзору.

11.02.2021    3526    Koder_Line    5    

Запрет повторного запуска комплексных процессов типовыми средствами в 1С: Документооборот

Документооборот и делопроизводство Документоборот 2 v8 ДО Бесплатно (free)

Реализация решения изложенного в статье, исключает ошибочный (повторный) запуск комплексного процесса в 1С: Документооборот.

09.11.2020    1556    sulig    4    

Интеграция «1С:Управление производственным предприятием» с «1С:Документооборот» Промо

Перенос данных из 1C8 в 1C8 Документооборот и делопроизводство Документооборот и делопроизводство v8 КА1 УПП1 ДО Бесплатно (free)

В данной статье пойдет речь о возможности интеграции 1С:Управление производственным предприятием ред. 1.3 с 1С:Документооборот КОРП и о том, что может получить предприятие от этой интеграции.

18.02.2013    65611    Vladimir_Konyrev    38    

Блокировка повторного запуска комплексного процесса по документу в 1С: Документооборот

Документооборот и делопроизводство v8 ДО БУ Бесплатно (free)

Доработка в 1С: Документооборот позволяет заблокировать повторный запуск комплексного процесса по шаблону для данного документа, если процесс по этому шаблону уже запущен.

02.11.2020    1030    vlad356987    13    

Проблемы организаций при подготовке к внедрению документооборота

Документооборот и делопроизводство v8 Россия Бесплатно (free)

Что необходимо сделать для реализации проекта по внедрению «1С:Документооборота?»Как мы говорили в предыдущей статье необходимо осознать проблему, провести классификацию проблем, определить риски и обосновать необходимость внедрения документооборота.

18.06.2020    3120    Marta.Snytkina    4    

Визуализация электронной подписи в заполняемом файле MS Word в 1С:Документооборот

Документооборот и делопроизводство v8 ДО Бесплатно (free)

Произвольное размещение визуализации электронной подписи в заполняемом документе MS Word в конфигурации 1С:Документооборот.

09.04.2020    5361    Xleo777    2    

Делегирование в 1С:Документооборот

Документооборот и делопроизводство v8 ДО Бесплатно (free)

Важной составляющей при настройке прав доступа пользователей в электронный документооборот «1С:Предприятия» является механизм делегирования прав. Он применяется в случае временного отсутствия одного сотрудника (отпуск, больничный и пр.) и необходимости перенаправлять обязанности и ответственность за своевременное выполнение задач на другого сотрудника. При процессе делегирования возможна передача нескольких или всех прав.

25.02.2020    6161    Koder_Line    4    

Отправка "Заявления на подключение к ЭДО ПФР" из программы "1С: Бухгалтерия предприятия, ред. 2" для СЗВ-ТД

Документооборот и делопроизводство Зарплата Управление персоналом (HRM) v8 v8::БУ БП2.0 Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Инструкция по отправке "Заявления на подключение к ЭДО ПФР" из программы "1С Бухгалтерия предприятия, ред. 2" для обмена сведениями об электронных трудовых книжках и отправки отчетов по форме СЗВ-ТД.

11.02.2020    28254    rusmil    9    

Детектор завершения согласования для 1С: Документооборот КОРП

Практика программирования Документооборот и делопроизводство v8::УФ ДО УУ Бесплатно (free)

Детектор, обнаруживающий завершение согласования и создающий соответствующее бизнес-событие, на которое можно настроить обработчик или автозапуск процесса.

04.02.2020    3619    shiaju    3    

Электронные трудовые книжки, СЗВ-ТД в ЗУП 3.1 - сборник ответов на вопросы и полезные ссылки

Документооборот и делопроизводство Зарплата v8 v8::СПР ЗУП3.x Россия БУ Бесплатно (free)

С 1 января 2020 г. начался переход на электронные трудовые книжки. До середины февраля 2020 г. все работодатели должны сдать первый отчет по форме СЗВ-ТД. Не смотря на то, что срок сдачи уже достаточно близок, информация по данному направлению постоянно изменяется и уточняется. Я постаралась собрать ключевые моменты, касающиеся перехода на электронный формат ведения трудовых книжек сотрудников в программе ЗУП 3.1, которые возникли при изучении этого нововведения. Данный сборник будет полезен как бухгалтеру/кадровику, так и 1С программисту или консультанту, сопровождающему переход. Весь предложенный материал можно найти самостоятельно, моей целью было собрать разные источники воедино дабы облегчить работу моим коллегам. В связи с тем, что информация может корректироваться и уточняться, необходимо проверять ее актуальность, поэтому в каждом найденном ответе указан источник для проверки. Внимание - данный сборник является справочным, работодатель должен руководствоваться исключительно Законодательством об электронных трудовых книжках. В сборник первоначально вошли только те вопросы, с которыми я столкнулась в своей работе лично, поэтому критика и предложения по дополнению приветствуются! !!!UPD - произошло значительное изменение функционала СЗВ - ТД https://its.1c.ru/db/updinfo#content:701:1:issogl2_2

28.01.2020    56882    Bene_Valete    220    

Новые возможности обработки Печать договоров по шаблонам для УТ 11, КА 2, ERP 2

Печатные формы документов Документооборот и делопроизводство v8 ERP2 УТ11 КА2 Бесплатно (free)

В публикации описаны возможности обработки, которые появились в новых релизах

19.12.2019    5337    pparshin    3    

Добавление собственного виджета в 1С:Документооборот

Практика программирования Документооборот и делопроизводство v8 ДО Бесплатно (free)

В данной публикации я хочу описать процесс добавления собственного виджета для функционала отсутствий в 1С документооборот.

14.12.2019    5701    pavelpribytkin96    2    

Вывод полной истории в задаче по всему "дереву" бизнес-процессов

Документооборот и делопроизводство Практика программирования v8::Бизнес-процессы ДО Россия УУ Бесплатно (free)

Вашему вниманию предлагается моя версия текста общего модуля "ОбзорЗадачВызовСервераПереопределяемый" для конфигурации 1С:Документооборот.

20.11.2019    6832    rmIvanT    24    

1С:Документооборот. Уведомление параллельных исполнителей. Дополнительный обработчик Бизнес-события

Документооборот и делопроизводство Практика программирования v8::Бизнес-процессы ДО Россия Бесплатно (free)

Вашему вниманию предлагается пользовательский обработчик бизнес-события по созданию уведомлений параллельных исполнителей. Для бизнес-процесса "Исполнение".

14.11.2019    3796    rmIvanT    0    

Использование справочника "Условия маршрутизации" для бизнес-событий в 1С Документооборот.

Документооборот и делопроизводство v8 ДО Бесплатно (free)

Часто возникает ситуация, когда нужно написать обработчик бизнес-события, в алгоритмах которого необходимо, например, использовать данные внутреннего документа (значения доп. реквизитов, обычных реквизитов и т.д.). В данной публикации я хочу поделиться своим решением данной задачи через условия маршрутизации.

28.10.2019    12059    pavelpribytkin96    6    

Автоматический запуск бизнес-процессов по входящим письмам с электронной почты в 1С Документооборот.

Документооборот и делопроизводство v8 ДО Бесплатно (free)

Коллеги, в данной публикации я хочу описать пример настройки автоматического запуска бизнес-процессов по входящим письмам в документообороте с использованием встроенного почтового клиента.

28.10.2019    13019    pavelpribytkin96    12    

Отображение схемы комплексного процесса в карточке процесса через бесшовную интеграцию с ДО.

Практика программирования Документооборот и делопроизводство v8 ДО ERP2 УТ11 КА2 Бесплатно (free)

В данной публикации я хочу описать доработку, с помощью которой можно вывести схему комплексного процесса через бесшовную интеграцию с ДО в форме комплексного процесса.

23.10.2019    5723    pavelpribytkin96    2    

Работа с автозаполнением шаблонов файлов в документообороте

Практика программирования Документооборот и делопроизводство v8 ДО Бесплатно (free)

При автозаполнении шаблонов файлов средствами MS Word возникает такая проблема - если одно и то же поле используется несколько раз в документе, тогда приходится дублировать закладки, например, если поле "Ответственный" используется 2 раза приходится создавать 2 закладки (Ответственный", "Ответственный2") и дублировать правила заполнения для этих полей. В данной статье я хочу рассказать каким образом можно создавать только 1 закладку и использовать данные из этой закладки в других местах документа.

22.09.2019    5875    pavelpribytkin96    2    

Как внедрить 1С:Документооборот в условиях хаоса

Управление проектом Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО УУ Бесплатно (free)

Не всегда проекты можно внедрить по заранее спланированному алгоритму. Скорее, даже никогда проекты не удается выполнить по универсальному плану: в каждой конкретной ситуации есть свои сложности и свои проблемы. Опытом внедрения 1C:Документооборот в отсутствии описанных процессов и утвержденной структуры предприятия на конференции поделилась руководитель отдела автоматизации торговой сети РЕМИ Марина Лимонтова (г. Владивосток).

21.08.2019    19885    limm28    16    

Механизм бизнес-событий на конкретном примере

Управление бизнес-процессами (BPM) Документооборот и делопроизводство Документооборот и делопроизводство v8::Бизнес-процессы ДО Россия УУ Бесплатно (free)

Есть в системе 1С:Документооборот механизм бизнес-событий. Когда мне понадобилось решить конкретную задачу, гугление ни к чему конкретному не привело. Хотелось так «вжух» и всё понять про данный механизм, но в итоге пришлось лезть в код 1С и смотреть реализацию данного механизма. В данной публикации поделюсь результатами исследований, может, кому-то это поможет быстро и легко во всём разобраться.

18.02.2019    15531    soulner    1    

Переход на новые форматы ЭДО после 01.07.2017. (использование УПД)

Пользователю системы Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Россия БУ Бесплатно (free)

В статье я постарался кратко расписать, какие варианты обмена ЭДО с контрагентами доступны в 1С (любой конфигурации 1С) по новым форматам. Скрины новых форматов в списке картинок к статье. Добавил исправление поведения УПД при формировании ЭД.

25.07.2017    20578    igo1    12    

1С:Документооборот. Дополнительные обработчики бизнес-событий

Практика программирования Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Бесплатно (free)

Есть ситуации, когда входящее письмо приходит из вышестоящей/контролирующей организации, зачастую со сроком исполнения "завтра". Поэтому разумно было бы в задачах рассмотрения иметь адекватный срок исполнения/рассмотрения. Если задачи рассмотрения создаются автоматически, тогда самым подходящим способом решения данной задачи будет пользовательский обработчик события.

03.05.2017    16110    aabogachev    1    

Добавление произвольной картинки (факсимиле, виза, подпись и т.д.) в шаблон документа (Microsoft Word doc., docx.) для конфигурации 1С: Документооборот 2.1 с минимальными изменениями в конфигурации

Документооборот и делопроизводство Практика программирования Документооборот и делопроизводство v8 ДО Бесплатно (free)

В данном примере представлен небольшой сниппет для добавления картинок (подписи, визы, факсимиле) к шаблону документа (Microsoft Word doc., docx.) в системе 1С: Документооборот 2, используя типовую функцию вставки штрихкода.

28.02.2017    14148    Spartacus    2    

Документооборот: Перепоручить задачу из почты

Практика программирования Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия Бесплатно (free)

Смысл доработки - в письмах-командах добавляется команда-ссылка "Перепоручить". При клике создается письмо, если в копию поставить email пользователей СЭД и отправить письмо, то данная задача будет перепоручена данным пользователям. Удобно для линейных руководителей - получив задачу от СЭД в почту, достаточно двух кликов, чтобы не заходя в 1С, поручить дело подчиненному.

13.02.2017    10295    aabogachev    4    

Управление договорами в 1С:Документооборот

Управление бизнес-процессами (BPM) Документооборот и делопроизводство Пользователю системы Бухгалтерский учет Документооборот и делопроизводство v8 ДО УУ Бесплатно (free)

В 1С:Документооборот в релизах 2.1.7 и 2.1.8 концепция учета договоров продолжила свое развитие (появились стороны договора). Это повлияло и на бизнес-процессы (теперь вместо процесса Утверждение надо пользоваться процессом Подписание для договоров). Рассмотрим основные моменты, на которые надо обратить внимание при внедрении управления договорами в 1С:Документооборот.

24.01.2017    38349    vlush78    0    

Добавление собственных "Автоподстановок" в 1С: Документооборот

Практика программирования Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Бесплатно (free)

При внедрении 1С: Документооборот КОРП, столкнулся с необходимостью добавить свою автоподстановку. Автоподстановок давольно-таки много, но иногда нужно что то не типовое. Так получилось и в данном случае.

27.10.2016    23236    iolko    22    

Настройка бесшовной интеграции 1С: ERP 2.0 и 1С: "Документооборот" КОРП. Варианты реализации бизнес-процессов

Управление бизнес-процессами (BPM) Перенос данных из 1C8 в 1C8 Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО ERP2 ИТ-компания Бесплатно (free)

Данная статья поможет настроить интеграцию 1С ERP и 1С "Документооборот" КОРП по технологии web сервисов. Описывается пошаговая настройка программ, а также приведены примеры процесса согласования договоров продажи контрагентам. Рассмотрены различные варианты реализации процесса согласования. Приведены примеры настроек маршрутизации процесса (условные и безусловные). В статье очень много скриншотов, может, кому-то это не понравится, но без этого считаю, что статья была бы не полной, т.к. описание именно "по шагам".

09.08.2016    88374    iolko    91    

Новое в 1С:Документооборот ред. 2.1

Пользователю системы Управленческий учет (прочее) Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО УУ Бесплатно (free)

Фирма 1С не стоит на месте и продолжает радовать нас своими новыми версиями конфигурации 1С:Документооборот. В конце мая 2016 года вышла новая редакция 2.1, которая содержит как принципиально новые возможности, так и улучшение старых функций. В данной статье будут рассмотрены отличия конфигурации 1С:Документооборот редакции 2.1 по сравнению с редакцией 2.0.

15.06.2016    34000    vlush78    7    

"1С:Договорчики" - инструкция по применению. Часть 1. Начало работы и создание шаблона договора

Бухгалтерский учет Документооборот и делопроизводство Документооборот и делопроизводство v8 УУ Бесплатно (free)

В конце 2015 года фирма "1С" выпустила продукт со скромным названием "1С:Договорчики". У продукта заявлен довольно неплохой функционал, делающий его пригодным для использования в небольших и средних организациях. По продукту мало методического материала. Я попытаюсь восполнить этот пробел несколькими публикациями.

15.02.2016    31739    Birby    31    

Нагрузочное тестирование 1С:Документооборот

Документооборот и делопроизводство Документооборот и делопроизводство Нагрузочное тестирование v8 ДО Бесплатно (free)

Перед запуском 1С:Документооборот для средних и крупных внедрений крайне желательно провести нагрузочное тестирование, чтобы проверить корректность и скорость работы системы электронного документооборота в условиях максимальной нагрузки. В данной статье пойдет речь о том, как провести нагрузочное тестирование в 1С:Документооборот без использования 1С:КИП.

28.12.2015    22125    vlush78    1