Шаблоны медицинских документов (ШМД) для 1С: Медицина поликлиника

21.08.19

Задачи пользователя - Адаптация типовых решений

Обработка предназначена для работы с отраслевым решением "1С: Медицина поликлиника 2.1.4.1". Может быть использована медицинскими организациями в работе врачебного участка при заполнении протокола операции (осмотра пациента) с помощью специально разработанного шаблона медицинского документа.Основана на использовании стандартов медицинской помощи для диагнозов классификатора МКБ10.

Скачать исходный код

Наименование Файл Версия Размер
Обработка "Протокол операций с вложенным ШМД" и шаблоны с загрузкой по медицинскому стандарту по коду МКБ10
.rar 1 004,61Kb
6
.rar Версия 1.2 1 004,61Kb 6 Скачать

1С Медицина поликлиника.

ШМД "Протокол операции".

При внедрении отраслевого решения "1с Медицина поликлиника" наибольшую трудность вызвала работа с механизмом "Шаблоны медицинских документов". Не всегда удобный и достаточный функционал и сложность в поиске справочной информации о возможности доработок привели к созданию собственных ШМД - обработок  для описания результатов протокола операции, врачебного осмотра.  В качестве примера приводится обработка "Протокол операции". Обработка подключается через подсистему «Электронные медицинские карты» (ЭМК) . Добавив ШМД-обработку и назначив ей медицинские услуги, можно использовать ее при исполнении назначенной медицинской услуги в сменном задании врача. (Подробно бизнес процесс формирования талона от регистратуры до врача можно найти на ИТС).  Выбрав талон в сменном задании, с помощью кнопки «Формирование медицинского документа» запускаем обработку. В списке ШМД выбираем "Протокол операции".

В открывшейся форме заполняются обязательные поля,

в разделе «Описание операции», можно добавить или выбрать из справочника графическое описание операции, доработать его с помощью графического редактора.

В разделе «Диагнозы, процедуры» по команде «Заполнить по диагнозу» медицинский документ заполняется назначениями,процедурами, лекарственными средствами из стандартов медицинской помощи. 

С работой данного функционала можно ознакомиться в видео по ссылке  https://youtu.be/XuMd_8Fz5As . После заполнения всех реквизитов формируется текст медицинского документа в виде табличной формы с описанием протокола операции (или осмотра, приема врача).

Основной код формирования вложенного ШМД вынесен в отдельную обработку «ВложенныйШМДДокумент». Для работы вложенного ШМД требуется добавить или отредактировать имеющуюся секцию из подсистемы «ЭМК» структура секций МД. 

Например, можно отредактировать секцию «Рекомендации» («Справочники.СтруктураСекцийМД.Рекомендации»). Можно добавлять свои предопределенные элементы в используемые справочники.

В обработке «Протокол операции» в макете добавлена секция «Схема» и назначены ячейки в области Примечание (см. на рисунке). При добавлениее секции необходимо заполнить CODE SYSTEM = «1.2.643.5.1.13.2.7.1.18»; CODE SYSTEM NAME = «LOINS»; CODE = «L-AMMMM» (код должен быть уникальным).

Вложенный ШМД необходимо подключить в шаблоны медицинских документов.   

 

ШМД Протокол операций шаблоны медицинских документов Медицина поликлиника больница

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4858    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3236    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4320    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2365    dimanich70    8    

14

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2269    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2476    34    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ivan453 11.02.21 06:23 Сейчас в теме
2. mitronov 04.03.21 02:01 Сейчас в теме
для поликлиники 3 есть??
3. roman1981 8 04.03.21 05:43 Сейчас в теме
Под 3 версию текущие шаблоны не тестировал.
4. MAlexey81 18.11.21 17:44 Сейчас в теме
+ Возможно для Поликлиники 3 что-то уже появилось? Лепим в нее функции оперблока, ШМД пришлись бы кстати
5. roman1981 8 19.11.21 08:30 Сейчас в теме
Под Поликлиники 3 я не писал, а что сильно изменился функционал под ШМД?
6. lenokv_07 05.05.23 07:22 Сейчас в теме
Добрый день. Скачала обработку. Пытаюсь переделать для Поликлиника 3. Обработка ВложенныйШМДДокумен.epf пустая.
Вышлите, пожалуйста, правильную.
7. lenokv_07 19.05.23 07:19 Сейчас в теме
Добрый день. Роман. Почти все переделала для Поликлиника 3. Но вот исправленный рисунок не встает в документ. Подскажите, пожалуйста, где вложенный ШМД передает информацию в вызывающий его документ?
8. jan-pechka 416 24.01.24 14:33 Сейчас в теме
Когда устанавливается дистрибутив 1с.Больница, то в папочку складываются готовые от 1с-разработчиков все возможные виды ШМД, на их основе проще разработать/доработать свой ШМД.
C:\Users\Пользователь\AppData\Roaming\1C\1cv8\tmplts\informed\­hospital\2_0_8_1\ExtFiles\ПримерыШМД
в архиве ниже,например, примеры ШМД для профОсмотров
Прикрепленные файлы:
ШМД для профосмотров.rar
9. lenokv_07 31.01.24 09:25 Сейчас в теме
(8)У вас получилось сделать вложенный шмд с картинкой ?
10. jan-pechka 416 02.02.24 13:18 Сейчас в теме
(9)пока не нужно было...обычную обработку-ШМД с макетом "Протокол консультации(ред.3)" сделала и все. Для откатки в тестовой среде РЭМД этого достаточно.
Но в примерах обработокШМД есть код для вставки картинки:
#Область РаботаСИзображениямиШМД
&НаКлиенте
Процедура ВставитьИзображение(Файл, ИмяФайла, Миме, ОписаниеФайла) Экспорт
КонецПроцедуры
&НаКлиенте
Функция ПолучитьСписокИзображений() Экспорт
	Возврат Неопределено;
КонецФункции
&НаКлиенте
Процедура УдалитьИзображение(Файл) Экспорт
КонецПроцедуры

Функция СтандартноеПрикреплениеИзображений() Экспорт
	Возврат Истина;
КонецФункции
#КонецОбласти 
Показать


А отрабатывает их сам механизм "ШаблоныМедицинских документов": сначала создает команду Картинок (это если в Проц.Оповещение передадите параметр Картинка), а потом сам же и отрабатывает, н-р, в общ.модуле ШаблоныМедицинскихДокументовПереопределяемыйКлиент:
Процедура ОбработкаОповещения(Форма, ИмяСобытия, Параметр, Источник) Экспорт
	
	Если ИмяСобытия = ОповещенияФорм.ПослеДобавленияФайловКОбъекту()
		И Источник = Форма.ВладелецФормы И НЕ Форма.ШМДДеактивирован
	Тогда
		// из за различного интерфейса у веб-ШМД и обработок-ШМД
		Попытка
			СсылкаШМД = Форма.ШМД.Ссылка;
		Исключение
			СсылкаШМД = Форма.ШМДСсылка;
		КонецПопытки;
	
		Если ТипЗнч(Параметр) = Тип("Структура") И Параметр.Свойство("НовыеФайлы") Тогда
			НовыеФайлы_ = Параметр.НовыеФайлы;
			
			Если ТипЗнч(НовыеФайлы_) = Тип("Массив") 
				И Истина = ШаблоныМедицинскихДокументов.ПолучитьПараметрОписанияШМД(СсылкаШМД, "ПрикреплениеИзображенийИФайлов")
			Тогда
				Для Каждого Файл_ Из НовыеФайлы_ Цикл
					Попытка
						ФайлОб_ = ШаблоныМедицинскихДокументовПоликлиника.ПолучитьИнформациюОФайле(Файл_);
						Форма.ВставитьИзображение(
							ФайлОб_.Идентификатор, 
							ФайлОб_.ИмяФайла,
							ФайлОб_.МИМЕТип,
							ФайлОб_.Описание
						);
					Исключение
					КонецПопытки;
				КонецЦикла;
			КонецЕсли;
		КонецЕсли;

		Если ТипЗнч(Параметр) = Тип("Структура") И Параметр.Свойство("УдаленныеФайлы") 
			И Истина = ШаблоныМедицинскихДокументов.ПолучитьПараметрОписанияШМД(СсылкаШМД, "ПрикреплениеИзображенийИФайлов")
		Тогда
			УдаленныеФайлы_ = Параметр.УдаленныеФайлы;
			
			Если ТипЗнч(УдаленныеФайлы_) = Тип("Массив") Тогда
				Для Каждого Файл_ Из УдаленныеФайлы_ Цикл
					Попытка
						Форма.УдалитьИзображение(
							ШаблоныМедицинскихДокументовПоликлиника.ПолучитьИнформациюОФайле(Файл_).Идентификатор
						);
					Исключение
					КонецПопытки;
				КонецЦикла;
			КонецЕсли;
		КонецЕсли;

	ИначеЕсли ИмяСобытия = ОповещенияФорм.ПослеЗаписиВОбработкеФормированиеМедицинскихДокументов() 
		И Источник = Форма.ВладелецФормы И НЕ Форма.ШМДДеактивирован
	Тогда
		Если Не ЗначениеЗаполнено(Форма.ШМД.ИдентификаторДокумента) Тогда
			Форма.ШМД.ИдентификаторДокумента = Параметр.МД.Ссылка;
		КонецЕсли;
		
		Если ОбщегоНазначенияКлиентСервер.ЕстьРеквизитИлиСвойствоОбъекта(Форма, "МедицинскийДокумент")
			И Не ЗначениеЗаполнено(Форма.МедицинскийДокумент)
		Тогда
			Форма.МедицинскийДокумент = Параметр.МД.Ссылка;
		КонецЕсли;
		
		// обновление назнчений и диагнозов в ШМД после записи документа
		Форма.СерверныйВызов("ПослеЗаписиВОбработке");
	КонецЕсли;

КонецПроцедуры
Показать
11. lenokv_07 07.02.24 19:10 Сейчас в теме
А как вам удалось подключиться к тестовой РЭМД?
12. jan-pechka 416 14.02.24 07:43 Сейчас в теме
(11)Напрямую. Подаете заявление в РЭМД и вперед. Главное, это чтобы 1с.Больница была 2 версии - там встроен уже механизм обмена с минздравом - > опубликовываете в Больнице 2.0 ее типовой http-сервис "ФедеральныеВебСервисы" и все - проходите тесты, которые задает тех.поддержка РЭМДа)) Мы тестовую среду РЭМДа прошли, сейчас ломаем голову над промышленной средой - там условие жесткой аппаратной защиты......Но в любом случае - 1с - это не промед - все решаемо))
13. lenokv_07 21.02.24 20:39 Сейчас в теме
в тест и продукт фрмо и фрмр зарегистрированы.
Дальше нужно мис зарегистрировать
а что писать в строках
Идентификатор ИС в ИПС
Адрес сервиса ИС в ИПС (указывается адрес сервиса в тестовой/промышленной среде ИПС соответственно, например- https://ips.rosminzdrav.ru/buAh1zqx5w )
нигде найти не могу, подскажите пожалуйста
14. jan-pechka 416 09.04.24 13:35 Сейчас в теме
(13)вот здесь подробно описала муки с РЭМДом
Оставьте свое сообщение