Вес номенклатуры в документе "Заказ клиента", УТ 11.5

25.06.24

Учетные задачи - Логистика, склад и ТМЦ

Пример реализации вывода веса номенклатуры в табличную часть "Товары" заказа клиента в УТ 11.5 при помощи расширения (все необходимые реквизиты созданы программно).

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Вес номенклатуры в документе "Заказ клиента" конфигурация УТ 11.5:
.cfe 57,51Kb
1
1
5 SM
Скачать Купить за 3 050 руб.

       Доброго времени суток, в данном примере я продемонстрирую свое решение вот такой задачи - необходимо вывести вес номенклатуры в табличную часть документа "Заказ клиента", реквизиты должны быть созданы программно, вес пересчитывается при изменении количества, номенклатуры или упаковки, в подвале документа выводится итоговый вес.

 

1. Создаем программно новые реквизиты, поля формы документа и устанавливаем действие для нового реквизита "вес"

 

Процедура ДобавитьРеквизитыВеса()
	МассивДобавляемыхРеквизитов = Новый Массив;	
	 
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Вес",                   Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(15,3)), 
					"Объект.Товары", "Вес")); 
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ВесИтого",              Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(15,3)), 
					"", "Итого вес", Ложь)); 
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Объем",                 Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(15,3)),
					"Объект.Товары", "Объем"));
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ВесУпаковки",           Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(18,9)),
					"Объект.Товары", "Вес упаковки"));
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ОбъемУпаковки",          Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(18,9)),
					"Объект.Товары", "Объем упаковки"));
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ЕдиницаИзмеренияВеса",  Новый ОписаниеТипов("СправочникСсылка.УпаковкиЕдиницыИзмерения"), 
					"Объект.Товары", "Единица измерения веса"));
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ЕдиницаИзмеренияОбъема",Новый ОписаниеТипов("СправочникСсылка.УпаковкиЕдиницыИзмерения"), 
					"Объект.Товары", "Единица измерения объема"));  
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ТипИзмеряемойВеличины", Новый ОписаниеТипов("ПеречислениеСсылка.ТипыИзмеряемыхВеличин"), 
					"Объект.Товары", "Единица измерения объема"));
				
	ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);  
	
	
	//Добавляем поле в табличную часть документа
	
	ЭлементВес = Элементы.Вставить("Вес", Тип("ПолеФормы"), Элементы.Товары,Элементы.ТоварыУпаковкаЕдиницаИзмерения); 
	ЭлементВес.Заголовок = "Вес"; 
	ЭлементВес.ПутьКДанным = "Объект.Товары.Вес"; 
	ЭлементВес.Вид = ВидПоляФормы.ПолеВвода;   
    ЭлементВес.ПропускатьПриВводе=Истина;
	ЭлементВес.УстановитьДействие("ПриИзменении","Расш1_ТоварыВесПриИзменении");   
	
	//Добавляем поле в подвал формы    
	
	ЭлементВес = Элементы.Вставить("ВесИтого", Тип("ПолеФормы"), Элементы.ГруппаПодвал); 
	ЭлементВес.Вид = ВидПоляФормы.ПолеНадписи;
	ЭлементВес.ПутьКДанным = "ВесИтого";    
	
	
    
КонецПроцедуры	

 

 

2. В расширении переопределяем обработчики событий элементов форм и вставляем необходимый код

&НаКлиенте  
&ИзменениеИКонтроль("ТоварыНоменклатураПриИзменении")
Процедура Расш1_ТоварыНоменклатураПриИзменении(Элемент)
	////////////////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////////////////////
	#Вставка
	СтруктураДействий.Вставить("ЗаполнитьПризнакТипИзмеряемойВеличины", Новый Структура("Номенклатура", "ТипИзмеряемойВеличины"));
	СтруктураДействий.Вставить("ЗаполнитьВесУпаковки",Новый Структура("Номенклатура, Упаковка", "ВесУпаковки"));
	СтруктураДействий.Вставить("ЗаполнитьОбъемУпаковки",Новый Структура("Номенклатура, Упаковка", "ОбъемУпаковки"));
	СтруктураДействий.Вставить("ЗаполнитьЕдиницуИзмеренияВеса",Новый Структура("Номенклатура, Упаковка", "ЕдиницаИзмеренияВеса"));
	СтруктураДействий.Вставить("ЗаполнитьЕдиницуИзмеренияОбъема",Новый Структура("Номенклатура, Упаковка", "ЕдиницаИзмеренияОбъема"));
	СтруктураДействий.Вставить("ПересчитатьВесОбъем");
	#КонецВставки
	
	//////////////////////////////////////////////////////////////////////////////////////////////
/////////////////////////////////////////////////////////////////////////////////////////////////

КонецПроцедуры


Подобные изменения необходимо внести в ряд процедур обработчиков событий (при изменении количества, единицы измерения).

 

3. Описываем процедуру обработчика события для созданного реквизита "Вес"

&НаКлиенте
Процедура Расш1_ТоварыВесПриИзменении()

	СтруктураДействий = Новый Структура;
	СтруктураДействий.Вставить("ПересчитатьКоличествоУпаковокПоВесу");
	
	ТекущаяСтрока = Элементы.Товары.ТекущиеДанные;
	
	ОбработкаТабличнойЧастиКлиент.ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);
    РассчитатьИтоговыеПоказателиЗаказа(ЭтаФорма);

КонецПроцедуры

 

Проверено на следующих конфигурациях и релизах:

  • Управление торговлей, редакция 11, релизы 11.5.17.90, 11.5.17.84

УТ11 вес заказ клиента

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93531    119    40    

210

Логистика, склад и ТМЦ Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа позволяет организовать учет ответственного хранения товаров с весовыми характеристиками, в том числе со сроком годности и личным кабинетом Поклажедателя. Модуль реализован в виде расширения конфигурации, устанавливается в режиме 1С:Предприятие 8 за 5 минут по инструкции, что позволяет оставить конфигурацию 1С на стандартной поддержке и продолжать получать стандартные обновления от фирмы "1С".

60000 руб.

09.06.2020    36473    32    59    

61

SALE! %

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 27000 руб.

24.04.2015    192472    141    241    

272

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5143    11    5    

20

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Бухгалтер Пользователь Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 10.07.2024, версия 9.8 - 9.11)

14400 руб.

20.11.2015    153504    373    376    

507
Оставьте свое сообщение