Отчёт по просроченной дебиторской задолженности для бухгалтерии (ФИФО)

21.11.14

Учетные задачи - Взаиморасчеты

Просроченная дебиторская задолженность по регистру бухгалтерии по 62-му счёту. Оплаты распределяются по методу ФИФО.

Скачать исходный код

Наименование Файл Версия Размер
ОтчётПоПросроченнойЗадолженности_БП_ФИФО.erf
.erf 19,88Kb
120
.erf 1 19,88Kb 120 Скачать
  • Отчёт на СКД.
  • По регистру бухгалтерии Хозрасчётный.
  • По 62-му счёту (при желании можно переделать на 60-й счёт).

Оплата покупателей распределяется на документ расчётов по методу ФИФО.

Алгоритм взят из следующих публикаций:

//infostart.ru/public/75089/ - для БП 2.0

//infostart.ru/public/122490/ - для УТ 10.3

 

Будет полезен, если:

  • не ведутся взаиморасчёты по документам расчёта (то есть на 62-м только субконто контрагент и договор).
  • ведутся взаиморасчёты по документам расчёта, но последовательность не восстановлена и невозможно добиться каждодневного восстановления последовательности. Так как после восстановления последовательности распределение долга по документам скорее всего будет меняться.
  • если невозможно получить данные из регистров накопления, например, есть ручные корректировки 62-го счёта
Особенности
  • Отчёт создавался для коплексной конфигурации, поэтому количество дней просрочки задаётся как дополнительное свойство договора контрагента "Дней отсрочки". Это свойтво нужно создать вручную, либо доработать отчёт.
  • В отчёт попадают авансы, как отрицательный долг, даже если документов, увеличивающих долг не было. Таким образом отчёт полностью сходится с ОСВ по 62-му.

Скорость работы
Зависит от объёма данных.
На тестовой базе заказчика формируется 3 секунды по всем контрагентам.
Для сравнения отчёт из публикации //infostart.ru/public/75089/ формируется 1-1.5 минуты.

Просрочка Дебиторка Дебиторская Задолженность Просроченная ФИФО Бухгалтерия

См. также

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191687    135    239    

270

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22757    186    7    

167

УТ 11, КА 2, ERP 2: Настраиваемые под каждую организацию печать и подпись ответственных лиц в печатных формах (ТОРГ-12, Счёт-фактура, УПД, УКД, Заказ клиента, Акт сверки, М-15 и др.)

Печатные формы Взаиморасчеты Оптовая торговля Производство готовой продукции (работ, услуг) Акт сверки Бухгалтер Пользователь Оперативный учет Управляемые формы 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Задайте для каждой организации свою печать и для каждого физического лица свою подпись. Выберите в документе печатную форму "... с печатью и подписью" - и автоматически сформируется табличный документ с печатью и подписями той организации и ответственных лиц, которые указаны в документе.

12000 руб.

13.03.2018    57332    187    76    

117

Автоматический зачет авансов в 1С:УНФ по ФИФО

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Знаем о взаиморасчетах в Управлении нашей фирмой все, что только можно знать. Самая большая проблема взаиморасчетов в УНФ в том, что зависают непонятные долги и предоплаты, в Пульсе бизнеса показываются неадекватные цифры, отчеты по долгам показывают не пойми что. Автоматический зачет авансов в 1С:УНФ поможет решить эту проблему.

12000 руб.

22.07.2021    24034    27    34    

33

Дебиторская задолженность по срокам долга

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Один из лучших вариантов отчета по дебиторской задолженности. Отображает сроки возникновения задолженности, просроченной задолженности с точностью до регистратора, а также многое другое, вне зависимости от схемы взаиморасчетов (online / offline) и объекта расчетов (УТ 11.3, 11.4, 11.5, КА 2.4, 2.5, ERP 2.4, 2.5), состояния флажка "по документам расчета" ( УТ 10, КА 1.1, УПП 1.3) в договоре. Группирует задолженность по интервалам. Имеет большое количество настроек. Не требует доработок конфигурации.

15120 руб.

28.09.2012    95246    590    281    

141

Перенос начальных остатков из Парус 7.71 в БГУ

Внешние источники данных Взаиморасчеты Учет ОС и НМА Логистика, склад и ТМЦ Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 1С:Бухгалтерия государственного учреждения Государственные, бюджетные структуры Россия Бюджетный учет Абонемент ($m)

Перенос словарей и начальных остатков из ПП Парус-Бухгалтерия Бюджет 7.71 в 1Сv8 БГУ2. Заполнение словарей и документов по вводу начальных остатков. Не требуется установка ПП Парус7. Возможна дозагрузка. Позволит автоматически ввести основные данные в программу для начала работы. 

10 стартмани

08.12.2011    81899    4    Skaredov    124    

147

Отчеты по расчетам с контрагентами для 1С:Бухгалтерии

Взаиморасчеты Бизнес-аналитик Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Внешние управленческие отчеты показывают дебиторскую и кредиторскую задолженность при расчетах с контрагентами – подробно и в различных разрезах, в том числе по срокам долга.

3600 руб.

13.01.2023    7108    11    9    

10
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ildarovich 7883 24.11.14 12:36 Сейчас в теме
У меня вопрос:
Будет полезен, если:

не ведутся взаиморасчёты по документам расчёта (то есть на 62-м только субконто контрагент и договор).
а разве такое когда-нибудь бывает?
2. AZel84 51 24.11.14 13:12 Сейчас в теме
(1) ildarovich, если это не риторический вопрос :), то вот скрин из БП 3.0
3. ildarovich 7883 24.11.14 14:48 Сейчас в теме
(2) ничего из этого скрина не понял. На мой взгляд, он показывает, что третье (документы взаиморасчетов) субконто на 62-м счете есть. Его нельзя отключить в настройках. Значит, взаиморасчеты по документам ведутся в БП всегда и отчет по ФИФО в этой конфигурации не нужен.
Вопрос не риторический. Я хотел свою разработку ускоренного ФИФО применить в БП, но решил, что там этот метод будет бесполезен, поскольку незакрытые отгрузки видны сразу из ОСВ по счету. А значит, просроченные долги определяются очень просто без всякого ФИФО.

Ну и лозунги на скриншоте абсолютно неуместны в контексте данного обсуждения.
4. CheBurator 3123 24.11.14 16:19 Сейчас в теме
(3) По моему можно отключить ведение взаиморасчетов в разрезе расчетных документов.
5. ildarovich 7883 24.11.14 16:27 Сейчас в теме
(4) CheBurator, в Бухгалтерии 2.0 и Бухгалтерии 3.0 такой возможности я не нашел.
6. AZel84 51 24.11.14 18:11 Сейчас в теме
(5) ildarovich, ведение взаиморасчётов в разрезе расчётных документов явно в БП не отключается. Это зависит от учётной политики организации, а именно от способа оценки стоимости МПЗ при выбытии (на закладке запасы). Там 2 варианта "по средней" и "ФИФО". Если ведётся "по средней", то 3-е субконто будет оставаться пустым при проведении документов.
Кстати в метаданных конфигурации изначально не заполнено 3-е субконто на 60-м и 62-м. Оно заполняется при создании новой базы и отключить его заполнение нельзя. По коду видно, что ранее это субконто заполнялось только если для любой из организаций выбран способ "ФИФО".

Отчёт писался для комплексной конфигурации 1.1.48.1 релиза. В базе 3-е субконто пустое. Кстати не смотря на то, что выбран способ "ФИФО"...

В общем для БП такой отчёт может понадобиться, если не ведётся учёт в разрезе расчётных документов (выбран способ учёта "по средней").
7. ildarovich 7883 24.11.14 20:05 Сейчас в теме
(6) я еще проверю, но пока кажется, что способ оценки стоимости МПЗ при выбытии не должен влиять на проведение документов по 62-му счету.
Какая тут связь?
Теоретически это скорее относится к 10, 41, 43-му. Там тоже есть третье субконто. Которое может быть пустым при проведении по этим счетам, но не по 62-му.
Там это субконто всегда задействовано (не бывает пустым).
А то, что оно пустое в комплексной, легко объяснимо, так как там учет взаиморасчетов сделан на регистрах накопления и третье субконто не нужно.
Так что пока остаюсь при своем мнении - для типовых конфигураций бухгалтерий 2.0 и 3.0 отчет "взаиморасчеты по ФИФО" не нужен.
8. AZel84 51 25.11.14 05:25 Сейчас в теме
(7) ildarovich, действительно, вчера вечером уже смотрел, ошибся. Настройка в запасах никак не влияет на взаиморасчёты (это и логично). Так что, похоже вы правы, для типовых БП отчёт в этом виде не нужен.
Ещё раз повторюсь, делал для комплексной, причём для такой, где иначе отчёт написать было нельзя.
9. AZel84 51 25.11.14 08:22 Сейчас в теме
Вообще меня смутил этот код:

Функция ПроверитьАналитикуПередЗаписью()
	
	Если СпособОценкиМПЗ = Перечисления.СпособыОценки.ФИФО Тогда
		
		// Проверка ведения партионного учета
		Сч41 = ПланыСчетов.Хозрасчетный.Товары.ПолучитьОбъект();
		ПартионныйУчет = ?(Сч41.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Партии, "ВидСубконто") = Неопределено, Ложь, Истина);
		
		Сч60 = ПланыСчетов.Хозрасчетный.РасчетыСПоставщиками.ПолучитьОбъект();
		УчетПоРасчетнымДокументам = ?(Сч60.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ДокументыРасчетовСКонтрагентами, "ВидСубконто") = Неопределено, Ложь, Истина);

		Если НЕ ПартионныйУчет ИЛИ НЕ УчетПоРасчетнымДокументам Тогда
			
			Если НЕ РольДоступна("ПолныеПрава") Тогда
				
				Предупреждение("Для указанных параметров учетной политики необходимо включаение дополнительных разрезов аналитического учета.
								|Недостаточно прав для изменения разрезов аналитического учета. Учетная политика не может быть записана!");
								
				Возврат Истина;
				
			КонецЕсли;
			
			Если НЕ ПартионныйУчет Тогда
				ТекстСообщения = " партионный учет МПЗ.";
			КонецЕсли;			
			Ответ = Вопрос("Для указанных параметров учетной политики необходимо включить дополнительные разрезы аналитического учета.", РежимДиалогаВопрос.ОКОтмена, , КодВозвратаДиалога.ОК, "");

			Если Ответ = КодВозвратаДиалога.ОК Тогда
				Если НЕ ПартионныйУчет Тогда
					СкладскойУчет = НЕ (Сч41.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады, "ВидСубконто") = Неопределено);
					СуммовойУчет = ?(СкладскойУчет, Сч41.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады, "ВидСубконто").Суммовой, Ложь);
					ОбщегоНазначения.ПрименитьПараметрыАналитикиМПЗ(Истина, СкладскойУчет, СуммовойУчет,);
				КонецЕсли;
				
				Если НЕ УчетПоРасчетнымДокументам Тогда
					ОбщегоНазначения.ПрименитьПараметрыАналитикиРасчетов(Истина,);
				КонецЕсли;
				
			Иначе
				Возврат Истина;
			КонецЕсли;
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции
Показать


Эта процедура вызывается при записи учётной политики.
Выполняется процедура ОбщегоНазначения.ПрименитьПараметрыАналитикиРасчетов(Истина,)
Если СпособОценкиМПЗ = Перечисления.СпособыОценки.ФИФО
10. AZel84 51 27.11.14 14:02 Сейчас в теме
Ещё вспомнил немаловажный момент. Учёт на 62-м счёте в разрезе документов расчётов ведётся при условии корректно восстановленной последовательности документов.
Восстановление последовательности часто проводится лишь при закрытии месяцев. Следовательно данные в подобных отчётах могут постоянно меняться. При расчёте долга по ФИФО изменения в отчёте отражаются сразу, так как распределение оплат происходит каждый раз заново.
Так что даже при наличии 3-го субконто, отчёт имеет место быть.

Так же обнаружил ещё одну базу БП 2.0, где учёт по документам расчёта не ведётся.
11. @Sonya 27 04.02.15 15:13 Сейчас в теме
Отчет работает как надо, спасибо. Применяю на СКАТе.
Замечания:
1) Если по документу просрочки еще нет, отрицательное число хорошо бы обнулить
2) Если задолженность отрицательная, можно было бы ее не показывать. Мы ведь дебиторку подразумеваем?
(у себя исправила)
12. Salty 12 01.10.15 09:24 Сейчас в теме
Очень полезный отчет, работает замечательно. Большое спасибо.
13. AnneF 54 13.11.15 21:30 Сейчас в теме
Как вставить "Дней отсрочки" для БУ 2.0. Из справочника Договора не берется.
14. AnneF 54 22.11.15 22:39 Сейчас в теме
Для бухгалтерии 3.0 совсем не работает
15. olegale 15.01.16 15:52 Сейчас в теме
Как я понял работает только от календарных дней отсрочки.А как же рабочие дни?
16. AZel84 51 15.01.16 21:44 Сейчас в теме
(15) olegale, да, только количество дней отсрочки. Для нужд многих клиентов этого достаточно.
Можете доработать. Использовать производственный календарь, который должен быть заполнен. Примеры на инфостарте есть.
17. zmo 20.04.16 17:06 Сейчас в теме
Для 1С 8.2 Бухгалтерия предприятия, редакция 2.0 (2.0.65.7)
не подтягивается "Дней отсрочки"

как быть?
18. SlaSla 29 10.08.16 22:13 Сейчас в теме
Возвраты каким образом отображаются в этом отчете?
19. Degtjarev 21.11.17 10:35 Сейчас в теме
Таблица не найдена : РегистрСведений.ЗначенияСвойствОбъектов
БП КОРП (3.0.49.28) 1С:Предприятие 8.3 (8.3.9.2233)
Как это исправить ??
Прикрепленные файлы:
Оставьте свое сообщение