Табель учета рабочего времени или как создать календарик в табличной части документа

24.08.18

Задачи пользователя - Адаптация типовых решений

Мой велосипед по созданию документа учета рабочего времени. Обработка предназначена для Управляемых форм, тестировалась на Управление нашей фирмой, редакция 1.6 (1.6.10.44),1С:ERP Управление предприятием 2 (2.4.4.124) платформы (8.3.12.1412),(8.3.11.2867)

Скачать исходный код

Наименование Файл Версия Размер
Табель учета рабочего времени или как создать календарик в табличной части документа:
.epf 12,45Kb
3
.epf 12,45Kb 3 Скачать

Итак...поступила мне задача - создать документ где можно выставить явку или не явку человека на рабочее место, делать особо было нечего и я решил не глядя на стандартные ЗУПы и т.д. написать все с нуля.

Во первых потому что в стандартных конфигах пока разберешься голову сломаешь, а во вторых стало интересно как это можно реализовать.

Итак ближе к делу - 

1) Создал документ и накидал в него реквизиты - все на скринах.

2)Создал форму дока и вот тут стало интересно - необходимо было вывести в заголовке столбца день недели и дату в зависимости от текущего месяца, да и еще раскрасить выходные красненьким.

Сделал так - 

&НаСервере
Процедура РасставитьДаты(ДатаДока)
СброситьВидимостьИЦвета(); // Скрываем все колонки и делаем в всех серый цвет
	Год = Формат(Год(ДатаДока),"ЧГ="); // Выбираем год
	Месяц = Формат(Месяц(ДатаДока),"ЧЦ=2; ЧВН="); // Выбираем месяц
	Для Сч = 1 По День(КонецМесяца(ДатаДока)) Цикл //Запускаем цикл по количество дней в месяце
	Число = Формат(СЧ,"ЧЦ=2; ЧВН="); // выбираем число
	ДатаДня = Дата(""+Год+""+Месяц+""+Число); // получаем дату
	ДеньНедели = Перечисления.ДниНедели.Получить(ДеньНедели(ДатаДня)-1); // получаем день недели
	НазваниеРеквизита = "ДоскаДень" + СЧ; // Получаем имя столбца
	Элементы[НазваниеРеквизита].Заголовок = ""+ ДеньНедели + "" + Символы.ПС + Число; //устанавливаем название столбца
	Элементы[НазваниеРеквизита].Видимость = Истина;// делаем столбец видимым
	Если ДеньНедели(ДатаДня) = 6 Или ДеньНедели(ДатаДня) = 7 Тогда // раскрашиваем выходные
	Элементы[НазваниеРеквизита].ЦветФона = WebЦвета.Красный;	
		КонецЕсли;
		КонецЦикла;	
КонецПроцедуры
&НаСервере
Процедура СброситьВидимостьИЦвета()
Для Сч = 1 По 31 Цикл
НазваниеРеквизита = "ДоскаДень" + СЧ;
Элементы[НазваниеРеквизита].Видимость = Ложь;
Элементы[НазваниеРеквизита].ЦветФона = WebЦвета.Серый;
	КонецЦикла;
	КонецПроцедуры

&НаКлиенте
Процедура ДатаПриИзменении(Элемент)
	РасставитьДаты(Объект.Дата);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	Если Не Параметры.Ключ.Пустая() Тогда
	РасставитьДаты(Объект.Дата);	
	Иначе
	РасставитьДаты(ТекущаяДата());	
	КонецЕсли;
	
КонецПроцедуры

Приведен полный код обработки.

календарь сотрудники учет рабочего времени

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4868    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3242    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4349    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2413    dimanich70    8    

15

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2277    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2490    34    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. jaroslav.h 180 30.08.18 18:13 Сейчас в теме
Делал похожее, только з программным добавление реквизитов формы.

Геморй еще тот.
2. Doreng 27 31.08.18 00:44 Сейчас в теме
(1)этот код не под обработку, а под расширение, тоесть сохраняет данные, просто не смог статьей оформить
3. fixin 4256 11.08.21 10:25 Сейчас в теме
Надо было бы заюзать производственный календарь, а не тупо 7-й день недели красным красить.
4. пользователь 03.05.24 18:14
Сообщение было скрыто модератором.
...
Оставьте свое сообщение