ЗиК 314 Отчет по перечислению НДФЛ в бюджет

29.03.12

Учетные задачи - Зарплата

Отчет о перечисленных суммах НДФЛ. Показывает суммы исчисленных, удержанных, перечисленных налогах по разным ставкам и остаток, если не все налоги удалось правильно перечислить.
Исправлена ошибка по дате периода документов.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
ВедомостьНДФЛ.ert
.ert 80,50Kb
93
93
1 SM
Скачать Купить за 1 850 руб.

Отчет о перечисленных суммах НДФЛ. Показывает суммы исчисленных, удержанных, перечисленных налогах по разным ставкам и остаток если не все налоги удалось правильно перечислить.
Подразумевается, что налоги перечисляются в текущем месяце и месяце следующем за расчетным периодом. Т.е. в отчет попадают документы перечисления НДФЛ с налогами периода ЯНВАРЬ, которые введены по дате в январе или феврале. Для ввода использовалась измененная процедура стандартного документа "Перечисление НДФЛ в бюджет". //infostart.ru/public/86020/

См. также

Зарплата Перенос данных 1C Программист Бухгалтер Бухгалтерский учет 7.7 Сложные периодические расчеты 1С:Бухгалтерия 7.7 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Как известно, Бухгалтерия 7.7 не имеет штатной возможности для обмена с ЗУП 3.1. Данная разработка пригодится тем, кто перешел с ЗиК 2.3 на ЗУП 3.1, но вынужден по каким-то своим причинам оставаться на Бухгалтерии 7.7.

18000 руб.

29.09.2020    13682    2    0    

5

Зарплата Бухгалтер Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Украина Бухгалтерский учет НДФЛ Абонемент ($m)

Просто запустим обработку. Файл "СтавкиНалоговЗарплата2014.ert" - выполнить.

1 стартмани

22.01.2014    28549    2    kompas-dm    1    

1

Зарплата Бухгалтер Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Производство+Услуги+Бухгалтерия 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Платные (руб)

Новая справка для расчета пособий по временной нетрудоспособности в соответствии с приказом Министерства труда и социальной защиты № 182Н от 30.04.2013 года (учитывая изменения вплоть до 2017 года). Справку необходимо выдавать на руки при увольнении сотрудника. Может помочь при расчете среднего заработка при нетрудоспособности сотрудников. Будет незаменимым помощником для бухгалтеров, осуществляющих расчеты по заработной плате, при отсутствии специализированной программы.

2000 руб.

03.08.2013    81486    31    21    

39

Регламентированный учет и отчетность Зарплата Бухгалтер Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Абонемент ($m)

При подготовке к сдаче отчета в ПФР столкнулся с тем, что программа не учитывает переплату - не распределяет сумму уплаченных взносов, превышающую начисленную, даже если это оплата проходит в январе 2013 за декабрь 2012. В случае, когда есть долг по оплате на начало периода (например, за декабрь 2012 платят в январе 2013) сумма уплаченных взносов может быть больше суммы начисленных. Программа же ставит сумму уплаченных взносов равную сумме начисленных. В этой обработке распределяются суммы уплаченных взносов, превышающих начисленные, а так же внесены исправления, связанные с возможными ошибками при формировании штатной обработки из 335 релиза (в пачки попадали ненужные уволенные, неправильно распределялись уплаты взносов, при выгрузке в файл возникали ошибки).

1 стартмани

20.04.2013    31043    425    mirrr    65    

41

Зарплата Бухгалтер Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Для бухгалтера : удобный отчет по начислениям-выплатам-удержаниям И повод задуматься о переходе на ЗУП Для программиста : удобный инструмент сверки данных при переходе с 1С:Бухгалтерии 7.7 на 1С:ЗУП 2.5

4 стартмани

01.03.2013    37478    87    Designer1C    7    

10
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. TrinitronOTV 15 10.10.11 18:20 Сейчас в теме
2. rimma_n 160 11.10.11 11:18 Сейчас в теме
Огромный ----------! обработка не работает!!! Автор тупо скопировал куски из разных обработокэ Поясняю:

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(РасчВед)
|Период с НачПериода по КонПериода;
|Сотрудник = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект;
|ФизЛицо = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект.ОсновнойЭлемент;
|Должность = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект.ОсновнойЭлемент.Должность;
|Подразделение = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект.ОсновнойЭлемент.Подразделение;
|Расчет = ЖурналРасчетов."+ЖурналДляЗапроса+".ВидРасч;
|Результат = ЖурналРасчетов."+ЖурналДляЗапроса+".Результат;
|Функция НДФЛ = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛ);
|Функция НДФЛУд = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛУдержанный);
|Функция НДФЛсД = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛсДивидендов);
|Функция НДФЛсДУд = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛсДивидендовУдержанный);
|Функция НДФЛпо35 = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛпо35процентов);
|Функция НДФЛпо35Уд = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛпо35процентовУдержанный);";
ТекстЗапроса = ТекстЗапроса + "
|Группировка ФизЛицо без групп;";

Это первый запрос - собираются начисленный НДФЛ. Группировка по ФизЛицо!

..................

далее запрос по документу Перечисление НДФЛвБюджет:

ЗапросКДокументам = СоздатьОбъект("Запрос");
НачалоПериода = НачМесяца(ДатаАктуальности);
КонецПериода = КонМесяца(ДатаАктуальности);
//Перечисления могут быть в следующем месяце по дате документа но Месяц налогового периода другой
КонецПериодаПлюс = КонМесяца(ДОБАВИТЬМЕСЯЦ(ДатаАктуальности,1));
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с НачалоПериода по КонецПериодаПлюс;
|Обрабатывать НеПомеченныеНаУдаление;
|ДокументПеречНДФЛ = Документ.ПеречислениеНДФЛВБюджет.ТекущийДокумент;
|Сотрудник = Документ.ПеречислениеНДФЛВБюджет.Сотрудник;
|Подразделение = Документ.ПеречислениеНДФЛВБюджет.Сотрудник.Подразделение;
|СтавкаДок = Документ.ПеречислениеНДФЛВБюджет.Ставка;
|СуммаДок = Документ.ПеречислениеНДФЛВБюджет.Сумма;
|Функция ПеречисленоНДФЛ = Сумма(СуммаДок) когда ((СтавкаДок=13)или(СтавкаДок=30)) ;
|Функция ПеречисленоНДФЛсД = Сумма(СуммаДок) когда ((СтавкаДок=9)или(СтавкаДок=15)) ;
|Функция ПеречисленоНДФЛ35 = Сумма(СуммаДок) когда (СтавкаДок=35);
|Группировка Сотрудник;
|Условие(ДокументПеречНДФЛ.МесяцНалоговогоПериода = КонецПериода);
|Условие(Сотрудник в СписокСотров);
|"//}}ЗАПРОС
;

1 ошибка.Обратите внимание - группировка по Сотрудник! напоминаю - Физлицо из первого запроса - это Сотрудник.Основной элемент.

2 ошибка. Условие(ДокументПеречНДФЛ.МесяцНалоговогоПериода = КонецПериода)
Если посмотреть документ ПеречислениеНДФЛВБюджет, то там МесяцНалоговогоПериода - это начало периода.
т.е. документы не находятся в любом случае. а если и найдутся(!?), то далее

Пока ТаблицаНДФЛ.ПолучитьСтроку() =1 Цикл
Сотр = ТаблицаНДФЛ.ФизЛицо;
НомерСтроки = 0;
Если ТаблицаПеречНДФЛ.НайтиЗначение(Сотр,НомерСтроки,"Сотрудник")=1 Тогда

конечно же, фигушки. сотрудник и физлицо - разные элементы
Автор проверял хоть свою обработку перед публикацией?
Помещаю исправленную http://infostart.ru/public/93931/
4. niktas2009@yandex.ru 83 11.10.11 16:57 Сейчас в теме
(2) rimma_n,

ФизЛицо не мешает просто по совместителям внутренним налог считается по Основному элементу.

А с датой да промашка
Сбило с толку это ----- при смене периода Дата становится КонецПериода

//******************************************************************************
// глСменитьПериод(ДатаАктуальности,Направление)
//
// Параметры:
// ДатаАктуальности- дата
// Направление - направление сдвига даты:
// 1 - увеличивает на один период журнала расчетов,
// -1 - уменьшает на один период журнала расчетов,
// 0 - не изменяет
// (по умолчанию 0)
//
// Возвращаемое значение:
// Возвращает описатель периода журнала расчетов, соответствующий новому значению
// параметра ДатаАктуальности.
//
// Описание:
// В зависимости от указанного направления сдвигает параметр ДатаАктуальности на
// один период журнала расчетов.
// Если дата не задана, устанавливает изначально конец текущего периода журнала
// расчетов Зарплата.
// ДатаАктуальности всегда устанавливается в конец периода журнала.
//
Функция глСменитьПериод(ДатаАктуальности,Направление=0) Экспорт
ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");
Если ТипЗначения(ДатаАктуальности)<>3 Тогда
ДатаАктуальности = ЖР.КонецТекущегоПериода()
КонецЕсли;
Если Направление=1 Тогда
ДатаАктуальности = ЖР.КонецПериодаПоДате(ЖР.КонецПериодаПоДате(ДатаАктуальности)+1)
ИначеЕсли Направление=-1 Тогда
ДатаАктуальности = ЖР.НачалоПериодаПоДате(ДатаАктуальности)-1
КонецЕсли;
Возврат ЖР.ОписательПериода(ДатаАктуальности)
КонецФункции // глСменитьПериод
3. TrinitronOTV 15 11.10.11 14:42 Сейчас в теме
жаль, что такие вещи бывают
5. still_ 19.10.11 09:41 Сейчас в теме
Не сразу въехала, но мне немного непонятно зачем такая табличка нужна. Когда формируешь ведомость за месяц, там тоже самое стоит. А форма 2 НДФЛ формирует исчисленный налоги с начала года. Может я не поняла в чем тут суть. А?
6. Rodriguezz 01.11.11 04:16 Сейчас в теме
Тоже не могу понять суть данной обработки.
7. AB3012 21.12.11 15:26 Сейчас в теме
Не сразу въехала, но мне немного непонятно зачем такая табличка нужна. Когда формируешь ведомость за месяц, там тоже самое стоит. А форма 2 НДФЛ формирует исчисленный налоги с начала года.
8. flash82 02.02.12 07:48 Сейчас в теме
нужный отчет спасибо...
9. Boroda 90 30.03.12 23:48 Сейчас в теме
ЗиК 314...? А если не секрет, зачем сдавать НДФЛ из такого древнего релиза? Там и формат выгружаемого файла, очевидно, старый, не соответствует последним требованиям...
Оставьте свое сообщение